Oneiric update to 3.0.49 stable release

Bug #1075329 reported by Herton R. Krzesinski on 2012-11-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Oneiric
Medium
Herton R. Krzesinski

Bug Description

SRU Justification

    Impact:
       The upstream process for stable tree updates is quite similar
       in scope to the Ubuntu SRU process, e.g., each patch has to
       demonstrably fix a bug, and each patch is vetted by upstream
       by originating either directly from Linus' tree or in a minimally
       backported form of that patch. The 3.0.49 upstream stable
       patch set is now available. It should be included in the Ubuntu
       kernel as well.

       git://git.kernel.org/

    TEST CASE: TBD

       The following patches are in the 3.0.49 stable release:

arch/tile: avoid generating .eh_frame information in modules
NLM: nlm_lookup_file() may return NLMv4-specific error codes
oprofile, x86: Fix wrapping bug in op_x86_get_ctrl()
SUNRPC: Prevent kernel stack corruption on long values of flush
Revert: lockd: use rpc client's cl_nodename for id encoding
pcmcia: sharpsl: don't discard sharpsl_pcmcia_ops
kernel/sys.c: fix stack memory content leak via UNAME26
use clamp_t in UNAME26 fix
x86: Exclude E820_RESERVED regions and memory holes above 4 GB from direct mapping.
xen/x86: don't corrupt %eip when returning from a signal handler
USB: cdc-acm: fix pipe type of write endpoint
usb: acm: fix the computation of the number of data bits
USB: option: blacklist net interface on ZTE devices
USB: option: add more ZTE devices
cgroup: notify_on_release may not be triggered in some cases
amd64_edac:__amd64_set_scrub_rate(): avoid overindexing scrubrates[]
media: au0828: fix case where STREAMOFF being called on stopped stream causes BUG()
drm/i915: apply timing generator bug workaround on CPT and PPT
net: Fix skb_under_panic oops in neigh_resolve_output
skge: Add DMA mask quirk for Marvell 88E8001 on ASUS P5NSLI motherboard
RDS: fix rds-ping spinlock recursion
tcp: resets are misrouted
sparc64: fix ptrace interaction with force_successful_syscall_return()
sparc64: Like x86 we should check current->mm during perf backtrace generation.
sparc64: Fix bit twiddling in sparc_pmu_enable_event().
sparc64: do not clobber personality flags in sys_sparc64_personality()
sparc64: Be less verbose during vmemmap population.
xHCI: add cmd_ring_state
xHCI: add aborting command ring function
xHCI: cancel command after command timeout
xHCI: handle command after aborting the command ring
Linux 3.0.49

The following change was already applied to master-next, and was not re-applied:
drm/i915: apply timing generator bug workaround on CPT and PPT

tags: added: kernel-stable-tracking-bug
description: updated
Changed in linux (Ubuntu):
status: New → Invalid
Changed in linux (Ubuntu Oneiric):
status: New → Fix Committed
importance: Undecided → Medium
assignee: nobody → Herton R. Krzesinski (herton)

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :
Download full text (15.0 KiB)

This bug was fixed in the package linux - 3.0.0-28.45

---------------
linux (3.0.0-28.45) oneiric-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1078663

  [ Tim Gardner ]

  * [Config] updateconfigs for stable updates

  [ Upstream Kernel Changes ]

  * Revert "SUNRPC: Ensure we close the socket on EPIPE errors too..."
    - LP: #1075332
  * mn10300: only add -mmem-funcs to KBUILD_CFLAGS if gcc supports it
    - LP: #1067857
  * kbuild: make: fix if_changed when command contains backslashes
    - LP: #1067857
  * media: rc: ite-cir: Initialise ite_dev::rdev earlier
    - LP: #1067857
  * ACPI: run _OSC after ACPI_FULL_INITIALIZATION
    - LP: #1067857
  * PCI: acpiphp: check whether _ADR evaluation succeeded
    - LP: #1067857
  * lib/gcd.c: prevent possible div by 0
    - LP: #1067857
  * kernel/sys.c: call disable_nonboot_cpus() in kernel_restart()
    - LP: #1067857
  * drivers/scsi/atp870u.c: fix bad use of udelay
    - LP: #1067857
  * workqueue: add missing smp_wmb() in process_one_work()
    - LP: #1067857
  * xfrm: Workaround incompatibility of ESN and async crypto
    - LP: #1067857
  * xfrm_user: return error pointer instead of NULL
    - LP: #1067857
  * xfrm_user: return error pointer instead of NULL #2
    - LP: #1067857
  * xfrm: fix a read lock imbalance in make_blackhole
    - LP: #1067857
  * xfrm_user: fix info leak in copy_to_user_auth()
    - LP: #1067857
  * xfrm_user: fix info leak in copy_to_user_state()
    - LP: #1067857
  * xfrm_user: fix info leak in copy_to_user_policy()
    - LP: #1067857
  * xfrm_user: fix info leak in copy_to_user_tmpl()
    - LP: #1067857
  * xfrm_user: don't copy esn replay window twice for new states
    - LP: #1067857
  * xfrm_user: ensure user supplied esn replay window is valid
    - LP: #1067857
  * net: ethernet: davinci_cpdma: decrease the desc count when cleaning up
    the remaining packets
    - LP: #1067857
  * ixp4xx_hss: fix build failure due to missing linux/module.h inclusion
    - LP: #1067857
  * netxen: check for root bus in netxen_mask_aer_correctable
    - LP: #1067857
  * net-sched: sch_cbq: avoid infinite loop
    - LP: #1067857
  * pkt_sched: fix virtual-start-time update in QFQ
    - LP: #1067857
  * sierra_net: Endianess bug fix.
    - LP: #1067857
  * 8021q: fix mac_len recomputation in vlan_untag()
    - LP: #1067857
  * ipv6: release reference of ip6_null_entry's dst entry in __ip6_del_rt
    - LP: #1067857
  * tcp: flush DMA queue before sk_wait_data if rcv_wnd is zero
    - LP: #1067857
  * sctp: Don't charge for data in sndbuf again when transmitting packet
    - LP: #1067857
  * pppoe: drop PPPOX_ZOMBIEs in pppoe_release
    - LP: #1067857
  * net: small bug on rxhash calculation
    - LP: #1067857
  * net: guard tcp_set_keepalive() to tcp sockets
    - LP: #1067857
  * ipv4: raw: fix icmp_filter()
    - LP: #1067857
  * ipv6: raw: fix icmpv6_filter()
    - LP: #1067857
  * ipv6: mip6: fix mip6_mh_filter()
    - LP: #1067857
  * l2tp: fix a typo in l2tp_eth_dev_recv()
    - LP: #1067857
  * netrom: copy_datagram_iovec can fail
    - LP: #1067857
  * net: do not disable sg for packets requiring no checksum
    - LP: #1067857
  * ...

Changed in linux (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers