Oneiric update to 3.0.46 stable release

Bug #1067857 reported by Herton R. Krzesinski on 2012-10-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Oneiric
Medium
Herton R. Krzesinski

Bug Description

SRU Justification

    Impact:
       The upstream process for stable tree updates is quite similar
       in scope to the Ubuntu SRU process, e.g., each patch has to
       demonstrably fix a bug, and each patch is vetted by upstream
       by originating either directly from Linus' tree or in a minimally
       backported form of that patch. The 3.0.46 upstream stable
       patch set is now available. It should be included in the Ubuntu
       kernel as well.

       git://git.kernel.org/

    TEST CASE: TBD

       The following patches are in the 3.0.46 stable release:

mn10300: only add -mmem-funcs to KBUILD_CFLAGS if gcc supports it
kbuild: make: fix if_changed when command contains backslashes
media: rc: ite-cir: Initialise ite_dev::rdev earlier
ACPI: run _OSC after ACPI_FULL_INITIALIZATION
PCI: acpiphp: check whether _ADR evaluation succeeded
lib/gcd.c: prevent possible div by 0
kernel/sys.c: call disable_nonboot_cpus() in kernel_restart()
drivers/scsi/atp870u.c: fix bad use of udelay
workqueue: add missing smp_wmb() in process_one_work()
xfrm: Workaround incompatibility of ESN and async crypto
xfrm_user: return error pointer instead of NULL
xfrm_user: return error pointer instead of NULL #2
xfrm: fix a read lock imbalance in make_blackhole
xfrm_user: fix info leak in copy_to_user_auth()
xfrm_user: fix info leak in copy_to_user_state()
xfrm_user: fix info leak in copy_to_user_policy()
xfrm_user: fix info leak in copy_to_user_tmpl()
xfrm_user: don't copy esn replay window twice for new states
xfrm_user: ensure user supplied esn replay window is valid
net: ethernet: davinci_cpdma: decrease the desc count when cleaning up the remaining packets
ixp4xx_hss: fix build failure due to missing linux/module.h inclusion
netxen: check for root bus in netxen_mask_aer_correctable
net-sched: sch_cbq: avoid infinite loop
pkt_sched: fix virtual-start-time update in QFQ
sierra_net: Endianess bug fix.
8021q: fix mac_len recomputation in vlan_untag()
ipv6: release reference of ip6_null_entry's dst entry in __ip6_del_rt
tcp: flush DMA queue before sk_wait_data if rcv_wnd is zero
sctp: Don't charge for data in sndbuf again when transmitting packet
pppoe: drop PPPOX_ZOMBIEs in pppoe_release
net: small bug on rxhash calculation
net: guard tcp_set_keepalive() to tcp sockets
ipv4: raw: fix icmp_filter()
ipv6: raw: fix icmpv6_filter()
ipv6: mip6: fix mip6_mh_filter()
l2tp: fix a typo in l2tp_eth_dev_recv()
netrom: copy_datagram_iovec can fail
net: do not disable sg for packets requiring no checksum
aoe: assert AoE packets marked as requiring no checksum
tg3: Fix TSO CAP for 5704 devs w / ASF enabled
SCSI: zfcp: Make trace record tags unique
SCSI: zfcp: Do not wakeup while suspended
SCSI: zfcp: remove invalid reference to list iterator variable
SCSI: zfcp: restore refcount check on port_remove
SCSI: zfcp: only access zfcp_scsi_dev for valid scsi_device
PCI: Check P2P bridge for invalid secondary/subordinate range
ext4: online defrag is not supported for journaled files
ext4: always set i_op in ext4_mknod()
ext4: fix fdatasync() for files with only i_size changes
ASoC: wm9712: Fix name of Capture Switch
mm: fix invalidate_complete_page2() lock ordering
mm: thp: fix pmd_present for split_huge_page and PROT_NONE with THP
ALSA: aloop - add locking to timer access
ALSA: usb - disable broken hw volume for Tenx TP6911
ALSA: USB: Support for (original) Xbox Communicator
drm/radeon: only adjust default clocks on NI GPUs
drm/radeon: Add MSI quirk for gateway RS690
drm/radeon: force MSIs on RS690 asics
rcu: Fix day-one dyntick-idle stall-warning bug
r8169: fix wake on lan setting for non-8111E.
r8169: don't enable rx when shutdown.
r8169: remove erroneous processing of always set bit.
r8169: jumbo fixes.
r8169: expand received packet length indication.
r8169: increase the delay parameter of pm_schedule_suspend
r8169: Rx FIFO overflow fixes.
r8169: fix Config2 MSIEnable bit setting.
r8169: missing barriers.
r8169: runtime resume before shutdown.
r8169: Config1 is read-only on 8168c and later.
r8169: 8168c and later require bit 0x20 to be set in Config2 for PME signaling.
r8169: fix unsigned int wraparound with TSO
r8169: call netif_napi_del at errpaths and at driver unload
revert "mm: mempolicy: Let vma_merge and vma_split handle vma->vm_policy linkages"
mempolicy: remove mempolicy sharing
mempolicy: fix a race in shared_policy_replace()
mempolicy: fix refcount leak in mpol_set_shared_policy()
mempolicy: fix a memory corruption by refcount imbalance in alloc_pages_vma()
CPU hotplug, cpusets, suspend: Don't modify cpusets during suspend/resume
mtd: autcpu12-nvram: Fix compile breakage
mtd: nandsim: bugfix: fail if overridesize is too big
mtd: nand: Use the mirror BBT descriptor when reading its version
mtd: omap2: fix omap_nand_remove segfault
mtd: omap2: fix module loading
Linux 3.0.46

tags: added: kernel-stable-tracking-bug
description: updated
Changed in linux (Ubuntu):
status: New → Invalid
Changed in linux (Ubuntu Oneiric):
status: New → Fix Committed
Changed in linux (Ubuntu Oneiric):
importance: Undecided → Medium
assignee: nobody → Herton R. Krzesinski (herton)

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :
Download full text (15.0 KiB)

This bug was fixed in the package linux - 3.0.0-28.45

---------------
linux (3.0.0-28.45) oneiric-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1078663

  [ Tim Gardner ]

  * [Config] updateconfigs for stable updates

  [ Upstream Kernel Changes ]

  * Revert "SUNRPC: Ensure we close the socket on EPIPE errors too..."
    - LP: #1075332
  * mn10300: only add -mmem-funcs to KBUILD_CFLAGS if gcc supports it
    - LP: #1067857
  * kbuild: make: fix if_changed when command contains backslashes
    - LP: #1067857
  * media: rc: ite-cir: Initialise ite_dev::rdev earlier
    - LP: #1067857
  * ACPI: run _OSC after ACPI_FULL_INITIALIZATION
    - LP: #1067857
  * PCI: acpiphp: check whether _ADR evaluation succeeded
    - LP: #1067857
  * lib/gcd.c: prevent possible div by 0
    - LP: #1067857
  * kernel/sys.c: call disable_nonboot_cpus() in kernel_restart()
    - LP: #1067857
  * drivers/scsi/atp870u.c: fix bad use of udelay
    - LP: #1067857
  * workqueue: add missing smp_wmb() in process_one_work()
    - LP: #1067857
  * xfrm: Workaround incompatibility of ESN and async crypto
    - LP: #1067857
  * xfrm_user: return error pointer instead of NULL
    - LP: #1067857
  * xfrm_user: return error pointer instead of NULL #2
    - LP: #1067857
  * xfrm: fix a read lock imbalance in make_blackhole
    - LP: #1067857
  * xfrm_user: fix info leak in copy_to_user_auth()
    - LP: #1067857
  * xfrm_user: fix info leak in copy_to_user_state()
    - LP: #1067857
  * xfrm_user: fix info leak in copy_to_user_policy()
    - LP: #1067857
  * xfrm_user: fix info leak in copy_to_user_tmpl()
    - LP: #1067857
  * xfrm_user: don't copy esn replay window twice for new states
    - LP: #1067857
  * xfrm_user: ensure user supplied esn replay window is valid
    - LP: #1067857
  * net: ethernet: davinci_cpdma: decrease the desc count when cleaning up
    the remaining packets
    - LP: #1067857
  * ixp4xx_hss: fix build failure due to missing linux/module.h inclusion
    - LP: #1067857
  * netxen: check for root bus in netxen_mask_aer_correctable
    - LP: #1067857
  * net-sched: sch_cbq: avoid infinite loop
    - LP: #1067857
  * pkt_sched: fix virtual-start-time update in QFQ
    - LP: #1067857
  * sierra_net: Endianess bug fix.
    - LP: #1067857
  * 8021q: fix mac_len recomputation in vlan_untag()
    - LP: #1067857
  * ipv6: release reference of ip6_null_entry's dst entry in __ip6_del_rt
    - LP: #1067857
  * tcp: flush DMA queue before sk_wait_data if rcv_wnd is zero
    - LP: #1067857
  * sctp: Don't charge for data in sndbuf again when transmitting packet
    - LP: #1067857
  * pppoe: drop PPPOX_ZOMBIEs in pppoe_release
    - LP: #1067857
  * net: small bug on rxhash calculation
    - LP: #1067857
  * net: guard tcp_set_keepalive() to tcp sockets
    - LP: #1067857
  * ipv4: raw: fix icmp_filter()
    - LP: #1067857
  * ipv6: raw: fix icmpv6_filter()
    - LP: #1067857
  * ipv6: mip6: fix mip6_mh_filter()
    - LP: #1067857
  * l2tp: fix a typo in l2tp_eth_dev_recv()
    - LP: #1067857
  * netrom: copy_datagram_iovec can fail
    - LP: #1067857
  * net: do not disable sg for packets requiring no checksum
    - LP: #1067857
  * ...

Changed in linux (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers