8086:4238 Lenovo ThinkPad T530 speakers not working after suspend with wireless enabled

Bug #1066437 reported by Yuriy Vidineev on 2012-10-14
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Headphones works well after suspend, spekers - not working at all. After reboot all works fine.
I'm running up-to-date Kubuntu 12.10 on Lenovo ThinkPad T530

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: alsa-base 1.0.25+dfsg-0ubuntu3
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
ApportVersion: 2.6.1-0ubuntu3
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: adept 2190 F.... pulseaudio
 /dev/snd/pcmC0D0p: adept 2190 F...m pulseaudio
Date: Sat Oct 13 20:27:52 2012
EcryptfsInUse: Yes
InstallationMedia: Kubuntu 12.10 "Quantal Quetzal" - Beta amd64 (20120926.3)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: alsa-driver
Symptom: audio
Symptom_Card: Built-in Audio - HDA Intel PCH
Symptom_Jack: Black Headphone Out, Rear, Docking station
Symptom_Type: No auto-mute between outputs
Title: [2359CTO, Realtek ALC269VC, Black Headphone Out, Rear, Docking station] No automute
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/29/2012
dmi.bios.vendor: LENOVO
dmi.bios.version: G4ET37WW (1.12 )
dmi.board.asset.tag: Not Available
dmi.board.name: 2359CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvrG4ET37WW(1.12):bd05/29/2012:svnLENOVO:pn2359CTO:pvrThinkPadT530:rvnLENOVO:rn2359CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 2359CTO
dmi.product.version: ThinkPad T530
dmi.sys.vendor: LENOVO
---
ApportVersion: 2.6.1-0ubuntu3
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: adept 2227 F.... pulseaudio
DistroRelease: Ubuntu 12.10
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=f5546f75-0b02-4586-8b73-131f85edff75
InstallationMedia: Kubuntu 12.10 "Quantal Quetzal" - Beta amd64 (20120926.3)
MachineType: LENOVO 2359CTO
Package: linux (not installed)
ProcEnviron:
 LANGUAGE=
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-17-generic root=UUID=687613bf-5d77-471c-9d65-be6288b79209 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-17-generic N/A
 linux-backports-modules-3.5.0-17-generic N/A
 linux-firmware 1.95
Tags: quantal quantal
Uname: Linux 3.5.0-17-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 05/29/2012
dmi.bios.vendor: LENOVO
dmi.bios.version: G4ET37WW (1.12 )
dmi.board.asset.tag: Not Available
dmi.board.name: 2359CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvrG4ET37WW(1.12):bd05/29/2012:svnLENOVO:pn2359CTO:pvrThinkPadT530:rvnLENOVO:rn2359CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 2359CTO
dmi.product.version: ThinkPad T530
dmi.sys.vendor: LENOVO

Yuriy Vidineev (adeptg) wrote :
Raymond (superquad-vortex2) wrote :

pin ctls of internal speaker should be OUT when unplugged

Node 0x14 [Pin Complex] wcaps 0x40058d: Stereo Amp-Out
  Control: name="Speaker Playback Switch", index=0, device=0
    ControlAmp: chs=3, dir=Out, idx=0, ofs=0
  Control: name="Speaker Phantom Jack", index=0, device=0
  Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
  Amp-Out vals: [0x00 0x00]
  Pincap 0x00010014: OUT EAPD Detect
  EAPD 0x2: EAPD
  Pin Default 0x90170110: [Fixed] Speaker at Int N/A
    Conn = Analog, Color = Unknown
    DefAssociation = 0x1, Sequence = 0x0
    Misc = NO_PRESENCE
  Pin-ctls: 0x00:
  Unsolicited: tag=00, enabled=0
  Power states: D0 D1 D2 D3 EPSS
  Power: setting=D0, actual=D0
  Connection: 2
     0x0c* 0x0d

Yuriy Vidineev (adeptg) wrote :

Thank you for answer!
Should I do something about it or it should be automatic?
P.S. Sorry for my English

Raymond (superquad-vortex2) wrote :

seem oops!

30408.234704] WARNING: at /build/buildd/linux-3.5.0/drivers/net/wireless/iwlwifi/iwl-trans.h:565 iwlagn_mac_flush+0x1a3/0x1b0 [iwlwifi]()
[30408.234707] Hardware name: 2359CTO
[30408.234709] iwl_trans_wait_tx_queue_empty bad state = 0
[30408.234711] Modules linked in: dm_crypt bnep rfcomm pci_stub vboxpci(O) vboxnetadp(O) vboxnetflt(O) vboxdrv(O) parport_pc ppdev binfmt_misc arc4 uvcvideo videobuf2_core iwlwifi videodev videobuf2_vmalloc snd_hda_codec_realtek videobuf2_memops snd_hda_intel snd_hda_codec btusb bluetooth joydev thinkpad_acpi snd_hwdep snd_pcm snd_seq_midi snd_rawmidi snd_seq_midi_event mac80211 coretemp snd_seq snd_timer snd_seq_device kvm_intel kvm cfg80211 snd mei microcode mac_hid psmouse snd_page_alloc soundcore serio_raw tpm_tis lpc_ich nvram lp parport usb_storage uas ghash_clmulni_intel aesni_intel cryptd aes_x86_64 i915 sdhci_pci sdhci drm_kms_helper e1000e drm i2c_algo_bit wmi video
[30408.234780] Pid: 10694, comm: kworker/u:2 Tainted: G O 3.5.0-17-generic #28-Ubuntu
[30408.234782] Call Trace:
[30408.234793] [<ffffffff81051c4f>] warn_slowpath_common+0x7f/0xc0
[30408.234799] [<ffffffff81051d46>] warn_slowpath_fmt+0x46/0x50
[30408.234812] [<ffffffffa0450ba3>] iwlagn_mac_flush+0x1a3/0x1b0 [iwlwifi]
[30408.234837] [<ffffffffa02a65ed>] ieee80211_mgd_probe_ap_send+0x12d/0x1f0 [mac80211]
[30408.234843] [<ffffffff8107055f>] ? cwq_activate_first_delayed+0x4f/0xc0
[30408.234862] [<ffffffffa02a6caf>] ieee80211_mgd_probe_ap.part.23+0x10f/0x130 [mac80211]
[30408.234879] [<ffffffffa02a6e4e>] ieee80211_sta_monitor_work+0x2e/0x30 [mac80211]
[30408.234883] [<ffffffff8107079a>] process_one_work+0x12a/0x420
[30408.234900] [<ffffffffa02a6e20>] ? ieee80211_beacon_connection_loss_work+0x150/0x150 [mac80211]
[30408.234904] [<ffffffff8107133e>] worker_thread+0x12e/0x2f0
[30408.234908] [<ffffffff81071210>] ? manage_workers.isra.26+0x200/0x200
[30408.234913] [<ffffffff81075e33>] kthread+0x93/0xa0
[30408.234918] [<ffffffff8168b024>] kernel_thread_helper+0x4/0x10
[30408.234923] [<ffffffff81075da0>] ? kthread_freezable_should_stop+0x70/0x70
[30408.234927] [<ffffffff8168b020>] ? gs_change+0x13/0x13

Yuriy Vidineev (adeptg) wrote :

looks like fault in Wi-Fi card driver

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in alsa-driver (Ubuntu):
status: New → Confirmed
Charles Profitt (cprofitt) wrote :

Based on the comment above I disabled wireless before suspending and when I resumed sound was working.

Yuriy Vidineev (adeptg) wrote :

Yes, you are right - with disabled wireless it's allright. But I can't understand how wireless may be related to sound :)

no longer affects: linux
summary: - On Lenovo ThinkPad T530 speakers not working after suspend
+ On Lenovo ThinkPad T530 speakers not working after suspend with wireless
+ enabled
Changed in linux (Ubuntu):
status: New → Confirmed

As per the reports there is some wierd interaction with wireless going on here, so I've added 'linux' in.
I've also edited the title to point out the wireless connection.

Changed in linux (Ubuntu):
status: Confirmed → New

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1066437

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

In order to complete this you will need to have the following python-launchpadlib installed.

sudo apt-get install python-launchpadlib

that will install and allow apport-collect to function.

Tom D. (dickmant) wrote :

I'm having the same issue with my T430s thinkpad.

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

I've changed bug status to 'Confirmed' after apport-collect

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu laptop testing tracker.

A list of all reports related to this bug can be found here:
http://laptop.qa.ubuntu.com/qatracker/reports/bugs/1066437

tags: added: laptop-testing
Yuriy Vidineev (adeptg) wrote :

Yuriy Vidineev, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the kernel in the mainline kernels archive directory daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.7-rc1-quantal

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

If you are unable to test the mainline kernel, please comment as to why specifically you were unable to test it and add the following tags:
kernel-unable-to-test-upstream
kernel-unable-to-test-upstream-VERSION-NUMBER

Please let us know your results. Thank you for your understanding.

Helpful bug reporting tips:
https://help.ubuntu.com/community/ReportingBugs

summary: - On Lenovo ThinkPad T530 speakers not working after suspend with wireless
- enabled
+ 8086:4238 Lenovo ThinkPad T530 speakers not working after suspend with
+ wireless enabled
tags: added: kernel-sound needs-upstream-testing
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Yuriy Vidineev (adeptg) wrote :

On 3.7-r2 it's all ok.
I'm pretty sure that it's duplicate of https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1064621 and I'm sorry for creating a second.

tags: added: kernel-fixed-upstream kernel-fixed-upstream-v3.7-rc2-raring
removed: needs-upstream-testing
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: kernel-fixed-upstream-v3.7-rc2
removed: kernel-fixed-upstream-v3.7-rc2-raring

Yuriy Vidineev, thank you for testing the mainline kernel. In order to rule out this being a duplicate of https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1064621 , could you please test for this in Quantal 3.5.0-18.29 and comment if this addresses your issue?

Thank you for your understanding.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Tom D. (dickmant) wrote :

Any updates on this bug? I hate to be pushy, but sound hasn't worked on my laptop for 2 months.

Any workarounds or anything?

Yuriy Vidineev (adeptg) wrote :

Sorry for my silence: 3.5.0-18.29 works as expected for me.

Tom D., if you have a bug in Ubuntu, could you please file a new report by executing the following in a terminal:
ubuntu-bug sound

For more on this, please see the Ubuntu Audio Developer team article:
https://wiki.ubuntu.com/DebuggingSoundProblems

the Ubuntu Kernel team article:
https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports

the Ubuntu Bug Control team and Ubuntu Bug Squad team article:
https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue

and Ubuntu Community article:
https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report may delay your problem being addressed as quickly as possible.

Thank you for your understanding.

Yuriy Vidineev, did you need a backport to a release prior to Quantal, or may we close this as Status Invalid?

Yuriy Vidineev (adeptg) wrote :

I'm happy with Quantal :) But maybe another users may wants to see this bugfix in recent LTS release.

Yuriy Vidineev, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1066437/comments/36 regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

no longer affects: alsa-driver (Ubuntu)
Changed in linux (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers