powerpc: "Fixing recursive fault but reboot is needed!"

Bug #1066435 reported by Greg Faith on 2012-10-14
92
This bug affects 15 people
Affects Status Importance Assigned to Milestone
linux (Debian)
Fix Released
Unknown
linux (Gentoo Linux)
Unknown
Medium
linux (Ubuntu)
High
Unassigned
Saucy
High
Unassigned

Bug Description

After what appears to be a completed installation trying to boot end in the following statement "Fixing recursive fault but reboot is needed!". Rebooting ends the same with scroll of text and enability to get to terminal or other. This occurred while doing real hardware iso testing on the 20121014 Lubuntu alternate powerpc iso doing qa iso-testing.

Since I do have another clean installed desktop on the computer I might be able to get some of the logs.
---
ApportVersion: 2.6.1-0ubuntu3
Architecture: powerpc
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
CRDA: Error: [Errno 2] No such file or directory
DistroRelease: Ubuntu 12.10
HibernationDevice: RESUME=UUID=22cec03b-37c9-46e0-b37a-227f56d90b1d
InstallationMedia: Lubuntu 12.10 "Quantal Quetzal" - Release powerpc (20121017.1)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Package: linux (not installed)
ProcFB: 0 ATI Radeon 4c66
ProcKernelCmdLine: root=UUID=afccd604-1698-439a-80e7-8e3243d1b8c8 ro quiet splash video=radeonfb:1280x854-32@60
ProcVersionSignature: Ubuntu 3.5.0-17.28-powerpc-smp 3.5.5
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-17-powerpc-smp N/A
 linux-backports-modules-3.5.0-17-powerpc-smp N/A
 linux-firmware 1.95
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
Tags: quantal
Uname: Linux 3.5.0-17-powerpc-smp ppc
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Greg Faith (gregfaith) on 2012-10-14
tags: added: iso-testing
Greg Faith (gregfaith) on 2012-10-14
affects: ubuntu → debian-installer (Ubuntu)
tags: added: powerpc
Jonathan Marsden (jmarsden) wrote :

I saw this same issue testing the Ubuntu Server PPC Quantal image of 20121013 on a Powerbook G4.

Changed in debian-installer (Ubuntu):
status: New → Confirmed
Greg Faith (gregfaith) wrote :

Correction the Lubuntu Alternate powerpc I was testing was dated 20121012.2.

tags: added: quantal
Walter Lapchynski (wxl) wrote :

using lubuntu alternate powerpc 20121012 i had no problems with an install.

Colin Watson (cjwatson) wrote :

This comes from kernel/exit.c. Happy to re-diagnose if the kernel guys think it's a userspace bug.

affects: debian-installer (Ubuntu) → linux (Ubuntu)
Joseph Salisbury (jsalisbury) wrote :

Are you able to boot in recovery mode? If so, it would be great if we can narrow down the last good kernel and the first kernel that caused this bug.

Phill Whiteside (phillw) wrote :

Hi Joseph, I don't have access to a PPC, but from reading the bug, the kernel in 20121012 was okay and the one in and after 20121012.2 was not. I'm sure the guys will provide exact kernels as soon as they can but that may be enough?

Changed in linux (Ubuntu):
importance: Undecided → High

if this is truly a kernel bug then what are the kernel versions that have the bug and which don't?

Joseph,
I tried to boot into recovery mode using 'Linux single' which is how I understand the powerpc yaboot command. It ended in the same results "Fixing recursive fault but reboot is needed!"

Greg Faith (gregfaith) wrote :

I also tried the Lubuntu alternate powerpc yesterday 20121014 and it failed as well.. It was noted on qa-tracker. I will add to this bug the reference to the kernel that I can see after a reboot. Not on my G4 but this is what I saw early in the scroll 'Oops: Kernel access of bad area, sig:11 [#2]'

Walter, you might want to confirm whether you're able to reproduce this bug on your hardware using the latest images, to save people going on a wild goose chase thinking this is a regression since 20121012 when it's possible it's not a regression but is instead hardware-specific.

In particular, there is no difference in the version of kernel installed by the the 20121012 and 20121012.2 powerpc lubuntu images; so if this is a kernel bug, it's a bug that was already present before the 20121012.2 image.

ojordan (ojordan12345) wrote :

The problem started in 3.5.0-17-26

success with:
$ cat /var/lib/apt/cdroms.list
CD::8cdd3b6f98ded4ac97443d9b940c3bff-2 "Lubuntu 12.10 _Quantal Quetzal_ - Release powerpc (20121015.1)";
CD::8cdd3b6f98ded4ac97443d9b940c3bff-2::Label "Lubuntu 12.10 _Quantal Quetzal_ - Release powerpc (20121015.1)";
$ uname -a
Linux ubuntu 3.5.0-17-powerpc-smp #28-Ubuntu SMP Tue Oct 9 19:35:15 UTC 2012 ppc ppc ppc GNU/Linux

i did need to create an xorg.conf, but that has been my experience with this nvidia chip. beyond that, no problems with install or boot.

i should point out that i am using the smp kernel by no choice of my own. mayhap this is why i lack the problem.

for those with the problem, i suggest trying either of the following at the yaboot prompt:
1. Linux single
2. Linux recovery

the former goes straight to the root prompt, while the second will offer a menu of options like normal recovery.

if that still fails, you should be able to use recovery from another desktop cd/dvd. even an old one. just get in there, set up networking if need be (when i tested Linux single, it was already set up), and have at it.

in any case, for me at least, not a bug, which is a total relief because, imho, nvidia depends upon alternate for quantal.

The title of this bug should be changed as it has nothing to do with the debian installer. It applies equally to a live ISO as well as an installed system that is updated to the latest kernel.

Don't waste your time with single/recovery modes. The only way I have been able to boot is to force a 32 bit depth on the radeonfb framebuffer. Any other colour depth (8, 16) still causes a crash. Forcing a 32 bit depth on radeondrmfb still has the crash - so KMS is currently impossible as far as I can tell. I don't know how you would overcome it on nvidia.....

Walter/wxl has 64mb of video ram I believe on nvidia. Jonathon Marsden also has nvidia, but how much video ram? Can everybody confirm how much they have - I have only 32mb. Is that the difference?

Or is the video a red herring and it is say sound modules that are the problem?

I can't get logs - anybody else?

Yep 64 megs of RAM on the video card here.

Can others confirm this applies to desktop, too? I can't get desktop going
well on nVidia so I'm of no help there.

Again I wonder if using SMP isn't what is making this work for me.

Jonathan I need your help checking out non-server nVidia please.

It would be nice to know what kernel everyone's using.

Hi guys, this may, or may well be not, be of any use. But off the top of my head.. If you have the install there but cannot access the logs maybe booting using the LiveCD from A3 that we did have working would give you access to them? http://phillw.net/isos/lubuntu/quantal/alpha-3/

Sorry I cannot be of more use.

phill, that's what i was sort of suggesting. if you have the system installed, as long as you can access the drive in some way or another (heck, use another distro if you have to! [you don't but finnix works quick and easy for recovery purposes]) you should be able to get to the logs.

also, /proc/version or /proc/version_signature should have your kernel info, unless someone wants to recommend something better (i suggest this instead of uname -a in case you can't access the system, but only the drive).

I got this with the 20121017 image, but first on the third of three tests. The first two "Alternate Install (Encryption)" and "Alternate Install (Entire Disk)" booted fine. It was only after resizing the partition that it failed to boot. So the bug does not occur in all cases. It comes with a whole screen of text which is too much to key in, but the last bit is "Fixing recursive fault but reboot is needed!"

On Wed, Oct 17, 2012 at 7:37 AM, Lars Noodén <email address hidden> wrote:
> I got this with the 20121017 image, but first on the third of three
> tests. The first two "Alternate Install (Encryption)" and "Alternate
> Install (Entire Disk)" booted fine. It was only after resizing the
> partition that it failed to boot. So the bug does not occur in all
> cases. It comes with a whole screen of text which is too much to key
> in, but the last bit is "Fixing recursive fault but reboot is needed!"

Lars it would appear you have found a clear distinction that makes since on
some of the issues. In my original bug filing I did not clearly state I
also was doing an "Alternate Install (Guided)" when I got the failure I
basically stopped testing the alternate after the crash. Instead you
started with the alternate entire drive installs. Perhaps that will help
narrow the scope on the fix.

Walter Lapchynski (wxl) wrote :

did all three with 20121017 and had no problems outside of the expected need for xorg.conf on my nVidia machine and some funkiness wiht the resizing mechanism: https://bugs.launchpad.net/ubuntu/+source/debian-installer/+bug/1067841. certainly did not have this recursive fault business. if anyone else has a nVidia chip, it would be interesting to see if you have the same experience.

Lars Noodén (larsnooden) wrote :

On 10/17/12, Greg Faith <email address hidden> wrote:

> Lars it would appear you have found a clear distinction that makes since on
> some of the issues. In my original bug filing I did not clearly state I
> also was doing an "Alternate Install (Guided)" when I got the failure I
> basically stopped testing the alternate after the crash. Instead you
> started with the alternate entire drive installs. Perhaps that will help
> narrow the scope on the fix.

I read in some engineering books that the optimum testing team is
about 5 people. You need a number of people because each one will
pick up new things, but above a threshold they start to become
redundant.

regards,
/Lars

Still seeing this here on 20121017.2 image for Ubuntu Server.

Colin Watson (cjwatson) on 2012-10-18
summary: - Debian-installer powerpc recursive fault
+ powerpc: "Fixing recursive fault but reboot is needed!"

Greg Faith, thank you for reporting this and helping make Ubuntu better. As per your Bug Description:
>"Since I do have another clean installed desktop on the computer..."

Could you boot into this and execute the following in a terminal:
apport-collect 1066435

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: needs-kernel-logs
Jackson Doak (noskcaj) wrote :

worryingly this means we cant release the netboot ppc

Jackson Doak, if you have a bug in Ubuntu, could you please file a new report by executing the following in a terminal:
ubuntu-bug linux

For more on this, please see the Ubuntu Bug Control and Ubuntu Bug Squad article:
https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue

and Ubuntu Community article:
https://help.ubuntu.com/community/ReportingBugs

When opening up the new report, please feel free to subscribe me to it. Thank you for your understanding.

> worryingly this means we cant release the netboot ppc

except that it's not a problem for everyone, myself included.

Greg Faith (gregfaith) wrote :

Christopher, since that statement I over-wrote the hard drive with Desktop iso tests for the quantal release. However, I will do the exact testing that caused the bug and attempt to gather the logs and data as needed.

Here is the plan:

1) Install from Lubuntu alternate powerpc iso (Entire Drive)
2) Install from Lubuntu alternate powerpc iso (Re-size Drive)

Lars Nooden installed the encrypted Lubuntu alternate powerpc iso cleanly during the recent release testing and I also did it last night.
Lars then installed the Full drive test case (no critical issues)
Lars tried the Re-size drive option and caught the Bug.

We think, as you can see, that the re-size option is when the Bug happens.

Walter Lapchynski (wxl) wrote :

can you guys tell me the EXACT steps you took with the re-size and everything involved in it? when i did the testing i took the default value, nothing that it's not exactly equivalent to 50% of maximum as it's supposed to be [1]. then i resized again, this time with the minimum, noting that the minimum percentage and the minimum value were apparently not the same. lastly, i did the maximum, which seemed to behave somewhat better (although i did not do 100%). it may be that the testcase is not entirely clear and maybe i'm interpreting it different than anyone else.

wxl

[1] https://bugs.launchpad.net/ubuntu/+source/partman-auto/+bug/1067841

Greg Faith, regarding your comments https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1066435/comments/27 :
>"Christopher, since that statement I over-wrote the hard drive with Desktop iso tests for the quantal release."

Could you please boot into either this install test, or Quantal live environment, and execute the following via a terminal:
apport-collect 1066435

>"Here is the plan:
1) Install from Lubuntu alternate powerpc iso (Entire Drive)
2) Install from Lubuntu alternate powerpc iso (Re-size Drive)"

Sounds good.

>"Lars Nooden installed the encrypted Lubuntu alternate powerpc iso cleanly during the recent release testing and I also did it last night.
Lars then installed the Full drive test case (no critical issues)
Lars tried the Re-size drive option and caught the Bug."

What you say Lars did, or what Lars says is not the focus of this report, as he is not the original reporter. As you are the original reporter for this report, it is focused on the hardware you can reproduce this problem with. For more on this, please see the Ubuntu Bug Control and Ubuntu Bug Squad article:
https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue

and Ubuntu Community article:
https://help.ubuntu.com/community/ReportingBugs

>"We think, as you can see, that the re-size option is when the Bug happens."

Please see above. As well, we have no evidence from you (e.g. apport-collect, logs, etc.) to support this.

Thank you for your understanding.

Greg Faith (gregfaith) wrote :

This is what happen when I try from a Live CD session.

lubuntu@lubuntu:~$ apport-collect 1066435
You need to run 'sudo apt-get install python-apport' for apport-collect to work.
lubuntu@lubuntu:~$ sudo apt-get install python-apport
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  python-problem-report
Suggested packages:
  python-launchpadlib
The following NEW packages will be installed:
  python-apport python-problem-report
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 95.0 kB of archives.
After this operation, 674 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://ports.ubuntu.com/ubuntu-ports/ quantal/main python-problem-report all 2.6.1-0ubuntu3 [10.3 kB]
Get:2 http://ports.ubuntu.com/ubuntu-ports/ quantal/main python-apport all 2.6.1-0ubuntu3 [84.7 kB]
Fetched 95.0 kB in 1s (55.7 kB/s)
Selecting previously unselected package python-problem-report.
(Reading database ... 119380 files and directories currently installed.)
Unpacking python-problem-report (from .../python-problem-report_2.6.1-0ubuntu3_all.deb) ...
Selecting previously unselected package python-apport.
Unpacking python-apport (from .../python-apport_2.6.1-0ubuntu3_all.deb) ...
Setting up python-problem-report (2.6.1-0ubuntu3) ...
Setting up python-apport (2.6.1-0ubuntu3) ...
lubuntu@lubuntu:~$ apport-collect 1066435
ERROR: The launchpadlib Python module is not installed. This functionality is not available.
lubuntu@lubuntu:~$

I will try from my installed encrypted partition.. next

Walter Lapchynski (wxl) wrote :

You didn't notice python-launchpad was a suggested package? :-)

honestly I'm not sure why it isn't required since it clearly is required
for function as specified by the documentation. Maybe this because it is
not an installed system? this should be checked against one and a new bug
filled as needed.

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

ojordan (ojordan12345) on 2012-10-20
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
ojordan (ojordan12345) on 2012-10-21
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
ojordan (ojordan12345) on 2012-10-21
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
26 comments hidden view all 106 comments
ojordan (ojordan12345) wrote :

I see the commits mentioned in post 64 are in the latest kernel (3.5.0-18.29) so that should solve some people's sound problems. I still can't get sound though, I'm wondering if the relevant bit of code just hasn't been written yet (something to do with the fabric layout module?). For me /dev/snd seems to be missing stuff (I only have seq and timer).

Jackson Doak (noskcaj) on 2012-10-26
tags: added: lubuntu-ppc netboot
tags: removed: needs-kernel-logs
1 comments hidden view all 106 comments
ojordan (ojordan12345) wrote :

Commits 3a3dd0186f619b74e61e6f29dddcaf59af7d3cac and 26b0d14106954ae46d2f4f7eec3481828a210f7d came in at 3.5.0-17-26 so they were indeed the cause of this problem.

ojordan (ojordan12345) wrote :

Greg, can you get a photo of the error message?

Hi I can confirm this issue on:

Ibook G4 1.33
PowerBook6,5

Installed form 12.10 Quantel

Currently running kernel:
ubuntu 3.5.0-18-powerpc-smp
Updated from 3.5.0-17 via aptitude which also had the same problem.

Disabling snd-powermac resolves the boot issue, however it looks like the aoa drivers do not support my sound card so no sound.

Reading this post this looks like this is a new kernel bug.

Is there a later kernel I could use or do i need to reinstall with 12.04. I have looked in http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.5-quantal/ butthese do not contain PowerPC kernels.

Appologies if this is not the appropriate forum to post to.

Greg Faith (gregfaith) wrote :

David,

If you are seeking a stable version i would recommend reinstalling 12.04. We are testing the 13.04 powerpc flavors and the kernel sound and radeon problems still exists. I can get a clean working version but with no sound as well on the 3.7.0 kernel.

Jackson Doak (noskcaj) on 2012-12-08
tags: added: raring
Daren EIlert (deilert) wrote :

Greg et al.,

Can you confirm the following for clarity:

1. Lubuntu 12.10 (Quantal Quetzal) has an issue for PowerPC related to the audio drivers?
2. Lubuntu 12.04 (Precise Pangolin) will install without the "Fixing recursive fault but reboot is needed!" error?
3. With regards to #2 above, the install is stable but without audio?
4. Lubuntu 13.04 still has issues with the audio drivers?

Thanks! I currently do have the issue listed here on my iBook G3 with following configuration:
Apple iBook PowerPC G3 800MHz
384MB SDRAM
30GB HD
Sony CD-RW CRX820E (fw 1.3a)
ATI Mobility Radeon 7500 (ATY, RageM7) 32MB VRAM 1024x768 32-bit
Audio = Texas Instruments TAS3004
Apple AirPort (fw 9.52)

Daren EIlert (deilert) wrote :

Screen shot of installation fault
"Fixing recursive fault but reboot is needed!"

Greg Faith (gregfaith) wrote :

@Daren
1. Yes Lubuntu 12.10 QQ has an issue for PowerPC related to the audio driver
2. Yes Lubuntu 12.04 PP will install without the "fixing recursive fault"
3 Regarding #2 above ...My PowerBook G4 has audio
4. Yes Lubuntu 13.04 RR has the reursive fault and audio issues.

I can work around the fixing recursive fault with a kernel command at yaboot prompt., but still have no audio.
I also have graphic issues in 12.10 & 13.04 with the kernel-radeon issues.. but we also have a workaround for that too.

Daren EIlert (deilert) wrote :

Thanks Greg! Lubuntu 12.04 running on the iBook G3 now.

ojordan (ojordan12345) wrote :

The proper fix for this is at the kernel level (has anybody reported it on the powerpc kernel mailing list?), but it is also caused by snd_powermac being liberally modprobed when it shouldn't be. The casper script /scripts/casper-bottom/23etc_modules does it on the live cd and then it is done again (live and alternate) by hw-detect/discover-mac-io.

Jodi Houareau (houareau) wrote :

When I try to boot with snd-powermac.blacklist=yes I get yes is not a vaild parameter for blacklist.

Harald Held (hheld) wrote :

I get the same problem since I installed the latest 64bit version (not powerpc; x86_64 generic kernel) of raring. I consistently need up to 10 boot attempts until it finally decides to boot normally.

Daniel (uabdali) wrote :

I see the same problem on my system (AMD64). Need approximately 4 reboots until it decides to boot up normally.

Alexander Röhnsch (roehnsch) wrote :

The same problem on my amd64 system. Should it be opened as another issue? The original bug seems to be specifical on powerpc architectures in quantal, while the current amd64 issue popped up with raring.

Steve Kowalik (stevenk) on 2013-04-29
no longer affects: ubuntu-cdimage

make another bug for AMD64, this is a kernel error that started at alpha 2
12.10 and still exists

On Tue, Apr 30, 2013 at 5:03 AM, Steve Kowalik <email address hidden> wrote:

> ** No longer affects: ubuntu-cdimage
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1066435
>
> Title:
> powerpc: "Fixing recursive fault but reboot is needed!"
>
> Status in “linux” package in Ubuntu:
> Confirmed
>
> Bug description:
> After what appears to be a completed installation trying to boot end
> in the following statement "Fixing recursive fault but reboot is
> needed!". Rebooting ends the same with scroll of text and enability
> to get to terminal or other. This occurred while doing real hardware
> iso testing on the 20121014 Lubuntu alternate powerpc iso doing qa
> iso-testing.
>
> Since I do have another clean installed desktop on the computer I might
> be able to get some of the logs.
> ---
> ApportVersion: 2.6.1-0ubuntu3
> Architecture: powerpc
> AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq',
> '/dev/snd/timer'] failed with exit code 1:
> CRDA: Error: [Errno 2] No such file or directory
> DistroRelease: Ubuntu 12.10
> HibernationDevice: RESUME=UUID=22cec03b-37c9-46e0-b37a-227f56d90b1d
> InstallationMedia: Lubuntu 12.10 "Quantal Quetzal" - Release powerpc
> (20121017.1)
> Lsusb:
> Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
> Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
> Package: linux (not installed)
> ProcFB: 0 ATI Radeon 4c66
> ProcKernelCmdLine: root=UUID=afccd604-1698-439a-80e7-8e3243d1b8c8 ro
> quiet splash video=radeonfb:1280x854-32@60
> ProcVersionSignature: Ubuntu 3.5.0-17.28-powerpc-smp 3.5.5
> RelatedPackageVersions:
> linux-restricted-modules-3.5.0-17-powerpc-smp N/A
> linux-backports-modules-3.5.0-17-powerpc-smp N/A
> linux-firmware 1.95
> RfKill:
> 0: phy0: Wireless LAN
> Soft blocked: no
> Hard blocked: no
> Tags: quantal
> Uname: Linux 3.5.0-17-powerpc-smp ppc
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1066435/+subscriptions
>

flux (luigimarco) wrote :

I confirm this bug in the latest Ubuntu 13.04 amd64 version

Graeme Hewson (ghewson) wrote :

Recent reporters, see also bug 1175660.

antoine (antoine-) wrote :

The same problem on my amd64 system.

Alexander Röhnsch (roehnsch) wrote :

Opened a dedicated bug #1177086 for people who get the message "Fixing recursive fault but reboot is needed!" on amd64 installations in Raring. Please head over, since this bug here seems to be powerpc specific.

7 comments hidden view all 106 comments

Created attachment 347790
emerge --info

ALSA snd-powermac I2C Regression in kernel >3.5.0-rc6+ PPC

ALSA module snd-powermac fails to load on recent kernel versions running on various PPC chips. This makes ALSA unusable for those kernels.

From dmesg:

[ 10.537194] i2c i2c-2: PMac Keywest Audio: attach_adapter method is deprecated
[ 10.537198] i2c i2c-2: Please use another way to instantiate your i2c_client
[ 10.537212] i2c i2c-2: Failed to register i2c client keywest at 0x35 (-16)

Using git-bisect I ascertained where the bug first appeared.

The bug is not present in kernel versions before 3.5.0-rc6+, and all subsequent kernels have the problem.

Here is the commit info from the bisect:

Bisecting: 0 revisions left to test after this (roughly 0 steps)
[3a3dd0186f619b74e61e6f29dddcaf59af7d3cac] i2c/powermac: Improve detection of devices from device-tree
3a3dd0186f619b74e61e6f29dddcaf59af7d3cac is the first bad commit
commit 3a3dd0186f619b74e61e6f29dddcaf59af7d3cac
Author: Benjamin Herrenschmidt <email address hidden>
Date: Mon Jun 18 12:00:50 2012 +1000

    i2c/powermac: Improve detection of devices from device-tree

    This patch adds a number of workarounds for broken Apple device-trees
    mostly around sound chips. It handles creating the missing audio codec
    devices and works around various issues with missing addresses or
    missing compatible properties.

    Signed-off-by: Benjamin Herrenschmidt <email address hidden>

:040000 040000 849b9ecd549338cf00f024c15aaa01d5217e1806 90e49b5143a97c43b4f07040b56dc6002ad51f9b M drivers

I've duplicated this bug on several PPC G4 machines, including:

PowerBook 12 (PowerBook6,1) 12" Aluminum PowerBook G4 867 MHz PowerPC 7455 processor originally released January 7, 2003, model number A1010, order number M8760LL/A

# cat /proc/cpuinfo
processor : 0
cpu : 7455, altivec supported
clock : 867.000000MHz
revision : 3.3 (pvr 8001 0303)
bogomips : 108.20
timebase : 33280414
platform : PowerMac
model : PowerBook6,1
machine : PowerBook6,1
motherboard : PowerBook6,1 MacRISC3 Power Macintosh
detected as : 287 (PowerBook G4 12")
pmac flags : 0000001a
L2 cache : 256K unified
pmac-generation : NewWorld
Memory : 1152 MB

iMac G4 (PowerMac6,1) 17" iMac G4 1.25GHz G4 PowerPC 7457 processor originally released Sep 8, 2003, model number M6498, order number M9168LL/A
# cat /proc/cpuinfo
processor : 0
cpu : 7455, altivec supported
clock : 1249.999995MHz
revision : 3.3 (pvr 8001 0303)
bogomips : 83.20
timebase : 41600571
platform : PowerMac
model : PowerMac6,1
machine : PowerMac6,1
motherboard : PowerMac6,1 MacRISC3 Power Macintosh
detected as : 287 (Flat panel iMac)
pmac flags : 00000010
L2 cache : 256K unified
pmac-generation : NewWorld
Memory : 512 MB

Any help would be much appreciated. Thank You.

The kernel tree I'm using is gentoo-sources

I have no idea from a first look at the commit, you may be able to try unapplying some of its changes to get an idea of where the fault in the commit lies. See the URL field of this bug for the commit.

I have similar issues on ibook g4 https://bugs.gentoo.org/show_bug.cgi?id=460580

9 comments hidden view all 106 comments
Lars Noodén (larsnooden) wrote :

Present in Saucy on PPC

David Kopec (snpukwana) wrote :

Present on stock Lubuntu 13.10 running on iBook G4 1.2 with Radeon 9200.

Changed in linux (Ubuntu Saucy):
milestone: none → ubuntu-13.07
9 comments hidden view all 106 comments

Did you try something? Let us know if you need help.

(In reply to Tom Wijsman (TomWij) from comment #4)
> Did you try something? Let us know if you need help.

Hi Tom, yes, I'd like some help. Would you recommend just removing a line or two in a trial-and-error fashion? I don't see anything that reaches out to me and says "bug."

Thank You,
Bill

(In reply to GrowlTiger from comment #5)
> Hi Tom, yes, I'd like some help. Would you recommend just removing a line or
> two in a trial-and-error fashion? I don't see anything that reaches out to
> me and says "bug."

It's quite a commit, over 100 lines; I'll try to read over it soon, let's see...

Phill Whiteside (phillw) on 2013-08-18
Changed in linux (Ubuntu Saucy):
status: Confirmed → In Progress
C de-Avillez (hggdh2) on 2013-08-19
tags: added: saucy-needs-verifying
10 comments hidden view all 106 comments
C de-Avillez (hggdh2) wrote :

This bug is awaiting verification that the kernel for Saucy in -proposed solves the problem (3.11.0-0.1). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-saucy' to 'verification-done-saucy'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

Changed in linux (Ubuntu Saucy):
status: In Progress → Fix Committed
tags: added: verification-needed-saucy
removed: saucy-needs-verifying

[PPC] I performed the following without encountering the bug:

1. Successfully booted the 20130818 Live iso. via USB flash drive.

2. Successfully performed a manual install from the 20130818 Live iso and successfully rebooted.

3. Successfully performed a "guided--use entire disk" install from the 20130820 iso and successfully rebooted.

I used a usb flash drive for all tests. The kernel is showing as 3.11.0-0 smp powerpc. The test hardware is Powermac G4 MDD FW800 model. Specs:

http://pastebin.com/0TLWxB86

The successful "guided--use entire disk" installation I noted in comment #90 was using the 20130820 Alternate Installer iso.

C de-Avillez (hggdh2) on 2013-08-22
tags: added: verification-done-saucy
removed: verification-needed-saucy
Changed in linux (Ubuntu):
milestone: ubuntu-13.07 → ubuntu-13.09
Changed in linux (Ubuntu):
milestone: ubuntu-13.09 → ubuntu-13.10
9 comments hidden view all 106 comments

Created attachment 360882
drivers/i2c/busses/i2c-powermac.c commit log

Hmm, sorry, the commit is too big for an out-stander to understand what really is going on and what the possible issue might be.

==> Can you try =sys-kernel/git-sources-3.12-rc5? <==

It contains a commit that might outline the problem better:

commit 874e955b171f0505e2371c1ca80a2188efdc217d
Author: Wolfram Sang <email address hidden>
Date: Thu Jul 11 22:02:03 2013 +0100

    i2c: powermac: fix return path on error

    We want to bail out immediately if i2c_add_adapter failed and not try to
    register child nodes with a nilled adapter structure.

    Signed-off-by: Wolfram Sang <email address hidden>

And possibly some other fixes (see attachment).

(Ignore the second half of that attachment, apparently hit CTRL+V twice)

Changed in linux (Ubuntu):
milestone: ubuntu-13.10 → saucy-updates
9 comments hidden view all 106 comments
Adam Smith (adamsmith) wrote :

I contacted the linuxppc-dev mailing list about this problem https://<email address hidden>/msg76259.html

I've also started a thread on the ubuntu forums http://ubuntuforums.org/showthread.php?t=2209340 to discuss fixing this.

I can get sound working on my iBook by patching snd-aoa. Previously it had used snd-powermac. Would you be interested in the patch?

Also, I booted a recent Trusty iso without hitting the recursive error, but snd-powermac does not work.

tags: added: patch
Changed in linux (Gentoo Linux):
importance: Unknown → Medium
Changed in linux (Debian):
status: Unknown → New
10 comments hidden view all 106 comments
Adam Smith (adamsmith) wrote :

I've added bug reports to casper (bug 1296386) and hw-detect (bug 1296373) which are related to this bug.

Adam Smith (adamsmith) wrote :

Patch sent to the linuxppc-dev list https://<email address hidden>/msg76945.html

This bug was nominated against a series that is no longer supported, ie saucy. The bug task representing the saucy nomination is being closed as Won't Fix.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu Saucy):
status: Fix Committed → Won't Fix
tags: added: lubuntu
removed: lubuntu-ppc raring verification-done-saucy
tags: removed: netboot
tags: removed: patch
tags: added: patch
Changed in linux (Debian):
status: New → Confirmed
Changed in linux (Debian):
status: Confirmed → Fix Released
Changed in linux (Debian):
status: Fix Released → Confirmed
Changed in linux (Debian):
status: Confirmed → Fix Released
Displaying first 40 and last 40 comments. View all 106 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.