Quantal update to v3.5.7 stable release

Bug #1066176 reported by Leann Ogasawara on 2012-10-12
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Leann Ogasawara
Quantal
Medium
Leann Ogasawara

Bug Description

SRU Justification

    Impact:
       The upstream process for stable tree updates is quite similar
       in scope to the Ubuntu SRU process, e.g., each patch has to
       demonstrably fix a bug, and each patch is vetted by upstream
       by originating either directly from Linus' tree or in a minimally
       backported form of that patch. The v3.5.7 upstream stable
       patch set is now available. It should be included in the Ubuntu
       kernel as well.

       git://git.kernel.org/

    TEST CASE: TBD

       The following patches are in the v3.5.7 stable release:

 * Linux 3.5.7
 * Convert properly UTF-8 to UTF-16
 * cifs: reinstate the forcegid option
 * JFFS2: don't fail on bitflips in OOB
 * JFFS2: fix unmount regression
 * mmc: sh-mmcif: avoid oops on spurious interrupts
 * mmc: omap_hsmmc: Pass on the suspend failure to the PM core
 * mtd: omap2: fix module loading
 * mtd: omap2: fix omap_nand_remove segfault
 * mtd: nand: Use the mirror BBT descriptor when reading its version
 * mtd: nandsim: bugfix: fail if overridesize is too big
 * mtd: autcpu12-nvram: Fix compile breakage
 * mtd: mtdpart: break it as soon as we parse out the partitions
 * Revert "drm/i915: correctly order the ring init sequence"
 * CPU hotplug, cpusets, suspend: Don't modify cpusets during suspend/resume
 * efi: initialize efi.runtime_version to make query_variable_info/update_capsule workable
 * efi: Build EFI stub with EFI-appropriate options
 * Revert "KVM: VMX: Fix KVM_SET_SREGS with big real mode segments"
 * mempolicy: fix a memory corruption by refcount imbalance in alloc_pages_vma()
 * mempolicy: fix refcount leak in mpol_set_shared_policy()
 * mempolicy: fix a race in shared_policy_replace()
 * mempolicy: remove mempolicy sharing
 * revert "mm: mempolicy: Let vma_merge and vma_split handle vma->vm_policy linkages"
 * rcu: Fix day-one dyntick-idle stall-warning bug
 * score: Add missing RCU idle APIs on idle loop
 * m32r: Add missing RCU idle APIs on idle loop
 * cris: Add missing RCU idle APIs on idle loop
 * alpha: Add missing RCU idle APIs on idle loop
 * m68k: Add missing RCU idle APIs on idle loop
 * mn10300: Add missing RCU idle APIs on idle loop
 * frv: Add missing RCU idle APIs on idle loop
 * xtensa: Add missing RCU idle APIs on idle loop
 * parisc: Add missing RCU idle APIs on idle loop
 * h8300: Add missing RCU idle APIs on idle loop
 * ia64: Add missing RCU idle APIs on idle loop
 * drm/i915: Fix GT_MODE default value
 * drm/i915: call drm_handle_vblank before finish_page_flip
 * drm/i915: Flush the pending flips on the CRTC before modification
 * drm/radeon: force MSIs on RS690 asics
 * drm/radeon: Add MSI quirk for gateway RS690
 * drm/radeon: only adjust default clocks on NI GPUs
 * drm: Destroy the planes prior to destroying the associated CRTC
 * drm/nvc0/fence: restore pre-suspend fence buffer context on resume
 * ALSA: USB: Support for (original) Xbox Communicator
 * ALSA: usb - disable broken hw volume for Tenx TP6911
 * ALSA: hda - limit internal mic boost for Asus X202E
 * ALSA: hda/realtek - Fix detection of ALC271X codec
 * ALSA: aloop - add locking to timer access
 * ALSA: hda - Add inverted internal mic quirk for Lenovo IdeaPad U310
 * drm/i915: prevent possible pin leak on error path
 * MIPS: ath79: use correct fractional dividers for {CPU,DDR}_PLL on AR934x
 * mm: thp: fix pmd_present for split_huge_page and PROT_NONE with THP
 * mm: fix invalidate_complete_page2() lock ordering
 * hugetlb: do not use vma_hugecache_offset() for vma_prio_tree_foreach
 * kpageflags: fix wrong KPF_THP on non-huge compound pages
 * ASoC: wm9712: Fix name of Capture Switch
 * ASoC: wm_hubs: Ensure volume updates are handled during class W startup
 * xfrm_user: ensure user supplied esn replay window is valid
 * ext4: fix fdatasync() for files with only i_size changes
 * ext4: always set i_op in ext4_mknod()
 * ext4: online defrag is not supported for journaled files
 * ext4: move_extent code cleanup
 * ext4: fix crash when accessing /proc/mounts concurrently
 * ext4: fix potential deadlock in ext4_nonda_switch()
 * ext4: avoid duplicate writes of the backup bg descriptor blocks
 * ext4: don't copy non-existent gdt blocks when resizing
 * ext4: ignore last group w/o enough space when resizing instead of BUG'ing
 * PCI: Check P2P bridge for invalid secondary/subordinate range
 * SCSI: zfcp: only access zfcp_scsi_dev for valid scsi_device
 * SCSI: zfcp: restore refcount check on port_remove
 * SCSI: zfcp: remove invalid reference to list iterator variable
 * SCSI: zfcp: Do not wakeup while suspended
 * SCSI: zfcp: Bounds checking for deferred error trace
 * SCSI: zfcp: Make trace record tags unique
 * SCSI: zfcp: Adapt to new FC_PORTSPEED semantics
 * drm/savage: re-add busmaster enable, regression fix
 * aoe: assert AoE packets marked as requiring no checksum
 * net: do not disable sg for packets requiring no checksum
 * netrom: copy_datagram_iovec can fail
 * l2tp: fix a typo in l2tp_eth_dev_recv()
 * ipv6: mip6: fix mip6_mh_filter()
 * ipv6: raw: fix icmpv6_filter()
 * ipv4: raw: fix icmp_filter()
 * net: guard tcp_set_keepalive() to tcp sockets
 * net: small bug on rxhash calculation
 * pppoe: drop PPPOX_ZOMBIEs in pppoe_release
 * sctp: Don't charge for data in sndbuf again when transmitting packet
 * tcp: flush DMA queue before sk_wait_data if rcv_wnd is zero
 * ipv6: fix return value check in fib6_add()
 * ipv6: del unreachable route when an addr is deleted on lo
 * ipv6: release reference of ip6_null_entry's dst entry in __ip6_del_rt
 * batman-adv: make batadv_test_bit() return 0 or 1 only
 * 8021q: fix mac_len recomputation in vlan_untag()
 * sierra_net: Endianess bug fix.
 * pkt_sched: fix virtual-start-time update in QFQ
 * net-sched: sch_cbq: avoid infinite loop
 * netxen: check for root bus in netxen_mask_aer_correctable
 * ixp4xx_hss: fix build failure due to missing linux/module.h inclusion
 * net: ethernet: davinci_cpdma: decrease the desc count when cleaning up the remaining packets
 * xfrm_user: don't copy esn replay window twice for new states
 * xfrm_user: fix info leak in copy_to_user_tmpl()
 * xfrm_user: fix info leak in copy_to_user_policy()
 * xfrm_user: fix info leak in copy_to_user_state()
 * xfrm_user: fix info leak in copy_to_user_auth()
 * xfrm: fix a read lock imbalance in make_blackhole
 * xfrm_user: return error pointer instead of NULL #2
 * xfrm_user: return error pointer instead of NULL
 * xfrm: Workaround incompatibility of ESN and async crypto
 * tcp: fix regression in urgent data handling
 * bnx2x: fix rx checksum validation for IPv6
 * localmodconfig: Fix localyesconfig to set to 'y' not 'm'
 * jbd2: don't write superblock when if its empty
 * workqueue: add missing smp_wmb() in process_one_work()
 * PM / Sleep: use resume event when call dpm_resume_early
 * rapidio/rionet: fix multicast packet transmit logic
 * ixgbe: fix PTP ethtool timestamping function
 * powerpc/eeh: Fix crash on converting OF node to edev
 * lguest: fix occasional crash in example launcher.
 * drivers/scsi/atp870u.c: fix bad use of udelay
 * kernel/sys.c: call disable_nonboot_cpus() in kernel_restart()
 * lib/gcd.c: prevent possible div by 0
 * mfd: max8925: Move _IO resources out of ioport_ioresource
 * PCI: acpiphp: check whether _ADR evaluation succeeded
 * ACPI: run _OSC after ACPI_FULL_INITIALIZATION
 * media: gspca_pac7302: add support for device 1ae7:2001 Speedlink Snappy Microphone SL-6825-SBK
 * media: rc: ite-cir: Initialise ite_dev::rdev earlier
 * em28xx: Make all em28xx extensions to be initialized asynchronously
 * ARM: 7548/1: include linux/sched.h in syscall.h
 * intel-iommu: Default to non-coherent for domains unattached to iommus
 * slab: fix the DEADLOCK issue on l3 alien lock
 * kbuild: Fix gcc -x syntax
 * kbuild: make: fix if_changed when command contains backslashes
 * mn10300: only add -mmem-funcs to KBUILD_CFLAGS if gcc supports it
 * Revert dyndbg: fix for SOH in logging messages

tags: added: kernel-stable-tracking-bug
description: updated
Changed in linux (Ubuntu Quantal):
assignee: nobody → Leann Ogasawara (leannogasawara)
importance: Undecided → Medium
status: New → In Progress
Changed in linux (Ubuntu Quantal):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (16.4 KiB)

This bug was fixed in the package linux - 3.5.0-18.29

---------------
linux (3.5.0-18.29) quantal-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1068224

  [ Andy Whitcroft ]

  * [packaging] do not fail secure copy on older kernels
  * SAUCE: efivarfs: efivarfs_file_read ensure we free data in error paths
    - LP: #1063061
  * SAUCE: efivars: efivarfs_create() ensure we drop our reference on inode
    on error
    - LP: #1063061
  * SAUCE: efivarfs: efivarfs_fill_super() fix inode reference counts
    - LP: #1063061
  * SAUCE: efivarfs: efivarfs_fill_super() ensure we free our temporary
    name
    - LP: #1063061
  * SAUCE: efivarfs: efivarfs_fill_super() ensure we clean up correctly on
    error
    - LP: #1063061
  * [Config] add fs/udf to linux-image to support DVD/CD formats in virtual
    instances
    - LP: #1066921

  [ Jeremy Kerr ]

  * SAUCE: efi: Handle deletions and size changes in efivarfs_write_file
    - LP: #1063061
  * SAUCE: efivarfs: Implement exclusive access for {get, set}_variable
    - LP: #1063061

  [ Kamal Mostafa ]

  * SAUCE: input: Cypress PS/2 Trackpad list additional contributors

  [ Kyle Fazzari ]

  * SAUCE: input: Cypress PS/2 Trackpad fix lost sync upon palm contact
    - LP: #1048258
  * SAUCE: input: Cypress PS/2 Trackpad fix taps turning into hardware
    clicks
    - LP: #1064086

  [ Leann Ogasawara ]

  * Revert "SAUCE: ext4: fix crash when accessing /proc/mounts
    concurrently"
    - LP: #1066176
  * Revert "SAUCE: ALSA: hda/realtek - Fix detection of ALC271X codec"
    - LP: #1066176

  [ Lee, Chun-Yi ]

  * SAUCE: efi: add efivars kobject to efi sysfs folder
    - LP: #1063061

  [ Matt Fleming ]

  * SAUCE: efivarfs: Add documentation for the EFI variable filesystem
    - LP: #1063061

  [ Matthew Garrett ]

  * SAUCE: efi: Add support for a UEFI variable filesystem
    - LP: #1063061

  [ Sarveshwar Bandi ]

  * SAUCE: bridge: Pull ip header into skb->data before looking into ip
    header.
    - LP: #1065150

  [ Upstream Kernel Changes ]

  * Revert "drm/i915: correctly order the ring init sequence"
    - LP: #1066176
  * vfs: dcache: fix deadlock in tree traversal
    - LP: #1063761
  * dm mpath: only retry ioctl when no paths if queue_if_no_path set
    - LP: #1063761
  * dm: handle requests beyond end of device instead of using BUG_ON
    - LP: #1063761
  * dm table: clear add_random unless all devices have it set
    - LP: #1063761
  * dm verity: fix overflow check
    - LP: #1063761
  * usb: gadget: make g_printer enumerate again
    - LP: #1063761
  * usb: gadget: initialize the strings in tcm_usb_gadget properly
    - LP: #1063761
  * USB: option: blacklist QMI interface on ZTE MF683
    - LP: #1063761
  * USB: ftdi_sio: add TIAO USB Multi-Protocol Adapter (TUMPA) support
    - LP: #1063761
  * USB: qcaux: add Pantech vendor class match
    - LP: #1063761
  * usb: host: xhci: Fix Null pointer dereferencing with 71c731a for
    non-x86 systems
    - LP: #1063761
  * USB: serial: fix up bug with missing {}
    - LP: #1063761
  * staging: speakup_soft: Fix reading of init string
    - LP: #1063761
  * tty: keyboard.c: Remove locking from vt_get_leds.
  ...

Changed in linux (Ubuntu Quantal):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Changed in linux (Ubuntu):
status: Fix Committed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers