Comment 172 for bug 1065400

no secure boot.
the lenovo t530 is configured for UEFI booting and it works fine.

i dont use unity I hate it. I have always used gnome classic (3).
before the attempt to fix the bluetooth yesterday the bluetooth menu from
the wifi icon on the upper right task bar on Ubuntu 14 gnome 3 at least
showed bluetooth.

i could also start the applications->systems settings-> bluetooth and get
the gnome app and it would at least say there were previous pairing listed
on the left (even tho they would not allow data to be exchanged).

now in that left list it just says "bluetooth is disabled".

I go thru the usual rfkill stuff and all seems OK. the "new driver from
github" reports it is good now in dmesg.

but I cant find any way to "enable"

any ideas?

thanks
rich

On Fri, May 5, 2017 at 4:00 PM, Cruz Fernandez <email address hidden>
wrote:

> Another one, do you have Secure Boot enabled?
>
> Le ven. 5 mai 2017 à 18:55, Cruz Fernandez <email address hidden> a
> écrit :
>
> > Have you tried to use Unity instead of Gnome?
> > Le ven. 5 mai 2017 à 18:49, rich painter <email address hidden> a
> écrit :
> >
> >> I did this morning. unfortunately some strange side effect has
> completely
> >> disabled the bluetooth. I dont even see the Ubuntu bluetooth item on the
> >> wifi drop down menu at the upper right on the Gnome desktop. I have
> tried
> >> everything to "enable" bluetooth but to no avail.
> >>
> >> it seems the problem is now worse.
> >>
> >> any ideas?
> >>
> >> thanks
> >> rich
> >>
> >> On Fri, May 5, 2017 at 6:13 AM, Cruz Fernandez <
> <email address hidden>>
> >> wrote:
> >>
> >> > @painterengr have you tried to download the file from somewhere else?
> >> > https://github.com/winterheart/broadcom-bt-firmware/blob/master/brcm/
> >> > BCM20702A1-0a5c-21e6.hcd
> >> >
> >> > Hope this is not infringing any legal issues
> >> >
> >> > Le ven. 5 mai 2017 à 04:49, Jesse Sung <email address hidden> a
> >> > écrit :
> >> >
> >> > > @painterengr, sorry #165 is not a reply to your comment. It's just
> >> > > another related bug for lp:1065400 and I added it here for record.
> >> > >
> >> > > --
> >> > > You received this bug notification because you are subscribed to the
> >> bug
> >> > > report.
> >> > > https://bugs.launchpad.net/bugs/1065400
> >> > >
> >> > > Title:
> >> > > Support for loading Broadcom bluetooth firmware
> >> > >
> >> > > Status in linux package in Ubuntu:
> >> > > Fix Released
> >> > > Status in linux source package in Precise:
> >> > > Fix Released
> >> > > Status in linux source package in Quantal:
> >> > > Fix Released
> >> > > Status in linux source package in Raring:
> >> > > Fix Released
> >> > > Status in linux source package in Saucy:
> >> > > Fix Released
> >> > > Status in linux source package in Trusty:
> >> > > Confirmed
> >> > >
> >> > > Bug description:
> >> > > Broadcom bluetooth chips require a tool called patchram uploader
> [1]
> >> > > to load firmware. This applies to at least BCM20702 and BCM43142.
> >> > > Although some of the devices have an OTPROM that contains required
> >> > > firmware, but it is found that these devices would not have
> HFP/HSP
> >> > > support unless a upgraded firmware is loaded via patchram
> uploader.
> >> > >
> >> > > This tool requires hci device to do the firmware loading, but this
> >> may
> >> > > cause some race condition between patchram tool and bluetoothd or
> >> > > something that also works on hci interface.
> >> > >
> >> > > Also it needs some hooks to make firmware loads after bootup, s3,
> >> s4,
> >> > > rfkill, and device hotplug events. Implement this loader in kernel
> >> > > module would make things more easier.
> >> > >
> >> > > [1] http://marc.info/?l=linux-bluetooth&m=132039175324993&w=2
> >> > >
> >> > > To manage notifications about this bug go to:
> >> > > https://bugs.launchpad.net/ubuntu/+source/linux/+bug/
> >> > 1065400/+subscriptions
> >> > >
> >> >
> >> > --
> >> > You received this bug notification because you are subscribed to the
> bug
> >> > report.
> >> > https://bugs.launchpad.net/bugs/1065400
> >> >
> >> > Title:
> >> > Support for loading Broadcom bluetooth firmware
> >> >
> >> > Status in linux package in Ubuntu:
> >> > Fix Released
> >> > Status in linux source package in Precise:
> >> > Fix Released
> >> > Status in linux source package in Quantal:
> >> > Fix Released
> >> > Status in linux source package in Raring:
> >> > Fix Released
> >> > Status in linux source package in Saucy:
> >> > Fix Released
> >> > Status in linux source package in Trusty:
> >> > Confirmed
> >> >
> >> > Bug description:
> >> > Broadcom bluetooth chips require a tool called patchram uploader [1]
> >> > to load firmware. This applies to at least BCM20702 and BCM43142.
> >> > Although some of the devices have an OTPROM that contains required
> >> > firmware, but it is found that these devices would not have HFP/HSP
> >> > support unless a upgraded firmware is loaded via patchram uploader.
> >> >
> >> > This tool requires hci device to do the firmware loading, but this
> may
> >> > cause some race condition between patchram tool and bluetoothd or
> >> > something that also works on hci interface.
> >> >
> >> > Also it needs some hooks to make firmware loads after bootup, s3,
> s4,
> >> > rfkill, and device hotplug events. Implement this loader in kernel
> >> > module would make things more easier.
> >> >
> >> > [1] http://marc.info/?l=linux-bluetooth&m=132039175324993&w=2
> >> >
> >> > To manage notifications about this bug go to:
> >> > https://bugs.launchpad.net/ubuntu/+source/linux/+bug/
> >> > 1065400/+subscriptions
> >> >
> >>
> >>
> >> --
> >> Richard A. Painter, P.E.
> >>
> >> --
> >> You received this bug notification because you are subscribed to the bug
> >> report.
> >> https://bugs.launchpad.net/bugs/1065400
> >>
> >> Title:
> >> Support for loading Broadcom bluetooth firmware
> >>
> >> Status in linux package in Ubuntu:
> >> Fix Released
> >> Status in linux source package in Precise:
> >> Fix Released
> >> Status in linux source package in Quantal:
> >> Fix Released
> >> Status in linux source package in Raring:
> >> Fix Released
> >> Status in linux source package in Saucy:
> >> Fix Released
> >> Status in linux source package in Trusty:
> >> Confirmed
> >>
> >> Bug description:
> >> Broadcom bluetooth chips require a tool called patchram uploader [1]
> >> to load firmware. This applies to at least BCM20702 and BCM43142.
> >> Although some of the devices have an OTPROM that contains required
> >> firmware, but it is found that these devices would not have HFP/HSP
> >> support unless a upgraded firmware is loaded via patchram uploader.
> >>
> >> This tool requires hci device to do the firmware loading, but this may
> >> cause some race condition between patchram tool and bluetoothd or
> >> something that also works on hci interface.
> >>
> >> Also it needs some hooks to make firmware loads after bootup, s3, s4,
> >> rfkill, and device hotplug events. Implement this loader in kernel
> >> module would make things more easier.
> >>
> >> [1] http://marc.info/?l=linux-bluetooth&m=132039175324993&w=2
> >>
> >> To manage notifications about this bug go to:
> >>
> >> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/
> 1065400/+subscriptions
> >>
> >
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1065400
>
> Title:
> Support for loading Broadcom bluetooth firmware
>
> Status in linux package in Ubuntu:
> Fix Released
> Status in linux source package in Precise:
> Fix Released
> Status in linux source package in Quantal:
> Fix Released
> Status in linux source package in Raring:
> Fix Released
> Status in linux source package in Saucy:
> Fix Released
> Status in linux source package in Trusty:
> Confirmed
>
> Bug description:
> Broadcom bluetooth chips require a tool called patchram uploader [1]
> to load firmware. This applies to at least BCM20702 and BCM43142.
> Although some of the devices have an OTPROM that contains required
> firmware, but it is found that these devices would not have HFP/HSP
> support unless a upgraded firmware is loaded via patchram uploader.
>
> This tool requires hci device to do the firmware loading, but this may
> cause some race condition between patchram tool and bluetoothd or
> something that also works on hci interface.
>
> Also it needs some hooks to make firmware loads after bootup, s3, s4,
> rfkill, and device hotplug events. Implement this loader in kernel
> module would make things more easier.
>
> [1] http://marc.info/?l=linux-bluetooth&m=132039175324993&w=2
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/
> 1065400/+subscriptions
>

--
Richard A. Painter, P.E.