Ubuntu

168c:002b eMachines e525 Ubuntu cant connect to wifi repeater

Reported by Kangarooo Jānis on 2012-10-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned

Bug Description

I have TL-WR340G router my repeater TL-WA500G set up to work BUT works with Windows, and Android, but not in Ubuntu. For 1/2 year I've tried different settings and setups using not bridge not repeater but universal repeater setting. So now i have HEX 128bit open WEP key (of course my repeater has only wep repeating or no key repeating function) and repeater has same HEX 128bit open WEP. Android was always even with non-compatible options able to connect. Like Hex key shared repeated open but on Android i put ASCII. Now i just tried on Windows and its working. So theres big problem in Ubuntu- cant connect no way to repeater.

https://support.gateway.com/us/en/emac/product/default.aspx?modelId=1257

From Wifi )) 25m )) Repeater )) 5m )) Laptop

I don't use MAC filtering QoS/WMM
And all is default

====================ROUTER: TL-WR340G
Latest firmware
Status
Firmware Version:
4.7.8 Build 100920 Rel.50756n
Hardware Version:
WR340G v5 0815311C
LAN
MAC Address:
74-EA-3A-C0-2E-94
IP Address:
192.168.1.1
Subnet Mask:
255.255.255.0
Wireless
Wireless Radio: Enable
SSID: Gints26
Channel: 13
Mode: 54Mbps (802.11g)
MAC Address: 74-EA-3A-C0-2E-94
IP Address: 192.168.1.1

WEP OPEN HEX 128-bit 3164726F7361327061726F6C65
Even when change to ASCII doesn't matter.

MTU Size (in bytes): The default is 1500.

Address Lease Time: 120 Default

Firewall is not on

Cant find Beacon Interval

====================REPEATER:

Status
Firmware Version:
4.3.3 Build 120727 Rel.56693n
Hardware Version:
WA500G v1 0815311C
LAN
MAC Address:
74-EA-3A-B7-B9-D9
IP Address:
192.168.1.254
Subnet Mask:
255.255.255.0
Wireless
Operating Mode: Universal Repeater
Signal: 25 dB
SSID: Gints26
Channel: 13
Mode: 54Mbps (802.11g) Sometimes jumps to 11Mbps(802.11b)
MAC Address: 74-EA-3A-B7-B9-D9
IP Address: 192.168.1.254

WEP OPEN HEX 128-bit 3164726F7361327061726F6C65
Even when change to ASCII doesn't matter.

Address Lease Time: 120 Default

RTS Threshold: 2346
Fragmentation Threshold: 2346
Beacon Interval: 100
Power: MAX

These are off:
 Enable WMM
 Enable AP Isolation
 Disable short preamble

WIFI Bug_Report_Minimum_Requirement_Information
https://wiki.ubuntu.com/Kernel/LinuxWireless#Bug_Report_Minimum_Requirement_Information

1. eMachines e525
2. No
3. Thats in top of this bug already
4. Yes- any Ubuntu version
5. 3-4 meters
6. Theres nothing in the way. WIfi is on a wardrobe.
    A. no
7. No
8. No regression- it happens in 10.04 and 12.04
9. Yes
10. Yes using http://support.gateway.com/us/en/emac/product/default.aspx?tab=1&modelId=1257 Wireless LAN Driver Atheros 7.7.0.348 5.7 MB 08/10/2010 from there in Ndiswrapper netathw.inf
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 0c:ee:e6:c5:3b:43 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.102/24 brd 192.168.1.255 scope global wlan0
    inet6 fe80::eee:e6ff:fec5:3b43/64 scope link
       valid_lft forever preferred_lft forever
wlan0 IEEE 802.11g ESSID:"Kangarooo"
          Mode:Managed Frequency:2.472 GHz Access Point: 2C:B0:5D:49:0E:7A
          Bit Rate=54 Mb/s
          Power Management:off
          Link Quality:90/100 Signal level:-38 dBm Noise level:-96 dBm
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0
tail /etc/network/interfaces
auto lo
iface lo inet loopback

11. Not
12. Not

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: linux-image-2.6.32-43-generic 2.6.32-43.97
Regression: No
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.32-43.97-generic 2.6.32.59+drm33.24
Uname: Linux 2.6.32-43-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC272 Analog [ALC272 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC272 Analog [ALC272 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: kangarooo 1287 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0x96700000 irq 22'
   Mixer name : 'Realtek ALC272'
   Components : 'HDA:10ec0272,10250212,00100001'
   Controls : 16
   Simple ctrls : 9
Date: Wed Oct 10 22:57:45 2012
HibernationDevice: RESUME=UUID=1d85bad1-8614-4df4-85f7-36f5c250068e
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Release i386 (20100429.4)
MachineType: eMachines eMachines E525
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-43-generic root=UUID=830d5829-198b-4ac4-9a58-18383e36bace ro quiet splash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
RelatedPackageVersions: linux-firmware 1.34.14
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
dmi.bios.date: 11/04/2010
dmi.bios.vendor: eMachines
dmi.bios.version: V3.10
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: eMachines E525
dmi.board.vendor: eMachines
dmi.board.version: V3.10
dmi.chassis.type: 10
dmi.chassis.vendor: eMachines
dmi.chassis.version: V3.10
dmi.modalias: dmi:bvneMachines:bvrV3.10:bd11/04/2010:svneMachines:pneMachinesE525:pvrV3.10:rvneMachines:rneMachinesE525:rvrV3.10:cvneMachines:ct10:cvrV3.10:
dmi.product.name: eMachines E525
dmi.product.version: V3.10
dmi.sys.vendor: eMachines

Kangarooo Jānis (kangarooo) wrote :
description: updated
description: updated
Changed in linux (Ubuntu):
status: New → Confirmed
description: updated
description: updated

Kangarooo, thank you for reporting this and helping make Ubuntu better. Could you please provide the information following https://wiki.ubuntu.com/Kernel/LinuxWireless#Bug_Report_Minimum_Requirement_Information ?

tags: added: precise
Changed in linux (Ubuntu):
importance: Undecided → High
status: Confirmed → Incomplete
Kangarooo Jānis (kangarooo) wrote :

I can post but it wont help couse Android and Windows can connect but Ubuntu only on one specific strande combination was working and disconnecting often.

description: updated
description: updated
description: updated
description: updated
description: updated
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
description: updated
summary: - Ubuntu 10.04 cant connect to wifi repeater
+ [ASUS Eee PC X101] Ubuntu cant connect to wifi repeater
summary: - [ASUS Eee PC X101] Ubuntu cant connect to wifi repeater
+ 168c:002b [ASUS Eee PC X101] Ubuntu cant connect to wifi repeater
summary: - 168c:002b [ASUS Eee PC X101] Ubuntu cant connect to wifi repeater
+ 168c:002b eMachines e525 Ubuntu cant connect to wifi repeater

Kangarooo, regarding your Bug Description:
>"9. Yes"

Quoting from https://wiki.ubuntu.com/Kernel/LinuxWireless :
"9. Does this problem occur in the newest mainline kernel following https://wiki.ubuntu.com/Kernel/MainlineBuilds? Please mention what specific version of the mainline kernel you tested with in your report."

description: updated
Changed in linux (Ubuntu):
status: Expired → Incomplete
description: updated
description: updated
Kangarooo Jānis (kangarooo) wrote :

That was the one with report.
I can test again but then to test correctly i need to remove ndiswrapper.
So ill do sudo apt-get purge ndiswrapper
how to revert sudo ndiswrapper -m ? ill put this to that wiki.
in gksudo gedit /etc/modules remove line ndiswrapper
and in
sudo gedit /etc/modprobe.d/blacklist.conf remove lines

blacklist ath_pci
blacklist ath_hal
blacklist ath9k

Thats all i think yes?
Then kernel will work again after reboot

Kangarooo Jānis (kangarooo) wrote :

And sudo apt-get purge ndisgtk

Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
Changed in linux (Ubuntu):
status: Expired → Confirmed

Kangarooo Jānis, could you please confirm this issue exists with the latest development release of Ubuntu (Saucy Salamander)? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ . If the issue remains, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available (v3.10-rc3-saucy) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the kernel in the mainline kernels archive directory daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.10-rc3

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

If you are unable to test the mainline kernel, please comment as to why specifically you were unable to test it and add the following tags:
kernel-unable-to-test-upstream
kernel-unable-to-test-upstream-VERSION-NUMBER

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: latest-bios-v3.10
description: updated
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers