Ubuntu

Lenovo S10-3 cannot wake up from suspend to RAM

Reported by Ivan Osadchii on 2012-10-10
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linux
Confirmed
Medium
linux (Ubuntu)
Medium
Unassigned
Precise
Undecided
Tim Gardner
Quantal
Medium
Unassigned

Bug Description

When I do `sudo pm-suspend` system goes to sleep without problems.

When I try to wake it by hitting space it cannot resume:
- power led changes from blinking to 'on'
- hdd led flashes shortly and then turns off
- wireless led never turns on
- screen stays black
- keyboard leds don't work, trying to `touch ~/test` fails - it's obviously not a backlight related bug
- after ~10sec cpu fan starts spinning fast

If I add hpet=disable kernel parameter the system can suspend/resume normally. But it doesn't make sense since CPUs are prevented from entering C1-C4 states and stay in POLL mode which means greater power consumption.

As for kernel versions: checked it in 3.2.0-31 and 3.6.1 from http://kernel.ubuntu.com/~kernel-ppa/mainline/ - both show identical symptoms and for both the workaround with hpet=disable works.

What is interesting - hibernate works just fine.

There is a similar bug https://bugs.launchpad.net/ubuntu/+source/hibernate/+bug/992229
It's marked as 'fix commited' but it either uses different hardware configuration or it's not fixed in fact. Anyway the bug is still present in the latest mainline kernel build.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-31-generic-pae 3.2.0-31.50
ProcVersionSignature: Ubuntu 3.2.0-31.50-generic-pae 3.2.28
Uname: Linux 3.2.0-31-generic-pae i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC272 Analog [ALC272 Analog]
   Subdevices: 0/1
   Subdevice #0: subdevice #0
ApportVersion: 2.0.1-0ubuntu13
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC272 Analog [ALC272 Analog]
   Subdevices: 0/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ivan 2266 F.... pulseaudio
 /dev/snd/pcmC0D0c: ivan 2266 F...m pulseaudio
 /dev/snd/pcmC0D0p: ivan 2266 F...m pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0x40100000 irq 45'
   Mixer name : 'Realtek ALC272'
   Components : 'HDA:10ec0272,17aa4004,00100001'
   Controls : 17
   Simple ctrls : 9
CurrentDmesg: [ 45.405295] [drm] Changing LVDS panel from (-hsync, -vsync) to (+hsync, +vsync)
Date: Wed Oct 10 17:07:19 2012
HibernationDevice: RESUME=UUID=84340472-1f79-4996-88ee-21645d14ab71
InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release i386 (20120822.4)
MachineType: LENOVO S10-3
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-31-generic-pae root=UUID=d63f6032-14a5-4fbc-8a91-3bd250af2d36 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-31-generic-pae N/A
 linux-backports-modules-3.2.0-31-generic-pae N/A
 linux-firmware 1.79.1
SourcePackage: linux
StagingDrivers: zram
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/23/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 2ACN37WW
dmi.board.name: Mariana3A
dmi.board.vendor: Lenovo
dmi.board.version: Rev 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Lenovo
dmi.chassis.version: Rev 1.0
dmi.modalias: dmi:bvnLENOVO:bvr2ACN37WW:bd09/23/2010:svnLENOVO:pnS10-3:pvrLenovo:rvnLenovo:rnMariana3A:rvrRev1.0:cvnLenovo:ct10:cvrRev1.0:
dmi.product.name: S10-3
dmi.product.version: Lenovo
dmi.sys.vendor: LENOVO

Ivan Osadchii (tepoga) wrote :
Brad Figg (brad-figg) on 2012-10-10
Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report[0]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

Please follow the instructions on the wiki page[0]. The first step is to email the appropriate mailing list. If no response is received, then a bug may be opened on bugzilla.kernel.org.

[0] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
tags: added: kernel-bug-exists-upstream
Ivan Osadchii (tepoga) wrote :

It seems that this exactly problem is discussed here https://bugzilla.kernel.org/show_bug.cgi?id=41932
I referenced this bugreport there.

Reading through it revealed one more workaround: you can add "intel_idle.max_cstate=3" to kernel parameters. This will allow CPU to enter C1-C2 and suspend/resume will also work

Also there is a patch (https://bugzilla.kernel.org/show_bug.cgi?id=41932#c22) which I was able to apply to kernel 3.6.1 and have the suspend problem fixed. I'm attaching it here just in case (for some reason the patch misses a closing bracket, had to add it by hand)

tags: added: patch
Joseph Salisbury (jsalisbury) wrote :

Awaiting for patch to get accepted in the upstream tree, per comment #29 in the upstream bug.

Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
Tim Gardner (timg-tpi) on 2012-10-12
Changed in linux (Ubuntu Quantal):
status: Triaged → Fix Released
Changed in linux (Ubuntu Precise):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
Tim Gardner (timg-tpi) on 2012-10-15
Changed in linux (Ubuntu Precise):
status: In Progress → Fix Committed
Joseph Salisbury (jsalisbury) wrote :

I built a Precise test kernel with commit a6371f8 applied.

The test kernel can be dowloaded from:
http://people.canonical.com/~jsalisbury/lp1065076/

Can you test this kernel and report back if it has the bug or not?

Can you build a kernel for 13.04 which I can test? I'm suffering from this bug, too.

Tim Gardner (timg-tpi) wrote :

Marking "Won't Fix" for Precise 3.2 since any of the LTS contain the fix.

Changed in linux (Ubuntu Precise):
status: Fix Committed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.