Precise update to 3.2.31 stable release

Bug #1065047 reported by Herton R. Krzesinski on 2012-10-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Precise
Medium
Herton R. Krzesinski

Bug Description

SRU Justification

    Impact:
       The upstream process for stable tree updates is quite similar
       in scope to the Ubuntu SRU process, e.g., each patch has to
       demonstrably fix a bug, and each patch is vetted by upstream
       by originating either directly from Linus' tree or in a minimally
       backported form of that patch. The 3.2.31 upstream stable
       patch set is now available. It should be included in the Ubuntu
       kernel as well.

       git://git.kernel.org/

    TEST CASE: TBD

       The following patches are in the 3.2.31 stable release:

target: Fix ->data_length re-assignment bug with SCSI overflow
ASoC: samsung dma - Don't indicate support for pause/resume.
fs/proc: fix potential unregister_sysctl_table hang
mm/ia64: fix a memory block size bug
nbd: clear waiting_queue on shutdown
drivers/rtc/rtc-twl.c: ensure all interrupts are disabled during probe
mm/page_alloc: fix the page address of higher page's buddy calculation
memory hotplug: fix section info double registration bug
cciss: fix handling of protocol error
vfs: dcache: use DCACHE_DENTRY_KILLED instead of DCACHE_DISCONNECTED in d_kill()
workqueue: reimplement work_on_cpu() using system_wq
cpufreq/powernow-k8: workqueue user shouldn't migrate the kworker to another CPU
sched: Fix ancient race in do_exit()
hpwdt: Fix kdump issue in hpwdt
rtlwifi: rtl8192ce: Log message that B_CUT device may not work
brcmfmac: fix big endian bug in i-scan.
brcmfmac: Fix big endian host configuration data.
dmaengine: at_hdmac: fix comment in atc_prep_slave_sg()
dmaengine: at_hdmac: check that each sg data length is non-null
ARM: 7532/1: decompressor: reset SCTLR.TRE for VMSA ARMv7 cores
drm/i915: Reduce a pin-leak BUG into a WARN
drm/i915: HDMI - Clear Audio Enable bit for Hot Plug
bnx2i: Fixed NULL ptr deference for 1G bnx2 Linux iSCSI offload
mpt2sas: Fix for issue - Unable to boot from the drive connected to HBA
hwmon: (ads7871) Add 'name' sysfs attribute
DMA: PL330: Check the pointer returned by kzalloc
hpsa: fix handling of protocol error
hwmon: (ad7314) Add 'name' sysfs attribute
cifs: fix return value in cifsConvertToUTF16
cfg80211: fix possible circular lock on reg_regdb_search()
xen/boot: Disable BIOS SMP MP table search.
asix: Support DLink DUB-E100 H/W Ver C1
Input: i8042 - disable mux on Toshiba C850D
tracing: Don't call page_to_pfn() if page is NULL
can: janz-ican3: fix support for older hardware revisions
can: ti_hecc: fix oops during rmmod
HID: logitech: fix mask to enable DJ mode
HID: logitech: don't use stack based dj_report structures
dj: memory scribble in logi_dj
HID: Fix logitech-dj: missing Unifying device issue
hwmon: (fam15h_power) Tweak runavg_range on resume
xen/boot: Disable NUMA for PV guests.
gpio-lpc32xx: Fix value handling of gpio_direction_output()
sb_edac: Avoid overflow errors at memory size calculation
dm: handle requests beyond end of device instead of using BUG_ON
dm table: clear add_random unless all devices have it set
md/raid10: fix "enough" function for detecting if array is failed.
USB: Fix race condition when removing host controllers
asus-laptop: HRWS/HWRS typo
Bluetooth: btusb: Add vendor specific ID (0a5c:21f4) BCM20702A0
Bluetooth: Use USB_VENDOR_AND_INTERFACE() for Broadcom devices
Bluetooth: Add support for Apple vendor-specific devices
net: Statically initialize init_net.dev_base_head
Fix a dead loop in async_synchronize_full()
rds: set correct msg_namelen
Prevent interface errors with Seagate FreeAgent GoFlex
mmc: Prevent 1.8V switch for SD hosts that don't support UHS modes.
Bluetooth: Change signature of smp_conn_security()
Bluetooth: Fix sending a HCI Authorization Request over LE links
pch_uart: Add eg20t_port lock field, avoid recursive spinlocks
irq_remap: disable IRQ remapping if any IOAPIC lacks an IOMMU
vfs: dcache: fix deadlock in tree traversal
usb: gadget: dummy_hcd: fixup error probe path
CPU hotplug, cpusets, suspend: Don't modify cpusets during suspend/resume
Revert "drm/radeon: rework pll selection (v3)"
x86/alternatives: Fix p6 nops on non-modular kernels
HID: hidraw: add proper error handling to raw event reporting
HID: fix return value of hidraw_report_event() when !CONFIG_HIDRAW
HID: hidraw: fix list->buffer memleak
HID: hidraw: improve error handling in hidraw_init()
HID: hidraw: don't deallocate memory when it is in use
PCI: acpiphp: check whether _ADR evaluation succeeded
bnx2x: fix rx checksum validation for IPv6
xfrm: Workaround incompatibility of ESN and async crypto
xfrm_user: return error pointer instead of NULL
xfrm_user: return error pointer instead of NULL #2
xfrm: fix a read lock imbalance in make_blackhole
xfrm_user: fix info leak in copy_to_user_auth()
xfrm_user: fix info leak in copy_to_user_state()
xfrm_user: fix info leak in copy_to_user_policy()
xfrm_user: fix info leak in copy_to_user_tmpl()
xfrm_user: don't copy esn replay window twice for new states
xfrm_user: ensure user supplied esn replay window is valid
net: ethernet: davinci_cpdma: decrease the desc count when cleaning up the remaining packets
ixp4xx_hss: fix build failure due to missing linux/module.h inclusion
netxen: check for root bus in netxen_mask_aer_correctable
net-sched: sch_cbq: avoid infinite loop
pkt_sched: fix virtual-start-time update in QFQ
sierra_net: Endianess bug fix.
8021q: fix mac_len recomputation in vlan_untag()
ipv6: release reference of ip6_null_entry's dst entry in __ip6_del_rt
tcp: flush DMA queue before sk_wait_data if rcv_wnd is zero
sctp: Don't charge for data in sndbuf again when transmitting packet
pppoe: drop PPPOX_ZOMBIEs in pppoe_release
net: small bug on rxhash calculation
net: guard tcp_set_keepalive() to tcp sockets
ipv4: raw: fix icmp_filter()
ipv6: raw: fix icmpv6_filter()
ipv6: mip6: fix mip6_mh_filter()
l2tp: fix a typo in l2tp_eth_dev_recv()
netrom: copy_datagram_iovec can fail
net: do not disable sg for packets requiring no checksum
aoe: assert AoE packets marked as requiring no checksum
tg3: Fix TSO CAP for 5704 devs w / ASF enabled
Bluetooth: Support AR3011 in Acer Iconia Tab W500
Bluetooth: add support for atheros 0930:0219
Bluetooth: add support for atheros 0489:e057
Bluetooth: Add support for Sony Vaio T-Series
Linux 3.2.31

These patches were not applied as they were already in Precise master-next:
drm/i915: HDMI - Clear Audio Enable bit for Hot Plug
Bluetooth: btusb: Add vendor specific ID (0a5c:21f4) BCM20702A0
Bluetooth: Use USB_VENDOR_AND_INTERFACE() for Broadcom devices
rds: set correct msg_namelen
tg3: Fix TSO CAP for 5704 devs w / ASF enabled
Bluetooth: Add support for Sony Vaio T-Series

This needed a rediff (context update) to be applied:
xen/boot: Disable NUMA for PV guests.

tags: added: kernel-stable-tracking-bug
Changed in linux (Ubuntu):
status: New → Invalid
Changed in linux (Ubuntu Precise):
status: New → Fix Committed
importance: Undecided → Medium
assignee: nobody → Herton R. Krzesinski (herton)
description: updated
Launchpad Janitor (janitor) wrote :
Download full text (9.1 KiB)

This bug was fixed in the package linux - 3.2.0-33.52

---------------
linux (3.2.0-33.52) precise-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1067666

  [ Andy Whitcroft ]

  * [Config] add fs/udf to linux-image to support DVD/CD formats in virtual
    instances
    - LP: #1066921

  [ James M Leddy ]

  * SAUCE: input: fix weird issue of synaptics psmouse sync lost after
    resume
    - LP: #717970

  [ Paolo Pisati ]

  * [SRU] [Config] enable TIDSPBRIDGE for omap arm[el|hf] flavours
    - LP: #1058022

  [ Sarveshwar Bandi ]

  * SAUCE: bridge: Pull ip header into skb->data before looking into ip
    header.
    - LP: #1065150

  [ Upstream Kernel Changes ]

  * Revert "drm/radeon: rework pll selection (v3)"
    - LP: #1065047
  * sched: Fix migration thread runtime bogosity
    - LP: #1057593
  * Bluetooth: Add support for Sony Vaio T-Series
    - LP: #1054307
  * drm/radeon: properly handle mc_stop/mc_resume on evergreen+ (v2)
    - LP: #1058303
  * Bluetooth: Use USB_VENDOR_AND_INTERFACE() for Broadcom devices
    - LP: #1058303
  * Bluetooth: Add USB_VENDOR_AND_INTERFACE_INFO() for Broadcom/Foxconn
    - LP: #1030233, #1058303
  * target: Fix ->data_length re-assignment bug with SCSI overflow
    - LP: #1065047
  * ASoC: samsung dma - Don't indicate support for pause/resume.
    - LP: #1065047
  * fs/proc: fix potential unregister_sysctl_table hang
    - LP: #1065047
  * mm/ia64: fix a memory block size bug
    - LP: #1065047
  * nbd: clear waiting_queue on shutdown
    - LP: #1065047
  * drivers/rtc/rtc-twl.c: ensure all interrupts are disabled during probe
    - LP: #1065047
  * mm/page_alloc: fix the page address of higher page's buddy calculation
    - LP: #1065047
  * memory hotplug: fix section info double registration bug
    - LP: #1065047
  * cciss: fix handling of protocol error
    - LP: #1065047
  * vfs: dcache: use DCACHE_DENTRY_KILLED instead of DCACHE_DISCONNECTED in
    d_kill()
    - LP: #1065047
  * workqueue: reimplement work_on_cpu() using system_wq
    - LP: #1065047
  * cpufreq/powernow-k8: workqueue user shouldn't migrate the kworker to
    another CPU
    - LP: #1065047
  * sched: Fix ancient race in do_exit()
    - LP: #1065047
  * hpwdt: Fix kdump issue in hpwdt
    - LP: #1065047
  * rtlwifi: rtl8192ce: Log message that B_CUT device may not work
    - LP: #1065047
  * brcmfmac: fix big endian bug in i-scan.
    - LP: #1065047
  * brcmfmac: Fix big endian host configuration data.
    - LP: #1065047
  * dmaengine: at_hdmac: fix comment in atc_prep_slave_sg()
    - LP: #1065047
  * dmaengine: at_hdmac: check that each sg data length is non-null
    - LP: #1065047
  * ARM: 7532/1: decompressor: reset SCTLR.TRE for VMSA ARMv7 cores
    - LP: #1065047
  * drm/i915: Reduce a pin-leak BUG into a WARN
    - LP: #1065047
  * bnx2i: Fixed NULL ptr deference for 1G bnx2 Linux iSCSI offload
    - LP: #1065047
  * mpt2sas: Fix for issue - Unable to boot from the drive connected to HBA
    - LP: #1065047
  * hwmon: (ads7871) Add 'name' sysfs attribute
    - LP: #1065047
  * DMA: PL330: Check the pointer returned by kzalloc
    - LP: #1065047
  * hpsa: fix handling of protocol error
    -...

Read more...

Changed in linux (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers