keyboard timing is broken

Bug #106427 reported by handy on 2007-04-14
8
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

xUbuntu install i386 .iso downloaded 13.4.2007

Motherboard: Gigabyte GA-K8NS Ultra-939

Had the same problem with Edgy & now with Feisty:

Problem:

Keyboard timing is out, when typing it lags & then runs ahead, resulting in the following:

Typpppiiiinnng wwwilllll llloooook likkkkkkkeeee thhiissssss....

I used Edgy for some weeks after it's release, I just typed slower & put up with the problem hoping for a bug fix, then went back to Dapper. Feisty is even worse, I can not use it at all on the Gigabyte board.

As a side note, thanks to all involved, Feisty has been working beautifully on an old Asus A7N-266 VM board, which FreeBSD has a hell of a time with! :-)

handy (greghand) wrote :

I should have mentioned that I have tested this with multiple keyboards, one being brand new.

Also, have used a variety of OS's on this same machine with no problems, specifically no keyboard problems.

I've encountered the same bug. However I've been running Ubuntu (Kubuntu more specifically) since Dapper and have not had this problem. This bug just came up around a week ago in Fiesty.

The thing is it happens completely randomly. I'll be doing something on the computer and suddenly the bug appears, and then any key I press takes forever to respond. I have to hold the key down for almost 2 seconds to get it to respond.

I also noticed that if I CLTR+ALT+F1 into a terminal then this bug stops affecting me, but if I go back into the xserver session then the bug reapears again.

handy (greghand) wrote :

Your bug behaves differently than mine OuchOfDeath.

Out of interest what kind of motherboard are you using?

I have an Abit KV8 Pro. (VIA 8237 Chipset)

Nanley Chery (nanoman) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

handy (greghand) wrote :

This bug still exists, though it no longer bothers me, as after discovering that it is caused by an incompatibility of sorts with the on board USB, I turned off the on board USB via the BIOS, & installed a PCI USB card.

Sabayon Linux 3.4e, & f, shares the same bug.

So, the bug does still exist, but a fairly simple & cheap (depending on where in the world you live) workaround is available.

This bug still exists. Search for keyboard lag on the Ubuntu forums. I'm using a Toshiba Satellite. Just upgraded from 7.04 to 7.10. Suddenly (after a year on 7.04 with no issues), the keyboard doesn't work (keys are unresponsive sometimes and at other times repeat). I have turned off the Kubuntu power manager in the task bar and I think that helps a little (repeat doesn't happen, but lag still does).

A search through Ubuntu indicates that this problem has occurred on laptops dating back to 2.6.15 kernel and now is showing up again in Gutsy for some laptop models.

I have similar issue on Ubuntu 8.04 2.6.24-19-generic #1 SMP Wed Jun 18 14:15:37 UTC 2008 x86_64 GNU/Linux

restarting X, or falling to console don't help(alt+ctrl+f1 did work after about a minute).

It's not only laptop problem.
My motherboard is Abit IP-35e, and keyboard is PS/2 Logitech "Internet Pro Keyboard"
It first appeared about 3weeks ago, I didn't have this issue earlier, and I use it with Ubuntu since Ubuntu 6.10, and even earlier I didn't have this problem with Mandriva 2006.
Lag occurs about two times a week, but I don't have idea how to trace it...using console with on screen keyboard is quite hard for me. Could you tell me how can I trace it?(because as far as I know it's almost impossible for programmers to fix a old bug which isn't reproducible, without any extra info)

Hi,

I can not help you with this problem, beyond saying that the problem I
experienced was due to the on board USB controller. I turned this
controller off in the BIOS, & installed a PCI USB card. This solved my
problem completely.

You may try turning off the USB controller on your machine to see if it
is responsible for your keyboard timing problem.

By the way, my keyboard was a PS/2, not a USB.

Strange bug I know.

I hope this helps you.

Regards,

handy

handy - I don't have such an option in my BIOS(anyway thank you for response I have read it just after you wrote it but I thought that answering to it then would be kind like a spam)
I haven't had that problem for a while, I don't remember when was last time when it occured, but hopefully it was solved by 2.6.27 kernel in ubuntu 8.10

Philip Muškovac (yofel) wrote :

Hi, first, sorry for the late response. We are closing this bug as the issue is resolved for the original reporter. If anyone can still reproduce this please file a new bug (everyone his own) by following
https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies

again, sorry for the late response and thanks for taking the time to report this bug and helping to make Ubuntu better. Please report any other bugs you may find.

affects: ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers