Ubuntu

[Asus M2N-SLI Deluxe] Suspend to RAM not working

Reported by Julien Aubin on 2012-09-27
This bug report is a duplicate of:  Bug #1171560: 10de:1183 Suspend to RAM is broken. Edit Remove
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Linux
New
Undecided
Unassigned
linux (Ubuntu)
Medium
Unassigned

Bug Description

Hello,

When suspending to RAM my computer it simply hangs. It is not suspended to RAM at all and there's no way to wake it up except hard reset.

This is a regression from Quantal Quetzal as the issue did not occur with Precise. I've done a fresh upgrade yesterday.

Steps to reproduce :
DO : suspend to RAM using pm-suspend or KDM
EXPECT : computer is properly suspended to RAM.
ACTUAL : computer hangs

WORKAROUND: Install 64-bit Ubuntu.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: linux-image-3.5.0-15-generic 3.5.0-15.23
ProcVersionSignature: Ubuntu 3.5.0-15.23-generic 3.5.4
Uname: Linux 3.5.0-15-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.5.2-0ubuntu4
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: julien 3359 F.... pulseaudio
 /dev/snd/controlC0: julien 3359 F.... pulseaudio
 /dev/snd/seq: timidity 3299 F.... timidity
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
Date: Thu Sep 27 20:04:54 2012
HibernationDevice: RESUME=UUID=1e2e6306-5da1-44ae-98dd-d137e96a8425
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.

 eth1 no wireless extensions.
Lsusb:
 Bus 002 Device 002: ID 046d:0928 Logitech, Inc. QuickCam Express
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: System manufacturer System Product Name
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcFB:

ProcKernelCmdLine: root=UUID=53dfbfeb-5955-48e2-9039-e6c3b9b219d0 ro quiet splash
PulseList:
 Error: command ['pacmd', 'list'] failed with exit code 1: Home directory /home/administrateur not ours.
 No PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-15-generic N/A
 linux-backports-modules-3.5.0-15-generic N/A
 linux-firmware 1.94
RfKill:

SourcePackage: linux
UpgradeStatus: Upgraded to quantal on 2012-09-26 (0 days ago)
WpaSupplicantLog:

dmi.bios.date: 10/02/2008
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: ASUS M2N-SLI DELUXE ACPI BIOS Revision 1701
dmi.board.name: M2N-SLI DELUXE
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: 1.XX
dmi.chassis.asset.tag: 123456789000
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvrASUSM2N-SLIDELUXEACPIBIOSRevision1701:bd10/02/2008:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnM2N-SLIDELUXE:rvr1.XX:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

Julien Aubin (gojulgarbmail) wrote :
Brad Figg (brad-figg) on 2012-09-27
Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.6 kernel[0] (Not a kernel in the daily directory) and install both the linux-image and linux-image-extra .deb packages.

Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. Please only remove that one tag and leave the other tags. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.6-rc7-quantal/

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: needs-bisect needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: needs-upstream-testingkernel-unable-to-test-upstream
removed: needs-upstream-testing
Julien Aubin (gojulgarbmail) wrote :

Issue still present with kernel 3.5.0-16-generic

tags: added: kernel-unable-to-test-upstream needs-upstream-testing
removed: needs-upstream-testingkernel-unable-to-test-upstream
Changed in linux (Ubuntu):
status: Incomplete → Triaged
tags: added: regression-release
Julien Aubin (gojulgarbmail) wrote :

Reopened the bug as it is not fixed in Raring. Thus it has a worse side effect, as it actually suspends the first hard disk of my computer but then hangs. So when I hard-reset, the first hard disk is still in state suspended, and is not shown at all in the BIOS until I switch power off and power on again and reconfigure the BIOS so that it appears again.

Maybe the issue only occurs on computers with several HDDs.

Changed in linux (Ubuntu):
status: Triaged → Confirmed
Julien Aubin (gojulgarbmail) wrote :

Hi,

Tried with latest kernel snapshot (3.9.0-rc6) and the bug is still present, so added the tag "kernel-bug-exist-upstream".

Rgds

tags: added: kernel-bug-exists-upstream raring
removed: kernel-unable-to-test-upstream needs-upstream-testing
Julien Aubin (gojulgarbmail) wrote :

Added file pm-suspend.log. You can see suspend attempts before and after my upgrade, all failed actually.

Julien Aubin (gojulgarbmail) wrote :

I upgraded my system to 64-bit and the bug no longer occurs (even without formatting). So I've very strong suspicion around something PAE-related...

Julien Aubin (gojulgarbmail) wrote :

Workaround there :
http://ubuntuforums.org/showthread.php?t=1978290

It'd be very nice that it is included within package pm-utils at least.

tags: added: bios-outdated-1804 needs-upstream-testing
description: updated
summary: - Suspend to RAM is broken
+ [Asus M2N-SLI Deluxe] Suspend to RAM not working
tags: added: needs-suspend-log resume suspend

Confirment bug. Distro : Kubuntu 13.10, same motherbord.
I have added the suspend log

Computers starts suspending, screens goes black with a cursos and hangs.
Hard reset is needed to use the computer again. Suspend did work in the past.

Julien Aubin, getting back to https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1057664/comments/7 would you need this addressed in i386 or may we close this as Status Invalid?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete

Christopher M. Penalver, I added it here because it is the same bug. If I made my own report it would be a duplicate of this one.
In addition to your question to julien aubin : I have a 64-bit install, so no the bug is not limited to 32-bit.

Julien Aubin (gojulgarbmail) wrote :

Hi,

Actually I'm not using any longer i386 release on this computer, but it is not fixed either on AMD64.

Bug this bug is a duplicate of bug 1237058 and marking it as duplicate (I provide a workaround in this bug)

Rgds,

Julien.

Julien Aubin (gojulgarbmail) wrote :

Sorry, the bug is actually not a duplicate.

Julien Aubin (gojulgarbmail) wrote :

Hi Rachelle,

Actually I've posted another bug related to this one, as linked in the report. There I provide a workaround to the bug (issued from kernel.org)

Rgds,

Julien Aubin, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the daily kernel folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.12-rc6

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: amd64 latest-bios-1701
removed: bios-outdated-1804
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

  • auto-joseph.salisbury Edit

Bug watches keep track of this bug in other bug trackers.