[Lenovo L530, 430, E49, K29, E535, E435, S430]: Media card reader [10ec:5229] does not work

Bug #1057089 reported by Jeff Marcom on 2012-09-26
74
This bug affects 13 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
James M. Leddy
Precise
High
Adam Lee
Quantal
High
Adam Lee

Bug Description

SRU Justification:

Impact: lots of systems' card reader don't work, block certification
Fix: backport the driver from upstream
Testcase: plug in the card, test the functionality. tested by adam(with e430) and certification team, all positive

---

Problem: Media cards (SD/SDHC/MMC) are not recognized when inserted.

Udevadm monitor and udisks show no signs of media being inserted or detected.

Release: 12.04.1

Kernel version: 3.2.0-30-generic #48-Ubuntu

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-30-generic 3.2.0-30.48
ProcVersionSignature: Ubuntu 3.2.0-30.48-generic 3.2.27
Uname: Linux 3.2.0-30-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu12
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: ALC269VC Analog [ALC269VC Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 1585 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0x92610000 irq 46'
   Mixer name : 'Intel PantherPoint HDMI'
   Components : 'HDA:10ec0269,17aa21f8,00100203 HDA:80862806,80860101,00100000'
   Controls : 36
   Simple ctrls : 13
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw unknown'
   Mixer name : 'ThinkPad EC (unknown)'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Wed Sep 26 14:25:14 2012
HibernationDevice: RESUME=UUID=f2450cbe-60bc-45ac-936f-57bc21ca63c6
InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release amd64 (20120823.1)
MachineType: LENOVO 814S12G
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-30-generic root=UUID=3fca65d4-bca0-49ae-a49d-0cca1641319c ro quiet splash initcall_debug vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-30-generic N/A
 linux-backports-modules-3.2.0-30-generic N/A
 linux-firmware 1.79
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
StagingDrivers: mei
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 03/28/2012
dmi.bios.vendor: LENOVO
dmi.bios.version: G3ET51WW(1.51)
dmi.board.asset.tag: Not Available
dmi.board.name: 814S12G
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvrG3ET51WW(1.51):bd03/28/2012:svnLENOVO:pn814S12G:pvrThinkPadL530:rvnLENOVO:rn814S12G:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 814S12G
dmi.product.version: ThinkPad L530
dmi.sys.vendor: LENOVO

Jeff Marcom (jeffmarcom) wrote :
tags: added: blocks-hwcert
Changed in linux (Ubuntu):
assignee: nobody → Canonical Hardware Enablement Team (canonical-hwe-team)
Brad Figg (brad-figg) on 2012-09-26
Changed in linux (Ubuntu):
status: New → Confirmed
Jeff Marcom (jeffmarcom) on 2012-09-26
tags: added: kernel-bug-exists-upstream
Changed in linux (Ubuntu):
importance: Undecided → Medium
summary: - [Lenovo L530]: Media card reader does not work
+ [Lenovo L530]: Media card reader [10ec:5229] does not work
Ara Pulido (ara) on 2012-10-08
tags: added: blocks-hwcert-enablement

On a Fujitsu u772 with 12.10 it also dont works

Anthony Wong (anthonywong) wrote :

Realtek has been working on submitting their driver to upstream: http://thread.gmane.org/gmane.linux.drivers.driver-project.devel/30356

James M. Leddy (jm-leddy) wrote :

We'll track progress in bug 931766

James M. Leddy (jm-leddy) wrote :

Please ignore comment #4, wrong bug

Jeff Marcom (jeffmarcom) on 2012-11-06
summary: - [Lenovo L530]: Media card reader [10ec:5229] does not work
+ [Lenovo L530, 430]: Media card reader [10ec:5229] does not work
Jeff Marcom (jeffmarcom) on 2012-11-29
summary: - [Lenovo L530, 430]: Media card reader [10ec:5229] does not work
+ [Lenovo L530, 430, E49, K29]: Media card reader [10ec:5229] does not
+ work

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux (Ubuntu Precise):
status: New → Confirmed
Ara Pulido (ara) on 2012-12-17
Changed in linux (Ubuntu):
importance: Medium → High
Jeff Marcom (jeffmarcom) on 2013-01-07
summary: - [Lenovo L530, 430, E49, K29]: Media card reader [10ec:5229] does not
- work
+ [Lenovo L530, 430, E49, K29, E535]: Media card reader [10ec:5229] does
+ not work

James -- Have a look at this bug, it does look like the driver has landed in staging. Given the amount of machines that require this driver that are blocked for certification we should investigate a backport, ideally to both quantal and precise.

--chris

Changed in linux (Ubuntu):
assignee: Canonical Hardware Enablement Team (canonical-hwe-team) → James M. Leddy (jm-leddy)
Changed in linux (Ubuntu Precise):
assignee: nobody → Canonical Hardware Enablement Team (canonical-hwe-team)
importance: Undecided → High
Changed in linux (Ubuntu Quantal):
importance: Medium → High
Anthony Wong (anthonywong) wrote :

Realtek has a driver in https://github.com/rspc/realtek_cr_mfd, and submitted to upstream: http://thread.gmane.org/gmane.linux.drivers.driver-project.devel/30356. It is now already in mainline.

Changed in linux (Ubuntu Precise):
assignee: Canonical Hardware Enablement Team (canonical-hwe-team) → Adam Lee (adam8157)
Changed in linux (Ubuntu Quantal):
assignee: Canonical Hardware Enablement Team (canonical-hwe-team) → Adam Lee (adam8157)
Adam Lee (adam8157) wrote :

upstream commit is 67d16a4686c9b94c8f52a66afe7521909aeb75b4, will build kernel packages to test.

Adam Lee (adam8157) wrote :

@anthonywong, we don't have these laptops in house, but I tested E430 and E530(with realtek 5229), this issue don't exist.

Is this fixed by https://bugs.launchpad.net/sutton/+bug/931766 ?

Adam Lee (adam8157) wrote :

Confirmed with our fresh install.

James M. Leddy (jm-leddy) wrote :

Hi Adam,

Bug 931766 is a dkms that we included with our preinstall machines. We haven't yet fully backported the new driver so it isn't working on some machines.

Adam Lee (adam8157) wrote :

Oops, I backaported that commit into 12.04.1 and 12.10(with my another patch), not working with 3.2 kernel, panic with 3.5 kernel.

And the most strange part is, it panic with upstream 3.8-rc3 kernel(no line modified by me).

So, it's a upstream bug, I will try to fix it or, an ugly way, port the staging driver(like dkms do, but in kernel src tree)

Adam Lee (adam8157) wrote :

PS, Contacted with the upstream developer, Wei Wang of Realtek.

He tested, my patch works with his hardware, he is looking at this issue.

The attachment "my another patch for porting" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Adam Lee (adam8157) wrote :

Submitted the staging driver of Precise to kernel team list, tested with E430, and works fine.

PS, still trying to catch the upstream driver's bug.

Adam Lee (adam8157) wrote :

Submitted the staging driver of Quantal to kernel team list, tested with E430, and works fine.

Changed in linux (Ubuntu Precise):
status: Confirmed → Fix Committed
Changed in linux (Ubuntu Quantal):
status: Confirmed → In Progress
Changed in linux (Ubuntu Precise):
status: Fix Committed → In Progress
Adam Lee (adam8157) wrote :

Ubuntu kernel team NAKed the staging driver, quoted as saying, "I'm not going to merge a driver that has been essentially abandoned, e.g., moved out of staging. I want the real thing that comes with upstream stable and security updates."

still debugging the upstream driver with realtek engineer

Adam Lee (adam8157) wrote :

Upstream author is trying to get a same hardware for debugging.

Jeff Marcom (jeffmarcom) on 2013-01-22
summary: - [Lenovo L530, 430, E49, K29, E535]: Media card reader [10ec:5229] does
- not work
+ [Lenovo L530, 430, E49, K29, E535, E435, S430]: Media card reader
+ [10ec:5229] does not work
Thomas (tom-rosary) wrote :

also effects Lenovo Ideacentre A720

Oleg Evnin (oleg-evnin) wrote :

also affects Compaq CQ45-803TU

Adam Lee (adam8157) wrote :

@Thomas and @Oleg, could you please check if the card reader working with newest upstream kernel under your hardware?

Anthony Wong (anthonywong) wrote :

@Thomas, Oleg
You can get the latest mainline kernel from http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.8-rc4-raring/. Get the linux-image-3.8.0-030800rc4-generic, linux-headers-3.8.0-030800rc4 and linux-headers-3.8.0-030800rc4-generic packages and the ones that correspond to the architecture (32/64-bit) of your system.

Thomas (tom-rosary) wrote :

installed linux-image-3.8.0-030800rc4-generic but can't test it cause my keyboard/mouse doesn't work

Thomas (tom-rosary) on 2013-01-23
tags: added: kernel-unable-to-test-upstream

On 01/23/2013 03:59 PM, Thomas wrote:
> installed linux-image-3.8.0-030800rc4-generic but can't test it cause my
> keyboard/mouse doesn't work

Hi Thomas -- Please grab linux-image-extras as well which is likely the
culprit here for your keyboard/mouse issue.

--chris

Dennis Kruyt (dennis-kruyt) wrote :

I just installed linux-image-3.8.0-030800rc4-generic but my RTS5229 doesnt seems to work om my Fujitsu U772

03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5229 PCI Express Card Reader (rev 01)
 Subsystem: Fujitsu Limited. Device 176b
 Flags: bus master, fast devsel, latency 0, IRQ 42
 Memory at f0400000 (32-bit, non-prefetchable) [size=4K]
 Capabilities: <access denied>
 Kernel driver in use: rtsx_pci
 Kernel modules: rtsx_pci

rspc (pclinux-realsil) wrote :

Hi Dennis:

What does it mean that RTS5229 doesn't work? SD card can't be recognized when inserted? Or the kernel will crash?
If SD card can't be recongized, please tell me the exact model of your SD card.

Thomas (tom-rosary) wrote :

even with linux-image-extras can't use mouse/keyboard

Thomas (tom-rosary) wrote :

sorry did sth wrong with linux-image-extras.
Tested again with upstream kernel and it worked fine for me.

Adam Lee (adam8157) wrote :

Status:

Precise, the upstream driver is not working, no panic, but sd card not recognized, still debugging.

Quantal, backported the upstream driver, panic issue fixed, card reader working fine, but not pushed right now(waiting to check the reason which make it not working with Precise)

Thomas (tom-rosary) wrote :

Also doesn't work with LiveCD 10.04.4 on my system

Dennis Kruyt (dennis-kruyt) wrote :

Ok it seems to work fine with 3.8.0-030800rc4-generic, forget my prevous comment I wasnt running the correct kernel.

This I tested on a fujitsu u772 with the RTS5229 PCI Express Card Reader, I can read and write to the SDCard.

Te only this I see is the Invalid Allocation Unit size message from the kernel, but it works so far ok.

[ 3355.880307] mmc0: SD Status: Invalid Allocation Unit size.
[ 3355.881424] mmc0: new SD card at address 9ffc
[ 3355.881770] mmcblk0: mmc0:9ffc SD01G 968 MiB
[ 3355.883203] mmcblk0: p1
[ 3366.263451] mmc0: card 9ffc removed

Oleg Evnin (oleg-evnin) wrote :

@ Adam & Anthony:

On Compaq CQ45-803TU, installed
linux-image-3.8.0-030800rc4-generic_3.8.0-030800rc4.201301172335_i386.deb
linux-headers-3.8.0-030800rc4_3.8.0-030800rc4.201301172335_all.deb
linux-headers-3.8.0-030800rc4-generic_3.8.0-030800rc4.201301172335_i386.deb
linux-image-extra-3.8.0-030800rc4-generic_3.8.0-030800rc4.201301172335_i386.deb

The card reader seems to be working fine now.

Amusingly, "sudo lspci -v -nn" still seems to give "Unassigned class", as below:

02:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device [10ec:5229] (rev 01)
 Subsystem: Hewlett-Packard Company Device [103c:1854]
 Flags: bus master, fast devsel, latency 0, IRQ 42
 Memory at 91000000 (32-bit, non-prefetchable) [size=4K]
 Capabilities: [40] Power Management version 3
 Capabilities: [50] MSI: Enable+ Count=1/1 Maskable- 64bit+
 Capabilities: [70] Express Endpoint, MSI 00
 Capabilities: [100] Advanced Error Reporting
 Capabilities: [140] Device Serial Number 00-00-00-01-00-4c-e0-00
 Kernel driver in use: rtsx_pci
 Kernel modules: rtsx_pci

However, as I said, the card reader seems to be working.

THANKS A LOT FOR ALL WORK!

Adam Lee (adam8157) wrote :

Upstream driver is backported to precise and quantal, tested OK and submitted, waiting the kernel team to approve.

Thanks to Wei Wang!

Adam Lee (adam8157) on 2013-01-29
Changed in linux (Ubuntu Quantal):
status: In Progress → Fix Committed
Adam Lee (adam8157) wrote :

ACKed in Quantal, but NAKed in Precise, kernel team don't like pulling in an entire driver into an LTS kernel, will update later.

Dennis Kruyt (dennis-kruyt) wrote :

I have a issue with this driver. I f I reboot my laptop with the card in it doesnt mount and get a lot off errors in the kernel messages:

   31.271608] end_request: I/O error, dev mmcblk0, sector 0
[ 31.271611] Buffer I/O error on device mmcblk0, logical block 0
[ 31.471310] mmcblk0: error -110 sending status command, retrying
[ 31.571207] mmcblk0: error -110 sending status command, retrying
[ 31.671083] mmcblk0: error -110 sending status command, aborting
[ 31.671089] end_request: I/O error, dev mmcblk0, sector 0
[ 31.870844] mmcblk0: error -110 sending status command, retrying
[ 31.970696] mmcblk0: error -110 sending status command, retrying
[ 32.070562] mmcblk0: error -110 sending status command, aborting
[ 32.070569] end_request: I/O error, dev mmcblk0, sector 0
[ 32.270308] mmcblk0: error -110 sending status command, retrying
[ 32.370155] mmcblk0: error -110 sending status command, retrying
[ 32.470048] mmcblk0: error -110 sending status command, aborting
[ 32.470054] end_request: I/O error, dev mmcblk0, sector 0
[ 32.669787] mmcblk0: error -110 sending status command, retrying
[ 32.769662] mmcblk0: error -110 sending status command, retrying
[ 32.869536] mmcblk0: error -110 sending status command, aborting
[ 32.869545] end_request: I/O error, dev mmcblk0, sector 0
[ 33.069240] mmcblk0: error -110 sending status command, retrying
[ 33.169142] mmcblk0: error -110 sending status command, retrying
[ 33.269008] mmcblk0: error -110 sending status command, aborting
[ 33.269014] end_request: I/O error, dev mmcblk0, sector 16
[ 33.269016] quiet_error: 4 callbacks suppressed
[ 33.269018] Buffer I/O error on device mmcblk0, logical block 2
[ 33.468675] mmcblk0: error -110 sending status command, retrying
[ 33.568596] mmcblk0: error -110 sending status command, retrying
[ 33.668495] mmcblk0: error -110 sending status command, aborting
[ 33.668501] end_request: I/O error, dev mmcblk0, sector 128

When I removed it en insert it again it seems to be ok.

[ 112.770183] mmcblk0: error -110 sending status command, aborting
[ 112.969901] mmcblk0: error -110 sending status command, retrying
[ 113.069762] mmcblk0: error -110 sending status command, retrying
[ 113.169656] mmcblk0: error -110 sending status command, aborting
[ 113.369402] mmcblk0: error -110 sending status command, retrying
[ 113.469273] mmcblk0: error -110 sending status command, retrying
[ 113.569120] mmcblk0: error -110 sending status command, aborting
[ 113.968708] mmc0: card 9ffc removed
[ 116.488884] mmc0: SD Status: Invalid Allocation Unit size.
[ 116.490180] mmc0: new SD card at address 9ffc
[ 116.490723] mmcblk0: mmc0:9ffc SD01G 968 MiB
[ 116.493196] mmcblk0: p1

Adam Lee (adam8157) on 2013-02-01
description: updated
Adam Lee (adam8157) on 2013-02-01
description: updated
Adam Lee (adam8157) on 2013-02-06
Changed in linux (Ubuntu Precise):
status: In Progress → Won't Fix
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel for Quantal in -proposed solves the problem (3.5.0-24.37). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-quantal' to 'verification-done-quantal'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-quantal
Oleg Evnin (oleg-evnin) wrote :

Hello Adam,

I notice you've changed the status for 12.04 to "Won't fix".

I am now running your 12.04 mainline kernel, which allows me to use the card reader (but has some minor problems with other pieces of hardware). Any advice you could give me about managing this situation?

Thanks!

londumas (helion331990) wrote :

I heve the same problem on a hp Pavilion g6.
The way around it is explained here for me: http://ubuntuforums.org/showthread.php?t=2059763
But every kernel udate I have to do it all over again.

Ubuntu 12.10, 64 bits
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5229 PCI Express Card Reader (rev 01)
HP pavilion g6

Luis Henriques (henrix) wrote :

Oleg: you can install our hardware enablement kernel in Precise by installing the package linux-generic-lts-quantal:

 $ sudo apt-get install linux-generic-lts-quantal

Note that you will still need to enable the -proposed pocket to test a kernel with this issue fixed (https://wiki.ubuntu.com/Testing/EnableProposed).

Helion: you seem to be running Quantal already, so you need only to install the kernel in -proposed and upgrade your kernel.

Oleg Evnin (oleg-evnin) wrote :

@Luis: Thanks a lot for the explanation. I will try to do that after the next kernel update. (Currently running the mainline kernel provided by Adam, and it generally works fine, including the card reader.)

Adam Lee (adam8157) wrote :

@Oleg: Yes, in view of the existing conditions, we won't fix this for 12.04. and I recommend you install linux-generic-lts-quantal, it is more stable than that "upstream rc one", especially with other ubuntu components.

Jeff Marcom (jeffmarcom) wrote :

This seems to work okay now with the proposed kernel 3.5.0.24 #37.

I tested this on an E535 and all SD/SDHC/MMC cards worked when inserted.

Chris Van Hoof (vanhoof) wrote :

Marking this as verification done based on Jeff's testing in Comment #43

tags: added: verification-done-quantal
removed: verification-needed-quantal
Jeff Marcom (jeffmarcom) wrote :

Verified with E49 as well.

Oleg Evnin (oleg-evnin) wrote :

I've got the card reader to work following the solution linked above by Hélion (installing a Realtek driver on 12.04, independently of Adam's mainline kernel, or Quantal updates). I first uninstalled Adam's mainline kernel (rolled back to the normal kernel I was running before, delivered to me via automatic updates), then I followed the steps given at http://ubuntuforums.org/showthread.php?t=2059763 , and voila, the card reader is working.

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :
Download full text (28.9 KiB)

This bug was fixed in the package linux - 3.5.0-24.37

---------------
linux (3.5.0-24.37) quantal-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1117492

  [ Tim Gardner ]

  * [Config] CONFIG_ALX=m for x86 only
    - LP: #927782

linux (3.5.0-24.36) quantal-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1116501

  [ Adam Lee ]

  * [Config] Enable RTSX_PCI modules
    - LP: #1057089

  [ Andy Whitcroft ]

  * [Config] enable various HVC consoles
    - LP: #1102206

  [ Brad Figg ]

  * Revert "SAUCE: samsung-laptop: disable in UEFI mode"
    - LP: #1111689

  [ Herton Ronaldo Krzesinski ]

  * [Config] updateconfigs for 3.5.7.3 stable update
  * d-i: Add mellanox ethernet drivers to nic-modules
    - LP: #1015339

  [ Kamal Mostafa ]

  * SAUCE: alx driver import script
    - LP: #927782

  [ Qualcomm Atheros, Inc ]

  * SAUCE: alx: Update to heads/master
    - LP: #927782

  [ Seth Forshee ]

  * SAUCE: samsung-laptop: Add quirk for broken acpi_video backlight on
    N250P
    - LP: #1086921

  [ Stefan Bader ]

  * (config) Move 9p modules into generic package
    - LP: #1107658

  [ Tim Gardner ]

  * [debian] Remove dangling symlink from headers package
    - LP: #1112442
  * [config] CONFIG_ALX=m
    - LP: #927782
  * [Config] Add alx to d-i nic-modules
    - LP: #927782

  [ Upstream Kernel Changes ]

  * Revert "8139cp: revert "set ring address before enabling receiver""
    - LP: #1102417
  * Revert "ath9k_hw: Update AR9003 high_power tx gain table"
    - LP: #1102417
  * Revert "drm/i915: no lvds quirk for Zotac ZDBOX SD ID12/ID13"
    - LP: #1102417
  * Revert "ALSA: hda - Shut up pins at power-saving mode with Conexnat
    codecs"
    - LP: #1106966, #886975
  * be2net: don't call vid_config() when there's no vlan config
    - LP: #1083088
  * be2net: cleanup be_vid_config()
    - LP: #1083088
  * be2net: do not modify PCI MaxReadReq size
    - LP: #1083088
  * be2net: fix reporting number of actual rx queues
    - LP: #1083088
  * be2net: do not use SCRATCHPAD register
    - LP: #1083088
  * be2net: Fix driver load for VFs for Lancer
    - LP: #1083088
  * be2net: Explicitly clear the reserved field in the Tx Descriptor
    - LP: #1083088
  * be2net: Regression bug wherein VFs creation broken for multiple cards.
    - LP: #1083088
  * be2net: Fix to trim skb for padded vlan packets to workaround an ASIC
    Bug
    - LP: #1083088
  * be2net: Fix Endian
    - LP: #1083088
  * be2net: Fix error while toggling autoneg of pause parameters
    - LP: #1083088
  * be2net : Fix die temperature stat for Lancer
    - LP: #1083088
  * be2net: Fix initialization sequence for Lancer
    - LP: #1083088
  * be2net: Activate new FW after FW download for Lancer
    - LP: #1083088
  * be2net: Fix cleanup path when EQ creation fails
    - LP: #1083088
  * be2net: Enable RSS UDP hashing for Lancer and Skyhawk
    - LP: #1083088
  * be2net: dont pull too much data in skb linear part
    - LP: #1083088
  * be2net: Fix VF driver load for Lancer
    - LP: #1083088
  * be2net: Ignore physical link async event for Lancer
    - LP: #1083088
  * be2net: Fix to parse RSS hash from Receive compl...

Changed in linux (Ubuntu Quantal):
status: Fix Committed → Fix Released
Anthony Wong (anthonywong) wrote :

All required patches are already in raring kernel.

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions