Please change AHCI driver back to module in 12.10

Bug #1056563 reported by Tony Hung on 2012-09-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

AHCI is build-in kernel since 12.04, but our customer is need to install our software RAID AHCI module support for ubuntu. Although We found a method to unbind original AHCI , but still hope you can change AHCI driver back to module in 12.10. Thank you. Tony Hung

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1056563

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Tony Hung (hatacpk) wrote :

Because our RAID driver replace ahci module during installation, since ahci built-in kernel can't breaklist it, then we can't run our RAID module to install OS, and I can't run command in

 (initramfs) apport-collect 1056563
/bin/sh: apport-collect: not found

Tony Hung

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: quantal
Changed in linux (Ubuntu):
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.8.0-4.9

---------------
linux (3.8.0-4.9) raring; urgency=low

  [ Herton Ronaldo Krzesinski ]

  * d-i: Add mellanox ethernet drivers to nic-modules
    - LP: #1015339

  [ Joseph Salisbury ]

  * SAUCE: ACPI: Add DMI entry for Sony VGN-FW41E_H
    - LP: #1113547

  [ Kamal Mostafa ]

  * SAUCE: alx driver import script

  [ Qualcomm Atheros, Inc ]

  * SAUCE: alx: Update to heads/master

  [ Tim Gardner ]

  * Release Tracking Bug
    - LP: #1117673

  * [debian] Remove dangling symlink from headers package
    - LP: #1112442
  * [config] CONFIG_ALX=m
  * [Config] Add alx to d-i nic-modules
  * [Config] CONFIG_SATA_AHCI=m
    - LP: #1056563
 -- Leann Ogasawara <email address hidden> Tue, 05 Feb 2013 05:54:32 -0800

Changed in linux (Ubuntu):
status: Triaged → Fix Released
Kano (master-kanotix) wrote :

This breaks booting without initrd without any need. If a new driver is activated by the same pci ids of an existing one then it would be much smarter to integrate the features into the other driver. When there is a demand for using it then where is the code? Will it go upsteam soon? If it is still under development i see no reason to break things just for 1 user that does not want to recompile the kernel. If i want to boot slow then i can use a fully modular kernel as well, but the Ubuntu kernel used to have all major modules builtin so booting without initrd was possible (for example via efibootmgr entry). Please change it back soon!

Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-quantal
Luis Henriques (henrix) wrote :

I've verified that the new Quantal kernel 3.5.0-26.40 now has the following modules:
 - hci_platform.ko
 - ahci.ko
 - acard-ahci.ko
 - libahci.ko
Tagging as verified for Quantal.

tags: added: verification-done-quantal
removed: verification-needed-quantal

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints