After applying update to 3.5.0-15.22, black screen on boot.

Bug #1055665 reported by Kate Stewart on 2012-09-24
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Critical
Kamal Mostafa
Quantal
Critical
Kamal Mostafa

Bug Description

Applied daily update, system booted to black screen with sound.
Tried 3.5.0-15.21, system booted to black screen no sound, so not sure how far actually got.

Reverted system to 3.5.0-14. Filling bug. Note ubuntu-bug linux won't work since -14 isn't official now.

Kate Stewart (kate.stewart) wrote :
Changed in linux (Ubuntu):
importance: Undecided → High
tags: added: quantal rls-q-incoming
Kate Stewart (kate.stewart) wrote :
Changed in linux (Ubuntu):
assignee: nobody → Kamal Mostafa (kamalmostafa)
tags: added: kernel-da-key

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1055665

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu):
importance: High → Critical
status: Incomplete → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.5.0-15.23

---------------
linux (3.5.0-15.23) quantal; urgency=low

  [ Upstream Kernel Changes ]

  * Revert "drm/i915: don't forget the PCH backlight registers"
    - LP: #1053269, #1055231, #1055665
  * Revert "drm/i915: fix up PCH backlight #define mixup"
    - LP: #1053269, #1055665
  * Revert "drm/i915: allow pipe A for lvds on gen4"
    - LP: #1053269, #1055665
  * Revert "drm/i915: properly enable the blc controller on the right pipe"
    - LP: #1053269, #1055665
  * Revert "drm/i915: clear up backlight #define confusion on gen4+"
    - LP: #1053269, #1055665
  * Revert "drm/i915: pnv has a backlight polarity control bit, too"
    - LP: #1053269, #1055665
 -- Leann Ogasawara <email address hidden> Mon, 24 Sep 2012 12:33:26 -0700

Changed in linux (Ubuntu):
status: In Progress → Fix Released
Changed in linux (Ubuntu Quantal):
milestone: none → ubuntu-12.10-beta-2

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers