both iwlwifi and ipw3945 are unable to turn off rf_kill

Bug #105420 reported by Andrea Bravetti on 2007-04-11
22
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
linux-source-2.6.20 (Ubuntu)
Undecided
Unassigned
linux-ubuntu-modules-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

both iwlwifi and ipw3945 are unable to turn off
rf_kill on a Fujitsu Siemens AMILO Pro V3505, so
wifi is unavailable on this notebook (and others...).

Someone (that has the power to do so) should ask
Fujitsu asking for spec...

This is (part of) the output of lspci:

04:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)

This is the output of iwconfig:

lo no wireless extensions.
eth0 no wireless extensions.

This is (part of) the output of dmesg using iwlwifi:

[ 24.548000] iwlwifi: Detected Intel PRO/Wireless 3945ABG Network Connection
[ 24.740000] iwlwifi: Radio Frequency Kill Switch is On:
[ 24.740000] Kill switch must be turned off for wireless networking to work.
[ 24.796000] iwlwifi: MAC is in deep sleep!
[ 24.796000] iwlwifi: MAC is in deep sleep!
[ 24.800000] iwlwifi: MAC is in deep sleep!
[ 24.804000] iwlwifi: MAC is in deep sleep!

This is (part of) the output of dmesg using ipw3945:

[ 23.720000] ipw3945: Intel(R) PRO/Wireless 3945 Network Connection driver for Linux, 1.2.0mp
[ 23.720000] ipw3945: Copyright(c) 2003-2006 Intel Corporation
[ 23.720000] ipw3945: Detected Intel PRO/Wireless 3945ABG Network Connection
... now i'm starting ipw3945d (ipw3945d-2.6.20-14-generic) ...
[ 375.008000] ipw3945: Radio Frequency Kill Switch is On:
[ 375.008000] Kill switch must be turned off for wireless networking to work.

When I try to unload iwlwifi and load ipw3945 I get
a dead keyboard, and I can use only the mouse to reboot...

When I try to turn off rf_kill "manually" I get only
a lot of time out error like this:

[ 565.588000] ipw3945: Error sending CARD_STATE_CMD: time out after 500ms.

When I try to turn on the led "manually" I get:

[ 615.604000] ipw3945: Error sending LEDS_CMD: time out after 500ms.

Now the only way to use this card with linux is:

1. Upgrade the BIOS to version B0E or newer.
2. Boot with Windows (but I don't have it now...).
3. Enable wifi under Windows.
4. Do an hot reboot and enter Linux.
5. Be happy with wifi...

This is a bug, since Linux should be able to turn off
rf_kill without using Windows...

I understand that on Fujitsu Siemens AMILO Pro V3505
there is something strange and it may be also an hardware
or BIOS related problem however it should work...

bye,
Andrea Bravetti

description: updated

It seems to be solved with bios B0F, so
this is a bios/hardware related problem.

iwlwifi:

wmaster0 IEEE 802.11a Frequency:5.68 GHz
          RTS thr:off Fragment thr=2346 B

wlan0 IEEE 802.11a ESSID:""
          Mode:Managed Frequency:5.68 GHz Access Point: Not-Associated
          RTS thr:off Fragment thr=2346 B
          Encryption key:off
          Link Quality:0 Signal level:0 Noise level:0
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Rich Wales (richw) wrote :

I think I'm seeing this same problem on a Toshiba Satellite A205-S4577, running the just-released Feisty.

The Intel PRO/Wireless 3945ABG in this laptop is detected during boot, but I get the "Radio Frequence Kill Switch is On" message, and the wireless interface is NOT shown in "ifconfig -a".

Wireless appears to be turned on/off via a hotkey (Function-F8), but this has no effect in Feisty.

It seems this is a duplicate of bug #99585, so I am marking accordingly. Rich, Now that the 7.10 Gutsy Gibbon release of Ubuntu is out, we were wondering if you can still reproduce this issue. Could you please download and try the new version of Ubuntu from http://www.ubuntu.com/getubuntu/download and report back your results to bug #99585. Thanks!

Changed in linux-source-2.6.20:
status: New → Incomplete
Gioele Barabucci (gioele) wrote :

No, this is not a dupe of #99585. The reporter of that bug did not notice that there was an hw switch to turn the wireless card on. This bug is about a notebook (actually many Fujitsu-Siemens notebooks) that do not have this hw switch. Windows is able to turn the wireless card on via software and put rf_kill to 0, instead of 2. Feisty and Gutsy cannot.

Please remove the duplicate status.

There is also a question related to this bug: https://answers.launchpad.net/ubuntu/+question/2639

Gioele Barabucci (gioele) wrote :

Tested on more than one AMILO Pro notebook with latest Gutsy.

Changed in linux-source-2.6.20:
status: Incomplete → Confirmed
Gioele Barabucci (gioele) wrote :

Can someone add this bug to linux-source-2.6.22 (the version run by Gutsy) as well?

Gioele, I've updated this report to be against linux-source-2.6.22 as well. Can you confirm that your BIOS is up to date? Andrea commented that this was no longer an issue after a BIOS update. You can usually locate the version of you BIOS by examining the output of 'dmidecode'. If this is still an issue can you please attach the following information:

* sudo dmidecode > dmidecode.log
* uname -a > uname-a.log
* cat /proc/version_signature > version.log
* dmesg > dmesg.log
* sudo lspci -vvnn > lspci-vvnn.log

Please be sure to attach each file as a separate attachment. For more information regarding the kernel team bug policy, please refer to https://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks again and we appreciate your help and feedback.

Changed in linux-source-2.6.22:
status: New → Incomplete
Gioele Barabucci (gioele) wrote :

Actually it is not a problem with the BIOS, you can enable the wireless card with Linux even without an updated BIOS.

As pointed out in https://answers.launchpad.net/ubuntu/+question/2639 you can force the rf_kill to 0 using the (now unmaintained) acerhk module. Once the ipw3945 module will have the necessary pieces of code integrated from the acerhk module, it will work out of the box.

I'll attach the logs soon.

Gioele Barabucci (gioele) wrote :
Gioele Barabucci (gioele) wrote :
Gioele Barabucci (gioele) wrote :

$ uname -a
Linux attila 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux

Gioele Barabucci (gioele) wrote :
Brian Murray (brian-murray) wrote :

I am assigning this bug to the 'ubuntu-kernel-team' per their bug policy. For future reference you can learn more about their bug policy at https://wiki.ubuntu.com/KernelTeamBugPolicies .

Changed in linux-source-2.6.20:
assignee: nobody → ubuntu-kernel-team

The Hardy Heron Alpha2 release will be coming out soon (around Dec 20). It will have an updated version of the kernel. It would be great if you could test with this new release if this issue still exists. I'll be sure to update this report when Alpha2 is available. Thanks!

Changed in linux:
status: New → Incomplete

Hardy Heron Alpha2 was recently released. It contains an updated version of the kernel. You can download and try the new Hardy Heron Alpha2 release from http://cdimage.ubuntu.com/releases/hardy/alpha-2/ . You should be able to then test the new kernel via the LiveCD. If you can, please verify if this bug still exists or not and report back your results. General information regarding the release can also be found here: http://www.ubuntu.com/testing/hardy/alpha2 . Thanks!

cbrmichi (cbrmichi) wrote :

I got a FSC Esprimo Mobile V5505 and have to use Windows to turn off/on wireless lan.
Is this the same problem?

mrx65 (giocecchini) wrote :

Same problem with intel 3945abg on my new laptop, Samsung Q70, bios S11 and now bios S12 :(
I can't turn on/off wifi adapter with key [Fn]+[F9] :'(
...both with Ubuntu Gutsy 7.10 (kernel 2.6.22-14 and ipw3945 driver)
and Debian Testing (Lenny, iwl3945 driver, kernel 2.6.22-3 and 2.6.24-1)

Thanks...

Again, it would be helpful If you can please test the latest 2.6.24-12 Hardy Heron 8.04 Beta kernel - http://www.ubuntu.com/testing. Thanks.

Espen Helgedagsrud (espenoh) wrote :

Same problem with my FSC AMILO Pro V3405 running latest Bios (R01-B0E) and the 8.04 beta with kernel 2.6.24-15-generic.
Both the dedicated WiFi-button and the shortcut ([FN]-[F10]) are completely dead. I can toggle the WiFi killswitch manually using the fsam7400 module (not sure if that really turns off the radio or not, but the WiFi-light turns off, and all WiFi-networks dissapear from Wicd), but I would very much like to see a more elegant way to handle this.

Hi Kleevah,

Care to try installing the linux-backports-modules-2.6.24 package. It recently pulled in an updated version of iwlwifi (version 1.2.25). If you still experience issues after this, care to attach the following information:

1) dmesg > dmesg.log
2) modinfo iwl3945 > modinfo.log
3) sudo lspci -vvnn > lspci-vvnn.log

Thanks.

Also just adding a note that we'll keep this report open against the actively developed kernel but against 2.6.20 and 2.6.22 this will be closed. Thanks.

Changed in linux-source-2.6.20:
status: Confirmed → Won't Fix
Changed in linux-ubuntu-modules-2.6.22:
status: Incomplete → Won't Fix
Espen Helgedagsrud (espenoh) wrote :

Still no luck, but dmesg keeps telling me this when i press the button:

        atkbd.c: Unknown key pressed (translated set 2, code 0xd5 on isa0060/serio0).
        atkbd.c: Use 'setkeycodes e055 <keycode>' to make it known.

Could it be just as simple as the key not being mapped properly?

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Incomplete → Triaged

I'm on Intrepid (Linux 2.6.26-5-generic #1 SMP Fri Aug 15 13:54:22 UTC 2008 x86_64 GNU/Linux) and after i took my laptop to the shop, and the run a Windows Vista install my intel begun to work. I've read i many places that many trouble with kill switches are only fixed by running at least one time windows on them.

https://bugs.launchpad.net/ubuntu/+bug/230844

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Leam on 2.6.26.5 I had my wifi 4965 working perfectly.
after installing 2.6.27.1 i cant turn my wifi on anymore, with either kernel .27 or .26

So its a serious regression for me.

adding some extra information. I some times get the card to work.
Most of the times it wont see any wireless network. when it does, most of the times it wont accept the passphrase (so i guess NetworkManager 0.7 is also messing up).
between yesterday and today, i was only able to make the card work 1 time.

Changed in linux:
status: Triaged → New
Allan Nordhøy (comradekingu) wrote :

I got it to work on a fresh ubuntu 8.04 install, then when i updated the kernel it was gone again.
Going back to the old didnt do the trick, nor did a reinstall.
The solution lies in the Bios version, because the killswitch button does not work.
This was confirmed by trying another card known to work.

Solution:
I was able to get it to work with the latest firmware (B0G)
Its available from fujitsu-siemens http://support.fujitsu-siemens.com/Download/ShowDescription.asp?SoftwareGUID=7F5DC06C-7C41-453C-A791-2D9039BB73FA&OSID=665F4A20-6E31-43C3-82C2-D98CE773007C&Status=True&Component=Flash%20Bios%20for%20AMILO%20Pro%20V3505
Dont worry about the XP category selection, BIOS is the same regardles of OS.
Burn .ISO to disk and boot. Press F12 to select CD during post.
Write "FLASH" when prompted.

Hi Andrea,

Can you confirm this is still an issue with the latest 2.6.27-7 Intrepid Ibex kernel? However, I'd also like to point out bug 193970 that might affect your wifi. Thanks.

Changed in linux:
status: New → Incomplete

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Brad Figg (brad-figg) wrote :

This bug report is being closed because we received no response to the previous inquiry for information. Please reopen if this is still an issue in the current Ubuntu release, Jaunty Jackalope 9.04. To reopen the bug, click on the current status, under the Status column, and change the status back to "New". Thanks.

Changed in linux (Ubuntu):
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers