reboot with -vga cirrus can result in broken output

Bug #1054129 reported by Serge Hallyn on 2012-09-21
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Quantal
Medium
Unassigned

Bug Description

plars discovered that after doing do-release-upgrade -d from a precise server image can result in what appears to be a frozen system. Input to the console works fine (you can log in and do things, and you can also ssh in if ssh-server was installed) but you see no output. jibel discovered that -vga std does not have this bug.

This could be a bug in the cirrus driver in quantal, or a bug in the vnc output in qemu-kvm, so I'm marking it against both.
---
AlsaDevices:
 total 0
 crw-rw---T 1 root audio 116, 1 Sep 21 10:52 seq
 crw-rw---T 1 root audio 116, 33 Sep 21 10:52 timer
AplayDevices: Error: [Errno 2] No such file or directory
ApportVersion: 2.5.2-0ubuntu4
Architecture: amd64
ArecordDevices: Error: [Errno 2] No such file or directory
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
CRDA: Error: [Errno 2] No such file or directory
CurrentDmesg:

DistroRelease: Ubuntu 12.10
HibernationDevice: RESUME=UUID=b91788fa-b5e6-4af1-a528-106b98586b87
InstallationMedia: Ubuntu-Server 12.04.1 LTS "Precise Pangolin" - Release amd64 (20120920.1)
IwConfig:
 eth0 no wireless extensions.

 lo no wireless extensions.
Lsusb: Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: Bochs Bochs
Package: qemu-kvm
PciMultimedia:

ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB:

ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-15-generic root=UUID=55f2675f-feec-4abb-8fa9-9f7c6ad70134 ro
ProcVersionSignature: Ubuntu 3.5.0-15.22-generic 3.5.4
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-15-generic N/A
 linux-backports-modules-3.5.0-15-generic N/A
 linux-firmware 1.93
RfKill: Error: [Errno 2] No such file or directory
Tags: quantal
Uname: Linux 3.5.0-15-generic x86_64
UpgradeStatus: Upgraded to quantal on 2012-09-21 (0 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 01/01/2007
dmi.bios.vendor: Bochs
dmi.bios.version: Bochs
dmi.chassis.type: 1
dmi.chassis.vendor: Bochs
dmi.modalias: dmi:bvnBochs:bvrBochs:bd01/01/2007:svnBochs:pnBochs:pvr:cvnBochs:ct1:cvr:
dmi.product.name: Bochs
dmi.sys.vendor: Bochs

Changed in linux (Ubuntu):
importance: Undecided → Medium
Changed in qemu-kvm (Ubuntu):
importance: Undecided → Medium

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1054129

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected quantal
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Serge Hallyn (serge-hallyn) wrote :

I'd like to complement the launchpad and apport folks for greatly improving the command-line-server usage of apport-collect (since lucid times).

Serge Hallyn (serge-hallyn) wrote :

The above information is collect using apport in the qemu-kvm quantal guest.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qemu-kvm (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.6 kernel[0] (Not a kernel in the daily directory) and install both the linux-image and linux-image-extra .deb packages.

Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. Please only remove that one tag and leave the other tags. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.6-rc6-quantal/

tags: added: needs-upstream-testing
Paul Larson (pwlars) wrote :

I'm still able to reproduce this problem after updating to the kernel at http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.6-rc6-quantal/

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: removed: needs-upstream-testing
Joseph Salisbury (jsalisbury) wrote :

Does this issue go away if you boot into the kernel prior to the upgrade?

Paul Larson (pwlars) wrote :

Not sure what you mean... I basically worked around the issue long enough to do the upgrade by booting with -vga std, upgraded to the new upstream kernel, rebooted to make sure the new kernel works with -vga std, then rebooted without -vga std and was able to reproduce it.

Quoting Paul Larson (<email address hidden>):
> Not sure what you mean... I basically worked around the issue long

I assume he meant install the precise kernel in the quantal vm?

Joseph Salisbury (jsalisbury) wrote :

Thanks, Serge. It would be good to know if the bug goes away if you boot the precise kernel in the quantal vm. That will tell us if this is a regression. If it is, we can perform a kernel bisect to identify the commit in Quantal that introduced the regression.

Serge Hallyn (serge-hallyn) wrote :

Quoting Joseph Salisbury (<email address hidden>):
> Thanks, Serge. It would be good to know if the bug goes away if you
> boot the precise kernel in the quantal vm. That will tell us if this is
> a regression. If it is, we can perform a kernel bisect to identify the
> commit in Quantal that introduced the regression.

Paul, is this something you'll be able to test?

Paul Larson (pwlars) wrote :

Not likely to happen this week, as I'm swamped with beta2 stuff at the moment, but I'll try to get to it as soon as I can

It might be worth re-testing with the 3.5.0-16.24 kernel once it lands in the quantal release pocket, it's currently sitting in quantal-proposed. It disables the cirrus driver as it was causing issues on other systems as well. See the following for more information. Thanks.

https://lists.ubuntu.com/archives/kernel-team/2012-September/022103.html
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1038055

Joseph Salisbury (jsalisbury) wrote :

@Paul, were you able to test the kernel mentioned in comment #22 ? The 3.5.0-17 kernel is now available as well.

Changed in linux (Ubuntu Quantal):
status: Confirmed → Incomplete
James Page (james-page) wrote :

I had seen this issue alot with automated iscsi root testing so had switched to using the vga qemu-kvm option; I just switched back and did some installs and a load of reboots and I can't reproduce this issue any longer on latest quantal images.

Joseph Salisbury (jsalisbury) wrote :

@Paul,

Can you also confirm this bug no longer exists in the latest quantal images? If so, please mark this bug as "Fix Released".

Paul Larson (pwlars) wrote :

Sorry for the delay. I tried this with quantal-latest (host) on the quantal-server-amd64 release iso and everything worked fine without having to specify vga

Closing Fix Released per comments #24 and #26. Thanks.

Changed in linux (Ubuntu Quantal):
status: Incomplete → Fix Released
Changed in linux (Ubuntu):
status: Incomplete → Fix Released
Serge Hallyn (serge-hallyn) wrote :

There are other open bugs for qemu+cirrus, so I will close this one for qemu to mirror the linux status.

no longer affects: qemu-kvm (Ubuntu Quantal)
no longer affects: qemu-kvm (Ubuntu)
Serge Hallyn (serge-hallyn) wrote :

(Or, just deleted it)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers