kernel does not boot without noefi on commandline

Bug #1053897 reported by Sébastien Bernard on 2012-09-21
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Colin Ian King
Quantal
High
Colin Ian King

Bug Description

The machine is an ASUS Laptop N53SN.
In BIOS mode, everything works ok, but in UEFI, the kernel does not boot.

The only way to boot it is to provide the noefi option on the cmdline.
This machine never booted with any ubuntu distribution in efi.

Direct boot with linux-efi kernel image, show the same behaviour.

The only distribution that boots in UEFI is the alpha version of Fedora 18.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: linux-image-3.5.0-14-generic 3.5.0-14.15
ProcVersionSignature: Ubuntu 3.5.0-14.15-generic 3.5.3
Uname: Linux 3.5.0-14-generic x86_64
AcpiTables: Error: command ['pkexec', '/usr/share/apport/dump_acpi_tables.py'] failed with exit code 127: Error executing /usr/share/apport/dump_acpi_tables.py: Permission denied
ApportVersion: 2.5.1-0ubuntu7
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: seb 1743 F.... pulseaudio
 /dev/snd/controlC0: seb 1743 F.... pulseaudio
Date: Fri Sep 21 11:04:04 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-14-generic root=UUID=2755aeb4-461b-4bdf-b217-63cb230defa9 ro noefi quiet splash
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-14-generic N/A
 linux-backports-modules-3.5.0-14-generic N/A
 linux-firmware 1.91
SourcePackage: linux
UpgradeStatus: Upgraded to quantal on 2012-09-07 (13 days ago)

Sébastien Bernard (sbernard) wrote :
Brad Figg (brad-figg) on 2012-09-21
Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.6 kernel[0] (Not a kernel in the daily directory) and install both the linux-image and linux-image-extra .deb packages.

Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. Please only remove that one tag and leave the other tags. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.6-rc6-quantal/

Changed in linux (Ubuntu):
importance: Undecided → High
tags: added: kernel-da-key needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Sébastien Bernard (sbernard) wrote :

I already tried to boot an upstream kernel trough a usb key with grub installed.
No luck up to rc4.

However I managed to boot previous kernels (a.k.a. everything from 3.5.0-14).

I did an update of the ubuntu installation and noticed at the boot that the grub was saying 1.99rcx.
This did not match with the one installed which was 2.0.0-5.

I manualy reinstalled the grub with :
 grub-install --efi-directory=/boot/efi/ --target=x86_64-efi --recheck --debug

And then, kernel started to boot. (Magic instant of pure joy).

So I need to say that new grub is doing quite some magic to make the kernel boot.

However, booting the efi enabled kernel directly by the efi shell or uefi bios, does not work.

I tried to boot the current testdrive build usb image, does not boot either.
I'm now able to boot my previously installed ubuntu (with the noefi cmdline), but I'm unable to boot from any CD or boot image.

Especially, the LTS version of ubuntu does not boot with this kind of hardware (sandy bridge, uefi is becoming more and more common).

tags: added: kernel-key
removed: needs-upstream-testing
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
123RaZoR321 (123razor321) wrote :

Same problem with N53SV. Nothing works in uefi mode. What I did to fix this was switching to kernel stub loader. It works like a charm.

Sébastien Bernard (sbernard) wrote :

For me, kernel stub loader didn't work.

Changed in linux (Ubuntu):
assignee: nobody → Colin King (colin-king)
Colin Ian King (colin-king) wrote :

I'm currently making a bit of a guess, but I suspect it may be due to an issue in radeon_card_posted(), so perhaps you can download and test a kernel and let me know. Kernel .debs available at:

http://kernel.ubuntu.com/~cking/lp-1053897

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Colin Ian King (colin-king) wrote :

Anyone care to test the kernel I built?

Sébastien Bernard (sbernard) wrote :

I did try to boot on your kernel.

The latest testdrive server (28-09-2012) boots ok on my laptop.
Differences is there is a new grub -2.00-5ubuntu isntalled as a bootloader.

It's maybe not related to kernel after all.

I'll try today to boot with your kernel on old grub.

Sébastien Bernard (sbernard) wrote :

ok, I did the test.
As predicted, kernel does not boot through the grub 1.99rc2....

But, your kernel boots ok when run directly from efi shell.
This is the first kernel that boots ok.

Btw, this laptop does not have any radeon GPU (Optimus NVIDIA + Intel HD3000).

Colin Ian King (colin-king) wrote :

@Sebastien,

I'm not 100% clear about your test results, I just want to clarify this before I submit a kernel fix.

1. so do the new grub allows the old and new kernel to boot OK? (i.e. your issue is fixed with the new grub?)

2. does the new kernel just fix the boot from UEFI shell?

Sorry to ask these questions, but I'd like to be totally clear on the results. Thanks!

Sébastien Bernard (sbernard) wrote :

Your analyze is correct.

I already mentionned in comment #3 that the grub upgrade did fix the boot.

Your kernel fix the boot from uefi using the efi stub.
Your kernel does not boot with grub 1.99rc2.

tags: removed: kernel-key
Mark Cariaga (mzc) wrote :

Has anyone tried to install or test if the bug still exist?

Kate Stewart (kate.stewart) wrote :

Since there's been no activity on this bug, not sure if this bug still exists or not. Can anyone confirm if it does?

Martin (napfi) wrote :

I experience the same problem with an brand new Ubuntu Server 12.04.2 LTS:
- kernel 3.5.0-37
- grub 1.99-21ubuntu3.9

I'm using an ASRock AD2550B-ITX.

Can I expect any "official" solution to the problem in near future? I want to store all my data on that system, so I rather have a LTS version than the latest feature version.

Martin (napfi) wrote :

I tried the latest kernel 3.8.0-27-generic provided for Precise but without any success.

geezanansa (geezanansa-ubuntu) wrote :

On different hardware GA A75 UD4H this is a very similar issue regarding using EFI to install Ubuntu. Have tried from 11.04 and up to 13.04 all with same result ie does not run installer in EFI mode, noefi does not work for me but running installer using BIOS/legacy mode does work then installing grub-efi gets Ubuntu booting using EFI mode. My bug report (https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/1213119) is still unfinished and not confirmed as bug as of yet. There are many similar bugs to this one and mine. My own research is indicating this type of problem is more and more likely to be vendor hard coding of firmware. This is unproven theory and currently stands as speculation. Just seems many vendors creating very similar issues regarding the installation of Ubuntu using U/EFI and that is with or without Secure Boot.

geezanansa (geezanansa-ubuntu) wrote :

Ubuntu flavours <=12.04.1 may cause trouble regarding making a 16bit; or wanting to use a 16bit ESP whereas firmwares are looking for 32bit ESP= no worky!? The workaround is to allow installer to run as it wants to but be sure to copy ESP save in another location then delete 16bit ESP and remake 32bit ESP replacing the files from 16bit ESP before rebooting trying to use U/EFI.
source http://www.rodsbooks.com/gb-hybrid-efi/
"A FAT-16 ESP, on the other hand, seems problematic. Ubuntu 11.04 (and 11.10) in EFI mode creates a dinky FAT-16 ESP, and after my test install of Ubuntu 11.04, the board hung on reboot until I reworked the ESP as FAT-32. Thus, if you plan to install Ubuntu, or any other OS that creates a FAT-16 ESP, be prepared to fix it, preferably before the system reboots!"
"rodsbooks" is an absolutely indispensible source of all things factual regarding U/EFI which demystifies and disproves many myths as well as misinformation regarding this subject.

Again these type of idiosyncrasies appear to be vendor specific.

This bug was nominated against a series that is no longer supported, ie quantal. The bug task representing the quantal nomination is being closed as Won't Fix.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu Quantal):
status: Incomplete → Won't Fix
Changed in linux (Ubuntu):
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers