screen goes black after grub, lights up again when X starts

Bug #1053269 reported by Lucazade on 2012-09-20
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Kamal Mostafa

Bug Description

after the latest updates I get a black screen during bootup... it seems related to the vt.handoff=7 feature of grub.
Infact removing this I can see at least the virtualterminal during bootup.
Maybe it is not correctly patched the latest release of grub (2.00-5ubuntu1)

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: grub2 (not installed)
ProcVersionSignature: Ubuntu 3.5.0-15.22-generic 3.5.4
Uname: Linux 3.5.0-15-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.5.2-0ubuntu4
Architecture: amd64
Date: Thu Sep 20 10:21:44 2012
InstallationMedia: Kubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120909)
ProcEnviron:
 LANGUAGE=
 TERM=xterm
 PATH=(custom, no user)
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
SourcePackage: grub2
UpgradeStatus: No upgrade log present (probably fresh install)

Update: Bug is still *not* fixed with kernel 3.5.0-15.23 on Ati Radeon cards.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in grub2 (Ubuntu):
status: New → Confirmed

dmesg of my hybrid notebook (intel + nvidia gfx cards)

http://pastebin.com/VdDtBQqs

dmesg blacklisting nvidia_current module (same broken behaviour)
http://pastebin.com/ZVSqxYk8

reverting to -21 kernel fixes the issue... so it is kernel related

Colin Watson (cjwatson) on 2012-09-21
affects: grub2 (Ubuntu) → linux (Ubuntu)
Stefan Bader (smb) on 2012-09-21
no longer affects: linux
Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: regression-update
Changed in linux (Ubuntu):
assignee: nobody → Kamal Mostafa (kamalmostafa)
importance: Medium → Critical
Changed in linux (Ubuntu):
status: Confirmed → In Progress
Kamal Mostafa (kamalmostafa) wrote :

@Lucazade- Thanks very much for reporting this regression. We're reasonably sure that the problem was introduced by one of the two backlight patches which were included in the 3.5.0-15.22 kernel. I've prepared two new test kernels -- each has just one of those patches applied:

http://people.canonical.com/~kamal/lp1053269/patch1only/
http://people.canonical.com/~kamal/lp1053269/patch2only/

Please try both of those test kernels, and let us know which one causes the problem. (Its not likely that the problem will occur with both, but please do test both to confirm that).

@Kamal:
tried both kernels you provided but unfortunately none of these works.. still a blank screen from post-grub to X.. no VT or plymouth are visible.

tried again the -21 release just to be sure it always work and it is ok..

let me know if I can provide any log to debug it better!

Kamal Mostafa (kamalmostafa) wrote :

@Lucazade-
I'm very surprised that neither of those fixes it! For each of those test kernels (patch1only and patch2only), please install and boot that kernel, capture the output from 'dmesg' , and post that here.

Also, please clarify exactly what happens... Are you saying that the black screen occurs post-grub, and then it *stays* black even after it has booted up all the way to the X login screen? Or are you saying that the screen goes black during the boot sequence but then lights itself up again at some point?

i'll gather both dmesg and paste it here asap ;)

I'm saying that the screen goes black during the boot sequence (just after grub) but then lights itself up again at lightdm (so when X goess up)

In that black period I don't see the usual plymouth splashscreen neither i'm able to switch to any virtualterminal to see what is happening. The framebuffer is not opened or refreshed after grub.

Kamal Mostafa (kamalmostafa) wrote :

Ah, thanks for the clarification!

Changed in linux (Ubuntu):
importance: Critical → Medium
summary: - black boot
+ screen goes black after grub, lights up again when X starts

any news?

btw it seems related to the latest patches in .22 kernel release about the i915 backlight.
in fact if I blacklist completely the i915 module the bootup is ok..

I tried to pass 'acpi_backlight=video/vendor' and 'i915.enable_backlight=1/0' but without success.

note: This laptop is a Dell L702X

Kamal Mostafa (kamalmostafa) wrote :

Due to this problem and LP: 1055665, we're planning to revert the patch set that we think is the cause.

@Lucazade- If you could, please try this test kernel, and advise whether it fixes the problem: http://people.canonical.com/~kamal/backlightrevert/

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.5.0-15.23

---------------
linux (3.5.0-15.23) quantal; urgency=low

  [ Upstream Kernel Changes ]

  * Revert "drm/i915: don't forget the PCH backlight registers"
    - LP: #1053269, #1055231, #1055665
  * Revert "drm/i915: fix up PCH backlight #define mixup"
    - LP: #1053269, #1055665
  * Revert "drm/i915: allow pipe A for lvds on gen4"
    - LP: #1053269, #1055665
  * Revert "drm/i915: properly enable the blc controller on the right pipe"
    - LP: #1053269, #1055665
  * Revert "drm/i915: clear up backlight #define confusion on gen4+"
    - LP: #1053269, #1055665
  * Revert "drm/i915: pnv has a backlight polarity control bit, too"
    - LP: #1053269, #1055665
 -- Leann Ogasawara <email address hidden> Mon, 24 Sep 2012 12:33:26 -0700

Changed in linux (Ubuntu):
status: In Progress → Fix Released
Kamal Mostafa (kamalmostafa) wrote :

@Lucazade- Please ignore the test kernel I mentioned in comment #13, and just test the Quantal 3.5.0-15.23 kernel instead. Confirm that it fixes the problem?

@Karmal
fixed with 3.5.0-15.23.. thanks :)

Unfortunately there are still some issues with ATI cards..
I've tried with a Radeon HD3000 and I get a blank bootup like it was for Intel.

Baokai Lei (leibaokai) wrote :

I can confirm that, the issue is *not* fixed with Ati Radeon cards! Radeon HD 6850 here.
Even with kernel 3.5.0-15.23, it's still the same. After selecting an entry from the Grub menu and booting starts, the screen goes blank, and the monitor displays "no signal". When booting ends, the screen comes back to life, and the LightDM login screen appears.

Baokai Lei (leibaokai) on 2012-09-26
description: updated
Steve Langasek (vorlon) wrote :

Please file a new bug report for your issue, as the bug the original reporter was experiencing has been fixed with a change to the i915 driver.

Baokai Lei (leibaokai) wrote :

Ok, I've filed a new bug here:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1057532

@Lucazade,
Please confirm at the link above that the bug also affects you.

@Baokai Lei (leibaokai)
confirmed!

CSRedRat (csredrat) wrote :

When Kernel was updated to 3.6? Kernel Freeze today!

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers