Firewire drive not detected

Bug #105317 reported by Tom Womack on 2007-04-10
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

I plug in a firewire drive (a Western Digital MyBook Premium); nothing happens.

If I have udevmonitor running, no messages appear, whilst I get a screed of messages if I plug or unplug my USB card reader.

The drive doesn't seem to be physically dead (it makes a happy whirring noise and the blue light at the front comes on), but the machine's behaving as if I don't have firewire at all.

This is an Intel DG965 board.

lspci says 06:03.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link)

dmesg | grep 1394 says

[ 31.205094] ieee1394: Initialized config rom entry `ip1394'
[ 33.366729] ohci1394: fw-host0: OHCI-1394 1.1 (PCI): IRQ=[19] MMIO=[e0004000-e00047ff] Max Packet=[2048] IR/IT contexts=[4/8]
[ 34.638121] ieee1394: Host added: ID:BUS[0-00:1023] GUID[0090270001b8faaa]

I'm not sure what to do next.

Stefan Richter (stefan-r-ubz) wrote :

If you still have this hardware: Compare the contents of /proc/interrupts right before and after you plugged the drive in.

Tommy Trussell (tommy-trussell) wrote :

I noticed your bug because I'm having a problem with a Firewire/ieee1394 drive, but I just switched to a new MyBook because I'm hoping it will be more reliable. So far so good....

Have you tried the USB port to see if it works?

ALSO, I had a problem with my Western Digital MyBook Premium Edition because it turns out the FIREWIRE CABLE that comes in the box is defective, and using it apparently destroyed BOTH Firewire ports on the drive. Call the manufacturer immediately. If they confirm you're affected, get a replacement cable and DON'T use the one that came in the box anywhere.

If you have another machine and a different Firewire cable you can confirm whether the ports work at all. In my case, the USB port continued working. However, since I had paid a premium for the Firewire model, I exchanged the drive at the store where I bought it, and have not had any trouble with the new one (though I DID NOT use the Firewire cable in the box!!!).

Hope that helps.

Nanley Chery (nanoman) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

Tommy Trussell (tommy-trussell) wrote :

I'm not the original bug reporter, but I stopped using my FireWire drives under Ubuntu 7.06 because in every case the drive would work at first and then become unreliable and then become unusable. HOWEVER I found that I could still access the data from an old machine still running Ubuntu "Dapper" 6.0.6.1. I opened Bug #134396 to report that.

Because I depend upon the data and was able to switch to USB in at least one case, I have been waiting to see whether anyone else could confirm the Firewire issues so I could explore the problem systematically. I have since upgraded to Ubuntu "Gutsy" 7.10 but have not tried the firewire drives recently.

I hope Tom Womack sees this and maybe he and I can confer on the issue since we also both happen to have one of the same model drive. In his case, his problem might have been another issue with the drive -- one which Western Digital acknowledged as a defective FireWire cable. I have several other enclosures and all have shown trouble with Firewire but no difficulty with USB.

I dont't know if my comment will help, but I also have a firewire drive 'laCie' that isn't detected when I plug it. What I do to see it is :
sudo rmmod ohci1394
and then
sudo modprobe ohci1394

Loïc

Stefan Richter (stefan-r-ubz) wrote :

Could you post the output of "uname -a", and the messages from "dmesg" which belong to the following events:
  1.) when ohci1394 is present in the kernel and you plug the disk in,
  2.) when you do the rmmod/modprobe workaround to get the disk recognized.

Tim Posey (timposey) wrote :
Download full text (23.2 KiB)

I have a Maxtor firewire drive and it will not work with firewire under ubuntu

my output with "uname -a" is as follows
Linux timposey-desktop 2.6.24-17-generic #1 SMP Thu May 1 14:31:33 UTC 2008 i686 GNU/Linux

"dmesg" is as follows

timposey@timposey-desktop:~$ dmesg
[ 0.000000] Initializing cgroup subsys cpuset
[ 0.000000] Initializing cgroup subsys cpu
[ 0.000000] Linux version 2.6.24-17-generic (buildd@palmer) (gcc version 4.2.3 (Ubuntu 4.2.3-2ubuntu7)) #1 SMP Thu May 1 14:31:33 UTC 2008 (Ubuntu 2.6.24-17.31-generic)
[ 0.000000] BIOS-provided physical RAM map:
[ 0.000000] BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
[ 0.000000] BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
[ 0.000000] BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
[ 0.000000] BIOS-e820: 0000000000100000 - 000000004dff0000 (usable)
[ 0.000000] BIOS-e820: 000000004dff0000 - 000000004dff3000 (ACPI NVS)
[ 0.000000] BIOS-e820: 000000004dff3000 - 000000004e000000 (ACPI data)
[ 0.000000] BIOS-e820: 00000000fec00000 - 00000000fec01000 (reserved)
[ 0.000000] BIOS-e820: 00000000fee00000 - 00000000fee01000 (reserved)
[ 0.000000] BIOS-e820: 00000000ffff0000 - 0000000100000000 (reserved)
[ 0.000000] 351MB HIGHMEM available.
[ 0.000000] 896MB LOWMEM available.
[ 0.000000] found SMP MP-table at 000f5260
[ 0.000000] Entering add_active_range(0, 0, 319472) 0 entries of 256 used
[ 0.000000] Zone PFN ranges:
[ 0.000000] DMA 0 -> 4096
[ 0.000000] Normal 4096 -> 229376
[ 0.000000] HighMem 229376 -> 319472
[ 0.000000] Movable zone start PFN for each node
[ 0.000000] early_node_map[1] active PFN ranges
[ 0.000000] 0: 0 -> 319472
[ 0.000000] On node 0 totalpages: 319472
[ 0.000000] DMA zone: 32 pages used for memmap
[ 0.000000] DMA zone: 0 pages reserved
[ 0.000000] DMA zone: 4064 pages, LIFO batch:0
[ 0.000000] Normal zone: 1760 pages used for memmap
[ 0.000000] Normal zone: 223520 pages, LIFO batch:31
[ 0.000000] HighMem zone: 703 pages used for memmap
[ 0.000000] HighMem zone: 89393 pages, LIFO batch:15
[ 0.000000] Movable zone: 0 pages used for memmap
[ 0.000000] DMI 2.2 present.
[ 0.000000] ACPI: RSDP signature @ 0xC00F6C80 checksum 0
[ 0.000000] ACPI: RSDP 000F6C80, 0014 (r0 AWARD )
[ 0.000000] ACPI: RSDT 4DFF3000, 002C (r1 AWARD AWRDACPI 42302E31 AWRD 0)
[ 0.000000] ACPI: FACP 4DFF3040, 0074 (r1 AWARD AWRDACPI 42302E31 AWRD 0)
[ 0.000000] ACPI: DSDT 4DFF30C0, 3906 (r1 AWARD AWRDACPI 1000 MSFT 100000E)
[ 0.000000] ACPI: FACS 4DFF0000, 0040
[ 0.000000] ACPI: APIC 4DFF6A00, 005A (r1 AWARD AWRDACPI 42302E31 AWRD 0)
[ 0.000000] ACPI: PM-Timer IO Port: 0x1008
[ 0.000000] ACPI: Local APIC address 0xfee00000
[ 0.000000] ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
[ 0.000000] Processor #0 6:8 APIC version 16
[ 0.000000] ACPI: LAPIC_NMI (acpi_id[0x00] high edge lint[0x1])
[ 0.000000] ACPI: IOAPIC (id[0x02] address[0xfec00000] gsi_base[0])
[ 0.000000] IOAPIC[0]: apic_id 2, version 20, address 0xfec00000, GSI 0-23
[ ...

Stefan Richter (stefan-r-ubz) wrote :

Tim, run "modprobe ohci1394" as root and see if there is anything added to the dmesg output.

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. It would be great if you could test this with the latest development release of Ubuntu, Intrepid Ibex Alpha 5, using the Live CD. You can find out more about it at http://www.ubuntu.com/testing . Thanks in advance.

Javier Jardón (jjardon) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in linux:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers