Pairing wiimote leads to kernel null pointer derefence in hid_wiimote

Bug #1048605 reported by Maurus Cuelenaere on 2012-09-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Luis Henriques
Precise
Undecided
Luis Henriques
Quantal
Medium
Luis Henriques

Bug Description

Relevant dmesg lines:

[ 55.782981] wiimote 0005:057E:0306.0006: hidraw3: BLUETOOTH HID v3a.1c Gamepad [Nintendo RVL-CNT-01] on 00:15:83:C7:39:BC
[ 55.783047] input: Nintendo Wii Remote Accelerometer as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1:1.0/bluetooth/hci0/hci0:38/0005:057E:0306.0006/input/input15
[ 55.783187] input: Nintendo Wii Remote IR as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1:1.0/bluetooth/hci0/hci0:38/0005:057E:0306.0006/input/input16
[ 55.783276] input: Nintendo Wii Remote as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1:1.0/bluetooth/hci0/hci0:38/0005:057E:0306.0006/input/input17
[ 55.783390] BUG: unable to handle kernel NULL pointer dereference at 0000000000000040
[ 55.783431] IP: [<ffffffff811ee58c>] sysfs_do_create_link+0x3c/0x210
[ 55.783463] PGD 3a5106067 PUD 3a5108067 PMD 0
[ 55.783485] Oops: 0000 [#1] SMP
[ 55.783502] CPU 0
[ 55.783510] Modules linked in: hid_wiimote(+) ff_memless hidp pci_stub vboxpci(O) vboxnetadp(O) vboxnetflt(O) vboxdrv(O) kvm_intel kvm dm_crypt snd_hda_codec_hdmi snd_hda_codec_idt deflate zlib_deflate ctr twofish_generic twofish_x86_64_3way twofish_x86_64 twofish_common camellia serpent blowfish_generic blowfish_x86_64 blowfish_common cast5 des_generic xcbc rmd160 sha512_generic crypto_null rfcomm af_key parport_pc bnep ppdev nfsd binfmt_misc nfs lockd fscache auth_rpcgss nfs_acl sunrpc btusb bluetooth uvcvideo videodev v4l2_compat_ioctl32 hid_logitech_dj joydev hp_wmi sparse_keymap snd_hda_intel snd_hda_codec snd_hwdep snd_pcm snd_seq_midi snd_rawmidi arc4 snd_seq_midi_event snd_seq snd_timer snd_seq_device ath9k snd mac80211 psmouse ath9k_common ath9k_hw ath serio_raw cfg80211 jmb38x_ms memstick soundcore snd_page_alloc mei(C) hp_accel lis3lv02d input_polldev mac_hid coretemp lp parport uas usb_storage usbhid hid wmi r8169 i915 radeon sdhci_pci sdhci video ttm drm_kms_helper drm i2c_algo_bit [last unloaded: ipmi_msghandler]
[ 55.783981]
[ 55.783990] Pid: 3180, comm: modprobe Tainted: G C O 3.2.0-30-generic #48-Ubuntu Hewlett-Packard HP ProBook 4530s/167C
[ 55.784038] RIP: 0010:[<ffffffff811ee58c>] [<ffffffff811ee58c>] sysfs_do_create_link+0x3c/0x210
[ 55.784077] RSP: 0018:ffff8803a5103c58 EFLAGS: 00010202
[ 55.784098] RAX: 0000000000000000 RBX: ffffffff81a4d9cc RCX: 0000000000000001
[ 55.784127] RDX: ffffffff81a4d9cc RSI: ffff8803e650b8b0 RDI: 0000000000000010
[ 55.784155] RBP: ffff8803a5103cb8 R08: 0000000000000000 R09: ffffffff8130e3d5
[ 55.784183] R10: fffffffffffffd67 R11: 0000000000000000 R12: 0000000000000000
[ 55.784211] R13: ffff8803a4b00000 R14: ffff8803e650b8b0 R15: 0000000000000001
[ 55.784240] FS: 00007f960dee0700(0000) GS:ffff8803ffc00000(0000) knlGS:0000000000000000
[ 55.784273] CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[ 55.784296] CR2: 0000000000000040 CR3: 00000003a4811000 CR4: 00000000000406f0
[ 55.784324] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
[ 55.784352] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
[ 55.784381] Process modprobe (pid: 3180, threadinfo ffff8803a5102000, task ffff8803a49a4500)
[ 55.784414] Stack:
[ 55.784423] 0000000000000282 ffffffff81c96ca0 ffff8803a5103ca8 ffffffff8104dea3
[ 55.784457] ffff8803a5103ca8 0000000000000000 ffff8803a5b1c800 ffff8803e650a000
[ 55.784489] 0000000000000000 ffff8803a4b00000 ffff8803a4b00040 ffff8803e650b8a0
[ 55.784522] Call Trace:
[ 55.784538] [<ffffffff8104dea3>] ? __wake_up+0x53/0x70
[ 55.784560] [<ffffffff811ee773>] sysfs_create_link+0x13/0x20
[ 55.784586] [<ffffffff814dc291>] power_supply_powers+0x21/0x30
[ 55.784612] [<ffffffffa07dc25d>] wiimote_hid_probe+0x1ed/0x304 [hid_wiimote]
[ 55.784647] [<ffffffffa021bba4>] hid_device_probe+0xb4/0x140 [hid]
[ 55.784674] [<ffffffff811ee773>] ? sysfs_create_link+0x13/0x20
[ 55.784699] [<ffffffff813f5a28>] really_probe+0x68/0x190
[ 55.784722] [<ffffffff813f5cb5>] driver_probe_device+0x45/0x70
[ 55.784747] [<ffffffff813f5d8b>] __driver_attach+0xab/0xb0
[ 55.784770] [<ffffffff813f5ce0>] ? driver_probe_device+0x70/0x70
[ 55.784795] [<ffffffff813f5ce0>] ? driver_probe_device+0x70/0x70
[ 55.786524] [<ffffffff813f4b1c>] bus_for_each_dev+0x5c/0x90
[ 55.788358] [<ffffffff813f57ee>] driver_attach+0x1e/0x20
[ 55.790670] [<ffffffff813f5440>] bus_add_driver+0x1a0/0x270
[ 55.792984] [<ffffffffa0071000>] ? 0xffffffffa0070fff
[ 55.794886] [<ffffffff813f62f6>] driver_register+0x76/0x140
[ 55.796586] [<ffffffffa0071000>] ? 0xffffffffa0070fff
[ 55.798276] [<ffffffffa021cb53>] __hid_register_driver+0x53/0x90 [hid]
[ 55.799946] [<ffffffffa0071021>] wiimote_init+0x21/0x1000 [hid_wiimote]
[ 55.802199] [<ffffffff81002040>] do_one_initcall+0x40/0x180
[ 55.804301] [<ffffffff810a83ee>] sys_init_module+0xbe/0x230
[ 55.805965] [<ffffffff81662a02>] system_call_fastpath+0x16/0x1b
[ 55.807622] Code: 89 6d e8 4c 89 75 f0 4c 89 7d f8 66 66 66 66 90 48 85 d2 49 89 f6 48 89 d3 41 89 cf 0f 84 bf 01 00 00 48 85 ff 0f 84 74 01 00 00 <4c> 8b 6f 30 b8 f2 ff ff ff 4d 85 ed 0f 84 ba 00 00 00 48 c7 c7
[ 55.809464] RIP [<ffffffff811ee58c>] sysfs_do_create_link+0x3c/0x210
[ 55.811298] RSP <ffff8803a5103c58>
[ 55.813514] CR2: 0000000000000040
[ 56.045155] ---[ end trace b1ebc7f8b069843a ]---

I can reproduce this consistently by pressing 1+2 on the wiimote and connecting to the device from gnome-bluetooth (I'm assuming I paired correctly, however I can't tell due to this being the problem in the first place).

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-30-generic 3.2.0-30.48
ProcVersionSignature: Ubuntu 3.2.0-30.48-generic 3.2.27
Uname: Linux 3.2.0-30-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu12
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: mcuelenaere 2724 F.... pulseaudio
 /dev/snd/pcmC0D0p: mcuelenaere 2724 F...m pulseaudio
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xd4a00000 irq 51'
   Mixer name : 'Intel CougarPoint HDMI'
   Components : 'HDA:111d76d1,103c167d,00100205 HDA:80862805,80860101,00100000'
   Controls : 23
   Simple ctrls : 11
Date: Mon Sep 10 13:48:46 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MachineType: Hewlett-Packard HP ProBook 4530s
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=nl_BE.utf8
 SHELL=/bin/bash
ProcFB:
 0 radeondrmfb
 1 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.2.0-30-generic root=/dev/mapper/vg_hp4530s-full--disk ro mem=16G quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-30-generic N/A
 linux-backports-modules-3.2.0-30-generic N/A
 linux-firmware 1.79.1
SourcePackage: linux
StagingDrivers: mei
UpgradeStatus: Upgraded to precise on 2012-04-27 (135 days ago)
dmi.bios.date: 03/09/2012
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 68SRR Ver. F.23
dmi.board.name: 167C
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 22.21
dmi.chassis.asset.tag: CNU1243SQW
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr68SRRVer.F.23:bd03/09/2012:svnHewlett-Packard:pnHPProBook4530s:pvrA0001D02:rvnHewlett-Packard:rn167C:rvrKBCVersion22.21:cvnHewlett-Packard:ct10:cvr:
dmi.product.name: HP ProBook 4530s
dmi.product.version: A0001D02
dmi.sys.vendor: Hewlett-Packard

Maurus Cuelenaere (mcuelenaere) wrote :
Brad Figg (brad-figg) on 2012-09-10
Changed in linux (Ubuntu):
status: New → Confirmed
Maurus Cuelenaere (mcuelenaere) wrote :

This doesn't make sense, the backtrace clearly states it visited power_supply_powers(), but it seems there's no trace of that function in the source?

apt-get source linux-image-`uname -r`
grep -R power_supply_powers linux-3.2.0/

yields nothing. Am I missing something?

Maurus Cuelenaere (mcuelenaere) wrote :

Using the kernel from http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-precise/ this works fine, so I presume 217c8b2b1978aa4a02ce040a99c59ed3b6418fe5 fixes the issue.

tags: added: kernel-fixed-upstream-v3.4
Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: needs-upstream-testing
tags: removed: needs-upstream-testing
tags: added: needs-bisect
Luis Henriques (henrix) wrote :

Thank you for your report. The commit you refer to is applied already to the Precise kernel since 3.2.0-25.40. Unfortunately, it looks like the backport of this commit is incorrect and this is probably causing the issue you're hitting.

I've reverted this commit, re-applied it and uploaded a test kernel here:

http://people.canonical.com/~henrix/lp1048605/v1/amd64/

Could you please test this kernel and let me know if it solves this issue? Thanks.

Maurus Cuelenaere (mcuelenaere) wrote :

Yes, this kernel fixes the issue, thanks.

Sep 11 13:27:07 hp4530s kernel: [ 121.758537] wiimote 0005:057E:0306.0006: hidraw3: BLUETOOTH HID v3a.1c Gamepad [Nintendo RVL-CNT-01] on 00:15:83:C7:39:BC
Sep 11 13:27:07 hp4530s kernel: [ 121.758609] input: Nintendo Wii Remote Accelerometer as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1:1.0/bluetooth/hci1/hci1:39/0005:057E:0306.0006/input/input15
Sep 11 13:27:07 hp4530s kernel: [ 121.758762] input: Nintendo Wii Remote IR as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1:1.0/bluetooth/hci1/hci1:39/0005:057E:0306.0006/input/input16
Sep 11 13:27:07 hp4530s kernel: [ 121.758860] input: Nintendo Wii Remote as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1:1.0/bluetooth/hci1/hci1:39/0005:057E:0306.0006/input/input17
Sep 11 13:27:08 hp4530s kernel: [ 122.755365] power_supply wiimote_battery: driver failed to report `capacity' property
Sep 11 13:27:08 hp4530s kernel: [ 122.755441] Registered led device: 0005:057E:0306.0006:blue:p0
Sep 11 13:27:08 hp4530s kernel: [ 122.755479] Registered led device: 0005:057E:0306.0006:blue:p1
Sep 11 13:27:08 hp4530s kernel: [ 122.755510] Registered led device: 0005:057E:0306.0006:blue:p2
Sep 11 13:27:08 hp4530s kernel: [ 122.755535] Registered led device: 0005:057E:0306.0006:blue:p3
Sep 11 13:27:08 hp4530s kernel: [ 122.755539] wiimote 0005:057E:0306.0006: New device registered

Maurus Cuelenaere (mcuelenaere) wrote :

Probably unrelated to this bug: it crashes when unplugging the USB bluetooth adapter (couldn't get a stack trace). I'll try to reproduce.

Maurus Cuelenaere (mcuelenaere) wrote :
Download full text (7.9 KiB)

This could be an upstream issue, had similar problems when testing the above mentioned 3.4 kernel.
Method of reproducing:

* plug USB bluetooth stick
* pair wiimote
* unplug USB bluetooth stick
* replug USB bluetooth stick

The actual problem (getting wiimote to work) is fixed though.

Sep 11 13:44:44 hp4530s kernel: [ 819.512448] wiimote 0005:057E:0306.0007: hidraw3: BLUETOOTH HID v3a.1c Gamepad [Nintendo RVL-CNT-01] on 00:15:83:C7:39:BC
Sep 11 13:44:44 hp4530s kernel: [ 819.512650] input: Nintendo Wii Remote Accelerometer as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1:1.0/bluetooth/hci1/hci1:39/0005:057E:0306.0007/input/input18
Sep 11 13:44:44 hp4530s kernel: [ 819.512945] input: Nintendo Wii Remote IR as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1:1.0/bluetooth/hci1/hci1:39/0005:057E:0306.0007/input/input19
Sep 11 13:44:44 hp4530s kernel: [ 819.513236] input: Nintendo Wii Remote as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1:1.0/bluetooth/hci1/hci1:39/0005:057E:0306.0007/input/input20
Sep 11 13:44:45 hp4530s kernel: [ 820.512501] power_supply wiimote_battery: driver failed to report `capacity' property
Sep 11 13:44:45 hp4530s kernel: [ 820.512665] Registered led device: 0005:057E:0306.0007:blue:p0
Sep 11 13:44:45 hp4530s kernel: [ 820.512716] Registered led device: 0005:057E:0306.0007:blue:p1
Sep 11 13:44:45 hp4530s kernel: [ 820.512759] Registered led device: 0005:057E:0306.0007:blue:p2
Sep 11 13:44:45 hp4530s kernel: [ 820.512802] Registered led device: 0005:057E:0306.0007:blue:p3
Sep 11 13:44:45 hp4530s kernel: [ 820.512808] wiimote 0005:057E:0306.0007: New device registered
Sep 11 13:44:53 hp4530s kernel: [ 828.245140] show_signal_msg: 48 callbacks suppressed
Sep 11 13:44:53 hp4530s kernel: [ 828.249114] pool[4964]: segfault at 100000007 ip 00007faca46a8882 sp 00007fac977decc0 error 4 in libc-2.15.so[7faca462a000+1b3000]
Sep 11 13:45:11 hp4530s bluetoothd[1168]: HCI dev 1 down
Sep 11 13:45:11 hp4530s bluetoothd[1168]: Adapter /org/bluez/1168/hci1 has been disabled
Sep 11 13:45:11 hp4530s kernel: [ 846.298284] usb 2-1.1: USB disconnect, device number 12
Sep 11 13:45:11 hp4530s kernel: [ 846.301945] Bluetooth: hci1 urb ffff8803e1b9cf00 submission failed
Sep 11 13:45:11 hp4530s kernel: [ 846.301967] wiimote 0005:057E:0306.0007: Device removed
Sep 11 13:45:11 hp4530s bluetoothd[1168]: HCI dev 1 unregistered
Sep 11 13:45:11 hp4530s bluetoothd[1168]: Stopping hci1 event socket
Sep 11 13:45:11 hp4530s bluetoothd[1168]: Unregister path: /org/bluez/1168/hci1
Sep 11 13:45:12 hp4530s kernel: [ 847.300846] power_supply wiimote_battery: driver failed to report `capacity' property
Sep 11 13:45:20 hp4530s kernel: [ 855.700520] usb 2-1.1: new full-speed USB device number 13 using ehci_hcd
Sep 11 13:45:21 hp4530s bluetoothd[1168]: HCI dev 1 registered
Sep 11 13:45:21 hp4530s bluetoothd[1168]: Listening for HCI events on hci1
Sep 11 13:45:21 hp4530s bluetoothd[1168]: HCI dev 1 up
Sep 11 13:45:21 hp4530s bluetoothd[1168]: sap-dummy interface org.bluez.SimAccessTest init failed on path /org/bluez/test
Sep 11 13:45:21 hp4530s bluetoothd[1168]: Sap driver initialization failed.
Sep 11 13:45:21 hp4530s bluetooth...

Read more...

Luis Henriques (henrix) wrote :

Thank you for testing. This new issue seems to be unrelated with the initial problem. It looks like the driver fails to cleanly unregister when the BT is unplugged and then it isn't able to reattach. This new issue may also not be related with the wiimote driver itself, but with the BT stack. Anyway, could you please report this in a new bug?

Luis Henriques (henrix) on 2012-09-11
Changed in linux (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Luis Henriques (henrix)
Tim Gardner (timg-tpi) on 2012-09-11
Changed in linux (Ubuntu Precise):
assignee: nobody → Luis Henriques (henrix)
status: New → Fix Committed
Changed in linux (Ubuntu Quantal):
status: In Progress → Fix Released
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel for Precise in -proposed solves the problem (3.2.0-32.51). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-precise' to 'verification-done-precise'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-precise

Verified working.

mcuelenaere@hp4530s:~$ uname -a
Linux hp4530s 3.2.0-32-generic #51-Ubuntu SMP Wed Sep 26 21:33:09 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
mcuelenaere@hp4530s:~$ tail -n 15 /var/log/syslog
Sep 29 11:58:13 hp4530s bluetoothd[946]: Endpoint unregistered: sender=:1.33 path=/MediaEndpoint/A2DPSource
Sep 29 11:58:13 hp4530s bluetoothd[946]: Endpoint unregistered: sender=:1.33 path=/MediaEndpoint/A2DPSink
Sep 29 11:58:18 hp4530s kernel: [ 36.321661] wiimote 0005:057E:0306.0004: hidraw1: BLUETOOTH HID v3a.1c Gamepad [Nintendo RVL-CNT-01] on 00:15:83:C7:39:BC
Sep 29 11:58:18 hp4530s kernel: [ 36.321712] input: Nintendo Wii Remote Accelerometer as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.3/1-1.3:1.0/bluetooth/hci0/hci0:38/0005:057E:0306.0004/input/input13
Sep 29 11:58:18 hp4530s kernel: [ 36.321805] input: Nintendo Wii Remote IR as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.3/1-1.3:1.0/bluetooth/hci0/hci0:38/0005:057E:0306.0004/input/input14
Sep 29 11:58:18 hp4530s kernel: [ 36.321891] input: Nintendo Wii Remote as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.3/1-1.3:1.0/bluetooth/hci0/hci0:38/0005:057E:0306.0004/input/input15
Sep 29 11:58:19 hp4530s kernel: [ 37.319813] power_supply wiimote_battery: driver failed to report `capacity' property
Sep 29 11:58:19 hp4530s kernel: [ 37.319893] Registered led device: 0005:057E:0306.0004:blue:p0
Sep 29 11:58:19 hp4530s kernel: [ 37.319926] Registered led device: 0005:057E:0306.0004:blue:p1
Sep 29 11:58:19 hp4530s kernel: [ 37.319954] Registered led device: 0005:057E:0306.0004:blue:p2
Sep 29 11:58:19 hp4530s kernel: [ 37.319983] Registered led device: 0005:057E:0306.0004:blue:p3
Sep 29 11:58:19 hp4530s kernel: [ 37.319987] wiimote 0005:057E:0306.0004: New device registered
Sep 29 11:58:25 hp4530s blueman-mechanism: Exiting
Sep 29 11:58:57 hp4530s dbus[895]: [system] Activating service name='com.ubuntu.SystemService' (using servicehelper)
Sep 29 11:58:57 hp4530s dbus[895]: [system] Successfully activated service 'com.ubuntu.SystemService'

tags: added: verification-done-precise
removed: verification-needed-precise

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :
Download full text (18.4 KiB)

This bug was fixed in the package linux - 3.2.0-32.51

---------------
linux (3.2.0-32.51) precise-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1056036

  [ Keng-Yu Lin ]

  * SAUCE: Intel xhci: Only switch the switchable ports
    - LP: #1034814

  [ Kyle Fazzari ]

  * SAUCE: input: Cypress PS/2 Trackpad fix disabling tap-to-click
    - LP: #1048816

  [ Seth Forshee ]

  * SAUCE: Input: synaptics - Adjust threshold for treating position values
    as negative
    - LP: #1046512

  [ Stefan Bader ]

  * Revert "SAUCE: Force xsave off on older Xen hypervisors"
    - LP: #1044550

  [ Upstream Kernel Changes ]

  * Revert "HID: wiimote: fix invalid power_supply_powers call"
    - LP: #1048605
  * Revert "drm/radeon: fix bo creation retry path"
    - LP: #1049899
  * HID: wiimote: fix invalid power_supply_powers call
    - LP: #1048605
  * HID: add ASUS AIO keyboard model AK1D
    - LP: #1027789, #1049899
  * nfs: tear down caches in nfs_init_writepagecache when allocation fails
    - LP: #1049899
  * NFS: Use kcalloc() when allocating arrays
    - LP: #1049899
  * NFSv4.1 fix page number calculation bug for filelayout decode buffers
    - LP: #1049899
  * fix page number calculation bug for block layout decode buffer
    - LP: #1049899
  * pnfs: defer release of pages in layoutget
    - LP: #1049899
  * ext4: avoid kmemcheck complaint from reading uninitialized memory
    - LP: #1049899
  * fuse: verify all ioctl retry iov elements
    - LP: #1049899
  * Bluetooth: Fix legacy pairing with some devices
    - LP: #1049899
  * xhci: Increase reset timeout for Renesas 720201 host.
    - LP: #1049899
  * xhci: Add Etron XHCI_TRUST_TX_LENGTH quirk.
    - LP: #1049899
  * USB: ftdi_sio: Add VID/PID for Kondo Serial USB
    - LP: #1049899
  * USB: option: Add Vodafone/Huawei K5005 support
    - LP: #1049899
  * USB: add USB_VENDOR_AND_INTERFACE_INFO() macro
    - LP: #1049899
  * USB: support the new interfaces of Huawei Data Card devices in option
    driver
    - LP: #1049899
  * usb: serial: mos7840: Fixup mos7840_chars_in_buffer()
    - LP: #1049899
  * usb: gadget: u_ether: fix kworker 100% CPU issue with still used
    interfaces in eth_stop
    - LP: #1049899
  * ARM: 7483/1: vfp: only advertise VFPv4 in hwcaps if CONFIG_VFPv3 is
    enabled
    - LP: #1049899
  * ARM: 7488/1: mm: use 5 bits for swapfile type encoding
    - LP: #1049899
  * ARM: 7489/1: errata: fix workaround for erratum #720789 on UP systems
    - LP: #1049899
  * drm/i915: ignore eDP bpc settings from vbt
    - LP: #1049899
  * ALSA: hda - fix Copyright debug message
    - LP: #1049899
  * sched: fix divide by zero at {thread_group,task}_times
    - LP: #1049899
  * ath9k: fix decrypt_error initialization in ath_rx_tasklet()
    - LP: #1049899
  * drm/nvd0/disp: mask off high 16 bit of negative cursor x-coordinate
    - LP: #1049899
  * drm/i915: reorder edp disabling to fix ivb MacBook Air
    - LP: #1049899
  * audit: don't free_chunk() after fsnotify_add_mark()
    - LP: #1049899
  * audit: fix refcounting in audit-tree
    - LP: #1049899
  * vfs: canonicalize create mode in build_open_flags()
    - LP: #1049899
  * PCI: EHCI: Fix crash d...

Changed in linux (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers