Kernel Panic at boot on new kernel linux-image-3.5.0-14

Bug #1048178 reported by fmo on 2012-09-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned

Bug Description

Hi,

I am experiencing a kernel panic at boot time since I updated to kernel 3.5.0-14.

I am using the 64 bits kernel.

My laptop is a Samsung Series 5 Ultrabook with Ivy Bridge chipset (model NP530U4C).

I have attached a screenshot of the kernel panic message.

If you have any questions please don't hesitate to ask, I am now running on previous kernel 3.5.0-13.

Regards

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: linux-image-3.5.0-14-generic 3.5.0-14.15
ProcVersionSignature: Ubuntu 3.5.0-13.14-generic 3.5.3
Uname: Linux 3.5.0-13-generic x86_64
AcpiTables: Error: command ['pkexec', '/usr/share/apport/dump_acpi_tables.py'] failed with exit code 127: Error executing /usr/share/apport/dump_acpi_tables.py: Permission denied
ApportVersion: 2.5.1-0ubuntu7
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: fmo 1786 F.... pulseaudio
CRDA:
 country EU:
  (2402 - 2482 @ 40), (N/A, 20)
  (5170 - 5250 @ 40), (N/A, 20)
  (5250 - 5330 @ 40), (N/A, 20), DFS
  (5490 - 5710 @ 40), (N/A, 27), DFS
Date: Sun Sep 9 10:50:00 2012
HibernationDevice: RESUME=UUID=7460718f-6469-4107-a3b8-f00c1e21de53
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120903.4)
MachineType: SAMSUNG ELECTRONICS CO., LTD. 530U3C/530U4C
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-13-generic root=UUID=71d3d43c-e8f3-4958-ab17-b563677c93f2 ro quiet splash
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-13-generic N/A
 linux-backports-modules-3.5.0-13-generic N/A
 linux-firmware 1.91
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/26/2012
dmi.bios.vendor: Phoenix Technologies Ltd.
dmi.bios.version: P01AAJ
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 530U3C/530U4C
dmi.board.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.board.version: FAB1
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 9
dmi.chassis.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnPhoenixTechnologiesLtd.:bvrP01AAJ:bd04/26/2012:svnSAMSUNGELECTRONICSCO.,LTD.:pn530U3C/530U4C:pvr0.1:rvnSAMSUNGELECTRONICSCO.,LTD.:rn530U3C/530U4C:rvrFAB1:cvnSAMSUNGELECTRONICSCO.,LTD.:ct9:cvr0.1:
dmi.product.name: 530U3C/530U4C
dmi.product.version: 0.1
dmi.sys.vendor: SAMSUNG ELECTRONICS CO., LTD.

fmo (fmo) wrote :
Brad Figg (brad-figg) on 2012-09-09
Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.6 kernel[0] (Not a kernel in the daily directory) and install both the linux-image and linux-image-extra .deb packages.

Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. Please only remove that one tag and leave the other tags. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.6-rc5-quantal/

Changed in linux (Ubuntu):
importance: Undecided → High
tags: added: needs-upstream-testing regression-update
tags: added: needs-bisect
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
fmo (fmo) wrote :

Hi,

I have tested with kernel 3.6.0-030600rc5-generic as requested and the bug is not present.

The bug appeared between 3.5.0-13 and 3.5.0-14.

I have removed the tag "needs-upstream-testing" and added "kernel-fixed-upstream" then mark as Confirmed.

Many thanks,
Fernando

tags: removed: needs-upstream-testing
tags: added: kernel-fixed-upstream
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

I'd like to perform a kernel bisect to identify the commit that introduced this regression. Would it be possible for you to assist, which would require testing of 7 to 10 kernels?

fmo (fmo) wrote :

Sure, send me a link to the kernels.

I probably won't be able to do much testing tonight or tomorrow during the day but I should be able to finish tomorrow evening.

That's of course if it doesn't fail at the first commit :)

Joseph Salisbury (jsalisbury) wrote :
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
fmo (fmo) wrote :

Hi,

Thanks a lot for sending this, I will try them tomorrow.

I wanted to add that I have had occasional kernel panic a boot time on "kernel 3.6.0-030600rc5-generic"

fmo (fmo) wrote :

Hi,

I'm afraid the test results won't be of a lot of help.

Both kernels work fine.

Actually even 3.5.0-14 works now following the last update.

The one behaviour I have noticed is that the problem seemed to happen more when running on battery (with 3.6rc).

I am not seeing the problem anymore but now the battery indicator doesn't seem to be able to notice when the power is plugged or unplugged...

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
fmo (fmo) wrote :

Do you need me to do any additional testing?

Joseph Salisbury (jsalisbury) wrote :

I don't think so at this point, since the panic stopped happening in 3.5.0-14.

Please change the bug back to 'Confirmed' if the panics start happening again.

fmo (fmo) on 2012-10-03
Changed in linux (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers