Wireless not active during installation or after boot

Bug #1043403 reported by Lars Noodén on 2012-08-29
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Low
Unassigned

Bug Description

The i386 has a Ralink corp. RT2561/RT61 802.11g PCI wireless card. However, the installation process seems unable to use it to find any wireless networks, not even open networks. Same goes after booting and trying manually.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: ubiquity (not installed)
ProcVersionSignature: Ubuntu 3.5.0-13.13-generic 3.5.3
Uname: Linux 3.5.0-13-generic i686
ApportVersion: 2.5.1-0ubuntu2
Architecture: i386
Date: Wed Aug 29 18:50:47 2012
InstallCmdLine: file=/cdrom/preseed/lubuntu.seed boot=casper only-ubiquity initrd=/casper/initrd.lz quiet splash --
InstallationMedia: Lubuntu 12.10 "Quantal Quetzal" - Alpha i386 (20120828)
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)
---
AcpiTables:

ApportVersion: 2.5.1-0ubuntu2
Architecture: i386
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/by-path', '/dev/snd/controlC0', '/dev/snd/pcmC0D0c', '/dev/snd/pcmC0D0p', '/dev/snd/pcmC0D1c', '/dev/snd/pcmC0D1p', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
CRDA: Error: [Errno 2] No such file or directory
CurrentDmesg: [ 27.408464] init: lightdm main process (943) terminated with status 1
DistroRelease: Ubuntu 12.10
HibernationDevice: RESUME=UUID=2a0d5ff8-7854-49fd-91e2-be4326cfc418
InstallationMedia: Lubuntu 12.10 "Quantal Quetzal" - Alpha i386 (20120828)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: Packard Bell Computers International Packard Bell EasyNote
Package: linux (not installed)
ProcFB: 0 VESA VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-13-generic root=UUID=1e64a51f-2f5b-4d0f-bb43-88c03014c8b4 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.5.0-13.13-generic 3.5.3
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-13-generic N/A
 linux-backports-modules-3.5.0-13-generic N/A
 linux-firmware 1.90
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: yes
Tags: quantal
Uname: Linux 3.5.0-13-generic i686
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: /08/0520
dmi.bios.vendor: Insyde Software Corporation
dmi.bios.version: R1.01
dmi.board.asset.tag: 87654321
dmi.board.name: NEC Versa Premium
dmi.board.vendor: NEC COMPUTERS INTERNATIONAL
dmi.board.version: 5a
dmi.chassis.asset.tag: 12345678
dmi.chassis.type: 5
dmi.modalias: dmi:bvnInsydeSoftwareCorporation:bvrR1.01:bd/08/0520:svnPackardBellComputersInternational:pnPackardBellEasyNote:pvrPB42BD0291:rvnNECCOMPUTERSINTERNATIONAL:rnNECVersaPremium:rvr5a:cvn:ct5:cvrI:
dmi.product.name: Packard Bell EasyNote
dmi.product.version: PB42BD0291
dmi.sys.vendor: Packard Bell Computers International

Lars Noodén (larsnooden) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1043403

tags: added: iso-testing
Dimitri John Ledkov (xnox) wrote :

In that case it is not installer issue, but a kernel issue. Assigning packages as appropriate. A bot message should appear soon with instruction what to do.

Changed in linux (Ubuntu):
status: New → Invalid
status: Invalid → New
Changed in ubiquity (Ubuntu):
status: New → Invalid

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1043403

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → New
status: New → Confirmed
Tim Gardner (timg-tpi) wrote :

The root of your issue might be this (found in BootDmesg.txt):

[ 8.981460] rt61pci 0000:00:06.0: enabling device (0000 -> 0002)
[ 8.981477] rt61pci 0000:00:06.0: can't find IRQ for PCI INT A; please try using pci=biosirq
[ 8.981495] rt61pci 0000:00:06.0: setting latency timer to 64

Lars Noodén (larsnooden) wrote :

I've tried adding 'pci=biosirq' to the boot options for linux via grub. I could not notice any change. What is it likely to affect? It still appears disabled.

$ sudo rfkill list all
0: phy0: Wireless LAN
 Soft blocked: no
 Hard blocked: yes

$ sudo lshw -C network
  *-network:0 DISABLED
       description: Wireless interface
       product: RT2561/RT61 802.11g PCI
       vendor: Ralink corp.
       physical id: 6
       bus info: pci@0000:00:06.0
       logical name: wlan0
       version: 00
       serial: 00:10:60:67:0b:72
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rt61pci driverversion=3.5.0-13-generic firmware=N/A latency=64 link=no multicast=yes wireless=IEEE 802.11bg
       resources: irq:0 memory:ffff8000-ffffffff
  *-network:1
       description: Ethernet interface
       product: VT6102 [Rhine-II]
       vendor: VIA Technologies, Inc.
       physical id: 12
       bus info: pci@0000:00:12.0
       logical name: eth0
       version: 74
       serial: 00:40:d0:95:11:55
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=via-rhine driverversion=1.5.0 duplex=full ip=192.168.2.35 latency=128 link=yes maxlatency=8 mingnt=3 multicast=yes port=MII speed=100Mbit/s
       resources: irq:11 ioport:e200(size=256) memory:d0000000-d00000ff

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.6 kernel[0] (Not a kernel in the daily directory) and install both the linux-image and linux-image-extra .deb packages.

Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. Please only remove that one tag and leave the other tags. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.6-rc3-quantal/

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Lars Noodén (larsnooden) wrote :

I think I have the upstream kernel now, but the problem still seems to be in place.

# uname -a
Linux easynote 3.6.0-030600rc3-generic #201208221735 SMP Wed Aug 22 21:45:31 UTC 2012 i686 i686 i686 GNU/Linux

# rfkill list all
0: phy0: Wireless LAN
 Soft blocked: no
 Hard blocked: yes

# iwlist scan
wlan0 Interface doesn't support scanning : Network is down

lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

tags: added: kernel-bug-exists-upstream
description: updated
tags: removed: needs-upstream-testing
Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report[0]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

[0] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Changed in linux (Ubuntu):
status: Incomplete → Triaged

Created attachment 78811
dmesg

The i386 has a Ralink corp. RT2561/RT61 802.11g PCI wireless card. However, the installation process seems unable to use it to find any wireless networks, not even open networks. Same goes after booting and trying manually. This is true even with the new kernel:

# uname -a
Linux easynote 3.6.0-030600rc3-generic #201208221735 SMP Wed Aug 22 21:45:31 UTC 2012 i686 i686 i686 GNU/Linux

# rfkill list all
0: phy0: Wireless LAN
 Soft blocked: no
 Hard blocked: yes

What information is needed to make a proper bug report?

[ 15.649864] rt61pci 0000:00:06.0: enabling device (0000 -> 0002)
[ 15.649882] rt61pci 0000:00:06.0: can't find IRQ for PCI INT A; please try using pci=biosirq
[ 15.649900] rt61pci 0000:00:06.0: setting latency timer to 64

Created attachment 78861
dmesg after pci=biosirq

I tried setting pci=biosirq in the grub menu and the only difference I see is that the consoles vanish. I can still log in via ssh though.

# rfkill list all
0: phy0: Wireless LAN
 Soft blocked: no
 Hard blocked: yes

Changed in ubiquity:
importance: Unknown → Medium
status: Unknown → Confirmed
no longer affects: ubiquity
Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed

Lars Noodén, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please just make a comment to this.

Also, could you please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.12

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

no longer affects: ubiquity (Ubuntu)
tags: added: needs-upstream-testing
removed: ubiquity-2.11.23
Changed in linux (Ubuntu):
status: Triaged → Incomplete
no longer affects: linux (Ubuntu)
affects: linux → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Medium → Undecided
status: Confirmed → New
importance: Undecided → Low
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.