Regression - screen brightness worked with kernel 3.2.0-23 but not with 3.2.0-29

Bug #1041846 reported by Tim Edwards on 2012-08-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

When I originally installed Ubuntu 12.04 it came with kernel 3.2.0-23 and the screen brightness controls on my Samsung NP530U3C worked out-of-the-box.

However after I applied the updates and rebooted into the latest kernel (3.2.0-29) the screen brightness controls no longer work.

Symptoms:
Press screen brightness function keys to either increase or decrease brightness OR try changing the screen brightness in either KDE or GNOME with the 'slider' in the respective power management GUI programs

Expected Result and Result with kernel 3.2.0-23:
Screen brightness increases or decreases accordingly

Actual Result with kernel 3.2.0-29:
Screen flickers a bit but the brightness level seems 'stuck' and won't change.

Workaround:
The funny thing is that manipulating the /sys/class/backlight/acpi_video0 files directly works, so:
echo 47 | sudo tee /sys/class/backlight/acpi_video0/brightness # set brightness to approx 50% of the maximum
---
ApportVersion: 2.0.1-0ubuntu12
Architecture: amd64
DistroRelease: Ubuntu 12.04
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
Package: acpi 1.6-1
PackageArchitecture: amd64
ProcEnviron:
 LANGUAGE=en_AU:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 3.2.0-29.46-generic 3.2.24
Tags: precise
Uname: Linux 3.2.0-29-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

apport information

tags: added: apport-collected precise
description: updated
Tim Edwards (tkedwards) wrote :

sudo lspci
00:00.0 Host bridge: Intel Corporation Ivy Bridge DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Ivy Bridge Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation Panther Point USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation Panther Point MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation Panther Point USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation Panther Point High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 1 (rev c4)
00:1c.3 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 4 (rev c4)
00:1d.0 USB controller: Intel Corporation Panther Point USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation Panther Point LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation Panther Point 6 port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation Panther Point SMBus Controller (rev 04)
01:00.0 Network controller: Intel Corporation Centrino Advanced-N 6235 (rev 24)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)

papukaija (papukaija) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 1028151, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

affects: acpi (Ubuntu) → linux (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers