WARN Successful completion on short TX: needs XHCI_TRUST_TX_LENGTH quirk?

Bug #1039478 reported by Marcin Juszkiewicz on 2012-08-21
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Tim Gardner
Quantal
Medium
Tim Gardner

Bug Description

I bought Toshiba 500GB harddrive with USB 3.0 interface. After connecting it to quantal desktop I got lot of crazy kernel messages. Device got connected, disconnected, connected, disconnected etc.

[165216.423303] usb 6-1: new SuperSpeed USB device number 2 using xhci_hcd
[165216.441744] usb 6-1: Parent hub missing LPM exit latency info. Power management will be impacted.
[165216.443969] xhci_hcd 0000:06:00.0: WARN Successful completion on short TX: needs XHCI_TRUST_TX_LENGTH quirk?
[165216.444696] xhci_hcd 0000:06:00.0: WARN Successful completion on short TX: needs XHCI_TRUST_TX_LENGTH quirk?
[165216.445466] xhci_hcd 0000:06:00.0: WARN Successful completion on short TX: needs XHCI_TRUST_TX_LENGTH quirk?
[165216.446193] xhci_hcd 0000:06:00.0: WARN Successful completion on short TX: needs XHCI_TRUST_TX_LENGTH quirk?
[165216.446229] usb 6-1: New USB device found, idVendor=0930, idProduct=0b1a
[165216.446231] usb 6-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[165216.446232] usb 6-1: Product: STOR.E ALU 2S
[165216.446233] usb 6-1: Manufacturer: TOSHIBA
[165216.446234] usb 6-1: SerialNumber: 201202104160
[165216.446691] xhci_hcd 0000:06:00.0: WARN Successful completion on short TX: needs XHCI_TRUST_TX_LENGTH quirk?
---
ApportVersion: 2.4-0ubuntu8
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: hrw 4039 F.... pulseaudio
 /dev/snd/controlC0: hrw 4039 F.... pulseaudio
 /dev/snd/pcmC0D0p: hrw 4039 F...m pulseaudio
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
DistroRelease: Ubuntu 12.10
MachineType: Gigabyte Technology Co., Ltd. P67X-UD3-B3
Package: linux (not installed)
ProcEnviron:
 TERM=xterm
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=pl_PL.UTF-8
 LANGUAGE=pl:en
ProcFB: 0 radeondrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-10-generic root=UUID=b998ea79-ff6e-44e6-b6d4-b5eddddedde0 ro nodmraid 8250.nr_uarts=7 loglevel=9 vt.handoff=7
ProcVersionSignature: Ubuntu 3.5.0-10.10ubuntu1-generic 3.5.1
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-10-generic N/A
 linux-backports-modules-3.5.0-10-generic N/A
 linux-firmware 1.89
RfKill:
 0: hci0: Bluetooth
  Soft blocked: no
  Hard blocked: no
Tags: quantal
Uname: Linux 3.5.0-10-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout libvirtd lpadmin plugdev sambashare vboxusers video
dmi.bios.date: 03/21/2012
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F9
dmi.board.name: P67X-UD3-B3
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF9:bd03/21/2012:svnGigabyteTechnologyCo.,Ltd.:pnP67X-UD3-B3:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnP67X-UD3-B3:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: P67X-UD3-B3
dmi.sys.vendor: Gigabyte Technology Co., Ltd.

Marcin Juszkiewicz (hrw) wrote :
Marcin Juszkiewicz (hrw) wrote :
tags: added: apport-collected quantal
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Marcin Juszkiewicz (hrw) wrote :

When I rebuilt kernel with attached patches device started working fine.

Patches taken from linux-usb ML: http://marc.info/?l=linux-usb&m=134445486007042&w=3

tags: added: patch usb
Brad Figg (brad-figg) on 2012-08-21
Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Can you test the v3.6-rc1[0] kernel to confirm it resolves this bug?

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.6-rc1-quantal/

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
tags: added: kernel-da-key
Marcin Juszkiewicz (hrw) wrote :

Those patches got merged after 3.6-rc1 so will try http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.6-rc2-quantal/ ones.

Marcin Juszkiewicz (hrw) wrote :

rc1 is not able to boot - fails to bring up CPUs and reboots

rc2 boots but my usb keyboard is not responding so no way to check does it work

Changed in linux (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Joseph Salisbury (jsalisbury)
Joseph Salisbury (jsalisbury) wrote :

I built a Quantal(12.10) test kernel with the following commits cherry-picked:

5cb7df2b2d3afee7638b3ef23a5bcb89c6f07bd9
8202ce2e2921941098aa72894ac5d7b486a9d273
50d0206fcaea3e736f912fd5b00ec6233fb4ce44

The kernel can be downloaded from(Note that you need to install both the linux-image and linux-image-extra packages):
http://people.canonical.com/~jsalisbury/lp1039478

Can you test that kernel and report back if it fixes this bug?

Joseph Salisbury (jsalisbury) wrote :

I will set the bug to Incomplete since the original bug reporter no longer has the hardware.

Please set this bug back to confirmed if anyone else runs into this bug, or if you are able to get the hardware again, Marcin.

Changed in linux (Ubuntu):
status: In Progress → Incomplete
assignee: Joseph Salisbury (jsalisbury) → nobody
Martin Gyurko (gyurma) on 2012-09-30
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Martin Gyurko (gyurma) wrote :
Download full text (5.0 KiB)

I have similar problem with etron USB3 controller and IOMEGA 1TByte USB3 disk
Sometimes it also crashes the driver, and drive is no longer recognized even after unpluging and replugging
...
05:00.0 USB controller: Etron Technology, Inc. EJ168 USB 3.0 Host Controller (rev 01) (prog-if 30 [XHCI])
 Subsystem: ASRock Incorporation Device 7023
 Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 64 bytes
 Interrupt: pin A routed to IRQ 40
 Region 0: Memory at fea00000 (64-bit, non-prefetchable) [size=32K]
 Capabilities: <access denied>
 Kernel driver in use: xhci_hcd
...

...
Bus 009 Device 002: ID 059b:0070 Iomega Corp.
Couldn't open device, some information will be missing
Device Descriptor:
  bLength 18
  bDescriptorType 1
  bcdUSB 3.00
  bDeviceClass 0 (Defined at Interface level)
  bDeviceSubClass 0
  bDeviceProtocol 0
  bMaxPacketSize0 9
  idVendor 0x059b Iomega Corp.
  idProduct 0x0070
  bcdDevice 0.06
  iManufacturer 1
  iProduct 2
  iSerial 3
  bNumConfigurations 1
  Configuration Descriptor:
    bLength 9
    bDescriptorType 2
    wTotalLength 121
    bNumInterfaces 1
    bConfigurationValue 1
    iConfiguration 4
    bmAttributes 0x80
      (Bus Powered)
    MaxPower 224mA
    Interface Descriptor:
      bLength 9
      bDescriptorType 4
      bInterfaceNumber 0
      bAlternateSetting 0
      bNumEndpoints 2
      bInterfaceClass 8 Mass Storage
      bInterfaceSubClass 6 SCSI
      bInterfaceProtocol 80 Bulk-Only
      iInterface 5
      Endpoint Descriptor:
        bLength 7
        bDescriptorType 5
        bEndpointAddress 0x01 EP 1 OUT
        bmAttributes 2
          Transfer Type Bulk
          Synch Type None
          Usage Type Data
        wMaxPacketSize 0x0400 1x 1024 bytes
        bInterval 0
        bMaxBurst 15
      Endpoint Descriptor:
        bLength 7
        bDescriptorType 5
        bEndpointAddress 0x81 EP 1 IN
        bmAttributes 2
          Transfer Type Bulk
          Synch Type None
          Usage Type Data
        wMaxPacketSize 0x0400 1x 1024 bytes
        bInterval 0
        bMaxBurst 15
    Interface Descriptor:
      bLength 9
      bDescriptorType 4
      bInterfaceNumber 0
      bAlternateSetting 1
      bNumEndpoints 4
      bInterfaceClass 8 Mass Storage
      bInterfaceSubClass 6 SCSI
      bInterfaceProtocol 98
      iInterface 5
      Endpoint Descriptor:
        bLength 7
        bDescriptorType ...

Read more...

Tim Gardner (timg-tpi) wrote :

cherry picked commit 8202ce2e2921941098aa72894ac5d7b486a9d273

Commits 5cb7df2b2d3afee7638b3ef23a5bcb89c6f07bd9 and 50d0206fcaea3e736f912fd5b00ec6233fb4ce44 are already applied

Changed in linux (Ubuntu Quantal):
assignee: nobody → Tim Gardner (timg-tpi)
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.5.0-17.26

---------------
linux (3.5.0-17.26) quantal-proposed; urgency=low

  [ David Henningsson ]

  * SAUCE: ALSA: hda - fix indices on boost volume on Conexant
    - LP: #1059523

  [ Leann Ogasawara ]

  * [Config] Build in CONFIG_X86_PCC_CPUFREQ=y
    - LP: #1061126

  [ Rob Herring ]

  * Revert "SAUCE: ahci_platform: add custom hard reset for Calxeda ahci
    ctrlr"
    - LP: #1059432
  * Revert "SAUCE: net: calxedaxgmac: add write barriers around setting
    owner bit"
    - LP: #1059432
  * Revert "SAUCE: ARM: highbank: use writel_relaxed variant for pwr
    requests"
    - LP: #1059432
  * Revert "SAUCE: force DMA buffers to non-bufferable on highbank"
    - LP: #1059432
  * Revert "SAUCE: input: add a key driver for highbank"
    - LP: #1059432
  * [Config] Align highbank config with amd64-generic and add new configs
    - LP: #1059432
  * SAUCE: net: calxedaxgmac: enable operate on 2nd frame mode
    - LP: #1059432
  * SAUCE: net: calxedaxgmac: remove explicit rx dma buffer polling
    - LP: #1059432
  * SAUCE: net: calxedaxgmac: use relaxed i/o accessors in rx and tx paths
    - LP: #1059432
  * SAUCE: net: calxedaxgmac: drop some unnecessary register writes
    - LP: #1059432
  * SAUCE: net: calxedaxgmac: rework transmit ring handling
    - LP: #1059432
  * SAUCE: ARM: highbank: retry wfi on reset request
    - LP: #1059432

  [ Tim Gardner ]

  * [Config] TIDSPBRIDGE=m
    - LP: #1058022
  * rebase to v3.5.5

  [ Upstream Kernel Changes ]

  * common: DMA-mapping: add DMA_ATTR_NO_KERNEL_MAPPING attribute
    - LP: #1059432
  * common: DMA-mapping: add DMA_ATTR_SKIP_CPU_SYNC attribute
    - LP: #1059432
  * ARM: dma-mapping: add support for DMA_ATTR_SKIP_CPU_SYNC attribute
    - LP: #1059432
  * ARM: add coherent dma ops
    - LP: #1059432
  * ARM: add coherent iommu dma ops
    - LP: #1059432
  * ARM: highbank: add coherent DMA setup
    - LP: #1059432
  * sata: add platform driver for Calxeda AHCI controller
    - LP: #1059432
  * xhci: Rate-limit XHCI_TRUST_TX_LENGTH quirk warning.
    - LP: #1039478
  * agp/intel-gtt: remove dead code
    - LP: #1011440
  * drm/i915: stop using dev->agp->base
    - LP: #1011440
  * agp/intel-gtt: don't require the agp bridge on setup
    - LP: #1011440
  * drm/i915 + agp/intel-gtt: prep work for direct setup
    - LP: #1011440
  * agp/intel-gtt: move gart base addres setup
    - LP: #1011440
  * drm/i915: don't use dev->agp
    - LP: #1011440
  * drm/i915: disable drm agp support for !gen3 with kms enabled
    - LP: #1011440
  * agp/intel-agp: remove snb+ host bridge pciids
    - LP: #1011440
  * rebase to v3.5.5
    - LP: #1000424
 -- Leann Ogasawara <email address hidden> Wed, 03 Oct 2012 11:11:18 -0700

Changed in linux (Ubuntu Quantal):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.