[ca0132] Sound: only dummy output

Bug #1038651 reported by Onno on 2012-08-19
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

On Dell Alienware 14x Ubuntu 12.04 sound was working. After few weeks it stopped working. I played around with the sound settings choosing between the different options. I thought it would be wise to disable sound for a while and then enable. This changes the sound settings. The ability to choose options disappears. So after disable once, it will disable forever. Is there a documented way to get sound or sound options back?

Ubuntu is a struggle.
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu12
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: CA0132 Analog [CA0132 Analog]
   Subdevices: 2/2
   Subdevice #0: subdevice #0
   Subdevice #1: subdevice #1
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/by-path', '/dev/snd/controlC0', '/dev/snd/hwC0D0', '/dev/snd/hwC0D3', '/dev/snd/pcmC0D0c', '/dev/snd/pcmC0D0p', '/dev/snd/pcmC0D3p', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
Card0.Amixer.info:
 Error: command ['amixer', '-c', '0', 'info'] failed with exit code 1: amixer: Mixer load hw:0 error: Invalid argument
 Card hw:0 'PCH'/'HDA Intel PCH at 0xd2710000 irq 46'
   Mixer name : 'Intel PantherPoint HDMI'
   Components : 'HDA:11020011,10280552,00100918 HDA:80862806,10280552,00100000'
   Controls : 15
Card0.Amixer.values: Error: command ['amixer', '-c', '0'] failed with exit code 1: amixer: Mixer hw:0 load error: Invalid argument
DistroRelease: Ubuntu 12.04
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
Package: pulseaudio 1:1.1-0ubuntu15.1
PackageArchitecture: i386
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 3.2.0-29.46-generic-pae 3.2.24
Tags: precise running-unity
Uname: Linux 3.2.0-29-generic-pae i686
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 02/08/2012
dmi.bios.vendor: Alienware
dmi.bios.version: A01
dmi.board.name: M14xR2
dmi.board.vendor: Alienware
dmi.board.version: A01
dmi.chassis.type: 8
dmi.chassis.vendor: Alienware
dmi.chassis.version: A01
dmi.modalias: dmi:bvnAlienware:bvrA01:bd02/08/2012:svnAlienware:pnM14xR2:pvrA01:rvnAlienware:rnM14xR2:rvrA01:cvnAlienware:ct8:cvrA01:
dmi.product.name: M14xR2
dmi.product.version: A01
dmi.sys.vendor: Alienware

Onno (ostraaten) wrote :

Sound settings now show:
Play sound through: Dummy Output.

Above "Test Sound" the select list to choose between options is gone.

Do I need to reinstall????

Please run the following command:
apport-collect 1038651

In addition, a pulseaudio verbose log may help: https://wiki.ubuntu.com/PulseAudio/Log

Changed in pulseaudio (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected precise running-unity
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

I reinstalled Ubuntu 12.04: no sound.

Changed in pulseaudio (Ubuntu):
assignee: nobody → David Henningsson (diwic)
status: Incomplete → In Progress
affects: pulseaudio (Ubuntu) → linux (Ubuntu)
summary: - Sound: only dummy output
+ [ca0132] Sound: only dummy output
David Henningsson (diwic) wrote :

Hi, and thanks for reporting this bug.

After talking a bit with upstream, it seems like the driver for your soundcard is not yet really ready. Creative Labs is still working on the DSP Loader code. But at least I was able to correct something that hopefully will improve it a bit, if so, hopefully you can try this on Wednesday: https://wiki.ubuntu.com/Audio/UpgradingAlsa/DKMS

Changed in linux (Ubuntu):
assignee: David Henningsson (diwic) → nobody
Onno (ostraaten) wrote :

Sound suddenly is working. I dont understand. Yesterday it didnt work. Today after boot it is working.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.5.0-14.15

---------------
linux (3.5.0-14.15) quantal-proposed; urgency=low

  [ Andy Whitcroft ]

  * SAUCE: fs: d_revalidate methods may be passed a NULL nameidata
    - LP: #1038075

  [ Dave Airlie ]

  * SAUCE: drm/vmwgfx: add MODULE_DEVICE_TABLE so vmwgfx loads at boot
    - LP: #1039157

  [ Ike Panhc ]

  * [Config] Enable CONFIG_DEVPTS_MULTIPLE_INSTANCES for highbank
    - LP: #1038259

  [ Tim Gardner ]

  * SAUCE: wlcore: Declare MODULE_FIRMWARE usage
    - LP: #1042918

  [ Upstream Kernel Changes ]

  * asus-nb-wmi: add some video toggle keys
    - LP: #1022427
  * [media] uvcvideo: Fix frame drop in bulk video stream
  * [media] uvcvideo: Fix alternate setting selection
  * Input: wacom - add support to Cintiq 22HD
    - LP: #1043733
  * ALSA: HDA: Create phantom jacks for fixed inputs and outputs
  * ALSA: HDA: Support single 3-pin jack without VREF on the actual pin
    - LP: #1018262
  * ALSA: hda - give 3-pin jack the name "Headphone Mic Jack"
  * ALSA: hda - Do not set GPIOs for speakers on IDT if there are no
    speakers
    - LP: #1040077
  * ALSA: hda - Fix pop noise in headphones on S3 for Asus X55A, X55V
    - LP: #1034779
  * ALSA: hda - Always call standard unsolicited event for Realtek codecs
    - LP: #1021192
  * ALSA: hda - Add the inverted digital mic workaround to Realtek codecs
  * ALSA: hda - Add inverted mic quirks for Asus U41SV, Acer 1810TZ and
    AOD260
    - LP: #1006089, #996611, #997227
  * ALSA: hda - don't create dysfunctional mixer controls for ca0132
    - LP: #1038651
  * ALSA: hda - Don't send invalid volume knob command on IDT 92hd75bxx
 -- Leann Ogasawara <email address hidden> Thu, 06 Sep 2012 10:06:28 -0700

Changed in linux (Ubuntu):
status: In Progress → Fix Released
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel for Precise in -proposed solves the problem (3.2.0-32.51). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-precise' to 'verification-done-precise'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-precise
Onno (ostraaten) on 2012-09-29
tags: added: verification-done-precise
removed: verification-needed-precise

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Lars Kumbier (derlars) wrote :

The sudden working indicates a broken initramfs, which may be either a bug in the update routine or a full /boot partition. If you have this problem (again), please
- run update-initramfs -k all -c
- check /boot free blocks: df -h

Onno (ostraaten) wrote :

Today - first day of the new year - sound is gone again. I don't understand why sound is such a tough issue on Linux/Ubuntu. We just don't seem to fix it right.

I tried the update-initramfs and df- h. Looks okay. Update does not show any errors or anything. I have around 3 GB free on boot partition.

I'm creating a new bug report

David Henningsson (diwic) wrote :

> I don't understand why sound is such a tough issue on Linux/Ubuntu.

The number one reason is probably that the hardware is so diverse, perhaps even more than other areas and components.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers