[Dell Precision M series] can't wake up from suspend

Bug #1036617 reported by TienFu Chen on 2012-08-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
TienFu Chen

Bug Description

system runs into suspend, but can't wake from it.
I executes suspend from the desktop menu, I can see the power led blinking. When I press power button to wake it up, the power button becomes solid but nothing comes back.

The following systems are affected.
Dell Precision M6700(201205-11042,VA7-E5-C5)
Dell Precision M4700(201205-11049,VA5-E5-C2)
Dell Precision M6700(201205-11041,VA7-E5-C2)
Dell Precision M4700(201205-11050,VA5-E5-C4)

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-29-generic 3.2.0-29.46
ProcVersionSignature: Ubuntu 3.2.0-29.46-generic 3.2.24
Uname: Linux 3.2.0-29-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu5
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: ubuntu 4108 F.... pulseaudio
 /dev/snd/controlC0: ubuntu 4108 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xf7730000 irq 47'
   Mixer name : 'IDT 92HD93BXX'
   Components : 'HDA:111d76df,1028053f,00100203'
   Controls : 19
   Simple ctrls : 10
Card1.Amixer.info:
 Card hw:1 'NVidia'/'HDA NVidia at 0xf6080000 irq 17'
   Mixer name : 'Nvidia GPU 40 HDMI/DP'
   Components : 'HDA:10de0040,1028053f,00100100'
   Controls : 12
   Simple ctrls : 2
Date: Tue Aug 14 07:23:38 2012
HibernationDevice: RESUME=UUID=8e1722c6-f28c-4d4e-a829-e3d2ea9339ca
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MachineType: Dell Inc. Precision M6700
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 VESA VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-29-generic root=UUID=de1206ef-45ff-40c2-a887-18e28fa8b794 ro quiet splash initcall_debug vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-29-generic N/A
 linux-backports-modules-3.2.0-29-generic N/A
 linux-firmware 1.79
SourcePackage: linux
StagingDrivers: mei
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/30/2012
dmi.bios.vendor: Dell Inc.
dmi.bios.version: X38
dmi.board.name: 011BL2
dmi.board.vendor: Dell Inc.
dmi.board.version: X03
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrX38:bd05/30/2012:svnDellInc.:pnPrecisionM6700:pvr01:rvnDellInc.:rn011BL2:rvrX03:cvnDellInc.:ct9:cvr:
dmi.product.name: Precision M6700
dmi.product.version: 01
dmi.sys.vendor: Dell Inc.

TienFu Chen (ctf) wrote :
summary: - can't wake from suspend
+ [Dell Precision M series] can't wake up from suspend
Brad Figg (brad-figg) on 2012-08-14
Changed in linux (Ubuntu):
status: New → Confirmed
TienFu Chen (ctf) on 2012-08-14
description: updated
TienFu Chen (ctf) on 2012-08-14
description: updated
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.5kernel[0] (Not a kernel in the daily directory) and install both the linux-image and linux-image-extra .deb packages.

Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. Please only remove that one tag and leave the other tags. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.6-rc1-quantal/

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
TienFu Chen (ctf) wrote :

This bug is fixed with kernel 3.6.0-030600rc1-generic.

Changed in linux (Ubuntu):
assignee: nobody → Anthony Wong (anthonywong)
Anthony Wong (anthonywong) wrote :

This could possibly be caused by the e1000e module.

@ctf
To verify, can you test again by adding the following line to a file in /etc/pm/config.d:

SUSPEND_MODULES=e1000e

TienFu Chen (ctf) wrote :

@a16g:
I tried as your comment, but bug remains.

Anthony Wong (anthonywong) wrote :

@ctf
Have you installed the corresponding NVIDIA/AMD proprietary graphics drivers?

Changed in linux (Ubuntu):
assignee: Anthony Wong (anthonywong) → Jesse Sung (wenchien)
status: Incomplete → Confirmed
assignee: Jesse Sung (wenchien) → Anthony Wong (anthonywong)
status: Confirmed → Incomplete
TienFu Chen (ctf) wrote :

@a16g:
Jockey didn't show up for the additional drivers. Should I try to install Nvidia driver manually?

Changed in linux (Ubuntu):
status: Incomplete → In Progress
TienFu Chen (ctf) wrote :

The video driver from Nvidia site fixes this suspend issue.
http://www.nvidia.com/object/linux-display-amd64-295.59-driver.html

Anthony Wong (anthonywong) wrote :

We will update the nvidia driver in bug 1037483.

Anthony Wong (anthonywong) wrote :

@ctf
Could you verify the -proposed package in bug 1037483, so that the fixed package can be released to fix this bug? Thanks.

Changed in linux (Ubuntu):
status: In Progress → Won't Fix
status: Won't Fix → Incomplete
Anthony Wong (anthonywong) wrote :

Bug 1037483 is now fix released, back to ctf for re-test.

Changed in linux (Ubuntu):
assignee: Anthony Wong (anthonywong) → Tim Chen (ctf)
status: Incomplete → Confirmed
TienFu Chen (ctf) on 2013-02-05
Changed in linux (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers