Can't remove directory from NCP server

Bug #1035226 reported by AZLinux on 2012-08-10
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Dave Chiluk
Precise
Undecided
Dave Chiluk
Quantal
Undecided
Dave Chiluk
Raring
Undecided
Dave Chiluk
Saucy
Undecided
Dave Chiluk

Bug Description

Client side:
Ubuntu 12.04
ncpfs 2.2.6-8

Server side:
Novell OES2

1. Mount a Novell Netware volume with ncpmount command:
/usr/bin/ncpmount -S 172.16.1.X -A 172.16.1.X -U .user.au.ou -V volumename -y utf8 -p cp850 -m -d 0755 -f 0644 /folder1/folder2 -u user -g users -N nfs -o tcp

2. Create a new directory (folder3)
mkdir /folder1/folder2/folder3

3. Remove folder
rm -rf /folder1/folder2/folder3

4. Error message
Device or resource busy
---------

However, removing files (not directories) , it does not exist any problem

Same problem here.

Ubuntu 12.10
ncpfs 2.2.6

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ncpfs (Ubuntu):
status: New → Confirmed
Dave Chiluk (chiluk) wrote :

Can someone with access to a netware server please check if this is still an issue with the below kernel? I think I narrowed it down to the root cause, but I can't be certain since I don't have a netware server.

http://people.canonical.com/~chiluk/lp1035226/

AZLinux (azlinux-launchpad) wrote :

Hello Dave

I'll try again this morning

Regards

AZLinux (azlinux-launchpad) wrote :

Hello Dave

We have tested the new kernel, that you attach, and behavior is similar when try to remove a NCP Network folder

Error: Device or resource busy

Dave, we have Netware servers and we are available to perform further tests

Regards

Dave Chiluk (chiluk) wrote :

I bisected this issue down to commit 1d2ef5901483004d74947bbf78d5146c24038fe7 when building a kernel for lucid.

If I build 003f6c9df54970d8b19578d195b3e2b398cdbde2 using mainline-build-one for lucid which is the commit immediately prior to 1d2ef5901483004d74947bbf78d5146c24038fe7 the resulting kernel works fine on lucid. However if I build the same commit using mainline-build-one 003f6c9df54970d8b19578d195b3e2b398cdbde2 precise rmdir works fine, but rm -rf does not on precise.

Tim Gardner (timg-tpi) on 2013-06-06
affects: ncpfs (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu Precise):
status: New → Fix Committed
Changed in linux (Ubuntu Quantal):
status: New → Fix Committed
Changed in linux (Ubuntu Raring):
status: New → Fix Committed
Changed in linux (Ubuntu Saucy):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.9.0-5.12

---------------
linux (3.9.0-5.12) saucy; urgency=low

  [ Andy Whitcroft ]

  * Revert "HAVE_CPLUS_DEMANGLE=n"
  * SAUCE: intel_pstate -- toggle default to disable
    - LP: #1188647
  * SAUCE: ubuntu: overlayfs -- ovl_path_open should not take path
    reference
    - LP: #1098378
 -- Andy Whitcroft <email address hidden> Wed, 12 Jun 2013 13:28:56 +0100

Changed in linux (Ubuntu Saucy):
status: Fix Committed → Fix Released
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-raring
Dave Chiluk (chiluk) wrote :

Verified!

tags: added: verification-done
removed: verification-needed-raring
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed' to 'verification-done'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-quantal
tags: added: verification-needed-precise
Dave Chiluk (chiluk) on 2013-06-21
Changed in linux (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu Quantal):
assignee: nobody → Dave Chiluk (chiluk)
Changed in linux (Ubuntu Raring):
assignee: nobody → Dave Chiluk (chiluk)
Changed in linux (Ubuntu Saucy):
assignee: nobody → Dave Chiluk (chiluk)
Changed in linux (Ubuntu Precise):
assignee: nobody → Dave Chiluk (chiluk)
Changed in linux (Ubuntu Quantal):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu Raring):
status: Fix Committed → Fix Released
tags: added: verification-done-precise verification-done-quantal verification-done-raring
removed: verification-done verification-needed-precise verification-needed-quantal

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers