Add cifs support to nfs-modules udeb

Bug #1031398 reported by Chris Van Hoof on 2012-07-31
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Tim Gardner
Precise
Undecided
Chris Van Hoof
Quantal
Medium
Tim Gardner

Bug Description

When testing mounting a cifs based share via netboot images I found that the cifs module is not available, although the version of mount provided in busybox does support mounting this protocol.

Attaching a patch which adds the cifs module to debian.master/d-i/modules/nfs-modules. I have verified this applies cleanly to both Quantal as well as Precise.

Chris Van Hoof (vanhoof) wrote :

Attaching patch against Precise master-next

Tim Gardner (timg-tpi) on 2012-07-31
Changed in linux (Ubuntu Quantal):
status: New → Fix Committed
Changed in linux (Ubuntu Precise):
assignee: nobody → Chris Van Hoof (vanhoof)
status: New → In Progress

The attachment "0001-adding-cifs-support-to-the-nfs-modules-list.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Tim Gardner (timg-tpi) on 2012-07-31
Changed in linux (Ubuntu Precise):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (3.7 KiB)

This bug was fixed in the package linux - 3.5.0-8.8

---------------
linux (3.5.0-8.8) quantal-proposed; urgency=low

  [ Andy Whitcroft ]

  * ubuntu: AUFS -- add BOM and automated update script
  * ubuntu: AUFS -- include the aufs_types.h file in linux-libc-headers
    - LP: #684666
  * ubuntu: AUFS -- update aufs-update to track new locations of headers
  * ubuntu: AUFS -- clean up the aufs updater and BOM
  * ubuntu: AUFS -- documentation on updating aufs2
  * ubuntu: AUFS -- fix undefined __devcgroup_inode_permission
  * ubuntu: AUFS -- update to 4cf5db36bcd9748e8e7270022f295f84d1fc2245
  * ubuntu: AUFS -- updateconfigs following update
  * ubuntu: AUFS -- suppress benign plink warning messages
    - LP: #621195
  * ubuntu: AUFS -- enable in config and makefile
  * ubuntu: AUFS -- disable in favor of overlayfs
  * ubuntu: AUFS -- adapt to the new changelog handling
  * ubuntu: AUFS -- sort out the relative header paths
  * ubuntu: AUFS -- update to d266b0c5d0693d6383976ee54b9e2c0fa9a3f5b0
  * ubuntu: AUFS -- aufs3-base.patch
  * ubuntu: AUFS -- aufs3-standalone.patch
  * ubuntu: AUFS -- update to 4a5e660ed7f5c1d0467c81c535d0fedcfe62d15f
  * ubuntu: AUFS -- reenable

  [ Chris Van Hoof ]

  * [Config] Add cifs support to the nfs-modules list
    - LP: #1031398

  [ Ilan Peer ]

  * (pre-stable) iwlwifi: Check BSS ctx active before call mac80211
    - LP: #1021086

  [ John Johansen ]

  * SAUCE: Update aufs for build failure caused by apparmor backport

  [ Tim Gardner ]

  * SAUCE: firmware: Remove ess files duplicated in linux-firmware
  * SAUCE: firmware: Remove kaweth files duplicated in linux-firmware
  * SAUCE: firmware: Remove obsolete Chelsio cxgb3 firmware
  * SAUCE: firmware: Remove cxgb3 files duplicated in linux-firmware
  * SAUCE: firmware: Remove edgeport files duplicated in linux-firmware
  * SAUCE: firmware: Remove ti_usb_3410_5052 duplicated in linux-firmware
  * SAUCE: firmware: Remove adaptec files duplicated in linux-firmware
  * SAUCE: firmware: Remove advansys files duplicated in linux-firmware
  * SAUCE: firmware: Remove ambassador files duplicated in linux-firmware
  * SAUCE: firmware: Remove av7110 files duplicated in linux-firmware
  * SAUCE: cpia2: Declare MODULE_FIRMWARE usage
  * SAUCE: firmware: Remove cpia2 files duplicated in linux-firmware
  * SAUCE: firmware: Remove korg files duplicated in linux-firmware
  * SAUCE: firmware: Remove matrox files duplicated in linux-firmware
  * SAUCE: firmware: Remove r128 files duplicated in linux-firmware
  * SAUCE: firmware: Remove radeon files duplicated in linux-firmware

  [ Upstream Kernel Changes ]

  * intel_idle: initial IVB support
  * KVM: x86: change PT_FIRST_AVAIL_BITS_SHIFT to avoid conflict with EPT
    Dirty bit
  * KVM: VMX: Use EPT Access bit in response to memory notifiers
  * KVM: VMX: Enable EPT A/D bits if supported by turning on relevant bit
    in EPTP
  * KVM: VMX: Add parameter to control A/D bits support, default is on
  * KVM: VMX: Add EPT A/D bits definitions
  * KVM: VMX: Implement PCID/INVPCID for guests with EPT
  * xhci: Export Latency Tolerance Messaging capabilities.
  * USB: Fix LPM disable/enable during device reset.
  * usb: convert ...

Read more...

Changed in linux (Ubuntu Quantal):
status: Fix Committed → Fix Released
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel for Precise in -proposed solves the problem (3.2.0-30.47). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-precise' to 'verification-done-precise'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-precise
Luis Henriques (henrix) wrote :

I've manually checked the d-i now contains the cifs kernel module:

$ dpkg -c nfs-modules-3.2.0-30-generic-di_3.2.0-30.47_amd64.udeb | grep cifs.ko
-rw-r--r-- root/root 504128 2012-08-15 21:13 ./lib/modules/3.2.0-30-generic/kernel/fs/cifs/cifs.ko

Tagging as verified.

tags: added: verification-done-precise
removed: verification-needed-precise
Launchpad Janitor (janitor) wrote :
Download full text (13.6 KiB)

This bug was fixed in the package linux - 3.2.0-30.48

---------------
linux (3.2.0-30.48) precise-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1041217

  [ Upstream Kernel Changes ]

  * mutex: Place lock in contended state after fastpath_lock failure
    - LP: #1041114

linux (3.2.0-30.47) precise-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1036581

  [ Andy Whitcroft ]

  * add support for generating binary device trees and install them in
    /lib/firmware
    - LP: #1030600
  * [Config] add dtb_file configuration for highbank
    - LP: #1030600

  [ Chris Van Hoof ]

  * SAUCE: dell-laptop: additional rfkill blacklist Dell XPS 13
    - LP: #1030957
  * [Config] Add cifs support to the nfs-modules list
    - LP: #1031398

  [ Daniel P. Berrange ]

  * SAUCE: (drop after 3.6) Forbid invocation of kexec_load() outside
    initial PID namespace
    - LP: #1034125

  [ Dann Frazier ]

  * [Config] Compile the rtc-pl031 driver builtin on the highbank kernel
    flavour
    - LP: #1035110

  [ Douglas Bagnall ]

  * SAUCE: Unlock the rc_dev lock when the raw device is missing
    - LP: #1015836

  [ Rob Herring ]

  * SAUCE: ARM: highbank: add soft power and reset key event handling
    - LP: #1033853
  * SAUCE: ARM: highbank: use writel_relaxed variant for pwr requests
    - LP: #1033853
  * SAUCE: ahci: un-staticize ahci_dev_classify
    - LP: #1033853
  * SAUCE: ahci_platform: add custom hard reset for Calxeda ahci ctrlr
    - LP: #1033853

  [ Stefan Bader ]

  * (pre-stable) KVM: VMX: Set CPU_BASED_RDPMC_EXITING for nested
    - LP: #1031090

  [ Tim Gardner ]

  * [Config] updateconfigs

  [ Upstream Kernel Changes ]

  * ideapad: generate valid key event only
    - LP: #1029834
  * mm: reduce the amount of work done when updating min_free_kbytes
    - LP: #1032640
  * mm: compaction: allow compaction to isolate dirty pages
    - LP: #1032640
  * mm: compaction: determine if dirty pages can be migrated without
    blocking within ->migratepage
    - LP: #1032640
  * mm: page allocator: do not call direct reclaim for THP allocations
    while compaction is deferred
    - LP: #1032640
  * mm: compaction: make isolate_lru_page() filter-aware again
    - LP: #1032640
  * mm: compaction: introduce sync-light migration for use by compaction
    - LP: #1032640
  * mm: vmscan: when reclaiming for compaction, ensure there are sufficient
    free pages available
    - LP: #1032640
  * mm: vmscan: do not OOM if aborting reclaim to start compaction
    - LP: #1032640
  * mm: vmscan: check if reclaim should really abort even if
    compaction_ready() is true for one zone
    - LP: #1032640
  * vmscan: promote shared file mapped pages
    - LP: #1032640
  * vmscan: activate executable pages after first usage
    - LP: #1032640
  * mm/vmscan.c: consider swap space when deciding whether to continue
    reclaim
    - LP: #1032640
  * mm: test PageSwapBacked in lumpy reclaim
    - LP: #1032640
  * mm: vmscan: convert global reclaim to per-memcg LRU lists
    - LP: #1032640
  * cpuset: mm: reduce large amounts of memory barrier related damage v3
    - LP: #1032640
  * mm/hugetlb: fix warni...

Changed in linux (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers