have to add nomodeset to the kernel commandline in order to boot with kernel 3.5.0-6,7,8,9,10

Bug #1030894 reported by Craig Magina on 2012-07-30
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

I am using a AMD Radeon HD 6000 Series video card. This issue does not happen when I use kernel 3.5.0-030500rc7 from the kernel upstream builds.

WORKAROUND: add nomodeset kernel parameter.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: linux-image-3.5.0-6-generic 3.5.0-6.6
ProcVersionSignature: Ubuntu 3.5.0-6.6-generic 3.5.0
Uname: Linux 3.5.0-6-generic x86_64
ApportVersion: 2.4-0ubuntu6
Architecture: amd64
CRDA: Error: [Errno 2] No such file or directory: 'iw'
Date: Mon Jul 30 10:34:30 2012
EcryptfsInUse: Yes
InstallationMedia: Kubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120424)
IwConfig:
 eth0 no wireless extensions.

 lo no wireless extensions.

 virbr0 no wireless extensions.
MachineType: System manufacturer System Product Name
ProcFB: 0 VESA VGA
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.5.0-6-generic root=/dev/mapper/sda2_crypt ro nomodeset quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-6-generic N/A
 linux-backports-modules-3.5.0-6-generic N/A
 linux-firmware 1.87
RfKill:
 0: hci0: Bluetooth
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/17/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1902
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: Crosshair IV Formula
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1902:bd02/17/2011:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnCrosshairIVFormula:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

Craig Magina (craig.magina) wrote :
Brad Figg (brad-figg) on 2012-07-30
Changed in linux (Ubuntu):
status: New → Confirmed

Marking Triaged Low as mainline tested and easily implementable WORKAROUND.

description: updated
tags: added: kernel-bug-fixed-upstream
Changed in linux (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Craig Magina (craig.magina) wrote :

I just tried the latest quantal kernel, 3.5.0-7, and it continues to suffer from the issue, while the 3.5.0-030500rc7 kernel continues to work perfectly. What happens when I try and boot without nomodeset is after grub, the monitor goes into sleep mode and never wakes up.

tags: added: kernel-bug-fixed-upstream-3.5.0-030500rc7
removed: kernel-bug-fixed-upstream
tags: added: performing-bisect
Changed in linux (Ubuntu):
importance: Low → Medium
Joseph Salisbury (jsalisbury) wrote :

Hi Craig,

I'd like to perform a kernel bisect to identify the cause of this bug. Have you see this issue in kernel versions prior to 3.5.0-6.6? I'd like to narrow down the first Quantal version that first exhibited this bug.

Just to confirm, you do not see this bug with the latest v3.5-rc7 kernel[0], but you do with 3.5.0-7.7? That might indicate the bug is due to a Ubuntu kernel config file option, or an Ubuntu SAUCE patch.

Could you test some earlier Quantal kernels and report back if they have this bug or not? For example, 3.5.0-3.3[1], 3.5.0-4.4[2] and/or 3.5.0-5.5[3]. The .deb files can be found by selecting your arch under the "Builds" section.

Thanks in advance!

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.5-rc7-quantal/
[1] https://launchpad.net/ubuntu/+source/linux/3.5.0-3.3
[2] https://launchpad.net/ubuntu/+source/linux/3.5.0-4.4
[3] https://launchpad.net/ubuntu/+source/linux/3.5.0-5.5

Joseph Salisbury (jsalisbury) wrote :

Hi Craig,

Actually a quicker thing would be for me to bisect between v3.5 and Ubuntu-3.5.0-7.7. To do that, we just need to confirm that v3.5 final does not have the bug. Can you test v3.5 final, which can be downloaded from:

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.5-quantal/

Changed in linux (Ubuntu):
status: Triaged → Incomplete
assignee: nobody → Joseph Salisbury (jsalisbury)
Craig Magina (craig.magina) wrote :

Everything works great with the v3.5 final kernel linked above.

I just updated to the new 3.5.0-9.9 kernel today and that one still suffers from this problem.

Joseph Salisbury (jsalisbury) wrote :

The next test kernel is available and is built up to commit:
047b25916bebc6afed8d60982caf7cba89b72e94

This kernel is available from:
http://people.canonical.com/~jsalisbury/lp1030894

Can you test that kernel and report back if it has the bug or not?

Craig Magina (craig.magina) wrote :

The latest kernel, 3.5.0-10, also has this issue. I will test your kernel today, thanks.

summary: have to add nomodeset to the kernel commandline in order to boot with
- kernel 3.5.0-6
+ kernel 3.5.0-6,7,8,9,10
Craig Magina (craig.magina) wrote :

I tested your kernel from http://people.canonical.com/~jsalisbury/lp1030894 and it does not fix the problem.

Joseph Salisbury (jsalisbury) wrote :

The next test kernel is available and is built up to commit:
d425e82f90d689a726c34f24d03bc2ea226750b7

This kernel is available from:
http://people.canonical.com/~jsalisbury/lp1030894

Can you test that kernel and report back if it has the bug or not?

Craig Magina (craig.magina) wrote :

Kernel from commit d425e82f90d689a726c34f24d03bc2ea226750b7 doesn't boot for me. I either get a grey screen or it drops me to console (no plymouth) asking for my luks password but doesn't seem to connect to my keyboard (tried my normal bluetooth one and a usb one).

I have noticed something odd however, 3.5.0-10 occasionally works just fine. The last two boots have been ok, but both of them have been reboots from Windows 7. I'm wondering if there could be an initialization bug in the kernel AMD/ATI driver. The reason I mention this is a possibly similar issue I have been experiencing on a different AMD system (HP dm1z E-350 APU) where on reboots the screen also powers off and I have to hard cycle the system, afterwhich it comes up ok. I'll try and experiment with different boot scenarios.

Joseph Salisbury (jsalisbury) wrote :

@Craig,

I was wondering if you were able to experiment with different boot scenarios and have additional details? If not, I can look at continuing the bisect.

Craig Magina (craig.magina) wrote :

Sorry for not continuing with this bug. Basically, I am unsure if I am still hitting this as I installed an SSD into the machine that was hitting it and now it boots so quick I never see the plymouth screen. The only thing I can say, is that the system goes from showing the grub screen to showing the login screen, the monitor loses display connectivity in between (thus going to sleep for a second, maybe 2).

Changed in linux (Ubuntu):
assignee: Joseph Salisbury (jsalisbury) → nobody
tags: removed: performing-bisect

Craig Mangina, as per http://www.asus.com/ROG/CROSSHAIR_IV_FORMULA/#support_Download_30 an update is available for your BIOS (Version 2101). If you update to this, does it change anything?

tags: added: regression-release
tags: added: bios-outdated
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers