Ubuntu

0bda:8176 RTL8188CUS does not connect to wireless networks

Reported by Richard Riley Gress on 2012-07-30
122
This bug affects 25 people
Affects Status Importance Assigned to Milestone
Linux
Confirmed
High
linux (Ubuntu)
High
Unassigned

Bug Description

The network manager will show the wireless card and networks, but will ask for the network password again after trying to connect.

There are drivers for this card from the Realtek website that no longer work.

---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: PCI [ESS Maestro3 PCI], device 0: Maestro3 [Maestro3]
   Subdevices: 2/2
   Subdevice #0: subdevice #0
   Subdevice #1: subdevice #1
ApportVersion: 2.0.1-0ubuntu11
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCI [ESS Maestro3 PCI], device 0: Maestro3 [Maestro3]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: richie 1207 F.... pulseaudio
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
Card0.Amixer.info:
 Card hw:0 'PCI'/'ESS Maestro3 PCI at 0xd800, irq 5'
   Mixer name : 'SigmaTel STAC9721,23'
   Components : 'AC97a:83847609'
   Controls : 31
   Simple ctrls : 21
DistroRelease: Ubuntu 12.04
HibernationDevice: RESUME=UUID=a88650de-9eb4-4de5-81f3-a13066d2880d
InstallationMedia: Lubuntu 10.04 "Lucid Lynx" - i386 (20100429)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 002: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN
MachineType: Dell Computer Corporation Latitude CPx J650GT
Package: linux (not installed)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 VESA VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-26-generic root=UUID=43aed9f8-23e8-47a9-9272-5c97db11ae0d ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.2.0-26.41-generic 3.2.19
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-26-generic N/A
 linux-backports-modules-3.2.0-26-generic N/A
 linux-firmware 1.79
RfKill: Error: [Errno 2] No such file or directory
Tags: precise
Uname: Linux 3.2.0-26-generic i686
UpgradeStatus: Upgraded to precise on 2012-07-15 (16 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 08/02/2000
dmi.bios.vendor: Dell Computer Corporation
dmi.bios.version: A08
dmi.board.name: Latitude CPx J650GT
dmi.board.vendor: Dell Computer Corporation
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Computer Corporation
dmi.modalias: dmi:bvnDellComputerCorporation:bvrA08:bd08/02/2000:svnDellComputerCorporation:pnLatitudeCPxJ650GT:pvr:rvnDellComputerCorporation:rnLatitudeCPxJ650GT:rvr:cvnDellComputerCorporation:ct8:cvr:
dmi.product.name: Latitude CPx J650GT
dmi.sys.vendor: Dell Computer Corporation

Brad Figg (brad-figg) on 2012-07-30
Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: quantal
description: updated
tags: added: needs-kernel-logs needs-upstream-testing

searchfgold, thank you for reporting this and helping make Ubuntu better. Please execute the following command, as it will automatically gather debugging information, in a terminal:
apport-collect 1030858
When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.
If you do not have an alternate internet connection port, could you please apport-collect following https://help.ubuntu.com/community/ReportingBugs#Filing_bugs_when_off-line ?

Helpful Bug Reporting Links:
https://help.ubuntu.com/community/ReportingBugs#Bug_Reporting_Etiquette
https://help.ubuntu.com/community/ReportingBugs#A3._Make_sure_the_bug_hasn.27t_already_been_reported
https://help.ubuntu.com/community/ReportingBugs#Adding_Apport_Debug_Information_to_an_Existing_Launchpad_Bug
https://help.ubuntu.com/community/ReportingBugs#Adding_Additional_Attachments_to_an_Existing_Launchpad_Bug

Changed in linux (Ubuntu):
importance: Undecided → High
status: Confirmed → Incomplete

I cannot create an apport information file; apport-cli reports that "'linux' is not an official ubuntu package." I have installed the Quantal kernel from PPA.
Please state precisely what needs to be added to this bug.

Joseph Salisbury (jsalisbury) wrote :

@searchfgold

The latest version of apport should be able to report backport kernel bugs.

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.5kernel[0] (Not a kernel in the daily directory) and install both the linux-image and linux-image-extra .deb packages.

Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.5-rc7-quantal/

This has not been tested in Quantal. My Apport version shipped with Precise. What is the 'needs-kernel-logs' tag?

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: kernel-bug-exists-upstream
removed: needs-upstream-testing

searchforgold, regarding your comment https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1030858/comments/5 :
<"I cannot create an apport information file; apport-cli reports that "'linux' is not an official ubuntu package." I have installed the Quantal kernel from PPA.
Please state precisely what needs to be added to this bug."

Assuming you are using Precise, you would want to boot into the kernel that came with Precise, or install the newest one available:
https://launchpad.net/ubuntu/+source/linux/3.2.0-27.43

following instructions from https://wiki.ubuntu.com/Kernel/MainlineBuilds#Installing_Mainline_Kernels to install it. Then, boot into this kernel, and you will be able to apport-cli.

Regarding your comment https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1030858/comments/8 :
tags: added: kernel-bug-exists-upstream
removed: needs-upstream-testing

Which kernel did you test specifically http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.5-rc7-quantal/ ?

>"What is the 'needs-kernel-logs' tag?"

This is a Ubuntu Kernel Team tracker tag for those reports that have not apport-collect'ed yet. For more on this please see https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#New_Bugs .

Changed in linux (Ubuntu):
status: Confirmed → Incomplete

I am following instructions from http://packages.qa.ubuntu.com/qatracker/milestones/223/builds/19371/testcases

I installed the latest upstream kernel: all packages pertaining to my architecture from http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.5-rc7-quantal/

I am not reporting a bug about the latest kernel that comes with Precise when you do an `# apt-get dist-upgrade'. I tested the latest upstream kernel with this specific hardware (because it needed to be tested per https://wiki.ubuntu.com/Testing/Kernel).

Is it appropriate to boot into a different kernel and do the apport-cli?

searchforgold, regarding your comments https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1030858/comments/10 :
>"I am following instructions from http://packages.qa.ubuntu.com/qatracker/milestones/223/builds/19371/testcases

I installed the latest upstream kernel: all packages pertaining to my architecture from http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.5-rc7-quantal/"

Thank you for following those instructions, installing the latest upstream kernel, and testing it.

<"I am not reporting a bug about the latest kernel that comes with Precise when you do an `# apt-get dist-upgrade'."

We all knew already that you are not reporting a bug about the kernel that comes with Precise when you do an `# apt-get dist-upgrade'. :D The issue remains, you may not apport-cli unless you have booted with a kernel that comes with Precise, not a proposed kernel, mainline kernel, or a PPA kernel.

>"I tested the latest upstream kernel with this specific hardware (because it needed to be tested per https://wiki.ubuntu.com/Testing/Kernel)."

Thank you for testing the latest upstream kernel with that specific hardware.

Regarding your comments https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1030858/comments/11 :
>"Is it appropriate to boot into a different kernel and do the apport-cli?"

At this time, it is appropriate to boot into a kernel that comes with Precise and do the apport-cli. It is not appropriate to boot into a proposed kernel, mainline kernel, or a PPA kernel and do the apport-cli.

apport information

tags: added: apport-collected precise
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

description: updated
tags: removed: needs-kernel-logs
summary: - RTL8188CUS is not detected or usable by network manager
+ 0bda:8176 RTL8188CUS is not detected or usable by network manager

searchforgold, thank you for providing the apport-cli data. Did this USB device work in a release of Ubuntu prior to Precise? Also, as a potential WORKAROUND, does your device work following https://help.ubuntu.com/community/WifiDocs/Driver/Ndiswrapper ?

Changed in linux (Ubuntu):
status: Incomplete → Invalid
Changed in linux (Ubuntu):
status: Invalid → Incomplete
summary: - 0bda:8176 RTL8188CUS is not detected or usable by network manager
+ 0bda:8176 RTL8188CUS does not connect to wireless networks
description: updated

WORKAROUND:
Installing the third party driver from realtek, blacklisting the built-in driver, and adding the realtek module to `/etc/modules':
While the USB dongle is not plugged in:
---
sudo apt-get install build-essential
wget ftp://WebUser:fh7SkVT4@209.222.7.36/cn/wlan/RTL819xCU%20_USB_linux_v3.4.3_4369.20120622.zip
unzip ./RTL819xCU\ _USB_linux_v3.4.3_4369.20120622.zip
cd ./RTL819xCU\ _USB_linux_v3.4.3_4369.20120622
cmod a+x ./install.sh
sudo ./install.sh
echo -e "# RTL8188CUS wifi\nblacklist 8192cu\nblacklist rtl8192c_common\nblacklist rtlwifi" | sudo tee -a /etc/modprobe.d/blacklist.conf
echo "8192cu" | sudo tee -a /etc/modules
---

description: updated

searchforgold, thank you for providing the WORKAROUND.

Did this USB device work in Ubuntu releases prior to Precise?

description: updated
tags: added: kernel-bug-exists-upstream-v3.5-rc7-quantal

I haven't tested it, but according to ahallabuntu of the Ubuntu Forums, in 11.10, the device had the same problem. In 10.04, 10.10, and 11.04, the device was also not usable without building the Realtek module but it was unclear from their post whether it was the same problem.

searchfgold, removing any WORKAROUND, could you please test for this issue in Lucid via http://cdimage.ubuntu.com/lucid/daily-live/current/ ?

Does it have to be from that link or could I use one of my old CD's?

searchfgold, you may use an old CD, just please make sure you install it on a partition and update it fully before making a test.

In Lucid, the RTL8188CUS is not recognized as a Network device in gnome-network.

searchfgold, thank you for testing Lucid.

For regression testing purposes, could you please test Natty and Oneiric? Either of live environment or install is fine. The reason for this request is developers want to know if the kernels from those series perform better, worse, or not at all for your hardware combination.

In Natty, the card is not displayed in the network manager. In Oneiric, the problem is the same as in Precise: After attempting to connect, the user is prompted for the wireless password, and after providing the password a connection is attempted and the password prompt returns.

tags: added: lucid natty

searchfgold, could you please test http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.6-rc1-quantal/ following https://wiki.ubuntu.com/Kernel/MainlineBuilds ?

As well, in Precise, could you please test compat-wireless following https://wiki.ubuntu.com/Kernel/LinuxWireless#Compat-wireless_in_Ubuntu ?

In kernel 3.6, the problem still exists.
After installing the 'linux-backports-modules-cw-3.3-3.2.0.27-generic-pae' package and booting the 3.2.0.27-pae kernnel, the problem also still exists.

Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org [1]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

[1] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Changed in linux (Ubuntu):
status: Incomplete → Triaged

According to http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=blob;f=MAINTAINERS there are maintainers for the RTL8180, RTL8187, and RTL8192CE drivers. However, there is no listing for the RTL8188CUS. Does this mean that there is no kernel driver for the hardware? and how should I proceed?

Richard Riley Gress, could you please send your E-Mail, with this Launchpad bug CC'ed, to <email address hidden> ?

Larry Finger (larry-finger) wrote :

On 08/15/2012 10:22 PM, Richie Gress wrote:
> [1] Summary of Problem.
> 0bda:8176 RTL8188CUS does not connect to wireless networks
>
> [2] Full description of the Problem.
> The RTL8188CUS USB wireless card will not connect to wireless networks. The connection is attempted over and over again, and the password prompt reappears each time if the network has one, but a connection is never established.
> There is a workaround for this bug: Drivers can be obtained from the Realtek website. But they are required in order for the hardware to function properly.

You gave quite a complete report, but you missed some important factors. What
kind of wireless connection are you trying to make (802.11n, 802.11g, etc)? What
kind of encryption? What is the make/model of the AP?

My tests show that rtl8192cu can make a connection for 802.11n and 802.11g, as
long as the encryption is WPA2. With WPA or WEP encryption, an 802.11g
connection fails as you describe.

I am now checking to see where this regression occurred. Please fill out a
kernel bugzilla on this regression, and assign it to me.

Thanks,

Larry

Larry Finger, I was not able to assign the bug to you, but I added you to the CC list.
I provided additional information in the report as best I could as you requested.

Richard Riley Gress, could you please provide the hyperlink to your upstream bug report so this may be tracked in Launchpad?

Changed in linux:
importance: Unknown → High
status: Unknown → Confirmed
sam (sferguso7) wrote :

I can confirm that this bug did not effect me with mythbuntu 11.04 (11.04 upgraded when 11.10 released) & 11.10 up until febuary march 2012. My system was fully patched base mythbuntu 64bit distro no 3rd party applications.
WPA2 security enabled to a netgear DG834GV firmware version V2.02.42_U ADSL Firmware Version 7.03.01.00 channel 1 mode g&b

Now running clean install mythbuntu 12.04 fully patched same issue as reported here.

sam, if you have a bug in Ubuntu, could you please file a new report by executing the following in a terminal:
ubuntu-bug linux

For more on this, please see the Ubuntu Bug Control and Ubuntu Bug Squad article:
https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue

and Ubuntu Community article:
https://help.ubuntu.com/community/ReportingBugs

When opening up the new report, please feel free to subscribe me to it. Thank you for your understanding.

pdecat (pdecat) wrote :

Same issue with Netgear WNA1000M :
Bus 002 Device 006: ID 0846:9041 NetGear, Inc. WNA1000M 802.11bgn [Realtek RTL8188CUS]

pdecat, if you have a bug in Ubuntu, could you please file a new report by executing the following in a terminal:
ubuntu-bug linux

For more on this, please see the Ubuntu Bug Control and Ubuntu Bug Squad article:
https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue

and Ubuntu Community article:
https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report may delay your problem being addressed as quickly as possible.

Thank you for your understanding.

pdecat (pdecat) wrote :

Issue #1075967 created.

Regards,
Patrick.

This bug is still not assigned to anyone, here or in bugzilla. I don't have permission to change the assignee.

Richard Riley Gress, thank you for testing the mainline kernel. Could you please test http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.7-rc4-raring/ ?

Changed in linux (Ubuntu):
status: Triaged → Incomplete

The bug is also in Linux v3.7-rc6-raring, and there is a better description of the bug by Larry Finger here: https://bugzilla.kernel.org/show_bug.cgi?id=46171#c25

Marking back to Triaged as newest mainline tested, and upstream activity.

tags: added: kernel-bug-exists-upstream-v3.7-rc6
removed: kernel-bug-exists-upstream-v3.5-rc7-quantal
Changed in linux (Ubuntu):
status: Incomplete → Triaged
Changed in linux (Ubuntu):
status: Triaged → In Progress

This is not In Progress as per https://wiki.ubuntu.com/Bugs/Status .

Changed in linux (Ubuntu):
status: In Progress → Triaged
tags: added: kernel-bug-exists-upstream-v3.7-rc7
removed: kernel-bug-exists-upstream-v3.7-rc6

The workaround of building drivers from the Realtek website no longer works.

tags: added: kernel-bug-exists-upstream-v3.7-rc8
removed: kernel-bug-exists-upstream-v3.7-rc7
description: updated

The bug still exists in kernel version 3.7.1. However, the dmesg output is different, and the cfg80211 complaints have disappeared.

tags: added: kernel-bug-exists-upstream-v3.7.1
removed: kernel-bug-exists-upstream-v3.7-rc8
Jan-Marek Glogowski (jmglogow) wrote :

Just wanted to add a "me too". My hardware is:

050d:1102 Belkin Components F7D1102 N150/Surf Micro Wireless Adapter v1000 [Realtek RTL8188CUS].

The attached patch fixes the RealTek drivers (3.4.4.4749.20121105) for the Raring kernel v3.7.1-030701.201212171620.

tags: added: patch
tags: added: kernel-bug-exists-upstream-v3.8-rc1
removed: kernel-bug-exists-upstream-v3.7.1
tags: added: kernel-bug-exists-upstream-v3.8-rc2
removed: kernel-bug-exists-upstream-v3.8-rc1
tags: added: kernel-bug-fixed-upstream kernel-bug-fixed-upstream-v3.8-rc3
removed: kernel-bug-exists-upstream kernel-bug-exists-upstream-v3.8-rc2

I spoke too hastily. I did load web pages, and ensured that rtlwifi &ct. were loaded. Upon reboot, the condition was as before. Will do further testing and investigation.

tags: added: kernel-bug-exists-upstream kernel-bug-exists-upstream-v3.8-rc3 kernel-wifi
removed: kernel-bug-fixed-upstream kernel-bug-fixed-upstream-v3.8-rc3

Bug is still valid. Attached is dmesg output using kernel 3.8-rc3. Of particular interest are lines 542 on.

tags: added: kernel-bug-exists-upstream-v3.8-rc4
removed: kernel-bug-exists-upstream-v3.8-rc3
tags: added: kernel-bug-exists-upstream-v3.8-rc5
removed: kernel-bug-exists-upstream-v3.8-rc4
tags: added: kernel-bug-exists-upstream-v3.8-rc6
removed: kernel-bug-exists-upstream-v3.8-rc5
tags: added: kernel-bug-exists-upstream-v3.8-rc7
removed: kernel-bug-exists-upstream-v3.8-rc6
Sergey (sergey1369) wrote :

Ubuntu 12.10 - bug exists, but compiling RealTek driver works for me.

Bus 001 Device 003: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter
driver - RTL8192xC_USB_linux_v3.4.4_4749.20121105.zip
module - /lib/modules/3.5.0-23-generic/kernel/drivers/net/wireless/8192cu.ko
if - wlan4 Link encap:Ethernet HWaddr f8:c0:91:11:28:45
          inet addr:10.197.210.132 Bcast:10.197.211.255 Mask:255.255.252.0

tags: added: kernel-bug-exists-upstream-v3.8
removed: kernel-bug-exists-upstream-v3.8-rc7
tags: added: kernel-bug-exists-upstream-v3.9-rc1
removed: kernel-bug-exists-upstream-v3.8

Richard Riley Gress, as per http://www.dell.com/support/troubleshooting/us/en/19/Product/latitude-cpx-j an update is available for your BIOS (A16). If you update to this, does it change anything?

tags: added: bios-outdated-a16
tags: added: needs-upstream-testing
Shiki (shiki) wrote :

Welp. I want to slap the guy who said this chip is supported by Linux. :(

Shiki, technically the chip IS supported by linux - you simply had to download drivers from < http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=21&PFid=48&Level=5&Conn=4&DownTypeID=3&GetDown=false&Downloads=true#2292 > under the header "RTL8188CUS". Recently, a patch referencing this bug was supposedly released in < http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.9-rc4-raring/ >.

I will do further testing if I find the laptop, which is missing.

Changed in linux (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.