The display can't show anything with Precise installer

Bug #1028811 reported by TienFu Chen on 2012-07-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Jesse Sung

Bug Description

The installer shows nothing but I can hear the greeting sound of the installer, appending "nomodeset" to kernel command line works.
Quantal installer also works.

Affected systems are Dell Latitude E6430 ATG(201201-10338), Dell Latitude E6430 (201201-10372).

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-23-generic 3.2.0-23.36
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu5
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: ubuntu 6750 F.... pulseaudio
 /dev/snd/controlC0: ubuntu 6750 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xf7730000 irq 47'
   Mixer name : 'IDT 92HD93BXX'
   Components : 'HDA:111d76df,10280534,00100203 HDA:14f12c06,14f1000f,00100000'
   Controls : 19
   Simple ctrls : 10
Card1.Amixer.info:
 Card hw:1 'NVidia'/'HDA NVidia at 0xf6080000 irq 17'
   Mixer name : 'Nvidia GPU 14 HDMI/DP'
   Components : 'HDA:10de0014,10de0101,00100100'
   Controls : 24
   Simple ctrls : 4
CasperVersion: 1.315
Date: Wed Jul 25 08:53:51 2012
LiveMediaBuild: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MachineType: Dell Inc. Latitude E6430
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB:

ProcKernelCmdLine: noprompt cdrom-detect/try-usb=true file=/cdrom/preseed/username.seed boot=casper initrd=/casper/initrd.lz nomodeset
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-23-generic N/A
 linux-backports-modules-3.2.0-23-generic N/A
 linux-firmware 1.79
SourcePackage: linux
StagingDrivers: mei
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/16/2012
dmi.bios.vendor: Dell Inc.
dmi.bios.version: X37
dmi.board.name: 0P02CD
dmi.board.vendor: Dell Inc.
dmi.board.version: X03
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrX37:bd02/16/2012:svnDellInc.:pnLatitudeE6430:pvr01:rvnDellInc.:rn0P02CD:rvrX03:cvnDellInc.:ct9:cvr:
dmi.product.name: Latitude E6430
dmi.product.version: 01
dmi.sys.vendor: Dell Inc.

TienFu Chen (ctf) wrote :
description: updated
Changed in linux (Ubuntu):
assignee: nobody → Anthony Wong (anthonywong)
TienFu Chen (ctf) on 2012-07-25
description: updated
Brad Figg (brad-figg) on 2012-07-25
Changed in linux (Ubuntu):
status: New → Confirmed
Changed in linux (Ubuntu):
assignee: Anthony Wong (anthonywong) → Jesse Sung (wenchien)
importance: Undecided → Medium
TienFu Chen (ctf) wrote :

Tried 12.04.1 image, bug remains.

Jesse Sung (wenchien) wrote :

Found some error messages while booting:

[ 20.689443] [drm] nouveau 0000:01:00.0: unknown i2c port 51
[ 20.689511] [drm] nouveau 0000:01:00.0: 0x7232: i2c bus not found
[ 20.689575] [drm] nouveau 0000:01:00.0: unknown i2c port 51
[ 20.689637] [drm] nouveau 0000:01:00.0: 0x7244: i2c bus not found
[ 20.694409] [drm] nouveau 0000:01:00.0: unknown i2c port 51
[ 20.694474] [drm] nouveau 0000:01:00.0: 0x89FC: Failed parsing init table opcode: INIT_I2C_LONG_IF -19
[ 20.714643] [drm] nouveau 0000:01:00.0: unknown i2c port 51
[ 20.752806] [drm] nouveau 0000:01:00.0: unknown i2c port 51
[ 20.753026] [drm] nouveau 0000:01:00.0: unknown i2c port 48
[ 20.797716] [drm] nouveau 0000:01:00.0: unknown i2c port 56
[ 20.797872] [drm] nouveau 0000:01:00.0: unknown i2c port 54
[ 20.798003] [drm] nouveau 0000:01:00.0: unknown i2c port 55

Jesse Sung (wenchien) wrote :

While using 12.04.1 precise installer, adding kernel parameter 'nomodeset' makes display work, although it's not using LCD native resolution.

Jesse Sung (wenchien) wrote :

linux-image 3.5.0-13.14~precise1 does not have this issue.

Jesse Sung (wenchien) wrote :

Quantal alpha3 installer also works fine.

Changed in linux (Ubuntu):
milestone: none → ubuntu-12.10
Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Ara Pulido (ara) on 2013-01-17
tags: added: blocks-hwcert-enablement
Jorge Suárez de Lis (ys) wrote :

Is this fixed on Precise? Since it's a LTS release, I expected this to be fixed there.

To post a comment you must log in.