[highbank] intermittent hangs on reboot with latest precise kernel

Bug #1026061 reported by Michael Casadevall on 2012-07-18
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned

Bug Description

During testing of the precise d-i image, I've noticed that the current kernel appears to intermittently hang on reboots, and on occasion, appears to take the BMC with it.

ubuntu@c01:~$ ipmitool -H *redacted* -U *redacted* -P *redacted* power reset
Error: Unable to establish LAN session
Unable to set Chassis Power Control to Reset

Steps to reproduce:
1. Install latest highbank precise kernel
2. Reboot until system hangs on "Restarting system".

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1026061

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: precise
Ike Panhc (ikepanhc) on 2012-07-18
tags: added: ike-radar
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.5kernel[0] (Not a kernel in the daily directory) and install both the linux-image and linux-image-extra .deb packages.

Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

tags: added: needs-upstream-testing
Ike Panhc (ikepanhc) wrote :

I've tried to reboot from several stock kernel and the a test kernel based on quantal/master-next on 4th node

Linux version 3.2.0-25-highbank (buildd@nihal) (gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5) ) #40-Ubuntu SMP PREEMPT Thu May 24 00:18:11 UTC 2012
Linux version 3.2.0-26-highbank (buildd@nihal) (gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5) ) #41-Ubuntu SMP PREEMPT Thu Jun 14 20:55:11 UTC 2012
Linux version 3.2.0-27-highbank (buildd@ain) (gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5) ) #43-Ubuntu SMP PREEMPT Fri Jul 6 16:48:52 UTC 2012
Linux version 3.5.0-3-highbank (buildd@nihal) (gcc version 4.7.1 (Ubuntu/Linaro 4.7.1-2ubuntu1) ) #3-Ubuntu SMP PREEMPT Mon Jul 2 20:08:03 UTC 2012
Linux version 3.5.0-4-highbank (buildd@nihal) (gcc version 4.7.1 (Ubuntu/Linaro 4.7.1-3ubuntu1) ) #4-Ubuntu SMP PREEMPT Tue Jul 10 01:50:33 UTC 2012
Linux version 3.5.0-5-highbank (root@tangerine) (gcc version 4.7.1 (Ubuntu/Linaro 4.7.1-5ubuntu1) ) #5 SMP PREEMPT Tue Jul 17 20:45:17 UTC 2012

and no hang occurs.

Will try 3rd node later

Ike Panhc (ikepanhc) wrote :

Unfortunately I can not get into 3rd node in any case. After chassic power cycle and several times of node reset, I can only see u-boot message once. I will consider this is an unstable hardware.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers