Ubuntu Precise ISO test failed in Jenkins due to debian installer failed to get debconf answer 'base-installer/kernel/linux/initrd'.

Bug #1021718 reported by Victor Zhou on 2012-07-06
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Precise
Medium
Unassigned

Bug Description

Ubuntu Precise ISO test on iso precise-alternate* and precise-server* failed. it seems new kernel was uploaded, but the version of the kernel is not updated in debian-installer.

Link to the fails:
https://jenkins.qa.ubuntu.com/view/Precise/view/ISO%20Testing%20Dashboard/job/precise-alternate-amd64_default/474/
https://jenkins.qa.ubuntu.com/view/Precise/view/ISO%20Testing%20Dashboard/job/precise-alternate-i386_default/458/
https://jenkins.qa.ubuntu.com/view/Precise/view/ISO%20Testing%20Dashboard/job/precise-server-amd64_default/228/

Logs: (you can find more detail from the attachment)

Jul 6 08:46:20 cdrom-retriever: warning: File /cdrom/dists/precise/main/debian-installer/binary-amd64/Packages does not exist.
Jul 6 08:46:20 cdrom-retriever: warning: File /cdrom/dists/precise/restricted/debian-installer/binary-amd64/Packages does not exist.
Jul 6 08:47:56 base-installer: warning: Failed to get debconf answer 'base-installer/kernel/linux/initrd'.
Jul 6 08:47:58 base-installer: error: exiting on error base-installer/kernel/failed-install

Victor Zhou (victor.zhou) wrote :
Changed in debian-installer (Ubuntu):
status: New → Confirmed
tags: added: debiam-installer iso-testing qa-daily-testing
tags: added: debian-installer
removed: debiam-installer
tags: added: rls-q-incoming
Colin Watson (cjwatson) wrote :

Not an installer bug. A -27 kernel needs to be reuploaded now that ddebs have been switched off in the canonical-kernel-team PPA, so that we can copy it to precise-proposed without hitting a Soyuz failure.

affects: debian-installer (Ubuntu) → linux (Ubuntu)
Gema Gomez (gema) wrote :

This seems to be a problem in the kernel and it's on its merry way to be fixed. We will verify and update the bug accordingly.

Changed in linux (Ubuntu):
importance: Undecided → High
Stéphane Graber (stgraber) wrote :

Please don't manually add the iso-testing tag, this tag is how the QA website detects whether it has touched a bug or not, so adding it prevents the bot from linking this bug back to the tracker.

Gema Gomez (gema) wrote :

This bug is blocking our smoke testing, needs to be fixed asap.

Changed in linux (Ubuntu):
importance: High → Critical
Joseph Salisbury (jsalisbury) wrote :

I noticed the rls-q-incoming tag was added. Does this bug also exist in Quantal, or just Precise?

tags: added: kernel-key
Kate Stewart (kate.stewart) wrote :

Problem sounds like its Precise specific. Am removing the rls-q-incoming tag, and adding rls-p-tracking.

Changed in linux (Ubuntu Precise):
status: New → Confirmed
importance: Undecided → Critical
tags: added: rls-p-tracking
removed: rls-q-incoming
tags: added: precise
Brad Figg (brad-figg) wrote :

@gema,

Are you testing kernel version 3.2.0-27.43 ? Due to build issues we were forced to re-upload new packages last week and I expect this to fix your issue.

Victor Zhou (victor.zhou) wrote :

test on precise-alternate* ISOs passed now(but there is still the error message in the d-i-syslog), the test on precise-server* ISOs are still failing.

Gema Gomez (gema) wrote :

@bjf
Linux version 3.2.0-26-generic (buildd@batsu) (gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5) ) #41-Ubuntu SMP Thu Jun 14 17:49:24 UTC 2012 (Ubuntu 3.2.0-26.41-generic 3.2.19)

Brad Figg (brad-figg) wrote :

It appears that the kernel version being discussed here is:

Linux version 3.2.0-26-generic-pae (buildd@lamiak) (gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5) ) #41-Ubuntu SMP Thu Jun 14 16:45:14 UTC 2012 (Ubuntu 3.2.0-26.41-generic-pae 3.2.19)

Linux version 3.2.0-26-generic (buildd@batsu) (gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5) ) #41-Ubuntu SMP Thu Jun 14 17:49:24 UTC 2012 (Ubuntu 3.2.0-26.41-generic 3.2.19)

Note: This is the version(s) that are in -updates and not -proposed.

Joseph Salisbury (jsalisbury) wrote :

@Gema and @Victor,

Were you able to test version 3.2.0-27.43, which was requested in comment #8

Changed in linux (Ubuntu Precise):
status: Confirmed → Incomplete
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-da-key
Changed in linux (Ubuntu):
importance: Critical → Medium
Changed in linux (Ubuntu Precise):
importance: Critical → Medium
tags: removed: kernel-key
Victor Zhou (victor.zhou) wrote :

Due to the latest kernel version is already updated to 3.2.0-30-generic, there is no this issue found any more for weeks, I think we can close this bug now.

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
Changed in linux (Ubuntu Precise):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers