Comment 50 for bug 1021471

Raring is EOL since January 27:

https://wiki.ubuntu.com/Releases

Excerpts from Alessandro Moscatelli's message of 2014-06-12 22:23:52 UTC:
> It looks I have this problem with Ubuntu Raring
> kernel version : 3.8.13
>
> I attached a screenshot with dmesg after I tried to start again my
> containers.
>
> Should I open a new bug ?
>
> Thank you in advance
>
>
> ** Attachment added: "screenshot"
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1021471/+attachment/4130637/+files/5.png
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1021471
>
> Title:
> clone() hang when creating new network namespace (dmesg show
> unregister_netdevice: waiting for lo to become free. Usage count = 2)
>
> Status in The Linux Kernel:
> Confirmed
> Status in “linux” package in Ubuntu:
> Fix Released
> Status in “linux” source package in Precise:
> Fix Released
> Status in “linux” source package in Quantal:
> Fix Released
>
> Bug description:
> SRU Justification:
>
> Impact:
> When creating new network namespace dmesg can show the following
> unregister_netdevice: waiting for lo to become free. Usage count = 1
>
> Fix:
> Stefan Bader's SAUCE patch has fixed this for Quantal:
> UBUNTU: SAUCE: net/ipv4: Always flush route cache on unregister batch call
>
> Testcase:
> The sourcecode found here:
> https://lists.debian.org/debian-kernel/2012/05/msg00494.html
> can be compiled and run as follows:
>
> sudo ./reproducer
> #ctrl+c
> sudo ./reproducer
> #wait for a while
> dmesg | grep unregister
>
>
> --
>
> I'm not sure how I triggered this. I've been moving around between
> networks and suspending/resuming all day.
>
> Earlier in this boot I successfully used a container (start,
> networking and stop). I came to start the same one later and noticed
> that it didn't come up. Trying to attach to the console with lxc-
> console informed me that it wasn't running. I then saw suspicious
> content in dmesg:
>
> [25800.412234] INFO: task lxc-start:25817 blocked for more than 120 seconds.
> [25800.412243] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
> [25800.412254] lxc-start D ffff88013fd13980 0 25817 1 0x00000000
> [25800.412266] ffff880007b43cc0 0000000000000086 ffff88003ba4c500 ffff880007b43fd8
> [25800.412275] ffff880007b43fd8 ffff880007b43fd8 ffff880134c65c00 ffff88003ba4c500
> [25800.412284] 000080d0ffffffff ffffffff81ca7c00 ffff88003ba4c500 ffffffff81ca7c04
> [25800.412288] Call Trace:
> [25800.412306] [<ffffffff81673759>] schedule+0x29/0x70
> [25800.412313] [<ffffffff81673a1e>] schedule_preempt_disabled+0xe/0x10
> [25800.412323] [<ffffffff81672537>] __mutex_lock_slowpath+0xd7/0x150
> [25800.412331] [<ffffffff8167200a>] mutex_lock+0x2a/0x50
> [25800.412340] [<ffffffff8155ede1>] copy_net_ns+0x71/0x100
> [25800.412350] [<ffffffff8107adfb>] create_new_namespaces+0xdb/0x190
> [25800.412357] [<ffffffff8107afec>] copy_namespaces+0x8c/0xd0
> [25800.412367] [<ffffffff81050142>] copy_process.part.22+0x902/0x1520
> [25800.412375] [<ffffffff81050ee5>] do_fork+0x135/0x390
> [25800.412385] [<ffffffff8116db40>] ? kmem_cache_free+0x20/0x100
> [25800.412395] [<ffffffff8118c6b3>] ? putname+0x33/0x50
> [25800.412402] [<ffffffff811811cc>] ? do_sys_open+0x16c/0x200
> [25800.412410] [<ffffffff8101c238>] sys_clone+0x28/0x30
> [25800.412418] [<ffffffff8167cbf3>] stub_clone+0x13/0x20
> [25800.412424] [<ffffffff8167c8e9>] ? system_call_fastpath+0x16/0x1b
> [25806.312385] unregister_netdevice: waiting for lo to become free. Usage count = 1
>
> ProblemType: Bug
> DistroRelease: Ubuntu 12.10
> Package: linux-image-generic 3.5.0.3.3
> ProcVersionSignature: Ubuntu 3.5.0-2.2-generic 3.5.0-rc4
> Uname: Linux 3.5.0-2-generic x86_64
> NonfreeKernelModules: nvidia wl
> AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.25.
> ApportVersion: 2.2.5-0ubuntu2
> Architecture: amd64
> ArecordDevices:
>  **** List of CAPTURE Hardware Devices ****
>  card 0: NVidia [HDA NVidia], device 0: Cirrus Analog [Cirrus Analog]
>    Subdevices: 1/1
>    Subdevice #0: subdevice #0
> AudioDevicesInUse:
>  USER PID ACCESS COMMAND
>  /dev/snd/controlC0: laney 2787 F.... pulseaudio
> CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
> Card0.Amixer.info:
>  Card hw:0 'NVidia'/'HDA NVidia at 0xd3480000 irq 22'
>    Mixer name : 'Nvidia MCP89 HDMI'
>    Components : 'HDA:10134206,106b0d00,00100301 HDA:10de000c,10de0101,00100200'
>    Controls : 37
>    Simple ctrls : 13
> Date: Thu Jul 5 21:26:08 2012
> HibernationDevice: RESUME=UUID=1c5b3f2c-2c89-4fa1-9ed8-0e238de8fe47
> InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64 (20100729)
> MachineType: Apple Inc. MacBookPro7,1
> ProcFB: 0 VESA VGA
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-2-generic root=UUID=2228fdfe-3834-40b2-b7b4-efea7463e3c1 ro quiet splash reboot=pci vt.handoff=7
> RelatedPackageVersions:
>  linux-restricted-modules-3.5.0-2-generic N/A
>  linux-backports-modules-3.5.0-2-generic N/A
>  linux-firmware 1.82
> SourcePackage: linux
> UpgradeStatus: Upgraded to quantal on 2012-01-13 (173 days ago)
> dmi.bios.date: 03/25/10
> dmi.bios.vendor: Apple Inc.
> dmi.bios.version: MBP71.88Z.0039.B05.1003251322
> dmi.board.name: Mac-F222BEC8
> dmi.board.vendor: Apple Inc.
> dmi.chassis.type: 10
> dmi.chassis.vendor: Apple Inc.
> dmi.chassis.version: Mac-F222BEC8
> dmi.modalias: dmi:bvnAppleInc.:bvrMBP71.88Z.0039.B05.1003251322:bd03/25/10:svnAppleInc.:pnMacBookPro7,1:pvr1.0:rvnAppleInc.:rnMac-F222BEC8:rvr:cvnAppleInc.:ct10:cvrMac-F222BEC8:
> dmi.product.name: MacBookPro7,1
> dmi.product.version: 1.0
> dmi.sys.vendor: Apple Inc.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/linux/+bug/1021471/+subscriptions