Ubuntu

gfs2 kernel oops when deleting file as first action after mounting

Reported by Dave Spano on 2012-07-02
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

I have an active/active drbd cluster with pacemaker running on cman. If I create a file on the shared gfs2 file system on one node, then try to delete it on the other, I'm receiving this kernel panic. I get the same error on both nodes, so it's not specific to either machine.

Jul 2 12:54:37 ha1 lrmd: [40983]: info: operation monitor[35] on nova-volumes:0 for client 40986: pid 2385 exited with return code 0
Jul 2 12:54:43 ha1 lrmd: [40983]: debug: rsc:p_gfsd:1 monitor[63] (pid 2459)
Jul 2 12:54:43 ha1 lrmd: [40983]: info: operation monitor[63] on p_gfsd:1 for client 40986: pid 2459 exited with return code 0
Jul 2 12:54:49 ha1 kernel: [238066.234067] BUG: unable to handle kernel NULL pointer dereference at 0000000000000018
Jul 2 12:54:49 ha1 kernel: [238066.236034] IP: [<ffffffffa037c00a>] gfs2_unlink+0x8a/0x220 [gfs2]
Jul 2 12:54:49 ha1 kernel: [238066.237305] PGD 40ca9f067 PUD 40de7b067 PMD 0
Jul 2 12:54:49 ha1 kernel: [238066.237336] Oops: 0000 [#1] SMP
Jul 2 12:54:49 ha1 kernel: [238066.237336] CPU 7
Jul 2 12:54:49 ha1 kernel: [238066.237336] Modules linked in: gfs2 drbd lru_cache ipmi_si mpt2sas scsi_transport_sas raid_class mptctl mptbase ipmi_devintf ipmi_msghandler dell_rbu kvm_amd kvm dlm configfs vesafb ib_iser rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi ext2 bonding psmouse sp5100_tco dcdbas tpm_tis joydev serio_raw i2c_piix4 amd64_edac_mod k10temp edac_core acpi_power_meter edac_mce_amd mac_hid lp parport usbhid hid ses enclosure igb megaraid_sas dca bnx2 [last unloaded: ipmi_si]
Jul 2 12:54:49 ha1 kernel: [238066.237336]
Jul 2 12:54:49 ha1 kernel: [238066.237336] Pid: 2544, comm: rm Not tainted 3.2.0-26-generic #41-Ubuntu Dell Inc. PowerEdge R515/03X0MN
Jul 2 12:54:49 ha1 kernel: [238066.237336] RIP: 0010:[<ffffffffa037c00a>] [<ffffffffa037c00a>] gfs2_unlink+0x8a/0x220 [gfs2]
Jul 2 12:54:49 ha1 kernel: [238066.237336] RSP: 0018:ffff8801fe13fd28 EFLAGS: 00010296
Jul 2 12:54:49 ha1 kernel: [238066.380032] RAX: 0000000000000000 RBX: ffff880410faa080 RCX: ffff8801fe13fd40
Jul 2 12:54:49 ha1 kernel: [238066.380032] RDX: 0000000000000000 RSI: 0000000000012346 RDI: ffff88040c8b1440
Jul 2 12:54:49 ha1 kernel: [238066.380032] RBP: ffff8801fe13fe38 R08: 4000000000000000 R09: 0000000000000000
Jul 2 12:54:49 ha1 kernel: [238066.380032] R10: fde3ec81bcd7720a R11: 0000000000000008 R12: ffff8801ffc709c0
Jul 2 12:54:49 ha1 kernel: [238066.380032] R13: ffff8801fe13fd80 R14: ffff8803f479d140 R15: ffff88040c8b1000
Jul 2 12:54:49 ha1 kernel: [238066.380032] FS: 00007fa1b5055700(0000) GS:ffff88041fa20000(0000) knlGS:0000000000000000
Jul 2 12:54:49 ha1 kernel: [238066.380032] CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
Jul 2 12:54:49 ha1 kernel: [238066.380032] CR2: 0000000000000018 CR3: 00000003f207c000 CR4: 00000000000006e0
Jul 2 12:54:49 ha1 kernel: [238066.380032] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
Jul 2 12:54:49 ha1 kernel: [238066.380032] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Jul 2 12:54:49 ha1 kernel: [238066.380032] Process rm (pid: 2544, threadinfo ffff8801fe13e000, task ffff8802044b5bc0)
Jul 2 12:54:49 ha1 kernel: [238066.380032] Stack:
Jul 2 12:54:49 ha1 kernel: [238066.380032] 0000000000000003 ffff8801fa72e260 ffff8801fe13fd58 ffff8801fe13fd40
Jul 2 12:54:49 ha1 kernel: [238066.380032] ffff8801fe13fd40 ffff8801fa72e218 ffff88020476a680 0000000000000001
Jul 2 12:54:49 ha1 kernel: [238066.380032] 0000000000000000 0000000000000000 ffffffffa037bfda ffff8801fe13fd80
Jul 2 12:54:49 ha1 kernel: [238066.380032] Call Trace:
Jul 2 12:54:49 ha1 kernel: [238066.380032] [<ffffffffa037bfda>] ? gfs2_unlink+0x5a/0x220 [gfs2]
Jul 2 12:54:49 ha1 kernel: [238066.380032] [<ffffffffa037bff4>] ? gfs2_unlink+0x74/0x220 [gfs2]
Jul 2 12:54:49 ha1 kernel: [238066.380032] [<ffffffff8129cb2c>] ? security_inode_permission+0x1c/0x30
Jul 2 12:54:49 ha1 kernel: [238066.380032] [<ffffffff81184e70>] vfs_unlink.part.26+0x80/0xf0
Jul 2 12:54:49 ha1 kernel: [238066.380032] [<ffffffff81184f1c>] vfs_unlink+0x3c/0x60
Jul 2 12:54:49 ha1 kernel: [238066.380032] [<ffffffff8118758a>] do_unlinkat+0x1aa/0x1d0
Jul 2 12:54:49 ha1 kernel: [238066.380032] [<ffffffff8117ce5a>] ? sys_newfstatat+0x2a/0x40
Jul 2 12:54:49 ha1 kernel: [238066.380032] [<ffffffff811880d2>] sys_unlinkat+0x22/0x40
Jul 2 12:54:49 ha1 kernel: [238066.380032] [<ffffffff81661fc2>] system_call_fastpath+0x16/0x1b
Jul 2 12:54:49 ha1 kernel: [238066.380032] Code: 00 00 49 83 c5 40 31 d2 4c 89 e9 be 01 00 00 00 e8 fc 1e ff ff 48 8b b3 28 02 00 00 4c 89 ff e8 ad 7e 00 00 48 8d 8d 08 ff ff ff <48> 8b 78 18 31 d2 be 01 00 00 00 48 83 e9 80 e8 d2 1e ff ff 48
Jul 2 12:54:49 ha1 kernel: [238066.380032] RIP [<ffffffffa037c00a>] gfs2_unlink+0x8a/0x220 [gfs2]
Jul 2 12:54:49 ha1 kernel: [238066.380032] RSP <ffff8801fe13fd28>
Jul 2 12:54:49 ha1 kernel: [238066.380032] CR2: 0000000000000018
Jul 2 12:54:49 ha1 kernel: [238066.394510] ---[ end trace 2009fc896a3dd969 ]---

Dave Spano (dspano) wrote :

I found this in a blog posting found here: http://blog.init.hr/?p=186.

Important: We’ve encountered couple of bugs that are in the queue for fixing. If you are using or have a desire of using cLVM, please do not use 12.04 yet. Once these fixes land into archives, we’ll send an email to ubuntu-ha mailing list and add cLVM howto to the wiki.

Is this one of the bugs that was referred to there?

Bart Verwilst (verwilst) on 2012-08-21
summary: - gfs2 on active/active drbd crashes when deleting file on other node
+ gfs2 kernel oops when deleting file on other cluster node
Download full text (3.9 KiB)

I can verify ( and reproduce ) this on an iscsi-based 3-node cluster ( which is why i changed the topic to remove the drbd reference ) based on Ubuntu 12.04.

root@vm02-test:/var/lib/libvirt/sanlock# touch bleh

root@vm03-test:/var/lib/libvirt/sanlock# ls
6ee322c1692b3116957d547dc030a22e aec9c4e866b0da01bd9d561f10b07fb5 bleh f60712817c1666f66a626a2d33551ca4 __LIBVIRT__DISKS__
root@vm03-test:/var/lib/libvirt/sanlock# rm bleh
Killed
root@vm03-test:/var/lib/libvirt/sanlock# ls
^C^C^C^C

meanwhile in dmesg:

[ 3953.436119] BUG: unable to handle kernel NULL pointer dereference at 0000000000000018
[ 3953.436573] IP: [<ffffffffa066e00a>] gfs2_unlink+0x8a/0x220 [gfs2]
[ 3953.436940] PGD 215067067 PUD 222d30067 PMD 0
[ 3953.437215] Oops: 0000 [#1] SMP
[ 3953.437408] CPU 4
[ 3953.437515] Modules linked in: gfs2 dlm configfs btrfs zlib_deflate libcrc32c ufs qnx4 hfsplus hfs minix ntfs vfat msdos fat jfs xfs reiserfs ext2 ip6table_filter ip6_tables iptable_filter ip_tables ebtable_nat ebtables x_tables ipmi_devintf ipmi_si ipmi_msghandler kvm_intel kvm vesafb dm_round_robin nfsd nfs lockd fscache auth_rpcgss nfs_acl sunrpc ib_iser rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi 8021q garp bridge stp dm_multipath dcdbas i7core_edac edac_core acpi_power_meter mac_hid lp parport bnx2 mpt2sas scsi_transport_sas raid_class e1000e scsi_dh_rdac
[ 3953.441164]
[ 3953.441244] Pid: 10792, comm: rm Not tainted 3.2.0-23-generic #36-Ubuntu Dell Inc. PowerEdge R310/05XKKK
[ 3953.441801] RIP: 0010:[<ffffffffa066e00a>] [<ffffffffa066e00a>] gfs2_unlink+0x8a/0x220 [gfs2]
[ 3953.442299] RSP: 0018:ffff8801d9d5bd28 EFLAGS: 00010296
[ 3953.442597] RAX: 0000000000000000 RBX: ffff88021c8da080 RCX: ffff8801d9d5bd40
[ 3953.443039] RDX: 0000000000000000 RSI: 0000000000020219 RDI: ffff88022ff8e440
[ 3953.443526] RBP: ffff8801d9d5be38 R08: 4000000000000000 R09: 0000000000000000
[ 3953.443994] R10: fe082ab8ad47720a R11: 0000000000000206 R12: ffff88021c8d8680
[ 3953.453405] R13: ffff8801d9d5bd80 R14: ffff88021ca02fc0 R15: ffff88022ff8e000
[ 3953.462850] FS: 00007fe2e9c14700(0000) GS:ffff880237280000(0000) knlGS:0000000000000000
[ 3953.481877] CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[ 3953.491648] CR2: 0000000000000018 CR3: 00000001f8244000 CR4: 00000000000006e0
[ 3953.501887] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
[ 3953.511719] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
[ 3953.520978] Process rm (pid: 10792, threadinfo ffff8801d9d5a000, task ffff88022d0f96f0)
[ 3953.539706] Stack:
[ 3953.548881] 0000000000000003 ffff880217b8cbb0 ffff8801d9d5bd58 ffff8801d9d5bd40
[ 3953.558660] ffff8801d9d5bd40 ffff880217b8cb68 ffff88022dc6ed00 0000000000000001
[ 3953.558665] 0000000000000000 0000000000000000 ffffffffa066dfda ffff8801d9d5bd80
[ 3953.558671] Call Trace:
[ 3953.558689] [<ffffffffa066dfda>] ? gfs2_unlink+0x5a/0x220 [gfs2]
[ 3953.558704] [<ffffffffa066dff4>] ? gfs2_unlink+0x74/0x220 [gfs2]
[ 3953.558712] [<ffffffff8129c82c>] ? security_inode_permission+0x1c/0x30
[ 3953.558718] [<ffffffff81184b00>] vfs_unlink.part.26+0x80/0xf0
[ 3953.558722] [<ffffffff81184b...

Read more...

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gfs2-utils (Ubuntu):
status: New → Confirmed
Bart Verwilst (verwilst) wrote :

"I wonder whether your distro kernel has this patch:
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=718b97bd6b03445be53098e3c8f896aeebc304aa

Thats the most likely thing that I can see that has been fixed recently."

>> Steven Whitehouse from Redhat.

Bart Verwilst (verwilst) wrote :

I installed kernel 3.3 from http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3-precise/ on 1 of the hosts.

Next, i mounted my gfs2 volume on 1 node, created a new empty file in it, unmounted the gfs volume, and then mounted it on all 3 nodes.

Then i simply rm'ed the file on each node ( starting with the normal 3.2-kernel based machines ).

On the 2 3.2 machines, rm triggered an oops, and the file wasn't gone. I then rm'ed it on the 3.3 kernel machine, which went perfectly. gfs mount still reachable afterwards, no oops. Both other nodes hung when trying to ls into the mount.

I tried booting the kernel from http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2.28-precise/ to try and narrow down the scope, but that one doesnt seem to be coming up anymore, so i'll have remote hands look at it asap.

But at least this kind of narrows down the scope?

Download full text (7.6 KiB)

I ended up using ceph instead of gfs2 because of this error. I do still have the kernel source (linux 3.2.0) that I was using at the time, and it's actually completely different than the gfs2_unlink routine in the patch.

There are no lines with if(!rgd).

This is what I've got:

static int gfs2_unlink(struct inode *dir, struct dentry *dentry)
{
struct gfs2_inode *dip = GFS2_I(dir);
struct gfs2_sbd *sdp = GFS2_SB(dir);
struct inode *inode = dentry->d_inode;
struct gfs2_inode *ip = GFS2_I(inode);
struct buffer_head *bh;
struct gfs2_holder ghs[3];
struct gfs2_rgrpd *rgd;
int error;

gfs2_holder_init(dip->i_gl, LM_ST_EXCLUSIVE, 0, ghs);
gfs2_holder_init(ip->i_gl, LM_ST_EXCLUSIVE, 0, ghs + 1);

rgd = gfs2_blk2rgrpd(sdp, ip->i_no_addr);
gfs2_holder_init(rgd->rd_gl, LM_ST_EXCLUSIVE, 0, ghs + 2);

error = gfs2_glock_nq(ghs); /* parent */
if (error)
goto out_parent;

error = gfs2_glock_nq(ghs + 1); /* child */
if (error)
goto out_child;

error = -ENOENT;
if (inode->i_nlink == 0)
goto out_rgrp;

if (S_ISDIR(inode->i_mode)) {
error = -ENOTEMPTY;
if (ip->i_entries > 2 || inode->i_nlink > 2)
goto out_rgrp;
}

error = gfs2_glock_nq(ghs + 2); /* rgrp */
if (error)
goto out_rgrp;

error = gfs2_unlink_ok(dip, &dentry->d_name, ip);
if (error)
goto out_gunlock;

error = gfs2_trans_begin(sdp, 2*RES_DINODE + 3*RES_LEAF + RES_RG_BIT, 0);
if (error)
goto out_gunlock;

error = gfs2_meta_inode_buffer(ip, &bh);
if (error)
goto out_end_trans;

error = gfs2_unlink_inode(dip, dentry, bh);
brelse(bh);

out_end_trans:
gfs2_trans_end(sdp);
out_gunlock:
gfs2_glock_dq(ghs + 2);
out_rgrp:
gfs2_holder_uninit(ghs + 2);
gfs2_glock_dq(ghs + 1);
out_child:
gfs2_holder_uninit(ghs + 1);
gfs2_glock_dq(ghs);
out_parent:
gfs2_holder_uninit(ghs);
return error;
}

Dave Spano
Optogenics
Systems Administrator

----- Original Message -----

From: "Bart Verwilst" <email address hidden>
To: <email address hidden>
Sent: Tuesday, August 21, 2012 8:26:22 AM
Subject: [Bug 1020207] Re: gfs2 kernel oops when deleting file on other cluster node

"I wonder whether your distro kernel has this patch:
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=718b97bd6b03445be53098e3c8f896aeebc304aa

Thats the most likely thing that I can see that has been fixed
recently."

>> Steven Whitehouse from Redhat.

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1020207

Title:
gfs2 kernel oops when deleting file on other cluster node

Status in “gfs2-utils” package in Ubuntu:
Confirmed

Bug description:
I have an active/active drbd cluster with pacemaker running on cman.
If I create a file on the shared gfs2 file system on one node, then
try to delete it on the other, I'm receiving this kernel panic. I get
the same error on both nodes, so it's not specific to either machine.

Jul 2 12:54:37 ha1 lrmd: [40983]: info: operation monitor[35] on nova-volumes:0 for client 40986: pid 2385 exited with return code 0
Jul 2 12:54:43 ha1 lrmd: [40983]: debug: rsc:p_gfsd:1 monitor[63] (pid 2459)
Jul 2 12:54:43 ha1 lrmd: [40983]: info: operation monitor[...

Read more...

Tried v3.2.28-precise, crashes as well. :( So 3.3 doesnt seem affected, every 3.2.x release is.

The patch is for 2.6.x, since that's Redhat's main kernel ( 2.6.32 ).

Bart Verwilst (verwilst) wrote :

I think i traced it down to 3.3-rc6, where a couple of patches have been included:

Merge git://git./linux/kernel/git/steve/gfs2-3.0-fixes

* git://git.kernel.org/pub/scm/linux/kernel/git/steve/gfs2-3.0-fixes:
  GFS2: Read resource groups on mount
  GFS2: Ensure rindex is uptodate for fallocate
  GFS2: Read in rindex if necessary during unlink
  GFS2: Fix race between lru_list and glock ref count

"GFS2: Read in rindex if necessary during unlink" is the one we're currently hitting i think.

Bart Verwilst (verwilst) on 2012-08-21
summary: - gfs2 kernel oops when deleting file on other cluster node
+ gfs2 kernel oops when deleting file as first action after mounting
affects: gfs2-utils (Ubuntu) → linux (Ubuntu)
Bart Verwilst (verwilst) on 2012-08-21
affects: linux (Ubuntu) → linux
Changed in linux:
status: Confirmed → Fix Released
affects: linux → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Fix Released → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Do you happen to know if the patch you mention has been submitted for consideration in upstream v3.2 stable?

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: kernel-da-key precise
Bart Verwilst (verwilst) wrote :

Joseph, no it has not, although imho it should be submitted upstream one way or another, since it's pretty vital if you want to get anything done with gfs2 with this kernel.

The patch itself seems pretty trivial, and i could mold it into a state where it would apply to 3.2, but that would hardly be scientific. :) I've asked Steven Whitehouse if he would be interested in backporting, but maybe a local Ubuntu kernel guy could do the same? I'm more than willing to test any build you can throw it me to test this in the next phase.

Bart Verwilst (verwilst) wrote :

--- inode.c.orig 2012-08-22 07:28:15.675859475 +0000
+++ inode.c 2012-08-22 07:33:05.895865014 +0000
@@ -1039,6 +1039,10 @@
  struct gfs2_rgrpd *rgd;
  int error;

+ error = gfs2_rindex_update(sdp);
+ if (error)
+ return error;
+
  gfs2_holder_init(dip->i_gl, LM_ST_EXCLUSIVE, 0, ghs);
  gfs2_holder_init(ip->i_gl, LM_ST_EXCLUSIVE, 0, ghs + 1);

Andy Whitcroft (apw) on 2012-08-22
Changed in linux (Ubuntu):
assignee: nobody → Andy Whitcroft (apw)
status: Confirmed → In Progress

Dave Spano, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

If reproducible, could you also please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.13-rc6

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

Changed in linux (Ubuntu):
assignee: Andy Whitcroft (apw) → nobody
status: In Progress → Incomplete
Download full text (7.6 KiB)

I'm not sure whether it's an issue or not anymore. I discontinued using gfs2 because I could not get the kernel panic to go away.

Dave Spano

----- Original Message -----

From: "Christopher M. Penalver" <email address hidden>
To: <email address hidden>
Sent: Monday, December 30, 2013 4:12:56 PM
Subject: [Bug 1020207] Re: gfs2 kernel oops when deleting file as first action after mounting

Dave Spano, this bug was reported a while ago and there hasn't been any
activity in it recently. We were wondering if this is still an issue? If
so, could you please test for this with the latest development release
of Ubuntu? ISO images are available from http://cdimage.ubuntu.com
/daily-live/current/ .

If it remains an issue, could you please run the following command in
the development release from a Terminal
(Applications->Accessories->Terminal), as it will automatically gather
and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

If reproducible, could you also please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.13-rc6

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's
Status as Confirmed. Please let us know your results. Thank you for your
understanding.

** Changed in: linux (Ubuntu)
Status: In Progress => Incomplete

** Changed in: linux (Ubuntu)
Assignee: Andy Whitcroft (apw) => (unassigned)

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1020207

Title:
gfs2 kernel oops when deleting file as first action after mounting

Status in “linux” package in Ubuntu:
Incomplete

Bug description:
I have an active/active drbd cluster with pacemaker running on cman.
If I create a file on the shared gfs2 file system on one node, then
try to delete it on the other, I'm receiving this kernel panic. I get
the same error on both nodes, so it's not specific to either machine.

Jul 2 12:54:37 ha1 lrmd: [40983]: info: operation monitor[35] on nova-volumes:0 for client 40986: pid 2385 exited with return code 0
Jul 2 12:54:43 ha1 lrmd: [40983]: debug: rsc:p_gfsd:1 monitor[63] (pid 2459)
Jul 2 12:54:43 ha1 lrmd: [40983]: info: operation monitor[63] on p_gfsd:1 for client 40986: pid 2459 exited ...

Read more...

Dave Spano, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1020207/comments/13 regarding you no longer user gfs2. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in linux (Ubuntu):
status: Incomplete → Invalid
Bart Verwilst (verwilst) wrote :

I'm also unable to comment on this since i switched server distributions. It became clear nobody uses Ubuntu for RHCS/gfs2, and I didn't want to be the only guy in the world. :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers