Ubuntu

Intel 2200BG (Calexico2) Wifi stops after activity

Reported by Bryan Paddock on 2012-07-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

I have issues similar to https://bugs.launchpad.net/ubuntu/+source/linux/+bug/479813 , but in Precise.

Have all updates applied as of precise-linux-3.2.0.26-generic x86 pae.

Wifi works fine until large amounts of data are transferred over wifi. Problem does seem to happen more often while using XBMC to stream media although problem does appear intermittently while transferring data over ssh too.

The problem is solved by using hardware switch to disable and re-enable wifi - all connections re-open and stream continues.

Some occasions the problem happens about 10mins in between each other - the strangest of them all is that while the problem is occurring a lot (every 10mins or so) I would switch from XBMC to VLC and the problem disappears. (I'm guessing XBMC does a lot more over the network than VLC? Download media info, plugin updates etc)

VLC has _never_ broken the wifi, although it has broken in a few other occasions just while using the pc (apt-get updates and such).

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-26-generic-pae 3.2.0-26.41
ProcVersionSignature: Ubuntu 3.2.0-26.41-generic-pae 3.2.19
Uname: Linux 3.2.0-26-generic-pae i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC260 Analog [ALC260 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
ApportVersion: 2.0.1-0ubuntu8
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC260 Analog [ALC260 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: bryan 1953 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xb0000000 irq 40'
   Mixer name : 'Realtek ALC260'
   Components : 'HDA:10ec0260,104d0d00,00100400 HDA:14f12bfa,104d0200,00090000'
   Controls : 17
   Simple ctrls : 9
Date: Mon Jul 2 08:51:48 2012
HibernationDevice: RESUME=UUID=b8684f6b-bc93-4280-9b07-3f20af09fbd1
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
MachineType: Sony Corporation VGN-FJ3S_W
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcEnviron:
 LANGUAGE=en_ZA:en
 TERM=xterm
 PATH=(custom, user)
 LANG=en_ZA.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-26-generic-pae root=UUID=3be5f96f-f176-4621-b44a-ce2a77dc11e4 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-26-generic-pae N/A
 linux-backports-modules-3.2.0-26-generic-pae N/A
 linux-firmware 1.79
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/10/2006
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: R0140X6
dmi.board.name: Q-Project
dmi.board.vendor: Sony Corporation
dmi.board.version: 01
dmi.chassis.type: 10
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrR0140X6:bd07/10/2006:svnSonyCorporation:pnVGN-FJ3S_W:pvrC10102XQ:rvnSonyCorporation:rnQ-Project:rvr01:cvn:ct10:cvr:
dmi.product.name: VGN-FJ3S_W
dmi.product.version: C10102XQ
dmi.sys.vendor: Sony Corporation

Bryan Paddock (bryanpaddock) wrote :
Brad Figg (brad-figg) on 2012-07-02
Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.5kernel[0] (Not a kernel in the daily directory) and install both the linux-image and linux-image-extra .deb packages.

Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.5-rc5-quantal/

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Bryan Paddock (bryanpaddock) wrote :

Sure thing.

bryan@pluto ~ $ uname -a
Linux pluto 3.5.0-030500rc5-generic #201206302035 SMP Sun Jul 1 00:43:03 UTC 2012 i686 i686 i386 GNU/Linux

Installed the kernel yesterday morning.

Transferred over 15GB from dev/urandom to the laptop with intel card via netcat - worked fine.

Loaded up laptop to watch a (1.5gb) movie on XBMC and wifi stopped again. Pings to any local/remote PC fail. Have to re-connect wifi again.

Loaded same movie in VLC, no problem.

Woke up this morning to surf - after loading up 2 webpages, wifi halts.

tags: added: kernel-bug-exists-upstream
removed: needs-upstream-testing
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers