10de:01d7 [Dell Inspiron 6400] Resume fails after Suspend; [drm] nouveau 0000:01:00.0: Failed to idle channel 1

Bug #1019415 reported by Robin Catling on 2012-06-29
54
This bug affects 11 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Running http://testcases.qa.ubuntu.com/System/SuspendResume in Quantal laptop testing.

Successful suspend; on pressing power button, LightDM session login locks - mouse moves but no selection possible; no cursor, unable to type into password box. 20-30 second delay then flips to terminal tty session displaying:

* Stopping System V run level compatibility
* Starting
3324.376027] [drm] nouveau 0000:01:00.0: Failed to idle channel 1.
[nnnn.nnnnn] [drm] nouveau 0000:01:00.0: Failed to idle channel 1.
[nnnn.nnnnn] [drm] nouveau 0000:01:00.0: Failed to idle channel 1.
[nnnn.nnnnn] [drm] nouveau 0000:01:00.0: Failed to idle channel 1.

20-30 second delay then flips back to locked LightDM login screen.

Cycles through, had to pull the power and restart.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: linux-image-3.5.0-2-generic 3.5.0-2.2
ProcVersionSignature: Ubuntu 3.5.0-2.2-generic 3.5.0-rc4
Uname: Linux 3.5.0-2-generic i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.25.
ApportVersion: 2.2.5-0ubuntu1
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: robin 1738 F.... pulseaudio
CRDA:
 country GB:
  (2402 - 2482 @ 40), (N/A, 20)
  (5170 - 5250 @ 40), (N/A, 20)
  (5250 - 5330 @ 40), (N/A, 20), DFS
  (5490 - 5710 @ 40), (N/A, 27), DFS
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xefffc000 irq 44'
   Mixer name : 'SigmaTel STAC9200'
   Components : 'HDA:83847690,102801bd,00102201 HDA:14f12bfa,14f100c3,00090000'
   Controls : 13
   Simple ctrls : 6
Date: Fri Jun 29 21:35:05 2012
HibernationDevice: RESUME=UUID=f69b1735-7ac9-4e18-86b8-48b960fd1dca
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha i386 (20120629)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: Dell Inc. MM061
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcFB: 0 nouveaufb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-2-generic root=UUID=790fd7e1-673f-4f43-889e-db400209d5f9 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-2-generic N/A
 linux-backports-modules-3.5.0-2-generic N/A
 linux-firmware 1.82
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/02/2007
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A14
dmi.board.name: 0XD720
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA14:bd04/02/2007:svnDellInc.:pnMM061:pvr:rvnDellInc.:rn0XD720:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: MM061
dmi.sys.vendor: Dell Inc.

Robin Catling (robinc) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu laptop testing tracker.

A list of all reports related to this bug can be found here:
http://laptop.qa.ubuntu.com/qatracker/reports/bugs/1019415

tags: added: laptop-testing
Brad Figg (brad-figg) on 2012-06-29
Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Do you know if this issue happened in a previous version of Ubuntu, or is this a new issue?

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.5kernel[0] (Not a kernel in the daily directory) and install both the linux-image and linux-image-extra .deb packages.

Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.5-rc4-quantal/

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
dino99 (9d9) wrote :

Got that issue today, doing:

- live usb : from precise i386 (full upgraded) and unetbootin (568-1 from ppa)
- stick formatted as fat32
- selected iso: daily live (quantal i386 Sept 15)
- unetbootin installation well done

- booting with that stick on an other pc: i get first a garbage coloured screen (might be related to lightdm), then the process continue in a loop, alterning garbage coloured screen and that error:

[drm] nouveau 0000:06:00:0: failed to idle channel x (x= 1/2/3 in a loop)

Changed in linux (Ubuntu):
status: Incomplete → New
Brad Figg (brad-figg) on 2012-09-15
Changed in linux (Ubuntu):
status: New → Confirmed
dino99 (9d9) wrote :

More comment about : [drm] nouveau 0000:06:00:0: failed to idle channel x (x= 1/2/3 in a loop)

as my previous workaround with unetbootin, i've tried something new (multisystem) and again the same error while trying to boot quantal: coloured bands garbage then the drm nouveau issue. Finally found that adding nomodeset as grub setting let the process ending cleanly. So it might be a regression with some latest package upgrades.

Giorgos Kylafas (gekylafas) wrote :

I tested kernels 3.6.3, 3.5.7 and 3.4.15 from http://kernel.ubuntu.com/~kernel-ppa/mainline/, as per comment #3.

3.6.3 fails with message "reloc wait_idle_failed: -16).

3.5.7 fails with the reported message ("Failed to idle channel...")

3.4.15 works OK.

tags: added: kernel-bug-exists-upstream
removed: needs-upstream-testing
CaptSaltyJack (csjubuntu) wrote :

This bug also affects kernel 3.5.0-21. Hardware is a System76 Bonobo P5.

tags: added: needs-full-computer-model needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Luca (pancallo) wrote :

Affects me as well.

System: Ubuntu 13.04 installed on harddrive
Dual Boot: Yes with Win7
Machine type: Desktop PC
CPU: Intel Core i7 950 @3.07Ghz (8 core total)
HD: 1TB, 150Gb for primary linux partition, 10Gb for Swap (partitions done by the installer). Those are /sda5 and /sda6
RAM: 10Gb
GPU: NVIDIA GeForce GTX 460

After suspend and restart, I get garbage on screen (patchwork of previous stuff I had on screen) and the after some seconds the message "Failed to idle channel 1" on a black shell screen, then the patchwork image comes up again, then shell after some seconds, etc... After about 5-6 "Failed to idle channel 1" the screen goes completely black and no way to recover.

Here is more information about my system.

    luke@luke-desktop:~$ uname -a
    Linux luke-desktop 3.8.0-31-generic #46-Ubuntu SMP Tue Sep 10 20:03:44 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

    luke@luke-desktop:~$ lsb_release -a
    No LSB modules are available.
    Distributor ID: Ubuntu
    Description: Ubuntu 13.04
    Release: 13.04
    Codename: raring

    luke@luke-desktop:~$ sudo fdisk -l
    Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
    255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 4096 bytes
    I/O size (minimum/optimal): 4096 bytes / 4096 bytes
    Disk identifier: 0x84917ceb

       Device Boot Start End Blocks Id System
    /dev/sda1 * 2048 206847 102400 7 HPFS/NTFS/exFAT
    /dev/sda2 206848 1646321663 823057408 7 HPFS/NTFS/exFAT
    /dev/sda3 1646323710 1953523711 153600001 5 Extended
    Partition 3 does not start on physical sector boundary.
    /dev/sda5 1646323712 1932572671 143124480 83 Linux
    /dev/sda6 1932574720 1953523711 10474496 82 Linux swap / Solaris

Regards.

Luca, if you have a bug in Ubuntu, the Ubuntu Kernel team, Ubuntu Bug Control team, and Ubuntu Bug Squad would like you to please file a new report by executing the following in a terminal while booted into a Ubuntu repository kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report would delay your problem being addressed as quickly as possible.

No need exists to comment here at this time. After reading the above documentation in it's entirety, if you have further questions, you are welcome to redirect them to the appropriate mailing list or forum via http://www.ubuntu.com/support/community/mailinglists , or you may contact me directly.

Thank you for your understanding.

summary: - Resume fails after Suspend; [drm] nouveau 0000:01:00.0: Failed to idle
- channel 1
+ 10de:01d7 Resume fails after Suspend; [drm] nouveau 0000:01:00.0: Failed
+ to idle channel 1
summary: - 10de:01d7 Resume fails after Suspend; [drm] nouveau 0000:01:00.0: Failed
- to idle channel 1
+ 10de:01d7 [Dell Inspiron 6400] Resume fails after Suspend; [drm] nouveau
+ 0000:01:00.0: Failed to idle channel 1
tags: added: bios-outdated-a17
removed: kernel-bug-exists-upstream needs-full-computer-model

Robin Catling, as per http://www.dell.com/support/troubleshooting/us/en/19/Product/inspiron-6400x an update is available for your BIOS (A17). If you update to this following https://help.ubuntu.com/community/BiosUpdate , does it change anything?

If not, could you please both specify what happened, and provide the output of the following terminal command:
sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date

Please note your current BIOS is already in the Bug Description, so posting this on the old BIOS would not be helpful.

For more on BIOS updates and linux, please see https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette .

Thank you for your understanding.

Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers