Ubuntu 12.04 Dell XPS 13 (Centrino Advanced-N 6230) can't connect to WPA Enterprise wireless

Bug #1019081 reported by Neo on 2012-06-28
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

I am having connection issues with on my Dell XPS 13 (running ubuntu 12.04) to my work WPA2 Enterprise wireless network.

On 12.04, WEP and WPA personal both work fine.

On 11.10, I am able to connect to WPA2 Enterprise fairly quick.

On 12.04 it is very difficult (nearly impossible) to connect to WPA2 Enterprise. I am only able to connect it couple times and the connection is extremely slow, not usable at all.

Attached the log file from syslog when connecting to my WPA2 Enterprise wireless network

> uname -a
Linux cjia-xps 3.2.0-26-generic #41+kamal2~DellXPS-Ubuntu SMP Wed Jun 20 20:25:04 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux:

> lsb_release -rd
Description: Ubuntu 12.04 LTS
Release: 12.04

Neo (neojia) wrote :
Neo (neojia) wrote :

BTW, I have tried the PPA provided by bug 969343 (Unable to connect to WPA enterprise wireless), it doesn't help and they suggest me to open a separate bug.

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1019081

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: precise
Neo (neojia) wrote :

When I run your that command I am getting this:

> apport-collect 1019081
No packages found matching linux.
ERROR: hook /usr/share/apport/general-hooks/ubuntu.py crashed:
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/apport/report.py", line 718, in add_hooks_info
    symb['add_info'](self, ui)
  File "/usr/share/apport/general-hooks/ubuntu.py", line 45, in add_info
    match_error_messages(report)
  File "/usr/share/apport/general-hooks/ubuntu.py", line 129, in match_error_messages
    if report['ProblemType'] == 'Package':
  File "/usr/lib/python2.7/UserDict.py", line 23, in __getitem__
    raise KeyError(key)
KeyError: 'ProblemType'
Traceback (most recent call last):
  File "/usr/share/apport/apport-gtk", line 499, in <lambda>
    GLib.idle_add(lambda: self.collect_info(on_finished=self.ui_update_view))
  File "/usr/lib/python2.7/dist-packages/apport/ui.py", line 867, in collect_info
    icthread.exc_raise()
  File "/usr/lib/python2.7/dist-packages/apport/REThread.py", line 34, in run
    self._retval = self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib/python2.7/dist-packages/apport/ui.py", line 111, in thread_collect_info
    if report['ProblemType'] == 'Crash' and \
  File "/usr/lib/python2.7/UserDict.py", line 23, in __getitem__
    raise KeyError(key)
KeyError: 'ProblemType'

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.5kernel[0] (Not a kernel in the daily directory) and install both the linux-image and linux-image-extra .deb packages.

Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.5-rc4-quantal/

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: needs-upstream-testing
Neo (neojia) wrote :

Just updated my kernel to v3.5-rc4-quantal, now my wireless is working now!!

Updated it with tag kernel-fixed-upstream. What would be the next step then? With this latest kernel, I am missing the Cypress trackpad driver, which is provided by https://launchpad.net/~kamalmostafa/+archive/dellxps.

Is it possible to back port the upstream fix for my wireless driver to the dellxps ppa?

tags: added: kernel-fixed-upstream
removed: needs-upstream-testing
Neo (neojia) wrote :

hmm, it is really strange. Once my wireless is working with the latest kernel (v3.5-rc4), I am able to use it when switching back to 3.2.0-26-generic kernel from https://launchpad.net/~kamalmostafa/+archive/dellxps

Neo (neojia) wrote :

I take that back, my 3.2.0 kernel doesn't work after a while and everything goes back as before. And I can only use the wireless device to connect to WPA2 with kernel 3.5.0-rc4.

Another issue with kernel 3.5.0-rc4 is that after rebooting the machine, I can't get into gnome any more. I have to enter recovery mode.

Please let know what would be the next step. Since I get the my older kernel working for couple hours after running the newer version, would that be a firmware overwriting problem?

psypher (psypher246) wrote :

HI,

I use WPA2 Enterprise at work as well, on Dell XPS 13, and have no issues connecting to the network. Do you perhaps know what access points you are using? We use Cisco.

Kamal Mostafa (kamalmostafa) wrote :

@Neo - I will monitor this bug report as well as #969343. Once a stable fix for Precise is discovered, we will consider whether it's feasible to include it in the DellXPS PPA. I'm afraid I have no WPA2 Enterprise AP here, so I cannot test it myself.

Neo (neojia) wrote :

@psypher, just check with my IT department, we are using Aruba APs.

I think I have found the issue that causes the problem after comparing the success and failure logs.

[ 29.704853] wlan0: Wrong control channel in association response: configured center-freq: 5180 hti-cfreq: 5805 hti->control_chan: 161 band: 1. Disabling HT.

I think the change from John should fix this issue eventually, but it requires a lot of patches to merge to http://kernel.ubuntu.com/git?p=kamal/ubuntu-precise.git;a=shortlog;h=refs/heads/dellxps tree.

So I just simply disable that checking and it works for me, attached the change.

Neo (neojia) wrote :

I forget to include the link of John's fix. Here it is.

http://www.spinics.net/lists/linux-wireless/msg87486.html

tags: added: patch
Simone Bianco (newcolour78) wrote :

Hi all,
  thanks for working on this. I have a similar problem on my xps 13. I too cannot connect to my university WPA2 wireless, with multiple access points. This is becoming hard to deal with, since wireless is campus-wide and I am forbidden by university rules to connect to the open access network.
I mentioned it is different because the output of my dmesg is the following (I am typing it instead of copy-paste for obvious reasons):

wlan0: d8:c7:c8:ea:f1:99 denied authentication (status 17)

I have googled but not really found a real solution to this, so I am wondering if the two problems are connected in some way. I have not applied the proposed patches.

I am using Kamal's latest xps kernel on precise pangolin LTS.

Cheers,
Simone

Neo (neojia) wrote :

I just verified that this mainline kernel works for me

http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/current/linux-headers-3.6.0-999-generic_3.6.0-999.201210080405_amd64.deb

But this mainline kernel lacks the support cypress trackpad. :-(

Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers