Ubuntu

Boot hangs after Plymouth in kernel 3.5.0-1

Reported by Christopher on 2012-06-21
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned

Bug Description

After upgrading the kernel to 3.5.0-1 Quantal will not boot. I can access recovery and the prior kernel but not the new one. I am still getting the amd microcode warning on boot.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: linux-headers-3.5.0-1 3.5.0-1.1
ProcVersionSignature: Ubuntu 3.4.0-5.11-generic 3.4.0
Uname: Linux 3.4.0-5-generic x86_64
NonfreeKernelModules: fglrx
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.25.
ApportVersion: 2.2.5-0ubuntu1
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: ALC259 Analog [ALC259 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC2: chris 2176 F.... pulseaudio
 /dev/snd/controlC0: chris 2176 F.... pulseaudio
 /dev/snd/controlC1: chris 2176 F.... pulseaudio
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xf2400000 irq 16'
   Mixer name : 'Realtek ALC259'
   Components : 'HDA:10ec0269,17aac012,00100100'
   Controls : 21
   Simple ctrls : 12
Card1.Amixer.info:
 Card hw:1 'Speaker'/'HOLTEK AudioHub Speaker at usb-0000:00:12.0-1.2.4, full speed'
   Mixer name : 'USB Mixer'
   Components : 'USB046d:0a0e'
   Controls : 2
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'PCM',0
   Capabilities: pvolume pvolume-joined pswitch pswitch-joined penum
   Playback channels: Mono
   Limits: Playback 0 - 51
   Mono: Playback 40 [78%] [-6.00dB] [on]
Card2.Amixer.info:
 Card hw:2 'HDMI'/'HDA ATI HDMI at 0xf2310000 irq 19'
   Mixer name : 'ATI RS690/780 HDMI'
   Components : 'HDA:1002791a,00791a00,00100000'
   Controls : 4
   Simple ctrls : 1
Card2.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Thu Jun 21 14:33:02 2012
HibernationDevice: RESUME=UUID=20544102-4994-4730-9f73-5316f5cf8016
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110803.1)
IwConfig:
 eth0 no wireless extensions.

 lo no wireless extensions.
MachineType: LENOVO 4311
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_CA:en
 PATH=(custom, no user)
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcFB:

ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.4.0-5-generic root=UUID=935151a7-3e66-4281-b03c-3e5543b35bbb ro quiet splash
RelatedPackageVersions:
 linux-restricted-modules-3.4.0-5-generic N/A
 linux-backports-modules-3.4.0-5-generic N/A
 linux-firmware 1.81
SourcePackage: linux
UpgradeStatus: Upgraded to quantal on 2012-06-15 (5 days ago)
dmi.bios.date: 09/07/2010
dmi.bios.vendor: LENOVO
dmi.bios.version: 36CN19WW(V2.05)
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Guam
dmi.board.vendor: LENOVO
dmi.board.version: Base Board Version
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnLENOVO:bvr36CN19WW(V2.05):bd09/07/2010:svnLENOVO:pn4311:pvrIdeaPadZ565:rvnLENOVO:rnGuam:rvrBaseBoardVersion:cvnChassisManufacturer:ct10:cvrChassisVersion:
dmi.product.name: 4311
dmi.product.version: IdeaPad Z565
dmi.sys.vendor: LENOVO

Christopher (soft-kristal) wrote :
Christopher (soft-kristal) wrote :

I didn't see this log attached and thought it might be useful.

Brad Figg (brad-figg) on 2012-06-21
Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.5kernel[0] (Not a kernel in the daily directory) and install both the linux-image and linux-image-extra .deb packages.

Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.5-rc3-quantal/

Changed in linux (Ubuntu):
importance: Undecided → High
tags: added: needs-upstream-testing
Joseph Salisbury (jsalisbury) wrote :

Also, can you follow the "Boot options" instructions on the following wiki to enable additional output on boot:

https://wiki.ubuntu.com/DebuggingKernelBoot

As mentioned on the wiki, it would be great if you can attach a log file which may have captured any messages you see. If you are unable to capture a log file, a digital photo will work just as well. As a last resort you can even copy messages down by hand.

tags: added: kernel-da-key
Christopher (soft-kristal) wrote :

OK - I downloaded these files but need to have it spelled out. I can get into the terminal mode in Recovery mode: would it be possible to install what's needed there?

linux-headers-3.5.0-030500rc3-generic_3.5.0-030500rc3.201206162135_amd64.deb
linux-headers-3.5.0-030500rc3_3.5.0-030500rc3.201206162135_all.deb
linux-image-3.5.0-030500rc3-generic_3.5.0-030500rc3.201206162135_amd64.deb
linux-image-extra-3.5.0-030500rc3-generic_3.5.0-030500rc3.201206162135_amd64.deb

Anyway, this will have to wait for a bit as I need a functioning machine on my Precise partition and work is beckoning.

Joseph Salisbury (jsalisbury) wrote :

There is some documentation here:
 https://wiki.ubuntu.com/KernelMainlineBuilds

You should only install the linux-image and linux-image-extra packages. That can be done from a terminal with the following commands:

sudo dpkg -i linux-image-3.5.0-030500rc3-generic_3.5.0-030500rc3.201206162135_amd64.deb
sudo dpkg -i linux-image-extra-3.5.0-030500rc3-generic_3.5.0-030500rc3.201206162135_amd64.deb

You can run sudo update-grub to automatically have grub updated to boot the new kernel by default. However, it is probably best to not update grub, and just select the new kernel from the grub menu.

The grub menu is hidden by default. You can access it by holding the "Shift" key after you power on your system.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Christopher (soft-kristal) wrote :

Can I do this from a terminal in the 3.4.0-5 kernel, or do I have to do it from the 3.5.0-1 recovery console?

Christopher (soft-kristal) wrote :

I encountered this error while trying to install the RC kernel:

dpkg: error processing linux-image-3.5.0-030500rc3-generic_3.5.0-030500rc3.201206162135_amd64.deb (--install):
 cannot access archive: No such file or directory
Errors were encountered while processing:
 linux-image-3.5.0-030500rc3-generic_3.5.0-030500rc3.201206162135_amd64.deb

Christopher (soft-kristal) wrote :

I found this on Ubuntu Geek (http://www.ubuntugeek.com/how-to-install-linux-kernel-3-5-rc-in-ubuntu-using-ppa.html) - does it make sense?

Important Note:- This is still in development so do not install in production system

Install linux kernel 3.5 RC in ubuntu using PPA

Open the terminal and run the following commands

    sudo add-apt-repository ppa:xorg-edgers/ppa
    sudo apt-get update
    sudo apt-get dist-upgrade

Joseph Salisbury (jsalisbury) wrote :

You shouldn't need to add a new ppa. Did you run the dpkg -i command in the same directory where that files were downloaded to?

Christopher (soft-kristal) wrote :

I need practise with 'cd', but in the meantime I moved the files to my home directory and installed them. I'm running RC3 now, and the only issue so far is that it only runs in 2d, which happens every time a new version is released. I have the ATI Radeon Graphic card which always needs an fglrx modification before I can work in 3d.

It's been running for about 5 minutes with no system problem notifications.

Dustofsnow (dustofsnow) wrote :

I have the exact same issue. No boot on 3.5.0.1 Tried rc3 and about to try rc2. Among the many commits, from 2 to 3, I found that this one has given similar trouble. https://lkml.org/lkml/2012/6/17/52

I am on an Xorg 1.11 system, running fglrx, amd64

Thanks for any support.

Christopher (soft-kristal) wrote :

RC3 boots, but pretty much everything launched behaves badly, with no controls on the windows. It may well be an fglrx issue as it's usually the culprit when 3d isn't available.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

v3.5 release candidate 4 is now out. rc-4 has the patch mentioned in comment #12:

git describe --contains 6ebb017de9d59a18c3ff9648270e8f6abaa93438
v3.5-rc4~17^2~10

Can you test the following to see if this bug is resolved with that commit:
http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.5-rc4-quantal/

Christopher (soft-kristal) wrote :

I had many messages while installing RC4 to install linux-headers-3.5.0-030500rc4-generic_3.5.0-030500rc4.201206241635_amd64.deb

Your previous instruction was not to install the headers, and I would appreciate clarification.

Joseph Salisbury (jsalisbury) wrote :

You don't have to install the RC4 headers.

Dustofsnow (dustofsnow) wrote :

3.5 rc4 boots with radeon drivers but so does 3.5.0.1 from the quantal repository. So I'm thinking its an fglrx issue. I haven't tried 3.5 rc4 with fglrx yet.

Dustofsnow (dustofsnow) wrote :

no dice on rc4 with fglrx. Any way I can give more input?

Joseph Salisbury (jsalisbury) wrote :

So you don't have any issues with the radeon drives, only the fglrx drivers?

The issue with the fglrx drivers is that they are proprietary. Which means we can't look at the code and figure out what's wrong and fix it. Since it's closed-source, only AMD can work on it and give efficient support.

There is some further information at the following two wikis:
https://help.ubuntu.com/community/RadeonDriver
https://help.ubuntu.com/community/BinaryDriverHowto/ATI

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Christopher (soft-kristal) wrote :

I use the fglrx and CCC provided by Ubuntu in the repositories. At the moment I'm down for the count in Quantal due to the xorg updates and am tempted to reinstall. I backed up my home folder in preparation.

I can use the recovery mode for updates and such but don't know how to downgrade the xorg video updates without using Symaptic.

Dustofsnow (dustofsnow) wrote :

Downgrade from what to what? Were you using xorg edgers?

@jsalisbury: yes alas, no fglrx with 3.5. Working well with 3.44 though. One takes what he can get.

Christopher (soft-kristal) wrote :

No - they were in the repositories as updates. See bug 1016908.

I'm pretty certain this is an issue with fglrx. I've tried both 8.960 from the quantal repos and a manually-patched 8.98 (12.6) and neither will boot with a 3.5 kernel (whether ppa-mainline or quantal repo). 3.4 works fine (Ubuntu or Liquorix).

Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers