infrared remote doesnt work anymore (3.2.0-26)

Bug #1014800 reported by Anderson Luiz Alves on 2012-06-18
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Luis Henriques
Oneiric
Medium
Unassigned
Precise
Medium
Unassigned
Quantal
Medium
Luis Henriques

Bug Description

== SRU Justification ==

A bug has been introduced on mainline by commit
"9ef449c6b31bb6a8e6dedc24de475a3b8c79be20" and this bug affects both
Oneiric and Precise. There's no upstream fix yet (couldn't even find
similar bug reports), but this will affect all users using the ENE IR
transceiver.

== Fix ==

The bug was introduced by accidentally moving the pnp_port_start()
invocation to a later stage in the device driver probe function,
while the goal was just to move the ISR and the pnp_port_start()
invocation. This patch fixes this.

== Impact ==

Users with an ENE IR transceiver will not be able to use it without
this fix.

== Test Case ==

Simply try to use the device, for example using a remote control.

==================================================================

i have a hp infrared RC6 remote,
it was working out-of-the-box with kernel linux-image-3.2.0-24-generic,
but doesnt work anymore with 3.2.0-25 or 3.2.0-26

Ubuntu 12.04 x64
linux-image-3.2.0-24-generic = 3.2.0-24.38 - works
linux-image-3.2.0-25-generic = 3.2.0-25.40 - doesnt work
linux-image-3.2.0-26-generic = 3.2.0-26.41 - doesnt work

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-26-generic 3.2.0-26.41
ProcVersionSignature: Ubuntu 3.2.0-26.41-generic 3.2.19
Uname: Linux 3.2.0-26-generic x86_64
NonfreeKernelModules: fglrx
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu8
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: alacn 2085 F.... pulseaudio
 /dev/snd/controlC0: alacn 2085 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xd2400000 irq 16'
   Mixer name : 'IDT 92HD71B7X'
   Components : 'HDA:111d76b2,103c3622,00100302 HDA:11c11040,103c137e,00100200'
   Controls : 25
   Simple ctrls : 14
Card1.Amixer.info:
 Card hw:1 'HDMI'/'HDA ATI HDMI at 0xd2310000 irq 19'
   Mixer name : 'ATI RS690/780 HDMI'
   Components : 'HDA:1002791a,00791a00,00100000'
   Controls : 4
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Mon Jun 18 16:09:06 2012
HibernationDevice: RESUME=UUID=37b91c5b-c2ae-4013-aa3c-4ae5235a36ff
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MachineType: Hewlett-Packard HP Pavilion DV5
ProcEnviron:
 LANGUAGE=en_US:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB:

ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz root=/dev/vg0/precise ro
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-26-generic N/A
 linux-backports-modules-3.2.0-26-generic N/A
 linux-firmware 1.79
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/11/2009
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.38
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 30F2
dmi.board.vendor: Quanta
dmi.board.version: 98.36
dmi.chassis.type: 10
dmi.chassis.vendor: Quanta
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.38:bd11/11/2009:svnHewlett-Packard:pnHPPavilionDV5:pvrRev1:rvnQuanta:rn30F2:rvr98.36:cvnQuanta:ct10:cvrN/A:
dmi.product.name: HP Pavilion DV5
dmi.product.version: Rev 1
dmi.sys.vendor: Hewlett-Packard

Anderson Luiz Alves (alacn1) wrote :
Changed in linux (Ubuntu):
importance: Undecided → Medium
Brad Figg (brad-figg) on 2012-06-18
Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test a few upstream kernels? I'd first like to have you test the latest mainline kernels, to see if this bug is already fixed:

v3.5-rc3: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.5-rc3-quantal/

Also, since this appears to be a regression, can you test the following two kernels to see if they are the proper ones to bisect between:

v3.2.16: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2.16-precise/
and
v3.2.17: http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2.17-precise/

I expect 3.2.16 to not have the bug. It would be good to know if 3.2.17 is when the bug was introduced.

tags: added: kernel-da-key
Luis Henriques (henrix) wrote :

Hi Anderson,

I believe I've found the issue with the driver, so I built a test kernel. Could you please download the packages from this location and check if they solve the issue?

http://people.canonical.com/~henrix/lp1014800/

(You can install them using dpkg -i <package>).

The fix is a little bit "conservative" (a one-liner), but it should do the job. If not, I can build another test kernel with a "more intrusive" approach.

Please let me know if this kernel allows you to use the IR again.

Anderson Luiz Alves (alacn1) wrote :

works:
3.2.16-030216.201204221935
3.2.17-030217.201205111935
3.5.0-030500rc3.201206162135

Anderson Luiz Alves (alacn1) wrote :

works:
3.2.0-26.41~lp1014800v1

Luis Henriques (henrix) wrote :

Thanks a lot for all this testing. Can I ask you to post a kernel log for the last kernel you tested (3.2.0-26.41~lp1014800v1)? Once you booted into this kernel, you can grab the kernel log from file /var/log/dmesg.

Anderson Luiz Alves (alacn1) wrote :

add attach dmesg 3.2.0-26.41~lp1014800v1

Luis Henriques (henrix) on 2012-06-19
Changed in linux (Ubuntu):
status: Confirmed → Triaged
assignee: nobody → Luis Henriques (henrix)
Luis Henriques (henrix) wrote :

Thank you Anderson. I'll follow up with this bug, and hopefully it will be available on Precise very soon.

Luis Henriques (henrix) on 2012-06-19
description: updated
Tim Gardner (timg-tpi) on 2012-06-19
Changed in linux (Ubuntu Oneiric):
status: New → Fix Committed
Changed in linux (Ubuntu Precise):
status: New → Fix Committed
Changed in linux (Ubuntu Quantal):
status: Triaged → Fix Released
status: Fix Released → In Progress
Tim Gardner (timg-tpi) on 2012-06-19
Changed in linux (Ubuntu Quantal):
milestone: none → quantal-alpha-2
Changed in linux (Ubuntu Quantal):
milestone: quantal-alpha-2 → quantal-alpha-3
Changed in linux (Ubuntu Precise):
milestone: none → ubuntu-12.04.1
Changed in linux (Ubuntu Precise):
importance: Undecided → Medium
Changed in linux (Ubuntu Oneiric):
importance: Undecided → Medium
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel for oneiric in -proposed solves the problem (3.0.0-23.38). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-oneiric' to 'verification-done-oneiric'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-oneiric
Anderson Luiz Alves (alacn1) wrote :

works:
3.0.0-23.38
3.2.0.27.29

tags: added: verification-done-oneiric
removed: verification-needed-oneiric
Anderson Luiz Alves (alacn1) wrote :

its linux-image-3.2.0-27-generic 3.2.0-27.43 (works)
instead of 3.2.0.27.29

Luis Henriques (henrix) wrote :

From comments #10 and #11, tagging as verified for Precise.

tags: added: verification-done-precise
Launchpad Janitor (janitor) wrote :
Download full text (6.9 KiB)

This bug was fixed in the package linux - 3.0.0-23.38

---------------
linux (3.0.0-23.38) oneiric-proposed; urgency=low

  [ Andy Whitcroft ]

  * No change upload to fix .ddeb generation in the PPA.

  [ Luis Henriques ]

  * Release Tracking Bug
    - LP: #1020623

linux (3.0.0-23.37) oneiric-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1020623

  [ Luis Henriques ]

  * SAUCE: (upstreamed) [media] ene_ir: Fix driver initialisation
    - LP: #1014800

  [ Upstream Kernel Changes ]

  * Revert "net: maintain namespace isolation between vlan and real device"
    - LP: #1013748
  * hwmon: (k10temp) Add support for AMD Trinity CPUs
    - LP: #1009086
  * hwmon: (fam15h_power) Increase output resolution
    - LP: #1009086
  * x86/amd: Re-enable CPU topology extensions in case BIOS has disabled it
    - LP: #1009087
  * SCSI: fix scsi_wait_scan
    - LP: #1013748
  * SCSI: Fix dm-multipath starvation when scsi host is busy
    - LP: #1013748
  * mm: consider all swapped back pages in used-once logic
    - LP: #1013748
  * mm: pmd_read_atomic: fix 32bit PAE pmd walk vs pmd_populate SMP race
    condition
    - LP: #1013748
  * iwlwifi: update BT traffic load states correctly
    - LP: #1013748
  * cifs: fix oops while traversing open file list (try #4)
    - LP: #1013748
  * PARISC: fix boot failure on 32-bit systems caused by branch stubs
    placed before .text
    - LP: #1013748
  * PARISC: fix TLB fault path on PA2.0 narrow systems
    - LP: #1013748
  * solos-pci: Fix DMA support
    - LP: #1013748
  * mac80211: fix ADDBA declined after suspend with wowlan
    - LP: #1013748
  * NFSv4: Map NFS4ERR_SHARE_DENIED into an EACCES error instead of EIO
    - LP: #1013748
  * drm/radeon: fix XFX quirk
    - LP: #1013748
  * drm/i915: properly handle interlaced bit for sdvo dtd conversion
    - LP: #1013748
  * drm/i915: wait for a vblank to pass after tv detect
    - LP: #1013748
  * Bluetooth: btusb: Add USB device ID "0a5c 21e8"
    - LP: #1013748
  * Bluetooth: btusb: typo in Broadcom SoftSailing id
    - LP: #1013748
  * Add Foxconn / Hon Hai IDs for btusb module
    - LP: #1013748
  * Bluetooth: Add support for Foxconn/Hon Hai AR5BBU22 0489:E03C
    - LP: #1013748
  * ALSA: usb-audio: fix rate_list memory leak
    - LP: #1013748
  * vfs: umount_tree() might be called on subtree that had never made it
    - LP: #1013748
  * mtd: nand: fix scan_read_raw_oob
    - LP: #1013748
  * drm/radeon: properly program gart on rv740, juniper, cypress, barts,
    hemlock
    - LP: #1013748
  * drm/radeon: fix HD6790, HD6570 backend programming
    - LP: #1013748
  * drm/ttm: Fix spinlock imbalance
    - LP: #1013748
  * ipv4: Do not use dead fib_info entries.
    - LP: #1013748
  * ipv4: fix the rcu race between free_fib_info and ip_route_output_slow
    - LP: #1013748
  * ipv6: fix incorrect ipsec fragment
    - LP: #1013748
  * l2tp: fix oops in L2TP IP sockets for connect() AF_UNSPEC case
    - LP: #1013748
  * pktgen: fix crash at module unload
    - LP: #1013748
  * pktgen: fix module unload for good
    - LP: #1013748
  * sctp: check cached dst before using it
    - LP: #1013748
  * skb: avoid unnecessary reallocations...

Read more...

Changed in linux (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (13.6 KiB)

This bug was fixed in the package linux - 3.2.0-27.43

---------------
linux (3.2.0-27.43) precise-proposed; urgency=low

  [ Andy Whitcroft ]

  * No change upload to fix .ddeb generation in the PPA.

  [ Luis Henriques ]

  * Release Tracking Bug
    - LP: #1020016

linux (3.2.0-27.42) precise-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1020016

  [ Chris J Arges ]

  * PACKAGING: add .gnu_debuglink sections to .ko files
    - LP: #669641

  [ Ike Panhc ]

  * [Config] Updateconfigs
    - LP: #1008345

  [ Luis Henriques ]

  * SAUCE: (upstreamed) [media] ene_ir: Fix driver initialisation
    - LP: #1014800
  * SAUCE: ocfs2: Fix NULL pointer dereferrence in
    __ocfs2_change_file_space
    - LP: #1006012

  [ Rob Herring ]

  * SAUCE: net: calxedaxgmac: enable rx cut-thru mode
    - LP: #1008345
  * SAUCE: EDAC: Add support for the highbank platform memory
    - LP: #1008345
  * SAUCE: EDAC: add support for highbank platform L2 cache ecc
    - LP: #1008345

  [ Seth Forshee ]

  * (pre-stable): bcma: add ext PA workaround for BCM4331 and BCM43431
    - LP: #925577

  [ Takashi Iwai ]

  * SAUCE: ALSA: hda - Fix power-map regression for HP dv6 & co
    - LP: #1013183

  [ Tim Gardner ]

  * [Config] Enable CONFIG_CGROUPS for highbank
    - LP: #1014692

  [ Upstream Kernel Changes ]

  * Revert "net: maintain namespace isolation between vlan and real device"
    - LP: #1013723
  * x86/amd: Re-enable CPU topology extensions in case BIOS has disabled it
    - LP: #1009087
  * hwmon: (k10temp) Add support for AMD Trinity CPUs
    - LP: #1009086
  * hwmon: (fam15h_power) Increase output resolution
    - LP: #1009086
  * Input: wacom - use BTN_TOOL_FINGER to indicate touch device type
    - LP: #1009435
  * Input: wacom - use switch statement for wacom_tpc_irq()
    - LP: #1009435
  * Input: wacom - isolate input registration
    - LP: #1009435
  * Input: wacom - wireless monitor framework
    - LP: #1009435
  * Input: wacom - create inputs when wireless connect
    - LP: #1009435
  * Input: wacom - wireless battery status
    - LP: #1009435
  * Input: wacom - check for allocation failure in probe()
    - LP: #1009435
  * Input: wacom - add basic Intuos5 support
    - LP: #1009435
  * Input: wacom - add Intuos5 Touch Ring/ExpressKey support
    - LP: #1009435
  * Input: wacom - add Intuos5 Touch Ring LED support
    - LP: #1009435
  * Input: wacom - add Intuos5 multitouch sensor support
    - LP: #1009435
  * iommu/amd: Add workaround for event log erratum
    - LP: #1013723
  * MIPS: BCM63XX: Add missing include for bcm63xx_gpio.h
    - LP: #1013723
  * cifs: Include backup intent search flags during searches {try #2)
    - LP: #1013723
  * sunrpc: fix loss of task->tk_status after rpc_delay call in
    xprt_alloc_slot
    - LP: #1013723
  * exofs: Fix CRASH on very early IO errors.
    - LP: #1013723
  * cifs: fix oops while traversing open file list (try #4)
    - LP: #1013723
  * Fix dm-multipath starvation when scsi host is busy
    - LP: #1013723
  * ixp4xx: fix compilation by adding gpiolib support
    - LP: #1013723
  * drm/i915: properly handle interlaced bit for sdvo dtd conversion
    - LP: #1013723
...

Changed in linux (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Julian Wiedmann (jwiedmann) wrote :

Landed in Quantal as

commit bd2c6675ad6c33e2130860ab513466bd9a4069e3
Author: Luis Henriques <email address hidden>
Date: Tue Jun 19 11:29:49 2012 -0300

    media: ene_ir: Fix driver initialisation

    commit b31b021988fed9e3741a46918f14ba9b063811db upstream.

    commit 9ef449c6b31bb6a8e6dedc24de475a3b8c79be20 ("[media] rc: Postpone ISR
    registration") fixed an early ISR registration on several drivers. It did
    however also introduced a bug by moving the invocation of pnp_port_start()
    to the end of the probe function.

    This patch fixes this issue by moving the invocation of pnp_port_start() to
    an earlier stage in the probe function.

Changed in linux (Ubuntu Quantal):
status: In Progress → Fix Released
Changed in linux (Ubuntu):
status: In Progress → Fix Released
Download full text (5.8 KiB)

I am sorry but i miggred on ubuntu 13.10 and everything is alright except my smartphone using USB.

Correct on ubuntu 13.04 and no works on ubuntu 13.10 (salamander). No way on MTP or MSC.

Is there a service not updated?  gvfs updated last week and always the same problem.

Thanks.

Guy Roche

mail <email address hidden>
mail <email address hidden>

domicile 0324 376446
mobile 0619 178018

> Message du 03/10/13 11:13
> De : "Julian Wiedmann"
> A : <email address hidden>
> Copie à :
> Objet : [Bug 1014800] Re: infrared remote doesnt work anymore (3.2.0-26)
>
>
> Landed in Quantal as
>
> commit bd2c6675ad6c33e2130860ab513466bd9a4069e3
> Author: Luis Henriques
> Date: Tue Jun 19 11:29:49 2012 -0300
>
> media: ene_ir: Fix driver initialisation
>
> commit b31b021988fed9e3741a46918f14ba9b063811db upstream.
>
> commit 9ef449c6b31bb6a8e6dedc24de475a3b8c79be20 ("[media] rc: Postpone ISR
> registration") fixed an early ISR registration on several drivers. It did
> however also introduced a bug by moving the invocation of pnp_port_start()
> to the end of the probe function.
>
> This patch fixes this issue by moving the invocation of pnp_port_start() to
> an earlier stage in the probe function.
>
>
> ** Changed in: linux (Ubuntu Quantal)
> Status: In Progress => Fix Released
>
> ** Changed in: linux (Ubuntu)
> Status: In Progress => Fix Released
>
> --
> You received this bug notification because you are subscribed to Ubuntu
> ubuntu-12.04.1.
> Matching subscriptions: No Audio after update kernel 3 2 025 in Ubuntu 12 04 32bits. Good in kernel 3 2 024 ! Alsa 1 025 not compiled in kernel 3 2 025. It's the same problem with ubuntu 12 10 alpha I tried today too !(but kernel 3 4 ...). A+
> https://bugs.launchpad.net/bugs/1014800
>
> Title:
> infrared remote doesnt work anymore (3.2.0-26)
>
> Status in “linux” package in Ubuntu:
> Fix Released
> Status in “linux” source package in Oneiric:
> Fix Released
> Status in “linux” source package in Precise:
> Fix Released
> Status in “linux” source package in Quantal:
> Fix Released
>
> Bug description:
> == SRU Justification ==
>
> A bug has been introduced on mainline by commit
> "9ef449c6b31bb6a8e6dedc24de475a3b8c79be20" and this bug affects both
> Oneiric and Precise. There's no upstream fix yet (couldn't even find
> similar bug reports), but this will affect all users using the ENE IR
> transceiver.
>
> == Fix ==
>
> The bug was introduced by accidentally moving the pnp_port_start()
> invocation to a later stage in the device driver probe function,
> while the goal was just to move the ISR and the pnp_port_start()
> invocation. This patch fixes this.
>
> == Impact ==
>
> Users with an ENE IR transceiver will not be able to use it without
> this fix.
>
> == Test Case ==
>
> Simply try to use the device, for example using a remote control.
>
> ==================================================================
>
> i have a hp infrared RC6 remote,
> it was working out-of-the-box with kernel linux-image-3.2.0-24-generic,
> but doesnt work anymore with 3.2.0-25 or 3.2.0-26
>
> Ubuntu 12.04 x64
> linux-image-3.2.0-24-generic = 3.2.0-24.38 - works
> linux-image-3.2.0-25-generic = 3.2.0-25...

Read more...

To post a comment you must log in.