[Asus eeepc 1225B] Keyboard and Touchpad randomly not working at startup

Bug #1014240 reported by enrico on 2012-06-17
This bug affects 18 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)

Bug Description

Usually, once every 5-6 times when I reboot or awake form hibernate, the touchpad and keyboard do not work: no way to input text and login so I need to hard reset the laptop. I can ssh in (so the system is not frozen) and Fn+keys to change screen brightness etc always work.
I collected X and kernel logs when it happens (by logging in remotely via SSH) but I'm not able to understand what is going on.

This issue is reported in multiple forums, and affects Asus 252b as well (same laptop model for US market). Another bug is filed for this laptop model, related to hibernate/suspend (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/951143) and a workaround exists, maybe it helps.

$ lsb_release -rd
Description: Ubuntu 12.04 LTS
Release: 12.04
$ uname -a
Linux picolo 3.2.0-24-generic #39-Ubuntu SMP Mon May 21 16:52:17 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

enrico (eliboni) wrote :

Attached a tar gz file containing some log files (with ".err" suffix are the ones I grab by loggin in remotely when the problem occours, with ".ok" suffix are the ones after a successful startup)
dmesg: dmesg output when issue occour
proc.bus.input.devices.err : cat /proc/bus/input/devices when issue occur

description: updated
description: updated

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1014240/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
enrico (eliboni) wrote :

I'm not sure about the specific source package - the login screen of LightDM or Xscreensaver once every 5-6 times after a boot/hibernate does not accept keyboard inputs and neither the touchpad works. However I don't think the issue is on those packages. Should likley be kernel or X related, somehow the keyboard/touchpad is initialized in an incorrect status.
This issue has been reported also in other Linux OS (while it works always fine in Win7).
I'll try to add some info more as reported in https://wiki.ubuntu.com/X/Troubleshooting (HAL, lspci output)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
b3nn0 (agib) wrote :

Same thing happens on my EEE-Pc R252B (which has essentially the exact same hardware and uses the same bios)

Luca Rodi (luca-rodi) wrote :

Same on EEE-PC 1225B

enrico (eliboni) wrote :

I grab logs just after a resume from hibernate when the problem appear - as stated before, this is happening just sometime, once every 5-6 times.
From those logs it seems the system complains since it does not find the mouse/keyboard to resume.

On syslog:
Jun 23 23:07:55 picolo kernel: [19006.270097] i8042: failed to resume active multiplexor, mouse won't work
Jun 23 23:07:55 picolo kernel: [19007.101288] i8042: Failed to enable KBD port
Jun 23 23:07:55 picolo kernel: [19009.671305] i8042: Can't write CTR while closing KBD port
Jun 23 23:07:55 picolo kernel: [19010.502090] i8042: Can't reactivate KBD port
Jun 23 23:07:55 picolo kernel: [19013.008480] i8042: Can't write CTR while closing KBD port

On Xorg.0.log
[ 19023.957] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
[ 19031.908] SynPS/2 Synaptics TouchPad: Read error No such device
[ 19031.908] (II) config/udev: removing device SynPS/2 Synaptics TouchPad
[ 19032.462] (II) UnloadModule: "synaptics"
[ 19032.463] (II) Unloading synaptics

lspci-vvnn output is unchanged.

on /proc/bus/input/devices the following entry is now missed

N: Name="SynPS/2 Synaptics TouchPad"
P: Phys=isa0060/serio2/input0
S: Sysfs=/devices/platform/i8042/serio2/input/input9
U: Uniq=
H: Handlers=mouse0 event9
B: EV=b
B: KEY=6420 30000 0 0 0 0
B: ABS=260800011000003

Strange enough, the previous entry is there when the issue occurs after plain reboot (i.e. not from hibernate).

LennartP (lennart-preuss) wrote :

I just got the problem after logging out, and then trying to log in again. So it would appear that is bug th is not necessarily related to hibernation and/or power-up.

 I was able to recover from it by pressing Fn+F9 (enable-disable touchpad). I've tried this before, but this was the first time it actually helped.

BTW, Fn+F5, Fn+F6, and Fn+F7 have always worked for me when all other keys and the touchpad doesn't.

It would appear that the keyboard and mouse needs to be re-initialized when the login screen appears -- does anyone know how to do that?

chipesz (chipesz) wrote :

Are someone, who have found a solution for this problem?
I wish to buy an Asus EEE-PC 1225b netbook, and I need to be sure, that this computer works well with (Ubuntu) Linux.

I have the same problem with Asus Eeeepc R252B. I have seen this problem also once in the original Express Gate SW from Asus.
Perhaps it is solved in newer Express Gate SW version from ASUS? Perhaps the solution can be found there?
Function keyes are working, but no touchpad and no keyboard. Fn+F9 helps sometimes after several repeats.

Łukasz Dąbek (sznurek) wrote :

Adding i8042.ignore to kernel command line solved problem for me (ASUS 1225b).

(One can add the option in /etc/default/grub, then run update-grub)

Mateus Araújo (iris-n) wrote :


Since the problem appears randomly, it is hard to be sure it is gone, but after applying your solution I rebooted ten times and there was no lock up, so I guess it is working. Thank you very much!

enrico (eliboni) wrote :

Good to see it seems we have a solution, so I edited /etc/default/grub, updating the GRUB_CMDLINE_LINUX_DEFAULT line to:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.ignore"

and run update-grub.

Btw, on kernel parameters docs I see i8042.reset or i8042.unlock might help, but I don't find i8042.ignore - what it is doing?

Łukasz Dąbek (sznurek) wrote :

What a shame, I was writing this option from memory: of course it is i8042.reset! Additionally I have i8042.nomux in my kernel command line - nearly 30 reboots with no keyboard/touchpad hangup.

enrico (eliboni) wrote :

Ha haaa... thanks Lukasz; I went up to the kernel i8042.c to understand the ignore option and concluded that it does nothing ;)

I've just updated /etc/default/grub with:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.reset"

If someone is interested, here are the i8042 kernel option:
        i8042.debug [HW] Toggle i8042 debug mode
        i8042.direct [HW] Put keyboard port into non-translated mode
        i8042.dumbkbd [HW] Pretend that controller can only read data from
                             keyboard and cannot control its state
                             (Don't attempt to blink the leds)
        i8042.noaux [HW] Don't check for auxiliary (== mouse) port
        i8042.nokbd [HW] Don't check/create keyboard port
        i8042.noloop [HW] Disable the AUX Loopback command while probing
                             for the AUX port
        i8042.nomux [HW] Don't check presence of an active multiplexing
        i8042.nopnp [HW] Don't use ACPIPnP / PnPBIOS to discover KBD/AUX
        i8042.notimeout [HW] Ignore timeout condition signalled by conroller
        i8042.reset [HW] Reset the controller during init and cleanup
        i8042.unlock [HW] Unlock (ignore) the keylock

enrico (eliboni) wrote :

atch, keyboard locked today with i8042.reset as kernel option, let's try adding nomux as well as in Lukasz configuration, hopefully that's the one:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.reset i8042.nomux"

enrico (eliboni) wrote :

after a few days and several reboots/hibernates etc. it really seems we have a solution - the nomux option, or the combination of reset and nomux does the trick.


I have the same problem also in a 1225B. I'm going to try this workaround that you suggest. Thanks

Peer (frucht-fleisch) wrote :

I have an Asus 1005HA and the same problem (no keyboard and touchpad funktion). I tried the solution above, without success.
First time I started the computer it worked, but afterwards not. I tried the Live-CD for first time and it worked. But not anymore.
Anyway the problem appears as well after closing the display. To reawake the computer I press a button on the keyboard but after Ubuntu comes back, there's no funktion.
It's really courios, the first times I had success by clearing the CMOS. But not anymore.

For me seems like an hardware problem as well as the previous netbook-user had the same problem with windows.
Pfffff - does anybody has an idea?


LennartP (lennart-preuss) wrote :

The "i8042.reset i8042.nomux" trick worked for me.

There used to be a bullet-proof way of reproducing the problem, and that was to connect or disconnect the charger before booting the system. That no longer happens, so I guess we have a solution here.

Thanks for your good advice.

This is an Issue I am having aswell.
I will try the update of grub with [GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.reset i8042.nomux"]
Ill post if this helps me.
Thank you for the solution.

I #'d (commented) out the line that said "GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" "

Inserted :
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.reset i8042.nomux"
updated grub

Tried with reset, nomux, and both.

It fixed the keyboard and touchpad issue but broke the login.
I get three separate results.
1)During boot i get the blueish screen that appears during all boots before the splash that covers the boot scroll. No button will take it away and show the boot log scroll. Just stays bluish till I manually reset.
2) The bluish screen turns to a Splash and a generic login box appears. Then typing in my info, brings up a symbol that says that I am logged in but doesnt disappear and goto the desktop. It just stays on the splash and login window.
3) Just like result two except the screen goes blueish and an error window comes up and says failed to login to gnome session.

I have checked my install iso with md5sum and the install on the usb. I have reinstalled with UEFI option on the boot menu screen(which doesn't install) and the regular option on that screen 12 times now. The live usb boots and runs flawlessly. The installation works after the first boot and then just crumbles more and more each boot.

I am just now taking my first C programming class so this is out of my league but am familiar with bash and willing to fix this if i can.

It may help to know that I am running the most recent version of Ubuntu gnome.

LennartP (lennart-preuss) wrote :

Andrew, I have no idea why this is happening to you, and I'm on Ubuntu 12.04LTS myself.

However, my Ubuntu used to deteriorate which each reboot too, when installed from USB sticks connected to USB 3.0 ports. On my particular machine, the 3.0 ports are on two on the left side; they distinguish themselves by being kind of bluish, which I didn't notice at first.

All of this "works as designed", since booting from USB3.0 isn't supported...

ebraz (erin-braswell) wrote :

Hi all -

I'm having this exact same problem on my ASUS 1225B running edubuntu 12.04 LTS, and unfortunately the same steps as others have done (editing GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.reset i8042.nomux" in /etc/default/grub and resetting grub) did not work for me.

It worked after the first reboot, which I jumped for joy over, but has not been consistent. I realize this is a bit of an old thread, but is anyone else still experincing this too? Is there anything else others have tried that might help fix the problem? Thank you!

I Have this problem still. I am on 12.10 on all of my PC's and I have this issue mostly with my ASUS 1225b. My Dell c521 just started doing it too but I noticed something interesting. If I boot up and the keyboard and mouse do not respond and then I leave it alone for up to an hour, when I retry without a reset It seems to have reinitialized the Mouse and Keyboard. Have a dell laptop that runs flawlessly on 12.10 but my main two boxes have developed glitches with 12.10. Wish I had the knowledge to debug these issues myself.

LennartP (lennart-preuss) wrote :

see also: Launchpad [Bug 1142118]

enrico, thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command, as it will automatically gather debugging information, in a terminal:
apport-collect 1014240

affects: ubuntu → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
Mélodie (meets) wrote :


I installed the Bento Openbox respin (Ubuntu with Openbox) version 14.04.3 on Asus EEE PC of the same version, 1225b, and seeking for all the best solutions for this little laptop to work correctly, stumbled upon this bug report. Hence I rebooted and removed the external keyboard and mouse I had plugged to work conveniently and met with the same keyboard/touchpad issue as you guys.

I applied the solution promoted by enrico on his comment #16, and all seems fine now. I hope it will continue to work right! (And I have no idea where the options added come from and what they refer to, if you people know what they refer to, I'd attempt to understand how that work).

Thanks and best regards,

Egbert van der Wal (eggie) wrote :

I had the same problem on my new laptop (Clevo P650RA), and adding 'i8042.reset' to GRUB_CMDLINE_LINUX_DEFAULT fixed it for me. Shouldn't this be enabled by default?

This is on "Ubuntu Xenial Xerus (development branch) - Release: 16.04" by the way.

My exact kernel error was:

i8042: failed to resume active multiplexor, mouse won't work

In that case, the mouse indeed didn't work, but neither did the touchpad. Closing the laptop lid, waiting for a couple of seconds for it to suspend again and reopening the laptop lid was a workaround to resolve the situation, but the i8042.reset takes away the need to do so.

Changed in linux (Ubuntu):
status: Expired → New

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1014240

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: precise
Egbert van der Wal (eggie) wrote :

Right, I can give that a try, but it's a tad hard. I'll remove the i8042.reset flag and wait until it hangs again. Because the keyboard doesn't work in that case, I'll have to resolve it by doing another suspend/resume iteration and then will link the items. Since it's not predictable, it may take one or two days.

In my case, you should add tag: xenial, rather than Precise, even though it seems to affect other releases too.

Egbert van der Wal, to advise, the bot's comment was directed to the original reporter.

Despite this, it will help immensely if you filed a new report with the Ubuntu repository kernel (not mainline/upstream) via a terminal:
ubuntu-bug linux

Please feel free to subscribe me to it.

For more on why this is helpful, please see https://wiki.ubuntu.com/ReportingBugs.

Egbert van der Wal (eggie) wrote :

Christopher, thanks for the explanation. However, I was under the impression that the automatic response was due to the fact that I changed state of this bug to 'new' (because it was set to 'expired' and I suffered from the same problem).

I'm currently awaiting the problem but I haven't encountered it since I installed the latest kernel version in 16.04: 4.4.0-16-generic. If it occurs again, I will file a new report rather than post here. Thanks again.

Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers