Oneiric update to 3.0.34 stable release

Bug #1013748 reported by Herton R. Krzesinski
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Invalid
Undecided
Unassigned
Oneiric
Fix Released
Medium
Herton R. Krzesinski

Bug Description

SRU Justification

    Impact:
       The upstream process for stable tree updates is quite similar
       in scope to the Ubuntu SRU process, e.g., each patch has to
       demonstrably fix a bug, and each patch is vetted by upstream
       by originating either directly from Linus' tree or in a minimally
       backported form of that patch. The 3.0.34 upstream stable
       patch set is now available. It should be included in the Ubuntu
       kernel as well.

       git://git.kernel.org/

    TEST CASE: TBD

       The following patches are in the 3.0.34 stable release:

SCSI: fix scsi_wait_scan
SCSI: Fix dm-multipath starvation when scsi host is busy
mm: consider all swapped back pages in used-once logic
mm: pmd_read_atomic: fix 32bit PAE pmd walk vs pmd_populate SMP race condition
iwlwifi: update BT traffic load states correctly
cifs: fix oops while traversing open file list (try #4)
PARISC: fix boot failure on 32-bit systems caused by branch stubs placed before .text
PARISC: fix TLB fault path on PA2.0 narrow systems
solos-pci: Fix DMA support
mac80211: fix ADDBA declined after suspend with wowlan
NFSv4: Map NFS4ERR_SHARE_DENIED into an EACCES error instead of EIO
drm/radeon: fix XFX quirk
drm/i915: properly handle interlaced bit for sdvo dtd conversion
drm/i915: wait for a vblank to pass after tv detect
Bluetooth: Add support for Broadcom BCM20702A0
Bluetooth: Add support for BCM20702A0 [0a5c:21e3]
Bluetooth: btusb: Add vendor specific ID (0a5c 21f3) for BCM20702A0
Bluetooth: btusb: add support for BCM20702A0 [0a5c:21e6]
Bluetooth: btusb: Add USB device ID "0a5c 21e8"
Bluetooth: btusb: Add vendor specific ID (0489 e042) for BCM20702A0
Bluetooth: btusb: typo in Broadcom SoftSailing id
Add Foxconn / Hon Hai IDs for btusb module
Bluetooth: Add support for Foxconn/Hon Hai AR5BBU22 0489:E03C
ALSA: usb-audio: fix rate_list memory leak
vfs: umount_tree() might be called on subtree that had never made it
mtd: nand: fix scan_read_raw_oob
drm/radeon: properly program gart on rv740, juniper, cypress, barts, hemlock
drm/radeon: fix HD6790, HD6570 backend programming
drm/ttm: Fix spinlock imbalance
ipv4: Do not use dead fib_info entries.
ipv4: fix the rcu race between free_fib_info and ip_route_output_slow
ipv6: fix incorrect ipsec fragment
l2tp: fix oops in L2TP IP sockets for connect() AF_UNSPEC case
pktgen: fix crash at module unload
pktgen: fix module unload for good
Revert "net: maintain namespace isolation between vlan and real device"
sctp: check cached dst before using it
skb: avoid unnecessary reallocations in __skb_cow
xfrm: take net hdr len into account for esp payload size calculation
ext4: force ro mount if ext4_setup_super() fails
ext4: add missing save_error_info() to ext4_error()
ext4: don't trash state flags in EXT4_IOC_SETFLAGS
ext4: add ext4_mb_unload_buddy in the error path
ext4: remove mb_groups before tearing down the buddy_cache
drm/radeon/kms: add new BTC PCI ids
ACPI battery: only refresh the sysfs files when pertinent information changes
wl1251: fix oops on early interrupt
ext4: don't set i_flags in EXT4_IOC_SETFLAGS
Linux 3.0.34

The following patches above were dropped as were already applied:
Bluetooth: Add support for Broadcom BCM20702A0
Bluetooth: Add support for BCM20702A0 [0a5c:21e3]
Bluetooth: btusb: Add vendor specific ID (0a5c 21f3)
Bluetooth: btusb: add support for BCM20702A0
Bluetooth: btusb: Add vendor specific ID (0489 e042)

The change "Bluetooth: btusb: Add USB device ID "0a5c 21e8" needed a rediff to apply.

tags: added: kernel-stable-tracking-bug
description: updated
Changed in linux (Ubuntu):
status: New → Invalid
Changed in linux (Ubuntu Oneiric):
status: New → Fix Committed
importance: Undecided → Medium
assignee: nobody → Herton R. Krzesinski (herton)
description: updated
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (6.9 KiB)

This bug was fixed in the package linux - 3.0.0-23.38

---------------
linux (3.0.0-23.38) oneiric-proposed; urgency=low

  [ Andy Whitcroft ]

  * No change upload to fix .ddeb generation in the PPA.

  [ Luis Henriques ]

  * Release Tracking Bug
    - LP: #1020623

linux (3.0.0-23.37) oneiric-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1020623

  [ Luis Henriques ]

  * SAUCE: (upstreamed) [media] ene_ir: Fix driver initialisation
    - LP: #1014800

  [ Upstream Kernel Changes ]

  * Revert "net: maintain namespace isolation between vlan and real device"
    - LP: #1013748
  * hwmon: (k10temp) Add support for AMD Trinity CPUs
    - LP: #1009086
  * hwmon: (fam15h_power) Increase output resolution
    - LP: #1009086
  * x86/amd: Re-enable CPU topology extensions in case BIOS has disabled it
    - LP: #1009087
  * SCSI: fix scsi_wait_scan
    - LP: #1013748
  * SCSI: Fix dm-multipath starvation when scsi host is busy
    - LP: #1013748
  * mm: consider all swapped back pages in used-once logic
    - LP: #1013748
  * mm: pmd_read_atomic: fix 32bit PAE pmd walk vs pmd_populate SMP race
    condition
    - LP: #1013748
  * iwlwifi: update BT traffic load states correctly
    - LP: #1013748
  * cifs: fix oops while traversing open file list (try #4)
    - LP: #1013748
  * PARISC: fix boot failure on 32-bit systems caused by branch stubs
    placed before .text
    - LP: #1013748
  * PARISC: fix TLB fault path on PA2.0 narrow systems
    - LP: #1013748
  * solos-pci: Fix DMA support
    - LP: #1013748
  * mac80211: fix ADDBA declined after suspend with wowlan
    - LP: #1013748
  * NFSv4: Map NFS4ERR_SHARE_DENIED into an EACCES error instead of EIO
    - LP: #1013748
  * drm/radeon: fix XFX quirk
    - LP: #1013748
  * drm/i915: properly handle interlaced bit for sdvo dtd conversion
    - LP: #1013748
  * drm/i915: wait for a vblank to pass after tv detect
    - LP: #1013748
  * Bluetooth: btusb: Add USB device ID "0a5c 21e8"
    - LP: #1013748
  * Bluetooth: btusb: typo in Broadcom SoftSailing id
    - LP: #1013748
  * Add Foxconn / Hon Hai IDs for btusb module
    - LP: #1013748
  * Bluetooth: Add support for Foxconn/Hon Hai AR5BBU22 0489:E03C
    - LP: #1013748
  * ALSA: usb-audio: fix rate_list memory leak
    - LP: #1013748
  * vfs: umount_tree() might be called on subtree that had never made it
    - LP: #1013748
  * mtd: nand: fix scan_read_raw_oob
    - LP: #1013748
  * drm/radeon: properly program gart on rv740, juniper, cypress, barts,
    hemlock
    - LP: #1013748
  * drm/radeon: fix HD6790, HD6570 backend programming
    - LP: #1013748
  * drm/ttm: Fix spinlock imbalance
    - LP: #1013748
  * ipv4: Do not use dead fib_info entries.
    - LP: #1013748
  * ipv4: fix the rcu race between free_fib_info and ip_route_output_slow
    - LP: #1013748
  * ipv6: fix incorrect ipsec fragment
    - LP: #1013748
  * l2tp: fix oops in L2TP IP sockets for connect() AF_UNSPEC case
    - LP: #1013748
  * pktgen: fix crash at module unload
    - LP: #1013748
  * pktgen: fix module unload for good
    - LP: #1013748
  * sctp: check cached dst before using it
    - LP: #1013748
  * skb: avoid unnecessary reallocations...

Read more...

Changed in linux (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers