Computer does not power off when attempting to shut down by any route.

Bug #1010981 reported by grege89 on 2012-06-09
64
This bug affects 13 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Computer does not shut down, but instead merely freezes at the graphical splash screen while remaining powered on, with monitor, fans, and all other hardware still running. I've attempted the following, all with no success:

- Issuing halt, poweroff, halt -P, shutdown -h/-H/-P, and every other conceivable variation thereof from a terminal. Have also attempted these commands from a tty after killing X.

- Graphical shutdown from unity panel. Have also tried this at login screen.

- Have attempted to disable various services and kernel modules that have been implicated in other bug reports complaining of similar issues (namely, laptop-mode, acpi-support, proprietary fglrx driver, networking, and misc. others).

- Various suggestions from Ubuntu forums (editing /etc/default/halt, updating grub with various different arguments to GRUB_CMDLINE_LINUX_DEFAULT, disabling network-manager service prior to attempting shut down, and others).

This shut down malfunction happens invariably and with total predictability. Oddly, rebooting does initially appear to work, but when computer powers back on, the OS fails to load and instead hangs at a blank, purple screen (without the typical Ubuntu logo).

Other relevant info:

- Computer is an Acer Aspire 5560-7402 laptop.

- Ubuntu is the sole OS, installed recently with default/automatic partitioning settings, using whole disk.

- uname -srvmpio output:
Linux 3.2.0-24-generic #39-Ubuntu SMP Mon May 21 16:52:17 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux (please note that the problem began immediately after installation, i.e., before upgrade from 3.2.0-23-generic kernel).

- lsb_release -rd output:
Description: Ubuntu 12.04 LTS
Release: 12.04
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu8
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 1: Generic_1 [HD-Audio Generic], device 0: ALC269VB Analog [ALC269VB Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: grisha 3169 F.... pulseaudio
 /dev/snd/controlC0: grisha 3169 F.... pulseaudio
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
Card0.Amixer.info:
 Card hw:0 'Generic'/'HD-Audio Generic at 0xf0244000 irq 43'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100200'
   Controls : 6
   Simple ctrls : 1
Card0.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Card1.Amixer.info:
 Card hw:1 'Generic_1'/'HD-Audio Generic at 0xf0240000 irq 16'
   Mixer name : 'Realtek ALC269VB'
   Components : 'HDA:10ec0269,1025059f,00100100'
   Controls : 20
   Simple ctrls : 11
DistroRelease: Ubuntu 12.04
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=752809a0-c0c2-4a3e-922e-32aafd530966
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MachineType: Acer Aspire 5560
NonfreeKernelModules: wl fglrx
Package: linux (not installed)
ProcEnviron:
 TERM=xterm-color
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 EFI VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-24-generic root=UUID=3e6d51a0-a09b-43bd-911e-8297b64dec52 ro acpi=force quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.2.0-24.39-generic 3.2.16
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-24-generic N/A
 linux-backports-modules-3.2.0-24-generic N/A
 linux-firmware 1.79
SourcePackage: linux
Tags: precise precise
Uname: Linux 3.2.0-24-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 12/05/2011
dmi.bios.vendor: Phoenix Technologies Ltd.
dmi.bios.version: V1.15
dmi.board.asset.tag: No Asset Tag
dmi.board.name: Aspire 5560
dmi.board.vendor: Acer
dmi.board.version: A11
dmi.chassis.asset.tag: Asset Tag
dmi.chassis.type: 9
dmi.chassis.vendor: Acer
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnPhoenixTechnologiesLtd.:bvrV1.15:bd12/05/2011:svnAcer:pnAspire5560:pvr0.1:rvnAcer:rnAspire5560:rvrA11:cvnAcer:ct9:cvr0.1:
dmi.product.name: Aspire 5560
dmi.product.version: 0.1
dmi.sys.vendor: Acer

apport information

tags: added: apport-collected precise
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

grege89 (grege89) wrote : Lspci.txt

apport information

grege89 (grege89) wrote : Lsusb.txt

apport information

apport information

apport information

apport information

apport information

apport information

grege89 (grege89) wrote : RfKill.txt

apport information

grege89 (grege89) wrote : UdevDb.txt

apport information

apport information

apport information

Brad Figg (brad-figg) on 2012-06-09
Changed in linux (Ubuntu):
status: New → Confirmed
grege89 (grege89) wrote :

I'd like to add also that, when this problem first appeared, I attempted a fresh re-install, first from DVD, then from USB flash drive, and the problem persisted. I can attempt to install 12.10 daily build and check if problem is resolved if that would be helpful.

grege89 (grege89) wrote :

Update: installed daily x64 daily 12.10 build, but issues with shutdown and reboot persisted. However, after downgrading to 32-bit version of 12.04, all issues appear to be resolved. I'm satisfied with this arrangement, although I'm still puzzled as to why the 64-bit install was so error prone, despite my laptop's architecture supporting it.

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.5kernel[0] (Not a kernel in the daily directory) and install both the linux-image and linux-image-extra .deb packages.

Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.5-rc2-quantal/

Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: needs-upstream-testing
tags: added: quantal
Changed in linux (Ubuntu):
status: Confirmed → Incomplete

I have the same exact problem, same computer model.
I believe it's ACPI related.

Linux 3.2.0-29-generic #46-Ubuntu SMP Fri Jul 27 17:03:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Description: Ubuntu 12.04.1 LTS
Release: 12.04

I just installed:
linux-image-3.6.0-030600rc3-generic_3.6.0-030600rc3.201208221735_amd64.deb
and also
linux-image-extra-3.6.0-030600rc3-generic_3.6.0-030600rc3.201208221735_amd64.deb

then rebooted and tested and I still have the same problem.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report[0]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

[0] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Changed in linux (Ubuntu):
status: Confirmed → Triaged
Citro87 (citro87) wrote :

Seems that the problem is related to the uefi booting

http://ubuntuforums.org/showthread.php?t=1974392

hope this helps.

iceman75 (javier-orejarena) wrote :

this bugs affects me as well. My laptop is an Acer 4560-sb604. The BIOS is Phoenix (Tiano?) booting in UEFI mode. The notebook was working perfectly using BIOS mode (even dual booting).

iceman75 (javier-orejarena) wrote :

I did report (maybe incorrectly) the same bug in https://bugs.launchpad.net/bugs/1048089 including fwts results log.

Rookcifer (rookcifer) wrote :

Affects me as well, except my machine is not a laptop, but a Desktop machine I built. I thought I might have a hardware problem at first, but after seeing this bug report, it appears I might not.

Essentially, I get the same problem. If I log out of Ubuntu and go to the splash screen and then try to shut the machine down, nothing happens. It just sits there indefinitely. I have to manually power the machine off.

Clara (claracagigal) wrote :

I am experiencing the same problem in a hp compaq 6720s laptop, ubuntu 12.04 dual boot with win vista:

When laptop on ac adapter, I can shutdown the computer from menu or command line (sudo poweroff ) without any problem,
but when on battery, the laptop doesn't shutdown, it remains in splash screen showing ubuntu logo and dots going from red to white forever, neither trying from command line. Laptop doesn't respond to any combination key : Alt+SysRq RESUIB or CTRL+alt+del. I have to poweroff the computer pressing the turn on/off button

ralphl (lachenmaier) wrote :

I have the same problem of the laptop not being able to do a shutdown, restart, suspend, or hibernate. Computer is Compaq Presario 2100, 0S is either Ubuntu 12.04.x or Kubuntu 12.04.x. I was able to get around the problem by installing Xubuntu 12.04.x. With Xubuntu all the shutdown functions worked right out of the box (well I had to install hibernate before it would work). My computer is supposed to support PAE, but the only difference between Ubuntu/Kubuntu and Xubuntu is that at present Xubuntu uses the non-PAE kernel. So this is definitely a bug that needs to be fixed.

psypher (psypher246) wrote :

I have this issue on 13.04 on a Dell XPS L701X. Have to hard shutdown the PC and then the next time it boots up it has to do a disk check on a healthy drive. Does it everytime I start up and I am worried that there is going to be DATA corruption soon.

psypher (psypher246) wrote :

Forgot to mention thgis only started happening after I installed 13.04. No issues with this hardware on 12.04 or 12.10

grege89, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please just make a comment to this.

Also, could you please test the latest upstream kernel available (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.12

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: latest-bios-v1.15 regression-potential
Changed in linux (Ubuntu):
status: Triaged → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers