omap fails to boot with oops in qantal alpha1

Bug #1010024 reported by Oliver Grawert on 2012-06-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Paolo Pisati
Quantal
High
Paolo Pisati

Bug Description

[ 10.249237] Freeing init memory: 256K
Loading, please wait...
[ 10.335052] usb 1-2.1: new high-speed USB device number 3 using ehci-omap
[ 10.376770] udevd[86]: starting version 175
[ 10.467651] mmc0: host does not support reading read-only switch. assuming write-enable.
[ 10.493225] mmc0: new high speed SDHC card at address b368
[ 10.513519] mmcblk0: mmc0:b368 3.72 GiB
[ 10.526672] mmcblk0: p1 p2
[ 10.545928] usb 1-2.4: new low-speed USB device number 4 using ehci-omap
[ 10.756805] usb 1-2.5: new low-speed USB device number 5 using ehci-omap
[ 11.602661] input: PS/2+USB Mouse as /devices/platform/usbhs_omap/ehci-omap.0/usb1/1-2/1-2.4/1-2.4:1.0/input/input0
[ 11.616149] generic-usb 0003:04F3:0210.0001: input,hidraw0: USB HID v1.11 Mouse [PS/2+USB Mouse] on usb-ehci-omap.0-2.4/input0
[ 11.637756] input: HID 0430:0005 as /devices/platform/usbhs_omap/ehci-omap.0/usb1/1-2/1-2.5/1-2.5:1.0/input/input1
[ 11.685913] generic-usb 0003:0430:0005.0002: input,hidraw1: USB HID v1.00 Keyboard [HID 0430:0005] on usb-ehci-omap.0-2.5/input0
[ 11.707916] usbcore: registered new interface driver usbhid
[ 11.713897] usbhid: USB HID core driver
[ 13.103332] Unable to handle kernel paging request at virtual address 5f5fd9c8
[ 13.110870] pgd = c0004000
[ 13.113677] [5f5fd9c8] *pgd=00000000
[ 13.117401] Internal error: Oops: 805 [#1] ARM
[ 13.122039] Modules linked in: usbhid hid
[ 13.126220] CPU: 0 Tainted: G W (3.4.0-5-omap #11-Ubuntu)
[ 13.133148] PC is at vma_prio_tree_remove+0xf0/0x104
[ 13.138305] LR is at __remove_shared_vm_struct+0x5c/0x84
[ 13.143829] pc : [<c00da2fc>] lr : [<c00e4a00>] psr: 600f0093
[ 13.143859] sp : df6d5e60 ip : ffffffaf fp : df6d4000
[ 13.155822] r10: 00000000 r9 : df6d4000 r8 : df6d5ec8
[ 13.161254] r7 : df126480 r6 : df1264a4 r5 : dd07bd68 r4 : 00000000
[ 13.168060] r3 : dd07bd68 r2 : dd07bd90 r1 : 5f5fd9c8 r0 : df5d1238
[ 13.174865] Flags: nZCv IRQs off FIQs on Mode SVC_32 ISA ARM Segment user
[ 13.182403] Control: 10c5387d Table: 9f620019 DAC: 00000015
[ 13.188385] Process console_setup (pid: 215, stack limit = 0xdf6d42e8)
[ 13.195220] Stack: (0xdf6d5e60 to 0xdf6d6000)
[ 13.199768] 5e60: 00000000 dd07bd68 df1264a4 c00e4a00 dd16b540 c00e4c1c dd07bda0 dd07bd68
[ 13.208282] 5e80: dd07b948 b6e35000 00001000 c00e0154 b6e35000 00000000 dd082780 00000a06
[ 13.216796] 5ea0: 00000000 dd07b840 dd082780 df6d5ee8 00000000 c00e6c84 df6d5ec4 00000000
[ 13.225341] 5ec0: 00000094 00000053 dd082780 00000001 00000000 00000000 00000000 00000094
[ 13.233856] 5ee0: 00000400 df5cf000 0016e35f 0000081f c04c4e38 c0722848 b6f36550 df6d5fb0
[ 13.242401] 5f00: 00009ac6 bea9d4ec dd082780 00000000 00000000 dd0827b4 c0013628 c00362b0
[ 13.250946] 5f20: 00000000 dd082780 dd0b1900 c003b9b8 bea9dd64 dd0b1900 000000f8 00000000
[ 13.259460] 5f40: bea9dd64 dd0b1900 000000f8 c003baf0 df6d4000 00000000 df6d4000 00000001
[ 13.268005] 5f60: 00000003 00000005 00000000 00000000 bea9d69c 00000000 bea9dd64 0000003c
[ 13.276519] 5f80: 000000f8 c0013628 df6d4000 00000000 00000000 c003c348 0006fe7e c003c3b8
[ 13.285064] 5fa0: 00000000 c0013460 0006fe7e bea9dd64 00000000 0006fe6a b6f30820 00000000
[ 13.293579] 5fc0: 0006fe7e bea9dd64 0000003c 000000f8 0004242c 00000000 b6f36000 00000000
[ 13.302124] 5fe0: 000000f8 bea9d7ac b6ea3223 b6e4c1d6 800f0030 00000000 00000000 00000000
[ 13.310668] [<c00da2fc>] (vma_prio_tree_remove+0xf0/0x104) from [<c00e4a00>] (__remove_shared_vm_struct+0x5c/0x84)
[ 13.321472] [<c00e4a00>] (__remove_shared_vm_struct+0x5c/0x84) from [<c00e4c1c>] (unlink_file_vma+0x34/0x40)
[ 13.331695] [<c00e4c1c>] (unlink_file_vma+0x34/0x40) from [<c00e0154>] (free_pgtables+0x80/0xc8)
[ 13.340850] [<c00e0154>] (free_pgtables+0x80/0xc8) from [<c00e6c84>] (exit_mmap+0x114/0x1d8)
[ 13.349670] [<c00e6c84>] (exit_mmap+0x114/0x1d8) from [<c00362b0>] (mmput+0x3c/0xdc)
[ 13.357757] [<c00362b0>] (mmput+0x3c/0xdc) from [<c003b9b8>] (exit_mm+0xec/0x104)
[ 13.365539] [<c003b9b8>] (exit_mm+0xec/0x104) from [<c003baf0>] (do_exit+0x120/0x730)
[ 13.373718] [<c003baf0>] (do_exit+0x120/0x730) from [<c003c348>] (do_group_exit+0x3c/0x9c)
[ 13.382324] [<c003c348>] (do_group_exit+0x3c/0x9c) from [<c003c3b8>] (__wake_up_parent+0x0/0x18)
[ 13.391479] Code: e590102c e2802028 e5900028 e5801004 (e5810000)
[ 13.398468] ---[ end trace 2e9de25caeeab16e ]---
[ 13.403289] Fixing recursive fault but reboot is needed!

Oliver Grawert (ogra) on 2012-06-07
Changed in linux (Ubuntu):
importance: Undecided → High
Changed in linux (Ubuntu Quantal):
milestone: none → quantal-alpha-2
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1010024

tags: added: iso-testing

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1010024

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: quantal
Changed in linux (Ubuntu Quantal):
milestone: quantal-alpha-2 → quantal-alpha-3
Oliver Grawert (ogra) wrote :

fixed in linux 3.5.0-2.2

Changed in linux (Ubuntu Quantal):
assignee: nobody → Paolo Pisati (p-pisati)
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers