Ext3 filesystems converted to ext4 can get erroneously reported as containing errors

Bug #1010022 reported by Theodore Ts'o on 2012-06-07
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Precise
Medium
Luis Henriques
Quantal
Medium
Unassigned

Bug Description

== Precise SRU Justification ==

From Ted Ts'o comment on LP bug:

"Given that many LTS users may have large RAID arrays who might not
want to copy data to do the backup / reformat / restore dance, and if
they were using ext3 and want to upgrade to ext4, they would get hit
by this, it would be great if you could get a kernel with this bug fix
pushed out with the next kernel release."

== Fix ==

The fix has been submitted upstreams here:

http://thread.gmane.org/gmane.comp.file-systems.ext4/32720

It has also been forwarded to stable.

== Impact ==

Users upgrading from ext3 to ext4 on kernels 3.2 and above will be hit
by this bug.

== Test Case ==

The following allows to trigger the bug:

mke2fs -q -t ext4 -O ^flex_bg /dev/vdd 5g
mount -t ext4 /dev/vdd /mnt
fallocate -l 4600m /mnt/test

==

The following patch is versus 3.5, and the patch will have to be modified for 3.2. However a user has reported this problem with the 3.2 upstream kernel, so I'm sure it's in precise. See the commit description for a reproduction. Could someone running precise try running the repro and confirm you're seeing it with the precise kernel?

    mke2fs -q -t ext4 -O ^flex_bg /dev/vdd 5g
    mount -t ext4 /dev/vdd /mnt
    fallocate -l 4600m /mnt/test

For the bug fix and any follow-on discussion, please see:

http://thread.gmane.org/gmane.comp.file-systems.ext4/32720

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1010022

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Theodore Ts'o (tytso) on 2012-06-07
Changed in linux (Ubuntu):
status: Incomplete → New
Brad Figg (brad-figg) on 2012-06-07
Changed in linux (Ubuntu):
status: New → Incomplete
Luis Henriques (henrix) wrote :

I've just done a quick test on a precise kernel (3.2.0-25.40) and I confirm I'm getting the mentioned errors:

[ 311.413827] EXT4-fs error (device loop0): ext4_mb_generate_buddy:739: group 2, 32254 clusters in bitmap, 32258 in gd

I'll build a kernel with the patch applied and re-test it.

tags: added: bot-stop-nagging kernel-da-key precise
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Triaged
Luis Henriques (henrix) wrote :

Just rebooted the same kernel with your patch applied and I can't reproduce the errors anymore.

(btw, the patch applies cleanly on precise kernel, which is currently based on stable 3.2.18).

Theodore Ts'o (tytso) wrote :

Ah, cool, good to know. I didn't think it would apply cleanly; but apparently either 3.2.18 or the Precise kernel pulled in enough of the patches after 3.2 was released so it would apply cleanly.

Given that many LTS users may have large RAID arrays who might not want to copy data to do the backup / reformat / restore dance, and if they were using ext3 and want to upgrade to ext4, they would get hit by this, it would be great if you could get a kernel with this bug fix pushed out with the next kernel release.

Thanks!!

Changed in linux (Ubuntu Precise):
importance: Undecided → Medium
Luis Henriques (henrix) on 2012-06-07
Changed in linux (Ubuntu Precise):
status: New → Triaged
description: updated
Brad Figg (brad-figg) on 2012-06-07
Changed in linux (Ubuntu Precise):
status: Triaged → Fix Committed
Tim Gardner (timg-tpi) on 2012-06-12
Changed in linux (Ubuntu Quantal):
status: Triaged → Fix Released
Luis Henriques (henrix) wrote :

I've booted the precise kernel 3.2.0-26.41 and I checked the error is not present anymore. Tagging as verified.

tags: added: verification-done-precise
Changed in linux (Ubuntu Precise):
assignee: nobody → Luis Henriques (henrix)
Launchpad Janitor (janitor) wrote :
Download full text (13.2 KiB)

This bug was fixed in the package linux - 3.2.0-26.41

---------------
linux (3.2.0-26.41) precise-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1012057

  [ Andy Whitcroft ]

  * [Config] fix up postinst to ensure we know which error is which
    - LP: #1002388
  * [Config] highbank -- commonise filesystems
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise subsystems
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise network protocols
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise input drivers
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise CRYPTO options
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise HID options
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise sensors options
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise EXPORTFS/FHANDLE
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise CONFIG_CRYPTO_LZO
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise ENCRYPTED_KEYS
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise CONFIG_ATALK
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise INET/INET6
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise NLS
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise BLK/CHR
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise PHY settings
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise CRC settings
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise BINFMT settings
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise DM settings
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise RTC_DRV settings
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise KEYBOARD/MOUSE settings
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise USB settings
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise GPIO settings
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise I2C settings
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise numerous subsystem selectors
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise A-C modules missmatches
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise D-F modules missmatches
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise G-I modules missmatches
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise J-L modules missmatches
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise M modules missmatches
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise N-P modules missmatches
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise Q-R modules missmatches
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise S modules missmatches
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise T modules missmatches
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise U-Z modules missmatches
    - LP: #1000831, #1010463

  [ Herton Ronaldo Krzesinski ]

  * SAUCE: fix get_gate_vma call in i386 NX emulation code
    - LP: #1009200

  [ Ike Panhc ]

  * [Config] add...

Changed in linux (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers