Wacom Intuos5 support

Bug #1009435 reported by Timo Aaltonen on 2012-06-06
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Timo Aaltonen
Quantal
Undecided
Unassigned

Bug Description

The kernel on 12.04 doesn't currently support Wacom Intuos5 tablets. Adding the following patches from the mainline kernel would fix that:

- these patches lay the groundwork for Intuos5
 from 3.3
8b4a0c1fe3b03c0cfe829413481d69c2e6fd844c Input: wacom - use BTN_TOOL_FINGER to indicate touch device type
31175a8348af76aea2f557857c90467d13632dc3 Input: wacom - use switch statement for wacom_tpc_irq()
 from 3.4:
3aac0ef10bf5c76ba4262cfd9b044a6c067d5aae Input: wacom - isolate input registration
d3825d51c3eddb8a3c7d1281f27181aff6db19b8 Input: wacom - wireless monitor framework
16bf288c4be67b68c3fcb6561ff145702cb7bd22 Input: wacom - create inputs when wireless connect
a1d552cc15b0be9124ccba593f99f59c4ec1e153 Input: wacom - wireless battery status
f182394033d639679264d61e6dca62761e659ff7 Input: wacom - check for allocation failure in probe()

- and finally the actual Intuos5 support (from v3.5-rc1)
9fee619505bdb202c9f54b58ec996884160cdbf2 Input: wacom - add basic Intuos5 support
f860e581fd473250c6dcbd3e13d576b6197e4694 Input: wacom - add Intuos5 Touch Ring/ExpressKey support
9b5b95dd516a13d53ecf9217672d2116f05097bc Input: wacom - add Intuos5 Touch Ring LED support
ae584ca473289377dd7fd8c61439db4bfab5489a Input: wacom - add Intuos5 multitouch sensor support

I've tested the patches on top of 3.2-25.40 and they work fine, and my Intuos4 continues to work as well. The Intuos5 support patches missed the 3.4 merge window due to a human error, so they're actually a bit older and have seen more testing than the kernel version would suggest (linuxwacom provides a kernel driver "snapshot" for users to install a bit like our dkms packages are).

The quantal kernel is missing support as well, but 3.5-rc1 is already being worked on, so best to just concentrate on precise here.

Timo Aaltonen (tjaalton) wrote :

Marking quantal as 'fix committed' since 3.5-rc1 will hit it soon enough.

Changed in linux (Ubuntu):
status: New → Fix Committed
Timo Aaltonen (tjaalton) on 2012-06-06
description: updated
Changed in linux (Ubuntu Precise):
importance: Undecided → Medium
status: New → Triaged
Timo Aaltonen (tjaalton) on 2012-06-13
Changed in linux (Ubuntu Precise):
assignee: nobody → Timo Aaltonen (tjaalton)
importance: Medium → Undecided
status: Triaged → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux (Ubuntu Precise):
status: New → Confirmed
Tim Gardner (timg-tpi) on 2012-06-15
Changed in linux (Ubuntu Precise):
status: Confirmed → Fix Committed
Changed in linux (Ubuntu Quantal):
status: Fix Committed → Fix Released
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel for Precise in -proposed solves the problem (3.2.0-27.43). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-precise' to 'verification-done-precise'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-precise
Timo Aaltonen (tjaalton) on 2012-07-11
tags: added: verification-done-precise
removed: verification-needed-precise
Launchpad Janitor (janitor) wrote :
Download full text (13.6 KiB)

This bug was fixed in the package linux - 3.2.0-27.43

---------------
linux (3.2.0-27.43) precise-proposed; urgency=low

  [ Andy Whitcroft ]

  * No change upload to fix .ddeb generation in the PPA.

  [ Luis Henriques ]

  * Release Tracking Bug
    - LP: #1020016

linux (3.2.0-27.42) precise-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1020016

  [ Chris J Arges ]

  * PACKAGING: add .gnu_debuglink sections to .ko files
    - LP: #669641

  [ Ike Panhc ]

  * [Config] Updateconfigs
    - LP: #1008345

  [ Luis Henriques ]

  * SAUCE: (upstreamed) [media] ene_ir: Fix driver initialisation
    - LP: #1014800
  * SAUCE: ocfs2: Fix NULL pointer dereferrence in
    __ocfs2_change_file_space
    - LP: #1006012

  [ Rob Herring ]

  * SAUCE: net: calxedaxgmac: enable rx cut-thru mode
    - LP: #1008345
  * SAUCE: EDAC: Add support for the highbank platform memory
    - LP: #1008345
  * SAUCE: EDAC: add support for highbank platform L2 cache ecc
    - LP: #1008345

  [ Seth Forshee ]

  * (pre-stable): bcma: add ext PA workaround for BCM4331 and BCM43431
    - LP: #925577

  [ Takashi Iwai ]

  * SAUCE: ALSA: hda - Fix power-map regression for HP dv6 & co
    - LP: #1013183

  [ Tim Gardner ]

  * [Config] Enable CONFIG_CGROUPS for highbank
    - LP: #1014692

  [ Upstream Kernel Changes ]

  * Revert "net: maintain namespace isolation between vlan and real device"
    - LP: #1013723
  * x86/amd: Re-enable CPU topology extensions in case BIOS has disabled it
    - LP: #1009087
  * hwmon: (k10temp) Add support for AMD Trinity CPUs
    - LP: #1009086
  * hwmon: (fam15h_power) Increase output resolution
    - LP: #1009086
  * Input: wacom - use BTN_TOOL_FINGER to indicate touch device type
    - LP: #1009435
  * Input: wacom - use switch statement for wacom_tpc_irq()
    - LP: #1009435
  * Input: wacom - isolate input registration
    - LP: #1009435
  * Input: wacom - wireless monitor framework
    - LP: #1009435
  * Input: wacom - create inputs when wireless connect
    - LP: #1009435
  * Input: wacom - wireless battery status
    - LP: #1009435
  * Input: wacom - check for allocation failure in probe()
    - LP: #1009435
  * Input: wacom - add basic Intuos5 support
    - LP: #1009435
  * Input: wacom - add Intuos5 Touch Ring/ExpressKey support
    - LP: #1009435
  * Input: wacom - add Intuos5 Touch Ring LED support
    - LP: #1009435
  * Input: wacom - add Intuos5 multitouch sensor support
    - LP: #1009435
  * iommu/amd: Add workaround for event log erratum
    - LP: #1013723
  * MIPS: BCM63XX: Add missing include for bcm63xx_gpio.h
    - LP: #1013723
  * cifs: Include backup intent search flags during searches {try #2)
    - LP: #1013723
  * sunrpc: fix loss of task->tk_status after rpc_delay call in
    xprt_alloc_slot
    - LP: #1013723
  * exofs: Fix CRASH on very early IO errors.
    - LP: #1013723
  * cifs: fix oops while traversing open file list (try #4)
    - LP: #1013723
  * Fix dm-multipath starvation when scsi host is busy
    - LP: #1013723
  * ixp4xx: fix compilation by adding gpiolib support
    - LP: #1013723
  * drm/i915: properly handle interlaced bit for sdvo dtd conversion
    - LP: #1013723
...

Changed in linux (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers