Ubuntu

can't wake up from suspend

Reported by Tim Chen on 2012-06-05
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Jesse Sung
Precise
Medium
Jesse Sung
Quantal
Medium
Jesse Sung

Bug Description

system: Asus ET2012E (201201 10354)
The failure rate is about 1/2.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-23-generic 3.2.0-23.36
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu5
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: ALC887-VD Analog [ALC887-VD Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 1513 F.... pulseaudio
CRDA:
 country TW:
  (2402 - 2472 @ 40), (3, 27)
  (5270 - 5330 @ 40), (3, 17), DFS
  (5735 - 5815 @ 40), (3, 30)
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xfe600000 irq 56'
   Mixer name : 'Intel CougarPoint HDMI'
   Components : 'HDA:10ec0887,10438503,00100302 HDA:80862805,80862805,00100000'
   Controls : 27
   Simple ctrls : 10
Date: Tue Jun 5 03:00:29 2012
HibernationDevice: RESUME=UUID=cf5c780e-8c99-459c-af3d-f6f7aa3e2082
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MachineType: ASUSTeK Computer INC. ET2012E
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-23-generic root=UUID=03c3781e-6fb3-4f31-95ed-a476afe87ae2 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-23-generic N/A
 linux-backports-modules-3.2.0-23-generic N/A
 linux-firmware 1.79
SourcePackage: linux
StagingDrivers: mei
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/15/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 9837
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: ET2012E
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr9837:bd02/15/2012:svnASUSTeKComputerINC.:pnET2012E:pvr9837:rvnASUSTeKComputerINC.:rnET2012E:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: ET2012E
dmi.product.version: 9837
dmi.sys.vendor: ASUSTeK Computer INC.

Tim Chen (ctf) wrote :
Brad Figg (brad-figg) on 2012-06-05
Changed in linux (Ubuntu):
status: New → Confirmed
Changed in linux (Ubuntu):
assignee: Anthony Wong (anthonywong) → Jesse Sung (wenchien)
importance: Undecided → Low
importance: Low → Medium
Ming Lei (tom-leiming) wrote :

Considered that the same xHCI controller(1b21:1042) is used in bug

     https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1002697

also similar phenomenon.

So could you test the image below which does fix the bug of 1002697?

      http://kernel.ubuntu.com/~ming/bugs/1002697/

Thanks,

Tim Chen (ctf) wrote :

bug remains with Ming Lei's image.

description: updated
Ming Lei (tom-leiming) wrote :

Tim chen

Could you please test the kernel image in the below link which includes
patch to address the suspend and resume problem?

  http://kernel.ubuntu.com/~ming/bugs/1002697/v1

You also can see the applied patch below suggested by upstream kernel guys.

   http://kernel.ubuntu.com/~ming/bugs/1002697/v1/xhci_asm_pm_timeout.patch

This one fixes the resume problem too as verified already:
   https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1002697/comments/66

Thanks,

Tim Chen (ctf) wrote :

@Ming Lei:
Bug remains with the v1 image you gave, I tried 3 times, the first two are ok, system can't wake up at the third try.

@Tim Chen,

Sounds not bad, at least it can work for two pm cycle, :-)

Is there any improvement against previous official precise release?
Or just same with before(still can work for several times)?

Maybe you should pass 'no_console_suspend' into kernel and try
to capture some log during wakeup to see what is happening...

Ara Pulido (apulido) wrote :

Marking as Incomplete, as they are waiting on Tim's reply

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Ara Pulido (apulido) on 2012-06-19
tags: added: blocks-hwcert-enablement
tags: added: rls-mgr-p-tracking rls-q-incoming
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux (Ubuntu Precise):
status: New → Confirmed
Tim Chen (ctf) wrote :
Tim Chen (ctf) wrote :

The pm-suspend.log captured while the suspend failed or passed.(Seems the system wake up successfully?)
I tried the kernel option: no_console_suspend, but the system is frozen. I can't get anything from console.

Changed in linux (Ubuntu Precise):
importance: Undecided → Medium
Ara Pulido (apulido) on 2012-07-24
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
James M. Leddy (jm-leddy) wrote :

We have had some failures with ATI graphics before, but not Nvidia graphics.

Anthony Wong (anthonywong) wrote :

From lspci and ProcModules.txt, it doesn't look like this model uses AMD or NVIDIA graphics.

Tim Chen, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the kernel in the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested and remove the tag:
needs-upstream-testing

This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the text:
needs-upstream-testing

If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested.

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested.

If you are unable to test the mainline kernel, please comment as to why specifically you were unable to test it and add the following tags:
kernel-unable-to-test-upstream
kernel-unable-to-test-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested.

Please let us know your results. Thank you for your understanding.

Helpful Bug Reporting Links:
https://help.ubuntu.com/community/ReportingBugs#Bug_Reporting_Etiquette
https://help.ubuntu.com/community/ReportingBugs#A3._Make_sure_the_bug_hasn.27t_already_been_reported
https://help.ubuntu.com/community/ReportingBugs#Adding_Apport_Debug_Information_to_an_Existing_Launchpad_Bug
https://help.ubuntu.com/community/ReportingBugs#Adding_Additional_Attachments_to_an_Existing_Launchpad_Bug

tags: added: needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Jesse Sung (wenchien) wrote :

72 suspend/resume cycles passed without any problem after rc6 disabled.

Tim Chen (ctf) on 2012-08-09
tags: added: quantal
Jesse Sung (wenchien) wrote :

Please try http://people.canonical.com/~jesse/lp1008867/ and see if this issue still exists.
Thank you.

Changed in linux (Ubuntu Quantal):
status: Incomplete → In Progress
Jesse Sung (wenchien) wrote :

Thanks for ctf's help for testing. The kernel in #15 works fine.
I proposed a fix at freedesktop bugzilla
https://bugs.freedesktop.org/show_bug.cgi?id=50545
and still wait for upstream developers' comment.

Changed in linux (Ubuntu Quantal):
milestone: none → ubuntu-12.10-beta-2
tags: removed: rls-q-incoming
Jesse Sung (wenchien) wrote :

Although I proposed to quirk these models, upstream developers would like to find out the root cause instead of just disabling rc6. Since https://bugs.freedesktop.org/show_bug.cgi?id=50545 is originally created for #1002170 , I create another entry for this issue, which can be found at https://bugs.freedesktop.org/show_bug.cgi?id=54739

Jesse Sung (wenchien) on 2012-09-17
Changed in linux (Ubuntu Quantal):
status: In Progress → Confirmed
Jesse Sung (wenchien) on 2012-09-25
Changed in linux (Ubuntu Precise):
assignee: nobody → Jesse Sung (wenchien)
Tim Gardner (timg-tpi) on 2012-09-25
Changed in linux (Ubuntu Quantal):
status: Confirmed → Fix Committed
Changed in linux (Ubuntu Precise):
status: Confirmed → Fix Committed
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel for Precise in -proposed solves the problem (3.2.0-32.51). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-precise' to 'verification-done-precise'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-precise
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 3.5.0-16.24

---------------
linux (3.5.0-16.24) quantal-proposed; urgency=low

  [ Andy Whitcroft ]

  * SAUCE: ata_piix: add a disable_driver option
    - LP: #994870

  [ Christian König ]

  * (pre-stable) drm/radeon: make 64bit fences more robust v3 (3.5 stable)
    - LP: #1029582

  [ David Henningsson ]

  * SAUCE: ALSA: hda - use both input paths on Conexant auto parser
    - LP: #1037642
  * SAUCE: ALSA: hda - fix control names for multiple speaker out on
    IDT/STAC
    - LP: #1046734

  [ Herton Ronaldo Krzesinski ]

  * SAUCE: ALSA: hda/via - don't report presence on HPs with no presence
    support
    - LP: #1052499
  * SAUCE: ext4: fix crash when accessing /proc/mounts concurrently
    - LP: #1053019
  * SAUCE: ALSA: hda/realtek - Fix detection of ALC271X codec
    - LP: #1006690

  [ Kyle Fazzari ]

  * SAUCE: input: Cypress PS/2 Trackpad fix disabling tap-to-click
    - LP: #1048816

  [ Leann Ogasawara ]

  * [Config] Disable CONFIG_DRM_AST
    - LP: #1053290

  [ Stefan Bader ]

  * [Config] Disable the Cirrus QEMU drm driver
    - LP: #1038055

  [ Upstream Kernel Changes ]

  * Revert "KVM: VMX: Fix KVM_SET_SREGS with big real mode segments"
    - LP: #1045027
  * x86, efi: Handover Protocol
  * drm/i915: HDMI - Clear Audio Enable bit for Hot Plug
    - LP: #1056729
  * UBUNTU SAUCE: apparmor: fix IRQ stack overflow
    - LP: #1056078
  * drm/nouveau: fix booting with plymouth + dumb support
    - LP: #1043518
  * ALSA: hda - Add DeviceID for Haswell HDA
    - LP: #1057698
  * ALSA: hda - add Haswell HDMI codec id
    - LP: #1057698
  * ALSA: hda - Fix driver type of Haswell controller to AZX_DRIVER_SCH
    - LP: #1057698
  * ALSA: hda_intel: Add Device IDs for Intel Lynx Point-LP PCH
    - LP: #1011438, #1057698

  [ Wang Xingchao ]

  * SAUCE: ALSA: hda - Add another pci id for Haswell board
    - LP: #1057698

  [ Wen-chien Jesse Sung ]

  * SAUCE: drm/i915: Explicitly disable RC6 for certain models
    - LP: #1002170, #1008867
 -- Leann Ogasawara <email address hidden> Thu, 27 Sep 2012 13:55:52 -0700

Changed in linux (Ubuntu Quantal):
status: Fix Committed → Fix Released
Tim Chen (ctf) wrote :

Bug fixed on Asus ET2012E with kernel 3.5.0-16.25

Tim Chen (ctf) wrote :

Bug fixed on Precise with kernel 3.2.0-32.51

Luis Henriques (henrix) wrote :

As per comment #21, I'm tagging this bug as verified. Thank you Tim.

tags: added: verification-done-precise
removed: verification-needed-precise

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :
Download full text (18.4 KiB)

This bug was fixed in the package linux - 3.2.0-32.51

---------------
linux (3.2.0-32.51) precise-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1056036

  [ Keng-Yu Lin ]

  * SAUCE: Intel xhci: Only switch the switchable ports
    - LP: #1034814

  [ Kyle Fazzari ]

  * SAUCE: input: Cypress PS/2 Trackpad fix disabling tap-to-click
    - LP: #1048816

  [ Seth Forshee ]

  * SAUCE: Input: synaptics - Adjust threshold for treating position values
    as negative
    - LP: #1046512

  [ Stefan Bader ]

  * Revert "SAUCE: Force xsave off on older Xen hypervisors"
    - LP: #1044550

  [ Upstream Kernel Changes ]

  * Revert "HID: wiimote: fix invalid power_supply_powers call"
    - LP: #1048605
  * Revert "drm/radeon: fix bo creation retry path"
    - LP: #1049899
  * HID: wiimote: fix invalid power_supply_powers call
    - LP: #1048605
  * HID: add ASUS AIO keyboard model AK1D
    - LP: #1027789, #1049899
  * nfs: tear down caches in nfs_init_writepagecache when allocation fails
    - LP: #1049899
  * NFS: Use kcalloc() when allocating arrays
    - LP: #1049899
  * NFSv4.1 fix page number calculation bug for filelayout decode buffers
    - LP: #1049899
  * fix page number calculation bug for block layout decode buffer
    - LP: #1049899
  * pnfs: defer release of pages in layoutget
    - LP: #1049899
  * ext4: avoid kmemcheck complaint from reading uninitialized memory
    - LP: #1049899
  * fuse: verify all ioctl retry iov elements
    - LP: #1049899
  * Bluetooth: Fix legacy pairing with some devices
    - LP: #1049899
  * xhci: Increase reset timeout for Renesas 720201 host.
    - LP: #1049899
  * xhci: Add Etron XHCI_TRUST_TX_LENGTH quirk.
    - LP: #1049899
  * USB: ftdi_sio: Add VID/PID for Kondo Serial USB
    - LP: #1049899
  * USB: option: Add Vodafone/Huawei K5005 support
    - LP: #1049899
  * USB: add USB_VENDOR_AND_INTERFACE_INFO() macro
    - LP: #1049899
  * USB: support the new interfaces of Huawei Data Card devices in option
    driver
    - LP: #1049899
  * usb: serial: mos7840: Fixup mos7840_chars_in_buffer()
    - LP: #1049899
  * usb: gadget: u_ether: fix kworker 100% CPU issue with still used
    interfaces in eth_stop
    - LP: #1049899
  * ARM: 7483/1: vfp: only advertise VFPv4 in hwcaps if CONFIG_VFPv3 is
    enabled
    - LP: #1049899
  * ARM: 7488/1: mm: use 5 bits for swapfile type encoding
    - LP: #1049899
  * ARM: 7489/1: errata: fix workaround for erratum #720789 on UP systems
    - LP: #1049899
  * drm/i915: ignore eDP bpc settings from vbt
    - LP: #1049899
  * ALSA: hda - fix Copyright debug message
    - LP: #1049899
  * sched: fix divide by zero at {thread_group,task}_times
    - LP: #1049899
  * ath9k: fix decrypt_error initialization in ath_rx_tasklet()
    - LP: #1049899
  * drm/nvd0/disp: mask off high 16 bit of negative cursor x-coordinate
    - LP: #1049899
  * drm/i915: reorder edp disabling to fix ivb MacBook Air
    - LP: #1049899
  * audit: don't free_chunk() after fsnotify_add_mark()
    - LP: #1049899
  * audit: fix refcounting in audit-tree
    - LP: #1049899
  * vfs: canonicalize create mode in build_open_flags()
    - LP: #1049899
  * PCI: EHCI: Fix crash d...

Changed in linux (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.