Precise: armhf should not be skipabi or skipmodules

Bug #1006913 reported by Tim Gardner on 2012-05-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Tim Gardner
Precise
Medium
Tim Gardner
Quantal
Medium
Tim Gardner

Bug Description

ABI and modules changes are undetectable on armhf

Tim Gardner (timg-tpi) on 2012-05-31
Changed in linux (Ubuntu Quantal):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → Fix Committed
Changed in linux (Ubuntu Precise):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
Changed in linux (Ubuntu Precise):
importance: Undecided → Medium
Changed in linux (Ubuntu Quantal):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :
Download full text (4.5 KiB)

This bug was fixed in the package linux - 3.4.0-4.9

---------------
linux (3.4.0-4.9) quantal; urgency=low

  [ Andy Whitcroft ]

  * [Config] fix config split to avoid the shared config
  * [Config] updateconfigs following split config fix
  * [Config] linux-image-extras needs full postinst
  * [Config] CONFIG_BLK_DEV_NVME commonise across architectures
  * [Config] CONFIG_HP_WATCHDOG enable as module
  * [Config] CONFIG_PDC_ADMA is not boot essential
  * [Config] CONFIG_XEN_ACPI_PROCESSOR should be enabled on x86
  * [Config] CONFIG_VT6655/CONFIG_VT6656=m
  * [Config] CONFIG_TRANZPORT=m commonise
  * [Config] CONFIG_R3964=m commonise
  * [Config] CONFIG_SCSI_DH=m commonise
  * [Config] CONFIG_SCSI_IBMVSCSIS=m commonise
  * [Config] CONFIG_AMD_PHY=y phys are not autoloadable
  * [Config] CONFIG_SCSI_QLA_ISCSI=m commonise
  * [Config] CONFIG_SCSI_SPI_ATTR=m commonise
  * [Config] CONFIG_USB_SN9C102 is deprecated disable
  * [Config] CONFIG_USB_SI470X=m commonise
  * [Config] CONFIG_USB_ET61X251=m commonise
  * [Config] CONFIG_RTS_PSTOR=m commonise
  * [Config] CONFIG_SCANLOG=m commonise
  * [Config] CONFIG_SCSI_SYM53C8XX_2=m commonise
  * [Config] CONFIG_SM_FTL=m commonise
  * [Config] CONFIG_SOLO6X10=m commonise
  * [Config] CONFIG_SND_PCM_OSS=n using pulseaudio emulation instead
  * [Config] CONFIG_SPI_DESIGNWARE=m commonise
  * [Config] CONFIG_SPI_SPIDEV=m commonise
  * [Config] CONFIG_TABLET_USB_WACOM=m commonise
  * [Config] CONFIG_TPS65010=m commonise
  * [Config] CONFIG_STE10XP=y commonise
  * [Config] CONFIG_X25_ASY=m commonise
  * [Config] CONFIG_USB_MON=m commonise
  * [Config] CONFIG_VME_BUS=m commonise
  * [Config] CONFIG_W35UND=m commonise
  * [Config] -CONFIG_TCG_TPM=y commonise
  * [Config] highbank -- commonise filesystems
  * [Config] highbank -- commonise subsystems
  * [Config] highbank -- commonise network protocols
  * [Config] highbank -- commonise input drivers
  * [Config] highbank -- commonise CRYPTO options
  * [Config] highbank -- commonise HID options
  * [Config] highbank -- commonise sensors options
  * [Config] highbank -- commonise EXPORTFS/FHANDLE
  * [Config] highbank -- commonise CONFIG_CRYPTO_LZO
  * [Config] highbank -- commonise ENCRYPTED_KEYS
  * [Config] highbank -- commonise CONFIG_ATALK
  * [Config] highbank -- commonise INET/INET6
  * [Config] highbank -- commonise NLS
  * [Config] highbank -- commonise BLK/CHR
  * [Config] highbank -- CONFIG_EXT2_FS=y boot essential on highbank
  * [Config] highbank -- commonise INET/INET6 part 2
  * [Config] highbank -- commonise PHY settings
  * [Config] highbank -- commonise CRC settings
  * [Config] highbank -- commonise BINFMT settings
  * [Config] highbank -- commonise DM settings
  * [Config] highbank -- commonise RTC_DRV settings
  * [Config] highbank -- commonise KEYBOARD/MOUSE settings
  * [Config] highbank -- commonise USB settings
  * [Config] highbank -- commonise GPIO settings
  * [Config] highbank -- commonise I2C settings
  * [Config] highbank -- commonise numerous subsystem selectors
  * [Config] highbank -- commonise A-C modules missmatches
  * [Config] highbank -- commonise D-F modules missmatches
  * [Config] CONFIG_AUDIT_LOGINUID_IMMUTABLE inco...

Read more...

Changed in linux (Ubuntu Quantal):
status: Fix Committed → Fix Released
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel for Precise in -proposed solves the problem (3.2.0-26.41). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-precise' to 'verification-done-precise'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-precise
Tim Gardner (timg-tpi) wrote :

Marking verified for Precise since this patch only affects builds.

tags: added: verification-done-precise
removed: verification-needed-precise
Changed in linux (Ubuntu Precise):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (13.2 KiB)

This bug was fixed in the package linux - 3.2.0-26.41

---------------
linux (3.2.0-26.41) precise-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1012057

  [ Andy Whitcroft ]

  * [Config] fix up postinst to ensure we know which error is which
    - LP: #1002388
  * [Config] highbank -- commonise filesystems
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise subsystems
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise network protocols
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise input drivers
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise CRYPTO options
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise HID options
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise sensors options
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise EXPORTFS/FHANDLE
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise CONFIG_CRYPTO_LZO
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise ENCRYPTED_KEYS
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise CONFIG_ATALK
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise INET/INET6
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise NLS
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise BLK/CHR
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise PHY settings
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise CRC settings
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise BINFMT settings
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise DM settings
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise RTC_DRV settings
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise KEYBOARD/MOUSE settings
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise USB settings
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise GPIO settings
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise I2C settings
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise numerous subsystem selectors
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise A-C modules missmatches
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise D-F modules missmatches
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise G-I modules missmatches
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise J-L modules missmatches
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise M modules missmatches
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise N-P modules missmatches
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise Q-R modules missmatches
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise S modules missmatches
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise T modules missmatches
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise U-Z modules missmatches
    - LP: #1000831, #1010463

  [ Herton Ronaldo Krzesinski ]

  * SAUCE: fix get_gate_vma call in i386 NX emulation code
    - LP: #1009200

  [ Ike Panhc ]

  * [Config] add...

Changed in linux (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers