Android 4 Device is not Automatically Mounted in MTP mode on Xubuntu 12.04 amd64

Bug #1002808 reported by Colin Norris on 2012-05-22
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

I have a Sony Xperia Arc S. It was recently upgraded to Android 4.0.3, which has removed support for USB Mass Storage mode.

Now, when I connect the USB cable between my phone and my computer, the phone claims to be connected, but the MTP storage is never mounted in Xubuntu, and the device is not visible in Gigolo, as I would expect as a user.

I have manually installed mtp-tools and mtpfs, but it made no difference.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-24-generic 3.2.0-24.38
ProcVersionSignature: Ubuntu 3.2.0-24.38-generic 3.2.16
Uname: Linux 3.2.0-24-generic x86_64
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
Card0.Amixer.info:
 Card hw:0 'XFi'/'Creative X-Fi 20K1 SB073x'
   Mixer name : '20K1'
   Components : ''
   Controls : 27
   Simple ctrls : 10
Card1.Amixer.info:
 Card hw:1 'Intel'/'HDA Intel at 0xf1df8000 irq 79'
   Mixer name : 'Realtek ALC889'
   Components : 'HDA:10ec0889,104383c0,00100004'
   Controls : 46
   Simple ctrls : 22
Card2.Amixer.info:
 Card hw:2 'NVidia'/'HDA NVidia at 0xf3dfc000 irq 34'
   Mixer name : 'Nvidia GPU 18 HDMI/DP'
   Components : 'HDA:10de0018,10de0101,00100100'
   Controls : 24
   Simple ctrls : 4
Date: Tue May 22 12:26:51 2012
GvfsMonitorLog: Monitoring events. Press Ctrl+C to quit.
HibernationDevice: RESUME=UUID=f3bd59f6-4e10-4192-b236-784f088911d2
HotplugNewDevices:

HotplugNewMounts:

InstallationMedia: Xubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
MachineType: System manufacturer System Product Name
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcFB: 0 VESA VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-24-generic root=UUID=e8780c4a-ee5b-454b-9c12-263c5b5195f5 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-24-generic N/A
 linux-backports-modules-3.2.0-24-generic N/A
 linux-firmware 1.79
RfKill:

SourcePackage: linux
Symptom: storage
UdisksMonitorLog: Monitoring activity from the disks daemon. Press Ctrl+C to cancel.
UpgradeStatus: Upgraded to precise on 2012-04-26 (25 days ago)
dmi.bios.date: 05/10/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0701
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P6X58D-E
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0701:bd05/10/2011:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP6X58D-E:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

Colin Norris (sirrontm) wrote :
Brad Figg (brad-figg) on 2012-05-22
Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

So this issue started happening when you upgraded your phone to Android 4.0.3? That would indicate an issue with Android and not the kernel.

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Invalid
Colin Norris (sirrontm) wrote :

No, this problem was always present, but android users could work around it by setting their Android device to mass storage mode. That feature has now been removed as of android 4, so this issue now needs to be addressed. On Windows 7 I can connect my Android device via USB and it is automatically mounted like any other drive. This problem will affect all android devices running android 4, and above if the mass storage feature stays gone (which is likely as google has reasons for removing it).

Changed in linux (Ubuntu):
status: Invalid → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v3.4kernel[1] (Not a kernel in the daily directory). Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag(Only that one tag, please leave the other tags). This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream'.
Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-precise/

tags: added: needs-upstream-testing
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Colin Norris (sirrontm) on 2012-05-23
tags: added: kernel-bug-exists-upstream
removed: needs-upstream-testing
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
MvW (2nv2u) wrote :

Running 3.4.5 in 12.04 precise (kernel downloaded from mainline) it still doesn't mount (Not a kubuntu only issue).
Althought I'm using a Galaxy S2 it's running Android 4.0.4 which indeed removed USB Mass Storage and allowes only MTP.

Seems to be a duplicate of:
https://bugs.launchpad.net/ubuntu/+source/udev/+bug/903422

To post a comment you must log in.