linux-source-3.4.0 does not contains debian/stamps/ directory

Bug #1001172 reported by Marcin Juszkiewicz on 2012-05-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
armel-cross-toolchain-base (Ubuntu)
High
Marcin Juszkiewicz
armhf-cross-toolchain-base (Ubuntu)
High
Marcin Juszkiewicz
linux (Ubuntu)
Medium
Unassigned

Bug Description

Armel-cross-toolchain-base is using linux-source-3.4.0 to build linux-libc-dev package for armel (same for armhf package). Since 3.4.0-2.6 it failed:

make[1]: Leaving directory `/build/buildd/armel-cross-toolchain-base-1.84/linux-source-3.4.0'
 debian/rules build
make[1]: Entering directory `/build/buildd/armel-cross-toolchain-base-1.84/linux-source-3.4.0'
Debug: build-arch
Debug: build-indep
make[1]: Leaving directory `/build/buildd/armel-cross-toolchain-base-1.84/linux-source-3.4.0'
 fakeroot debian/rules binary
make[1]: Entering directory `/build/buildd/armel-cross-toolchain-base-1.84/linux-source-3.4.0'
Debug: install-headers
Debug: install-doc
Debug: install-source
Debug: /build/buildd/armel-cross-toolchain-base-1.84/linux-source-3.4.0/debian/stamps/stamp-prepare-perarch
touch /build/buildd/armel-cross-toolchain-base-1.84/linux-source-3.4.0/debian/stamps/stamp-prepare-perarch
touch: cannot touch `/build/buildd/armel-cross-toolchain-base-1.84/linux-source-3.4.0/debian/stamps/stamp-prepare-perarch': No such file or directory
make[1]: *** [/build/buildd/armel-cross-toolchain-base-1.84/linux-source-3.4.0/debian/stamps/stamp-prepare-perarch] Error 1
make[1]: Leaving directory `/build/buildd/armel-cross-toolchain-base-1.84/linux-source-3.4.0'
dpkg-buildpackage: error: fakeroot debian/rules binary gave error exit status 2
make: *** [stamp-dir/build-linux] Error 2

Full log: https://launchpadlibrarian.net/105354468/buildlog_ubuntu-quantal-i386.armel-cross-toolchain-base_1.84_FAILEDTOBUILD.txt.gz

I checked why it happened. Normal linux source package contains "debian/stamps/" directory but it is not present in "linux-source-3.4.0" package which I use.

There are few possible solutions:

1. add "debian/stamps/" into linux-source-3.4.0
2. add "install -d debian/stamps/" into 'clean' target of "linux" package
3. add "install -d linux-source-$(VER_LINUX)/debian/stamps/" into "armel-cross-toolchain-base" package

For now I went with last option as this is package which I maintain but would like to know should I provide patch for 1st or 2nd solution.

Marcin Juszkiewicz (hrw) on 2012-05-18
Changed in armel-cross-toolchain-base (Ubuntu):
status: New → Triaged
Changed in armhf-cross-toolchain-base (Ubuntu):
status: New → Triaged
Changed in armel-cross-toolchain-base (Ubuntu):
assignee: nobody → Marcin Juszkiewicz (hrw)
Changed in armhf-cross-toolchain-base (Ubuntu):
assignee: nobody → Marcin Juszkiewicz (hrw)
Changed in armel-cross-toolchain-base (Ubuntu):
importance: Undecided → High
Changed in armhf-cross-toolchain-base (Ubuntu):
importance: Undecided → High
tags: added: armel armhf cross

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1001172

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package armel-cross-toolchain-base - 1.85

---------------
armel-cross-toolchain-base (1.85) quantal; urgency=low

  * Create debian/stamps/ directory for linux package - LP: #1001172
 -- Marcin Juszkiewicz <email address hidden> Fri, 18 May 2012 11:54:05 +0200

Changed in armel-cross-toolchain-base (Ubuntu):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package armhf-cross-toolchain-base - 1.85

---------------
armhf-cross-toolchain-base (1.85) quantal; urgency=low

  * Create debian/stamps/ directory for linux package - LP: #1001172
 -- Marcin Juszkiewicz <email address hidden> Fri, 18 May 2012 11:54:05 +0200

Changed in armhf-cross-toolchain-base (Ubuntu):
status: Triaged → Fix Released
Marcin Juszkiewicz (hrw) on 2012-05-18
Changed in linux (Ubuntu):
status: Incomplete → Opinion
Changed in linux (Ubuntu):
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers